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Preface
INTRODUCTION

This chapter contains general information that will be useful to know before using the 
MPLAB® Integrated Programming Environment (IPE). Items discussed in this chapter 
include:

• Document Layout

• Conventions Used in this Guide

• Recommended Reading

DOCUMENT LAYOUT

This document describes how to use the IPE as a programming tool to program 
devices. The document is organized as follows:

• Chapter 1. IPE Application Overview – Defines the IPE, provides software 
installation requirements and upgrade procedures, lists the supported tools, and 
provides a feature matrix.

• Chapter 2. General Setup – Discusses launching and setting up the application, 
and provides Advanced Mode login and options information.

• Chapter 3. IPE Reference – Provides reference information for the menu items.

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXXXXA”, where “XXXXXXXX” is the document number and “A” is the revision level 
of the document.

For the most up-to-date information on development tools, see the MPLAB® X IDE online help. 
Select the Help menu, and then Topics to open a list of available online help files.
 2013-2017 Microchip Technology Inc. DS50002227C-page 5
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB X IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}

DS50002227C-page 6  2013-2017 Microchip Technology Inc.



Preface
RECOMMENDED READING

This user's guide describes how to use Microchip MPLAB IPE. Other useful documents 
are listed below. The following Microchip documents are available and recommended 
as supplemental reference resources.

Processor Extension Pak and Header Specification (DS50001292)

This booklet describes how to install and use headers. Headers are used to better 
debug selected devices using special -ICE device versions, without the loss of pins or 
resources. See also the Header online help file.

Transition Socket Specification (DS51194)

Consult this document for information on transition sockets available for use with 
headers.

SQTP File Format Specification (DS50002539)

This document shows how a Serial Quick Turn Programming (SQTPSM) file is produced 
and used by MPLAB® IPE Integrated Programming Environment. Engineers can use 
this information to generate their own SQTP file. 
 2013-2017 Microchip Technology Inc. DS50002227C-page 7
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Chapter 1.  IPE Application Overview
1.1 IPE DEFINED

The MPLAB® Integrated Programming Environment (IPE) is a software application that 
provides a simple interface to quickly access key programmer features. The IPE 
provides a secure programming environment for production programming.

The IPE uses the MPLAB X IDE framework, Microchip Debugger (MDB) database, 
hardware tool interfaces and respective drivers to provide programming capabilities for 
all Microchip programmers.

1.2 SOFTWARE INSTALLATION REQUIREMENTS

The IPE application must be installed on your PC. It is available during the MPLAB X 
IDE installation process if the check box is selected (see Figure 1-1). You do not need 
to install the MPLAB X IDE in order to use the IPE application. However, you may want 
to refer to the online help for the MPLAB X IDE for additional information.

FIGURE 1-1: SELECT PROGRAMS DIALOG
 2013-2017 Microchip Technology Inc. DS50002227C-page 9
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Once you’ve installed the software, the IPE application can be accessed through the 
MPLAB IPE icon on your desktop or startup menu. 

1.3 PROGRAMMING TOOLS SUPPORTED

The following programming tools work with the IPE:

• MPLAB ICD 3 In-Circuit Debugger – recommended for production programming

• MPLAB PICkit™ 3 Debugger/Programmer – for development programming only

• MPLAB PM3 Programmer – recommended for production programming

• MPLAB REAL ICE™ Emulator – recommended for production programming

• Licensed PKOB Starter Kits – recommended for development programming only

1.4 IPE MODES

1.4.1 Modes

The IPE application operates in two modes: 

• Production Mode – in which you can perform production programming operations. 
By default, the IPE is in Production Mode when it is launched. The Production 
Mode capabilities are set from the Advanced Mode menu discussed in 
Section 2.5.6 “Production Mode” of this document.

• Advanced Mode – a feature-rich GUI interface in which you can view and change 
the settings for programming operations, and set up secure environments for 
production programming. To enable Advanced Mode, see Section 2.3 “Setting Up 
the Programmer”. 

1.4.2 Feature Matrix

The following matrix shows the default features that are accessible in Production Mode. 

However, in Advanced Mode, the default behavior of Production Mode can be 
changed, and features can be added or removed as per the authorized personnel’s 
discretion. 

  

Note: See the Release Notes for MPLAB IPE (Readme for MPLAB IPE.htm) for 
up-to-date version compatibility information. This can be found in:
C:\Program Files (x86)\Microchip\MPLABX\vx.xx\docs 
where vx.xx represents the version.
It can also be found in the installation directory, for example:
C:\Program Files\Micro-
chip\MPLABX\vx.xx\mplab_ide\mplab_ide\modules\docs
where vx.xx represents the version.

Note: The IPE must be run as ADMINISTRATOR for all features to be fully 
functional.

Note: The IPE must be run as ADMINISTRATOR for all features to be fully 
functional.
DS50002227C-page 10  2013-2017 Microchip Technology Inc.



IPE Application Overview
TABLE 1-1: FEATURE MATRIX

Feature Description
Production 

Mode 
Defaults

Import Hex file loads the Hex file On

Import Environment loads the Environment file Off

Import SQTP file loads the pre-built SQTP file Off

Export Hex file saves the all memory contents into a hex file Off

Program connects to hardware tool and performs program operation On

Erase erases the device On

Verify verifies the device against the memory contents of IPE On

Blank Check checks that the device is blank On

Read reads the device and fills the read content in memory On

Memory View

Program Memory displays the program memory contents Off

Auxiliary Memory displays the auxiliary memory contents Off

Config Memory displays the configuration memory contents Off

Flash Data displays the Flash data memory contents Off

User IDs displays the User ID memory contents Off

EEPROM displays the data memory contents Off

Memory Edit

Program Memory program memory contents can be edited Off

Auxiliary Memory auxiliary memory contents can be edited Off

Flash Data Memory Flash data memory contents can be edited Off

EEPROM data memory contents can be edited Off

User IDs User ID memory contents can be edited Off

Boot Memory boot memory contents can be edited Off

Config Memory configuration memory contents can be edited Off

Save Environment creates or overwrites the environment Off

View Memory Settings views the memory ranges On

Edit Memory Settings changes the memory ranges Off

View Voltage Settings views the voltage values On

Edit Voltage Settings changes the voltage values Off

Create SQTP generates the SQTP file Off

Manual Download Firmware to select and download the firmware into the Hardware tool On

Auto Download Firmware when a tool is connected, the latest firmware (available in the 
system) will be downloaded

On

Erase All Before Program erases the device before programming Off
 2013-2017 Microchip Technology Inc. DS50002227C-page 11
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Chapter 2.  General Setup
2.1 INTRODUCTION

Getting started using the IPE is discussed.

• Launching the IPE Application

• Setting Up the Programmer

• Advanced Mode Login

• Advanced Mode Settings

• Creating Desktop Shortcuts

2.2 LAUNCHING THE IPE APPLICATION

2.2.1 Launching the IPE

After installing the software, double-click the MPLAB IPE application icon located on 
the desktop. The IPE main window opens.

FIGURE 2-1: IPE MAIN WINDOW

2.2.2 Multiple Instances of IPE

If you need to have multiple instances of the IPE available, refer to the MPLAB X IDE 
help. Open MPLAB X IDE, go to Help>Tool Help Contents>MPLAB X IDE Help and 
navigate to the “Before You Begin” section, then “Launch Multiple Instances of the IDE.” 
Follow the instructions and apply to the IPE.
 2013-2017 Microchip Technology Inc. DS50002227C-page 13
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2.3 SETTING UP THE PROGRAMMER

For programming devices, you can use any of the supported tools (see 
Section 1.3 “Programming Tools Supported”). Refer to the online help of the selected 
tool (e.g., MPLAB ICD 3, PICkit 3, etc.) for information on programming a device.

1. Using the Family drop-down menu, select the family of the device you wish to 
program and use the Device drop-down menu to select the device. Or, use the 
Device drop-down menu to directly select the device. 

2. Click Apply to configure the IPE to the current device (e.g., Memory View, 
checksum).

3. Connect the development tool to the PC. Attach the appropriate target board, 
device, and power. Refer to the tool’s online help for additional instructions and 
information on connecting to target boards, etc.

4. Use the Tool drop-down menu to select the tool you want to use. If more than one 
development tool is connected to the PC, select the one you wish to use (see the 
figure below).

Note: The IPE must be run as ADMINISTRATOR for all features to be fully 
functional.

Note: Selecting the Recently Used option from the Family menu lists the latest 10 
devices used in the Device menu.

Note: An exclamation point before the tool name (as shown below) indicates that 
the USB drivers need to be updated. This will not occur with the PICkit 3. 
However, the USB drivers may need to be updated for the MPLAB ICD 3, 
MPLAB PM3, and REAL ICE.

 

For information on installing the correct USB drivers for Microsoft 
Windows®, launch MPLAB X IDE and click the MPLAB IDE v8 Users - 
IMPORTANT link, which is located on the Start Page of the Learn & 
Discover tab. Follow the instructions to install the driver; then, return to 
the IPE.
DS50002227C-page 14  2013-2017 Microchip Technology Inc.



General Setup
FIGURE 2-2: SELECT TOOL

5. Click the Connect button (next to the Tool name) to establish a connection 
between the IPE and the tool.

FIGURE 2-3: CONNECTING THE TOOL
 2013-2017 Microchip Technology Inc. DS50002227C-page 15
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6. When the tool is connected, any messages or errors related to this tool will be 
displayed in the Output window, see Figure 2-4.

FIGURE 2-4: OUTPUT WINDOW

7. After the tool is successfully connected, proceed to Chapter 3. “IPE Reference” 
to program the device with the IPE.
DS50002227C-page 16  2013-2017 Microchip Technology Inc.



General Setup
2.4 ADVANCED MODE LOGIN

2.4.1 Logging In

Typically, someone has been authorized to establish the settings that production will 
use for the device and tool. To input those settings, log in to the Advanced mode.

Select Settings>Advanced Mode to open the Advanced Mode login dialog. The 
password is case sensitive. Type in the default password microchip and click Log on.

FIGURE 2-5: ADVANCED MODE LOGIN

2.4.2 Staying Logged In

To start up the MPLAB IPE directly in Advanced mode without entering the password 
again, type the password, check the “Keep me logged in” check box (see Figure 2-6), 
then click Log on. A new installation or first time usage will launch the MPLAB IPE in 
basic mode. Once the “Keep me logged in” check box is checked, subsequent 
launchings will open in Advanced mode.

FIGURE 2-6: KEEP ME LOGGED IN 

Note: The IPE must be run as ADMINISTRATOR for all features to be fully 
functional.
 2013-2017 Microchip Technology Inc. DS50002227C-page 17
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To cancel the automatic Advanced mode login, click Log Out (see Figure 2-7) on the 
Advanced Settings dialog.

FIGURE 2-7: CANCEL KEEP ME LOGGED IN

Note: Prior to MPLAB IPE v3.26 the Advanced Settings dialog had a “Remember 
password” check box instead of a “Keep me logged in” check box.
DS50002227C-page 18  2013-2017 Microchip Technology Inc.
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2.4.3 Changing the Password

To change the password after the initial log on, click Change Password. 

If you forget the new password, you must uninstall the IPE, delete the ipe.key file 
(located in the IPE install directory) to remove any settings made previously in IPE, then 
reinstall the IPE to begin with the default password microchip. 

FIGURE 2-8: CHANGE PASSWORD DIALOG
 2013-2017 Microchip Technology Inc. DS50002227C-page 19
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2.5 ADVANCED MODE SETTINGS

Advanced mode settings must be set by someone authorized to do so. Some settings 
that are selected in these dialogs will allow a production specialist to view and control 
certain commands from the IPE Menu bar, Settings menu. 

2.5.1 Operate

After validating the password to log in to the Advanced Mode, the dialog opens in the 
Operate view. This display is similar to the main display, with the addition of option 
buttons located along the left side of the window. The dialog shows the device and tool 
that has been selected (see Section 2.3 “Setting Up the Programmer”).

FIGURE 2-9:  ADVANCED MODE, OPERATE DIALOG
DS50002227C-page 20  2013-2017 Microchip Technology Inc.
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2.5.2 Power

The Power option is only available when a tool is connected. From the Advanced Mode dialog, click Power 
to display the available settings. 

TABLE 2-1: POWER SETTINGS

Setting Description

Voltage Settings: Voltage settings will vary for different device families. All of the settings and parame-
ters are similar to MPLAB X IDE.

VDD This voltage is used by the programmer to verify memory. The value 
should be the maximum voltage for the designated circuit. The default is 
the device's maximum voltage value.

VPP This is the voltage used to bring the device into a programming mode. 
Although this is dependent on the device's programming specification, it 
can be changed.

VDD Nom The default value depends on the device. For example, PIC32 has 3.3V 
as default VDD Nom.

VDD APP This is the voltage used by the programmer to verify Flash memory. The 
default is the device's nominal voltage value.

Reset Voltages Returns voltages to their default settings

ICSP™ Options:

Low voltage program The tool allows low voltage programming (LVP) with certain PICXXFXXX 
Flash devices. 
The Flash device selected must be capable of low voltage and 
programming must be performed in ICSP mode. 

Power Target Circuit from 
tool

This setting enables the connected tool to power the target.

High Voltage on MCLR This setting enables high voltage to be used on a Master Clear Reset 
(MCLR).
 2013-2017 Microchip Technology Inc. DS50002227C-page 21
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2.5.3 Memory

From the Advanced Mode dialog, click Memory to display the available settings for the device and tool you 
selected. You can control the memory address and other parameters related to a programming operation. 
Some of the options in this window are also available on the main screen, for viewing and to provide easy 
access to these settings.

Note 1: The MPLAB PM3 programmer does not support the Preserve Memory options in the environment .pm3 
files.

2: If you wish to use any of the Preserve Memory options, first ensure that your code is not code-protected. 
For memory to be preserved, the programmer reads the section it needs to save, performs a bulk erase of 
the device, reprograms the device and then rewrites the area that is preserved with what was saved. 
Therefore, this area cannot be code protected.

Note: The memory settings for the MPLAB PM3 Programmer may be different in versions of MPLAB 
IPE prior to v3.60.

TABLE 2-2: MEMORY SETTINGS

Setting Description

Allow Tool to select memories 
and ranges

When the check box is selected, the programmer tool sets the memory 
types and ranges. If selected, the Program Memory fields are disabled. 

Manual Select:

• Program Memory Allows the tool to program the program memory

• Auxiliary Memory Allows the tool to program the auxiliary memory

• Flash Data Allows the tool to program the Flash data

• EEPROM Allows the tool to program the EEPROM

• User IDs Allows the tool to program the User IDs

• Boot Flash Allows the tool to program the Boot Flash

• Configuration Memory Allows the tool to program the configuration memory

Program Memory Range - define the addresses to be used to preserve memory for range programming 
of the program memory.

   Enter Range: The address range in Hex of the program space that will be programmed

Reset Addresses Returns addresses to default settings

Preserve Memory1 - define the addresses to be used for EEPROM or Flash memory.

Preserve EEPROM on 
Program2

When the check box is selected, the device will not be programmed with 
any new data that is present in the memory (shown in the EEPROM win-
dow). The data in the EEPROM memory area on the device will not be 
erased.

   Enter Range: The address range in Hex of the program space that will be preserved

Preserve Flash on Program2 When the check box is selected, the program memory range specified in 
the following Program Memory (Start and End Address) fields will not be 
programmed with any new data.

   Enter Range: The address range in Hex of the program space that will be preserved

Preserve Auxiliary Memory When the check box is selected, the auxiliary memory will not be pro-
grammed with any new data that is present in the auxiliary memory.

Preserve ID Memory When the check box is selected, the ID memory will not be programmed 
with any new data that is present in the ID memory. Only available if 
device has user ID memory.
DS50002227C-page 22  2013-2017 Microchip Technology Inc.
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2.5.4 Environment 

Environments allow you to save settings, so that all of the same settings can be reloaded in another 
programming session. Environments are supported, under all tools, as either .pen files or .pm3 files.

From the Advanced Mode dialog, click Environment to display the available settings. 

Note: MPLAB PM3 programmer does not support the Preserve Memory options in the environment 
.pm3 files.

TABLE 2-3: ENVIRONMENT SETTINGS

Setting Description

Environment Name the environment name you specify

.pm3 file for MPLAB PM3, select this type of file

.pen file for MPLAB ICD 3, PICkit 3 and REAL ICE tools, select this type of file

Description the description you use for the environment

SQTP File the SQTP file name used in the environment

Misc Files other files used in the environment, e.g., data sheets, instructions, etc. 
Multiple files can be selected.

Save to PM3 SD Card saves the environment file to a MPLAB PM3 SD card destination
See Section 3.4.2 “Save Firmware into SD Card” for additional information 
on saving multiple operating system firmware to the SD card.

Save to PC saves the environment file to a destination on the PC

Copy opens the Copy Environment dialog to select source and destination for 
copying the environment

More > > opens the Environment Browser dialog with two tabs:

• From PC tab lets you select an environment to delete or view.

• From PM3 tab lets you perform the following on the SD card in the 
MPLAB PM3:

- display the properties

- format the SD card

- select an environment to delete 

- select an environment to view 
 2013-2017 Microchip Technology Inc. DS50002227C-page 23
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2.5.5 SQTP

SQTP (serial quick turn programming) is used to program a unique serial number into each device. This 
number can be used as an entry code, password or ID number.From the Advanced Mode dialog, click SQTP 
to display the available settings. 

If using SQTP with MPLAB PM3, see Section 2.5.5.1 “Using SQTP with MPLAB PM3” for additional 
information. If using PIC32 devices, see Section 2.5.5.2 “Using SQTP with PIC32 Devices” for information 
on the import methods. For information about how the SQTP files are produced, refer to the SQTP File 
Format Specification (DS50002539).

TABLE 2-4: SQTP SETTINGS

Setting Description

Generation Method:

Random Select this option to generate unique, random numbers for each part. 
Also enter the start address, number of bytes and number of parts in the 
corresponding fields.

Pseudo Random
   Seed Value (Hex):

Select this option to generate a pseudo-random set of non-repeating numbers 
based on the Hex value you enter into the Seed Value field. 
Also enter the start address, number of bytes and number of parts in the 
corresponding fields.

Sequential
   Start Value (Hex):
   Increment (Hex):

Select this option to generate sequential numbers based on the starting value 
specified and incrementing each number by the amount specified. 
Also enter the start address, number of bytes and number of parts in the 
corresponding fields.

Start Address (Hex) Enter the starting address (in Hex) for the serial number.

Number of bytes (Dec) Enter the size of the serial number (in decimal). 
Make sure a large enough serial number is specified for the number of parts 
planned to program using this file. 

Number of parts (Dec) Enter the number of parts to be programmed using this file. 

Generate Click Generate to create the SQTP (.num) file.

Location:

Program Memory Select this option to load the SQTP number in program memory. 

EEPROM Select this option to load the SQTP number in EEPROM. 

Access Method:

RETLW Select this option to use a series of RETLW (Return Literal W) instructions with 
the serial number bytes as the literal data. 

Raw Data Select this option to use the raw data. 

Format for PSV If the Raw Data option is selected, selecting Format for PSV formats SQTP data 
to make it compatible with PSV (Program Space Visibility). 
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2.5.5.1 USING SQTP WITH MPLAB PM3

SQTP files for Flash Data memory that were generated prior to MPLAB IPE v2.20 will 
work with MPLAB PM3 firmware up to v3.00. SQTP file generation for Flash Data 
memory has been modified to the 32-bit byte order (12345678) and the firmware is 
updated accordingly. A new SQTP file must be regenerated to work with MPLAB IPE 
v3.00 and higher.

2.5.5.2 USING SQTP WITH PIC32 DEVICES

For PIC32 devices only, starting with MPLAB IPE v3.15, a dialog box, similar to the one 
below, is provided to choose either 32-bit byte order (12345678) or 16-bit byte order 
(56781234) when loading an SQTP file.

FIGURE 2-10: IMPORT SQTP FILE DIALOG
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2.5.6 Production Mode

From the Advanced Mode dialog, click Production Mode to display the available 
Production Mode Settings. 

The Production Mode Settings dialog enables authorized personnel to select the 
options that are available during production programming. The options that are 
selected in the Production Mode Settings determine which commands will be available 
under the File, View, and Settings menus in Production Mode.

Select the appropriate settings for your production programming project by checking or 
unchecking the settings. Selecting a check box in the Production Mode Settings dialog 
causes a check mark to display in front of that option under the IPE Settings menu. 

A check mark indicates that an option has been set in the Advanced Mode. If the item 
is available and has a check mark, then the production specialist can control this item 
by toggling it on or off. 

TABLE 2-5: PRODUCTION MODE SETTINGS

Setting Description

Production Mode Settings

Allow Export Hex This setting enables a production specialist to export Hex files.
If checked, this option displays under the File>Export menu.

Allow Import Hex file enables a production specialist to import Hex files. 
If checked, this option displays under the File>Import menu.
Note: If using a Hex file in the IPE and the file is modified using Notepad, 
MPLAB X IDE, etc., outside of the IPE, a message displays: “File modified. 
The loaded hex file has been modified externally. Would you like to reload 
hex file?”

Allow Import Environment This setting enables a production specialist to import environments. 
If checked, this option displays under the File>Import menu.

Allow Import SQTP file This setting enables a production specialist to import SQTP files. 
If checked, this option displays under the File>Import menu.

Generate Reports This setting enables reports to be generated. 
If Generate Reports is checked, click Browse to set the location where the 
reports will be placed. 

Limit the Program Count to If selected, this option limits the pass, fail, and total counts to the value that 
is entered into the associated field. 
This actually halts further programming operations from occurring. 
To clear the counts on the main window, click Reset Counters.

Allow “Verify Device ID 
before Program” under 
Settings menu

This setting activates this option in the Settings menu and enables a pro-
duction specialist to control this option.
This setting is valid only for tools that are capable of performing this 
function, e.g., MPLAB PM3. 

Allow “Auto Download 
Firmware” under Settings 
menu

If selected, this option displays in the Settings menu and can be controlled 
by a production specialist. 
If it is not selected, the IPE automatically downloads the latest firmware for 
the tool, if needed.

Allow “Erase All before 
Program” under Settings 
menu

If selected, this option displays in the Settings menu and can be controlled 
by a production specialist. 
If it is not selected, the production specialist cannot control this option from 
the Settings menu.
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Allow “Communication” 
under Settings menu

If selected, this option is enabled (Section 3.4 “Settings Menu”) and can be 
controlled by a production specialist. 
If using the MPLAB PM3 programmer COM port (RS-232), you must select 
this option in order to set the appropriate COM port. 

Remove Read button from 
main window

If this option is selected, the Read button is removed from the main window.

Audible notification on 
successful program 
completion

If selected, this option generates a sound when programming completes 
successfully.

Allow memory editing and 
filling

Enables memory editing and filling of memory. 
If enabled, this option is accessed in Production Mode from the 
View>Fill Memory option.

Display EEPROM check-
sum in the output window

If selected, the EEPROM checksum is displayed in the output window.

Display imported hex 
checksum with CP=OFF

If selected, the non-code protected checksum is displayed in the Results 
area.

Enable programming 
operations only if hex file is 
loaded

If selected, 

a) If Hex file is not loaded: All the programming buttons (Program, Read, 
Erase, Verify, Blank Check) will be disabled.

b) If Hex file is loaded, all the programming buttons will be enabled.

Allow Memory View

Program Memory If this option is selected, program memory can be displayed in the Memory 
View pane on the main window.

Auxiliary Memory If this option is selected, auxiliary memory can be displayed in the Memory 
View pane on the main window.

Config Memory If this option is selected, configuration memory can be displayed in the 
Memory View pane on the main window. 

Flash Data If this option is selected, Flash memory can be displayed in the Memory 
View pane on the main window. 

User IDs If this option is selected, user IDs can be displayed in the Memory View 
pane on the main window. This is only applicable if user IDs are supported 
by the tool.

EEPROM If this option is selected, EEPROM memory can be displayed in the Memory 
View pane on the main window.

TABLE 2-5: PRODUCTION MODE SETTINGS (CONTINUED)
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2.5.7 Settings

From the Advanced Mode dialog, click Settings to display the available options 
(Figure 2-11).

FIGURE 2-11: GENERAL SETTINGS OPTIONS 
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TABLE 2-6: GENERAL SETTINGS

Settings Description

PICkit 3 programming 
speed

Use the slider to adjust the programming speed (see Figure 2-12). This option 
can be used to help troubleshoot problems by slowing the speed to allow suffi-
cient time for signal levels. The PICkit 3 slider will slow down ICSP program-
ming which may help communication problems created by heavy loading on 
the ICSP lines. It is suggested that these lines are clear of any components. 
The programming speed control may help to program boards that already have 
existing components on these lines.

PICkit 3 Programmer To 
Go

Opens the PICkit 3 Programmer To Go dialog (see Figure 2-13) showing the 
settings that will be applied the next time the Programmer-To-Go feature is 
used. Enter an Image Name that will be used for the image on the PICkit 3. 
Click Programmer To Go to activate. Refer to the PICkit 3 In-Circuit Debug-
ger/Programmer User’s Guide, DS52116, for information on the Program-
mer-To-Go feature. This feature may not be supported on all devices.
Note: Programmer To Go does not support the Preserve Memories options.

Secure Segments

Segments to 
Program

Available only for devices with CodeGuard, e.g., dsPIC33FJ12GP202, etc. 
Supported by REAL ICE, MPLAB ICD 3 and PICkit 3.
Select the segments to program:
• Full Chip Programming
• Boot, Secure and General Segments
• Secure and General Segments
• General Segment Only

SQTP

Disable operations 
if SQTP values are 
exhausted

Selecting the check box prohibits further programming if all SQTP values from 
the specified .num file have been exhausted.

Display the next 
SQTP sequence 
in the output 
window

Select this check box to display the next SQTP sequence in the output window.

Program Method This option allows you to choose the Test mode entry method for devices. This 
feature is supported by the tools which can power the target (except for 
PM3).This setting refers to the order in which the VPP and VDD voltages will be 
applied when programming/reading the target device. 

Apply VPP before 
VDD 
(Recommended)

This is the default setting.

Apply VDD before 
VPP

Caution is recommended when using this setting as it may have adverse side 
effects. This options is available only when powering the device from the 
debug tool.
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Diagnostics

Logging Level Set the message logging level.
OFF: No logging
SEVERE: Log severe (error) messages only.
WARNING: Log warning messages only.
INFO: Log informational messages only.
CONFIG: Log configuration information only.
FINE: Log some module-to-module communication.
FINER: Log more module-to-module communication.
FINEST: Log all module-to-module communication.

Log File Path and name of log file.

Special Memory Regions

Program Calibra-
tion Memory

Enables programming of registers used to hold calibration values for a device.

Program/Read 
User OTP

Enables programming or reading of a serial user ID that is OTP (one time 
programmable). Once programmed, it cannot be changed.

TABLE 2-6: GENERAL SETTINGS (CONTINUED)

Settings Description
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FIGURE 2-12: PICkit 3 SETTINGS OPTIONS 

FIGURE 2-13: PICkit 3 PROGRAMMER TO GO DIALOG 

2.5.8 Log out

After the settings are selected, click Log out to save your settings, exit the Advanced 
Mode, and return to the main window.
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2.6 CREATING DESKTOP SHORTCUTS

Desktop shortcuts can be created for devices, Hex files, or environments. 

To do this:

1. Create a copy of the MPLAB IPE desktop icon.

2. Right click the new shortcut icon, then click Properties.

FIGURE 2-14: RIGHT CLICK MENU

3. The Properties dialog opens. Click the Shortcut tab.

4. In the Target field (see Figure 2-15), add additional commands that will load a 
specified device, Hex file or environment. Place the command in the Target field 
at the end of the string after the “....jar”. You must add a space before the com-
mand. Command are preceded by a dash. Commands are not case sensitive. 
Paths must be in quotations.

Switch Command Description

-P -P18f1220 Select the specified device when IPE is 
launched.

-P,-F -P12f1501 -F"E:\12f1501.hex" Load the specified device for the specified 
Hex file when IPE is launched.

-BL -BL"E:\18f1220.pm3" Load the specified environment when IPE 
is launched.
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FIGURE 2-15: SHORTCUT TAB

5. Click OK.

6. Right click the new shortcut icon, then click Rename. Type a new name for the 
shortcut.

7. Double click the new shortcut icon to launch IPE. The specified target 
(environment, device, etc.) automatically loads when the IPE opens. 
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Chapter 3.  IPE Reference
3.1 IPE MAIN WINDOW

The following figure shows the main window of the IPE. The IPE Menu bar contains the 
following menus, with commands:

• File Menu

• View Menu

• Settings Menu

• Help Menu

Commands are available or not depending on the settings selected in Advanced Mode. 

FIGURE 3-1: IPE MAIN WINDOW

Note: The IPE must be run as ADMINISTRATOR for all features to be fully 
functional.
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TABLE 3-1: IPE MAIN WINDOW FIELDS

Item Description

Select Device and Tool:

• Family filters devices by family or recently used

• Device specifies the device; click Apply to select

• Tool specified the tool; click Connect or Disconnect as 
appropriate

Results:

• CP=OFF 
Checksum

This field displays only if enabled in Advanced Mode.
Displays the imported hex checksum as if code protect is 
off for the device with current memory contents; value can 
be copied using CTRL+C. 

• Checksum checksum value for the device with current memory 
contents; value can be copied using CTRL+C

• Pass Count details the programming operations that passed

• Fail Count details the programming operations that failed

• Total Count the total amount of programming operations

Command Buttons:

• Program (Alt+F5) programs the device

• Erase(Alt+F6) erases the device

• Read(Alt+F7) reads the device

• Verify(Alt+F8) performs a verify operation on the device

• Blank 
Check(Alt+F9)

checks whether the device is blank

Other:

Source the Hex file location, Browse to locate the file

SQTP the SQTP file location, Browse to locate the file

More/Less display more or less information

Output Tab display of output data.
Right-click in the Output window to undock, split view, clear 
contents, or copy.

Tool Tab display of specific tool data, i.e., PM3, ICD 3, PICkit 3
If a tool is connected, right-click in the Output area and 
select Split View to display the tool tab.

Memory View displays only if the View>Show Memory is selected
This option displays memory addresses, device ID, 
configuration memory, etc.
Right click in the Memory View to undock, fill memory, go 
to, find, or print. To re-dock an undocked memory view, 
close the undocked window.
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3.2 FILE MENU

On the IPE Menu bar, the File menu provides three commands: 

• Import

• Export

• Exit

3.2.1 File>Import

The Import menu item allows you to import files into the IPE.

File->Import->Hex – select to import the hexadecimal file (*.hex).

File->Import->Environment – select to import (load) the environment (*.pen or .pm3 
file).

File->Import->SQTP – select to load the SQTP file (*.num file).

3.2.2 File>Export

The Export menu item allows you to export data from IPE to storage media. By default, 
these commands are not available in Production Mode. However, in Advanced Mode, 
an authorized user can change the default states of this feature for the Production 
Mode.

File->Export->Hex – this command allows you to export all the memory contents into 
Intel® Hex file format. 

3.2.3 File>Exit

This command closes the IPE application.

3.3 VIEW MENU

The View menu commands are described below:

• Show Memory

• Clear All Memory

• Fill Memory

• Memory Settings

• Power Settings

• Read Device ID

3.3.1 Show Memory

The specific kinds of memory that are shown are determined by Advanced or 
Production Mode settings. This command toggles between showing and not showing 
the memory. A check mark before the command indicates it is enabled (showing) in the 
Memory View pane that is located near the bottom of the window; unchecked indicates 
that the memory is not showing.

Note: If using a Hex file in the IPE and the file is modified using Notepad, MPLAB 
X IDE, etc., outside the IPE, the following message displays:
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FIGURE 3-2: MEMORY VIEW PANE

The viewable memory types are determined by the Production settings that are selected in the Advanced 
Mode.
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FIGURE 3-3: MEMORY TYPES

If enabled, the configuration settings can be edited. Select Config Memory from the drop-down list in 
Memory View. Use the scroll bar to view the Setting column. Click the setting you want to edit and a list 
displays that shows the options that are available for that setting. Click on your selection. 

This is shown in the following figure.

FIGURE 3-4: EDITING A CONFIGURATION SETTING
 2013-2017 Microchip Technology Inc. DS50002227C-page 39



MPLAB® IPE User’s Guide
3.3.1.1 RIGHT-CLICK MENU COMMANDS

Undock/Dock – when viewing the memory window, a right-click menu is available with 
commands to undock/dock, fill memory and print.

The memory window can be undocked to view a larger area in a separate window. 
Right-click on any value in the Memory View and select Undock (see following figure). 

To return the undocked window to the IPE window, close the memory window.

FIGURE 3-5: UNDOCKED MEMORY VIEW

Fill Memory – you can also access this dialog by right-clicking on any value in the 
Memory View window and select Fill Memory.

Print – to print the memory window, right-click on any value in the Memory View 
window and select Print. 

Note: this command will print the entire contents of the memory. So, if you have a large 
device, such as a PIC32, the printout will probably be quite large. You might consider 
printing to a file, rather than to a printer, in some cases.

3.3.2 Clear All Memory

Clears all of the memory views.

3.3.3 Fill Memory

If enabled in Advanced Mode, the Fill Memory command is available in Production 
Mode under the View menu.

TABLE 3-2: FILL MENU OPTIONS

Setting Description

Start Address start address of the fill operation

End Address end address of the fill operation

Data the value used for the fill operation

Use Data as Fill Value – fills each address with the Data value
Sequence Start – fills each address with incrementing Data value
Randomize – fills each address with a random value

Write writes addresses to the memory view

Close exits the dialog
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3.3.4 Memory Settings

Displays the current memory settings (see Figure 3-6 for an example). The Memory 
Settings are view-only and cannot be changed from this window.

FIGURE 3-6: MEMORY SETTINGS DISPLAY

3.3.5 Power Settings

Displays the current power settings (see example in Figure 3-7).

FIGURE 3-7: POWER SETTINGS DISPLAY

3.3.6 Read Device ID

Displays the device ID of the selected device in the Output window.
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3.4 SETTINGS MENU

3.4.1 Understanding the Settings Menu Commands

The Settings menu on the IPE Menu bar (see Table 3-3) contains commands available 
for production personnel. Many of these commands are made available through the 
Advanced Mode, Production Mode dialog.

Menu commands are shown as active (black) or unavailable (grayed out). 

Active commands with a check mark indicate that the production personnel can control 
these settings. 

Active commands without a check mark indicate that only authorized personnel can 
access them. 

Unavailable commands with or without a check mark indicate that production personnel 
cannot control these settings.

* The download of firmware will not occur until the connect/disconnect button is clicked or a programming opera-
tion is performed.

TABLE 3-3: SETTINGS MENU COMMANDS

Setting Description

Advanced Mode This command opens the Advanced Mode login dialog. Once the login is vali-
dated, additional settings can be set by authorized personnel. 
Refer to  “Setting Up the Programmer” and  “Advanced Mode Settings” for 
more information.

Verify Device ID Before 
Program

This command is only appropriate when using devices that have device IDs.

Erase All Before 
Program

This command is used to control whether or not the contents of the device will be 
erased before it is programmed. 
It is not applicable to One-Time-Programmable (OTP). When the “Erase All 
Before Program” command is enabled (check box is checked), the device will be 
erased before it is programmed. 
If it is disabled (unchecked), the device will not be erased before it is 
programmed 

Auto Download 
Firmware*

If this command is selected, the application verifies that the firmware is the latest 
available; and, if needed, downloads the newer firmware automatically. 

Manual Download 
Firmware*

This command enables manual download of firmware.

Save Firmware into SD 
Card

This command downloads the operating system firmware into an SD Card that 
has been inserted into the MPLAB PM3 programmer. See Section 3.4.2 “Save 
Firmware into SD Card”

Hold on Reset This command prevents the code from running after programming.

Release from Reset This command removes the Reset and allows the code to run.

Communication This command is only used with the MPLAB PM3 programmer.
This command opens the PM3 Communication Setting dialog. Use this dialog to 
set communications for COM or USB ports. SeeSection 3.4.3 “PM3 
Communication Setting Dialog” for more information.
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3.4.2 Save Firmware into SD Card

In production houses, there may be a need to program several different device family 
architectures without having access to a computer.

Between MPLAB IPE v3.25 and v3.40, the PM3 operating system was split into two 
parts based on the device architecture (32-bit vs all other devices). In MPLAB IPE 
v3.40, the PM3 operating system and database are split into three parts based on the 
architectures for 8-, 16- and 32-bit devices.

MPLAB IPE v3.40 or greater enables you to save the three PM3 operating system 
firmwares supporting each of the device family architectures into a PM3 SD card.

Once all the PM3 operating system firmwares are downloaded, when a PM3 
environment is selected in Stand-Alone mode, the MPLAB PM3 programmer will load 
the correct operating system and database for the device from the PM3 SD card.

This feature is available only in the MPLAB IPE v3.40 or greater, not in the MPLAB X 
IDE.

To save all three operating systems into the PM3 SD card:

1. Insert any supported SD card into PM3 SD card slot.

2. Open MPLAB IPE v3.40 or greater and connect the MPLAB PM3 programmer to 
the computer.

3. Select Settings>Save firmware into SD Card. The output window in the MPLAB 
IPE displays messages when the operating systems and databases for the 8-bit, 
16-bit and 32-bit MCUs are successfully saved onto the SD card.

Points To Be Considered:

• Please ensure the PM3 operating system firmware version stored on the SD card 
matches the operating system firmware version on the MPLAB PM3 programmer. 
A mismatch may occur if an upgrade of the PM3 operating system was performed 
but the SD card firmware was not updated. Use the MPLAB IPE v3.40 or greater 
to select the Settings>Save firmware into SD Card option to load the PM3 SD 
card with the desired PM3 operating system firmware version.

• Any firmware versions of v3.40 or greater are not compatible with earlier versions 
of MPLAB IPE. It is highly recommended that the MPLAB PM3 use the firmware 
packaged within the same MPLAB IPE version 

Version Support

Prior to MPLAB IPE v3.25 One operating system supported

MPLAB IPE v3.25-3.35 Two operating systems supported (32-bit and all 
other devices)

MPLAB IPE v3.40 or greater Three operating systems supported (8-, 16-, 32-bit 
devices)
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3.4.3 PM3 Communication Setting Dialog

The PM3 Communication Setting dialog is available under the IPE Menu bar, Settings 
menu only when the associated check box for Allow “Communication” under Settings 
menu is selected in the Advanced Mode, Production Mode dialog. 

The MPLAB PM3 must be connected to the PC, using the appropriate cable, prior to 
using the PM3 Communication Setting dialog.

This dialog enables selecting the communication port for the MPLAB PM3 programmer 
through the IPE.

To use the RS-232 port on the MPLAB PM3, select the COM port option button and use 
the drop list to select the available port. Click the refresh button if necessary to view 
available ports. Click the Test button to check communication between the IPE and the 
MPLAB PM3. 

To use USB for the communication port, select the USB option button.

Setting up the COM Port Manually

On some systems, you may need to set up the communications port manually.

On Windows, from the Start menu, select Control Panel, then System and Security. 
Under the System settings, click Device Manager. Expand the Ports drop-down list 
and double-click on the port you are trying to use. Click the Port Settings tab, and 
select the following: 

Bits per second: 57600 (baud rate)
Data bits: 8
Parity: None
Stop bits: 1
Flow control: Hardware

Click Advanced. Uncheck the Use FIFO buffers check box. 

Reboot the PC to implement the change.

3.5 HELP MENU

The Help menu provides access to the online IPE help, the readme for IPE and 
information about the program.
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Appendix A. Revision History
Revision A (December 2013)

This is the initial release of this document.

Revision B (August 2015)

Modified Section 1.2 “Software Installation Requirements”. The IPE is now a separate 
installation than the MPLAB X IDE.

Modified the description of Production Mode.

In Chapter 2. “General Setup”:

• Added information on new features: Recently Used option in the Family list of 
devices and Creating Desktop Shortcuts.

• Added information on Preserve Memory options.

• Added notes regarding MPLAB PM3 programmer environment files.

• Added a note in the description of the Allow Import Hex file option in Table 2-5.

• Added information regarding using the MPLAB PM3 programmer with the option 
Allow “Communication” under Settings menu in Table 2-5.

• Added Special Memory Regions information to Table 2-6.

In Chapter 3. “IPE Reference”:

• Added a note regarding the File>Import>Hex option.

Revision C (March 2017)

• Added Note with location of Readme file for MPLAB IPE in Section 1.2 “Software 
Installation Requirements”.

• Added Section 2.4.2 “Staying Logged In”.

• Updated memory range descriptions in Table 2-2 .

• Updated environment settings options in Table 2-3.

• Revised Section 2.5.5 “SQTP” and added sections for using SQTP with MPLAB 
PM3 and with PIC32 devices.

• Added new SQTP setting in Table 2-6.

• Updated Table 3-1 to add more field descriptions to the main IPE window.

• Added new Read Device ID option to the View menu in Section 3.3 “View Menu”.

• Added new settings menu command in Table 3-3 for saving firmware into SD card 
and added a revised Section 3.4.2 “Save Firmware into SD Card”.
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Support
INTRODUCTION

Please refer to the items discussed here for support issues.

• Warranty Registration

• The Microchip Web Site

• myMicrochip Personalized Notification Service

• Customer Support

WARRANTY REGISTRATION

If your development tool package includes a Warranty Registration Card, please 
complete the card and mail it in promptly. Sending in your Warranty Registration Card 
entitles you to receive new product updates. Interim software releases are available at 
the Microchip web site.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at http://www.microchip.com. This 
web site is used as a means to make files and information easily available to 
customers. Accessible by using your favorite Internet browser, the web site contains 
the following information:

• Product Support – Data sheets and errata, application notes and sample 
programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

myMICROCHIP PERSONALIZED NOTIFICATION SERVICE

Microchip's personal notification service helps keep customers current on their 
Microchip products of interest. Subscribers will receive e-mail notification whenever 
there are changes, updates, revisions or errata related to a specified product family or 
development tool.

Please visit http://www.microchip.com/pcn to begin the registration process and select 
your preferences to receive personalized notifications. A FAQ and registration details 
are available on the page, which can be opened by selecting the link above.
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When you are selecting your preferences, choosing “Development Systems” will 
populate the list with available development tools. The main categories of tools are 
listed below:

• Compilers – The latest information on Microchip C compilers, assemblers, linkers 
and other language tools. These include all MPLAB C compilers; all MPLAB 
assemblers (including MPASM™ assembler); all MPLAB linkers (including 
MPLINK™ object linker); and all MPLAB librarians (including MPLIB™ object 
librarian).

• Emulators – The latest information on Microchip in-circuit emulators.These 
include the MPLAB REAL ICE in-circuit emulators

• In-Circuit Debuggers – The latest information on Microchip in-circuit debuggers. 
These include the MPLAB ICD 3 in-circuit debuggers and PICkit 3 debug express.

• MPLAB X IDE – The latest information on Microchip MPLAB X IDE, the 
Windows® Integrated Development Environment for development systems tools.

• Programmers – The latest information on Microchip programmers. These include 
the device (production) programmers MPLAB REAL ICE in-circuit emulator, 
MPLAB ICD 3 in-circuit debugger, MPLAB PM3, and PICkit 3 development 
(nonproduction) programmer.

• Starter/Demo Boards – These include MPLAB Starter Kit boards, PICDEM demo 
boards, and various other evaluation boards.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Technical Support

Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document. See our web site 
for a complete, up-to-date listing of sales offices.

Technical support is available through the web site at http://support.microchip.com.

Documentation errors or comments may be emailed to docerrors@microchip.com.
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