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GETTING STARTED WITH
MPLAB® MINDI™
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Preface
INTRODUCTION
This chapter contains general information that will be useful to know before using the 
MPLAB® Mindi™ Analog Simulator Tool. Items discussed in this chapter include:

• Document Layout
• Conventions Used in this Guide
• Recommended Reading
• The Microchip Web Site
• Customer Support
• Document Revision History

DOCUMENT LAYOUT
This document describes how to use the MPLAB® Mindi™ Analog Simulator Tool as a 
development tool to emulate and debug firmware on a target board. The manual layout 
is as follows:

• Introduction
• Running MPLAB® Mindi™ Simulator

• Welcome Page Overview and Navigation

• Creating a New Schematic

• Running the Simulation

• Simulation Results

NOTICE TO CUSTOMERS

All documentation becomes dated, and this manual is no exception. Microchip tools and 
documentation are constantly evolving to meet customer needs, so some actual dialogs 
and/or tool descriptions may differ from those in this document. Please refer to our web site 
(www.microchip.com) to obtain the latest documentation available.

Documents are identified with a “DS” number. This number is located on the bottom of each 
page, in front of the page number. The numbering convention for the DS number is 
“DSXXXXXXXXA”, where “XXXXXXXX” is the document number and “A” is the revision level 
of the document.

For the most up-to-date information on development tools, see the MPLAB® IDE online help. 
Select the Help menu, and then Topics, to open a list of available online help files.
 2017 Microchip Technology Inc. DS50002564A-page 5
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CONVENTIONS USED IN THIS GUIDE

This manual uses the following documentation conventions:

DOCUMENTATION CONVENTIONS

Description Represents Examples

Arial font:

Italic characters Referenced books MPLAB® IDE User’s Guide

Emphasized text ...is the only compiler...

Initial caps A window the Output window

A dialog the Settings dialog

A menu selection select Enable Programmer

Quotes A field name in a window or 
dialog

“Save project before build”

Underlined, italic text with 
right angle bracket

A menu path File>Save

Bold characters A dialog button Click OK

A tab Click the Power tab

N‘Rnnnn A number in verilog format, 
where N is the total number of 
digits, R is the radix and n is a 
digit.

4‘b0010, 2‘hF1

Text in angle brackets < > A key on the keyboard Press <Enter>, <F1>

Courier New font:

Plain Courier New Sample source code #define START

Filenames autoexec.bat

File paths c:\mcc18\h

Keywords _asm, _endasm, static

Command-line options -Opa+, -Opa-

Bit values 0, 1

Constants 0xFF, ‘A’

Italic Courier New A variable argument file.o, where file can be 
any valid filename

Square brackets [ ] Optional arguments mcc18 [options] file 
[options]

Curly brackets and pipe 
character: { | }

Choice of mutually exclusive 
arguments; an OR selection

errorlevel {0|1}

Ellipses... Replaces repeated text var_name [, 
var_name...]

Represents code supplied by 
user

void main (void)
{ ...
}
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Preface
RECOMMENDED READING

This user’s guide describes how to use the MPLAB® Mindi™ Analog Simulator Tool. 
Other useful documents are listed below. 

• None available at this time.

THE MICROCHIP WEB SITE

Microchip provides online support via our web site at www.microchip.com. This 
web site is used as a means to make files and information easily available to 
customers. Accessible by using your favorite Internet browser, the web site contains 
the following information:

• Product Support – Data sheets and errata, application notes and sample 
programs, design resources, user’s guides and hardware support documents, 
latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical 
support requests, online discussion groups, Microchip consultant program 
member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip 
press releases, listing of seminars and events, listings of Microchip sales offices, 
distributors and factory representatives

PRODUCT CHANGE NOTIFICATION SERVICE 

Microchip’s customer notification service helps keep customers current on Microchip 
products. Subscribers will receive e-mail notifications whenever there are changes, 
updates, revisions or errata related to a specified product family or development tool of 
interest.

To register, access the Microchip web site at www.microchip.com, click on Product 
Change Notification and follow the registration instructions.

CUSTOMER SUPPORT

Users of Microchip products can receive assistance through several channels:

• Distributor or Representative

• Local Sales Office

• Field Application Engineer (FAE)

• Technical Support

Customers should contact their distributor, representative or field application engineer 
(FAE) for support. Local sales offices are also available to help customers. A listing of 
sales offices and locations is included in the back of this document.

Technical support is available through the web site at: 
http://www.microchip.com/support.

DOCUMENT REVISION HISTORY

Revision A (January 2017)

• Initial Release of this Document.
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Getting Started with MPLAB® Mindi™ Analog Simulator Tool
1.1 INTRODUCTION

The MPLAB® Mindi™ Analog Simulator Tool is a comprehensive tool for circuit 
analysis. It consists of:

• SIMPLIS (SIMulation of Piecewise LInear Systems): A circuit simulator 
specifically designed to handle the simulation challenges of switching power 
systems. Similar to SPICE, SIMPLIS works at the component level, but typically 
can perform a transient analysis of a switching circuit 10 to 50 times faster. For 
switching power systems, the Piecewise Linear (PWL) modeling and simulation 
techniques employed by SIMPLIS result in qualitatively superior convergence 
behavior as compared to SPICE.

• SIMetrix: A general analog and mixed-signal simulator that includes an enhanced 
SPICE simulator, schematic editor and waveform viewer in a unified environment. 
It is easy to use, offers good accuracy and performance, and rapid convergence 
for a broad range of analog and mixed-signal design applications.

1.2 RUNNING MPLAB® MINDI™ SIMULATOR

To start the MPLAB Mindi Simulator, double-click on the desktop shortcut after 
installation or select Start>All Programs>Mindi 8.00. A splash screen will display the 
MPLAB Mindi Simulator logo followed by the MPLAB Mindi Simulator desktop.

FIGURE 1-1: MPLAB® Mindi™ Simulator Splash Screen.
 2017 Microchip Technology Inc. DS50002564A-page 9
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FIGURE 1-2: MPLAB® Mindi™ Simulator Desktop.

FIGURE 1-3: MPLAB® Mindi™ Update Settings Window.

NOTICE

It is strongly recommended that the user lets MPLAB® Mindi™ periodically check for 
updates to ensure that the simulator always has the latest models and example 
schematics. 
The user can do this by clicking on Help>Check for updates… and set the Automatic 
Update Schedule to Monthly.
DS50002564A-page 10  2017 Microchip Technology Inc.
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1.3 WELCOME PAGE OVERVIEW AND NAVIGATION

After the MPLAB Mindi Simulator start-up, the Welcome Page will be shown. It has 
quick links for the following actions:

• Create New/Open: Open or create a new schematic for SIMPLIS or SIMetrix from 
scratch.

• Application Schematics: Browse existing application schematics by category.

• Recent Schematics: Open recent schematics.

• MPLAB® Mindi™ Support: Get help or more application schematics from 
Microchip Technology Inc.

The existing directory structure, containing application schematics, can also be visualized 
in the left frame by clicking on the File View tab.

FIGURE 1-4: Directory Structure in the File View Tab.
 2017 Microchip Technology Inc. DS50002564A-page 11
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The user can also easily navigate through this directory structure using the Welcome 
Page breadcrumbs by clicking on one directory in the Application Schematics frame.

FIGURE 1-5: The Application Schematics Frame.

During navigation, the breadcrumb area will indicate the current path in the directory 
hierarchy.

FIGURE 1-6: Breadcrumb Area View Showing the Current Path.

Note: The directory-type icon  means that the user can go down in the hierarchy. 
The Mindi  icon represents folders that are at the bottom level. In those 
folders, you can find the application schematic that you want. The faded 
icons mean empty directories.
DS50002564A-page 12  2017 Microchip Technology Inc.
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FIGURE 1-7: MPLAB® Mindi™ Application Schematics View.

The schematic files have two types of icons. SIMetrix files are marked with the  icon 
and SIMPLIS schematics are marked with the  icon.

NOTICE

It is highly recommended that if the example schematics require modifications, the 
user should save the modified schematics in a different location by using 
File>Save Schematic As… to avoid any potential conflicts.
 2017 Microchip Technology Inc. DS50002564A-page 13



Getting Started with MPLAB® Mindi™ Analog Simulator Tool
1.4 CREATING A NEW SCHEMATIC

The user can create a new schematic from File>New>SIMetrix/SIMPLIS Schematic or 
by using the Create New/Open quick link from the Welcome Page.

By pressing the <Ctrl + G> key combination, the user can see all the models that are 
installed.

Microchip Technology Inc. models are available from Place>From Microchip Library. 
Here, the user will find only the models that are compatible with the schematic type 
(SIMetrix or SIMPLIS).

FIGURE 1-8: View of Installed Models.
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1.5 RUNNING THE SIMULATION

After opening a Microchip application schematic, the user can run the default analysis 
by pressing the <F9> key or by clicking on Simulator>Run Schematic.

FIGURE 1-9: Running the Default Analysis on a Microchip Schematic.

The default analysis type is highlighted in the application schematic’s file name 
(e.g., MCP1623_AC_Load_Transient) and its parameters can be altered after 
opening the Choose Analysis window, which is available by pressing the <F8> key or 
by clicking on Simulator>Choose Analysis. If the user wants to run a user-created 
schematic, the analysis type and its parameters must be chosen first.

FIGURE 1-10: The Choose Analysis Window.
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The analysis options for SIMPLIS and SIMetrix are different and the models are not 
compatible from one tool to another. If the user wants to run a SIMPLIS schematic 
using the SIMetrix tool (or vice versa), the MPLAB Mindi Simulator will issue a warning 
and will highlight the non-compatible parts.

FIGURE 1-11: MPLAB® Mindi™ Simulator Warning Message with Highlighted Non-Compatible Parts.
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1.6 SIMULATION RESULTS

The user can check the state of the analysis in the Simulation Status window.

FIGURE 1-12: Simulation Status Window.

After the simulation is finished, the results will pop up. 

The MPLAB Mindi Simulator can do time domain (waveforms) and frequency domain 
(Bode plots) analysis. 

A time domain simulation shows characteristics, such as response time and overshoot.

FIGURE 1-13: Time Domain Simulation.

Note: The schematic must have signal probes that are consistent with the 
analysis type.
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While time domain analysis shows how a signal changes over time, frequency domain 
analysis shows how the signal’s energy is distributed over a range of frequencies.

FIGURE 1-14: Frequency Domain Simulation

This frequency domain analysis produces the Bode plots. These plots include critical 
information regarding the circuit’s closed-loop stability, such as gain and phase margins.
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