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1. Installing GDD X plug-in under MPLAB X
Pre-requisites
1. MPLABX IDE (v1.20 and above).
2. Java Runtime Environment (v1.6.0 and above).

Plug-in Installation Steps
1. Launch MPLAB X IDE, Navigate to Tools ->Plug-ins.

The below Plug-in dialog should appear.

X P =
Updates | Available Flugins (15) | Downloaded (1) | Installed (24) | Setﬁngsl
Reload Catalog Search:
Update  Name Category ¥ :
|pdate
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2. Select “Downloaded” tab and click on “Add Plug-ins” button.

x Plugins

| Updates | Avaiable Plugins (15) | Downloaded | Installed (24) | Settings |

Add Plugins...

Instal

Name

Install

K 2dd Plugins

Lokin: | , build

1 EE

|| com-microchip-mplab-modules-gdd.nbrm

L =
o
Recent Items

Desktop

F

My Documents

Computer

I
H File name:

Netwark ' r
stnor Files of type: \Plugin distribution files (*.nbm)

*

Cancel
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3. Locate GDD X NBM file in the local disk from the user saved path. The
released version of GDD X NBM file is named as “com-microchip-mplab-
modules-gdd.nbm”.

o 1

3K Add Plugins (=S
Look in: . build ': ; ] ?"E

com-microchip-mplab-modules-gdd.nbm:

L Jeverrd.
oY

Recent Items

Desktop

4
My Documents

A

—

Computer

= Y
‘...4 File name:
Metwork - r 1
Files of type: Plugin distribution files {*.nbm) -

4. Select the NBM (com-microchip-mplab-modules-gdd.nbm) file and Click on
“Open” button.
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5. In the “Downloaded” tab you can see “Graphics Display Designer X" with
description and plug-in version.

| updates | Avalable Fugns (11)| Donioasded (1) | nstaled (23) | Settngs

Add Plugrs... Search:

Instal Hame . lep—ul]
Graphics Display Designer X Resmive
(iraphics Display Desigrer ¥ P Y : :
i Community Contributed Plugin
|
Version: 1.0
Dates 1/31/13 I
Source: tom-mictachip-mplab-modules-god. nbm |
Plugin Description i

The Graphics Desplay Desgrer X(500 ) 5 2 MPLAB X IDE plug-n that provides you a
|. quick and eagy way of ceatng graphical user interface (GUT) soreens for embedded
spbeations o Microchip micacontroliers, The GOO X i & visual design tal ereated for

wse with the Migochip Graphics Lirary,
VErSon
300 X v1.00 -
| dnsial | 1phogn selcted
[Lome |[ 1 |
— —— —
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6. Click on “Install” button to start plug-in installation. Press “Next” to continue
installation.

P )

& Plugin Installer =

Welcome to the Plugin Installer
The installer will download, verify and then install the selected plugins.

The following plugins will be installed:

Graphics Display Designer X [1.0]

< Back ’ MNext > ” Cancel ] Help
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7. Click and check the option “I accept the terms in all of the license
agreements” to enable “Install” button. The installation process will begin.

Note: Ignore warning dialogs related to signing.

P

K Plugin Installer =

License Agreement
Please read all of the following license agreements carefully,

In order to continue with the installation, you need to agree with all of the license agreements
assodated with the particular plugins.

Graphics Display Designer ¥ License Agreement
GOIMPORTANT,

MICROCHIP IS WILLING TO LICEMSE THE MPLAE IDE SOFTWARE AMD ACCOMPANYING
DOCUMENTATION OFFERED TO YOU OMLY ON THE CONDITION THAT YOU ACCEFT ALL OF THE
FOLLOWIMNG TERMS, TO ACCEPT THE TERMS OF THIS LICEMSE, CLICK T ACCEPT AND PROCEED
WITH THE DOWMLOAD OR. INSTALL. IF YOU DO NOT ACCEFT THESE LICEMSE TERMS, CLICK I DO
NOT ACCEFT, AMD DO NOT OPEN, DOWNLOAD OR INSTALL THIS SOFTWARE,

MPLAB IDE LICEMSE version 10

This Monexdusive Software License Agreement (Agreement) is a contract between you, your heirs,
- | i i Yo B fmirm T b | L T o Pl =gy = i

-

[7]1 accept the terms in all of the license agreements.
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8. Click on “Finish” to complete the Plug-in installation.

P =

& Plugin Installer =

Installation completed successfully
Click Finish to quit the installer.

The Plugin Installer has successfully installed the following plugins:
GGraphics Display Designer X

m
=]
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2. Creating a project using MPLAB X

Pre-requisites
1. The latest Microchip Application Libraries (MLA) must be installed on your
system. This can be downloaded from the Microchip website.
2. GDD X project folder must be inside “Microchip Solutions vXXXX-XX-XX"
folder only.
3. Latest C30/C32 compiler version for MPLAB X.

MPLAB X Steps
1. Click on File->New Project when MPLAB X starts.
Select Microchip Embedded->Standalone Project and press “Next”.
Select the device(PIC Device) and press Next.
Select Header dialog, press Next.
Select the programmer tool(ICD3, PICKit etc) and press Next.
Choose a compiler ( C30 ) and press Next.
This will open the last dialog which is the Project creation dialog. Please
follow the below steps exactly as mentioned
a. Name of the project must be entered in the “Project Name” field.
b. Project location must be inside the MLA directory (e.g.: E:\\Microchip
Solutions v2012-05-12) .

R A

x New Project @

Steps Select Project Name and Folder

Choose Project / Enter the name ofthe project
Select Device

Select Header
Select Tool

Project Name: gddx

Select Plugin Board Project Location: C:\Microchip Solutions v2012-10-15| Browse, ..

Select Compiler
Select Project Name and
Folder

~_ g o sTha T R

Project Folder: Ct'\Microchip Solutions w2012-10-15\gddx. X

I=h

Civerwrite existin

te existing project.

Also delete sources Folder is created automatically.

o Do not create seperate folder.
Set as main project

Browse to Microchip Solutions xos-o- folder

A

Encoding: 150-3859-1

< Back Mext = Finish H Cancel || Help

Microchip Technology Inc. Page 10



GDD X Plug-in Installation Guide

8. On Pressing Finish, the project creation is successful.

Project Settings: (Right click on Project name in Project window and Select
Properties)

1. Heap memory : Select pic30-Id->Option Categories(General)-> Heap Size.

' Project Properties - gddX
Cfiﬂ:“ 1 Options For pic30-d (v3_30 ()
= @ Coré: [defauk] Oplion cabegories: :'5""'““ El Enter hera
> KD3 ; / '
o Libraries Heap size (bytes) 3000 ol
2 Buidng/Loading ! (bryhes
= @ C30(Global Options) prock s )
3 pic3D-as Alowy overlapped sections |
L@ peab-gee Initiskze daka sactions [
@ e Pack data template [+
Create handies &
Creabe defauk 157
—ey Keen al I
Additional options:

Ophion Description | Generated Command Line

Lok J[ comcel || aeety J[ tee |
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2. Large code memory: Select pic30-gcc->Option Categories(Memory Model).

Project Properties - gdd¥X

X

e

Option Descripkion I izenerated Command Line |

Categories:
w0 (General Dpkion categories: IMemDry rnodel Reset |
= @ Conf: [Default]
i o RealICE Zode rodel Large ll
’ @ Loading [ata model Large LI
@ Libraries Sicalar model Large ll
e @ Building
E @ ¥C16 (Global Options) Location of constant model  |[default] LI
- ----- @ xclé-as
e @ welf-gee Additional options: I-Fnl:l-ivu:upts
e @ xclfdld

mMEemary space,

- Data - Put const gualified variables in the data

- Code - Put const qualified variables in the
auto_psy space. The compiler will access these
variables using the PSY window,

Manage Canfigurations. .,

(0] 4 I Zancel Apply

[mlmck:

Help
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3. Launching GDD X from MPLAB X
Select Tools->Embedded->Graphics Display Designer X.

Tearn Todls  ‘Window  Help

:. Embedded ¢ Graphics Display Designer % E

T A I:
] Apply Diff Pakch... D |g_| |_
5 Add ko Favaoribes

Templates
DTDs and XML Schemas

Plugins

Options
TT

4. Warnings while operating GDD X

1. When there is no project selected in MPLAB X IDE.

rwal'l"lihg! - h - ﬁ1
ﬁ..__ T

l _ Create a new MPLAE X 16/32-bit project in the MLA directory and set it as the main project.
% The MLA directery is typically named “Microchip Selutions wWYYY-MM-DD". Do not add any files in to the project.

2. When the MPLAB X project selected is not present in the Microchip Solutions

folder.

-
Warning! =

T ¥ W ¥ﬁ1

l _ Create a new MPLAB X 16/32-bit project in the MLA directory and set it as the main project.
% The MLA directary is typically named “Microchip Solutions vYYYY-MM-DD". Do not add any files in to the project.
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3. When user tries to open GDD X multiple times.

-
Warning! ﬁ

L GDD X is running.

Note: If GDD X doesn’t start from Tools->Embedded, then please restart the
MPLABX IDE and try again.

5. Code generation from GDD X

Create your design using the GDD X and save it.

Click on Project->Generate Code to generate code from GDD X and add files to
MPLAB X project

5. Graphics Display Designer X : Project : ;g
maiit Wiew Screen Sellings Help

¥ | New Project Ctrl+N
[e5 Open Project Cirl+0 I
Q Save Project Cirl+3 L
Save As Ctrl+Shift+5
k Generate Code

Import Default Files F
:’ Close project Ctrl+C

Exit

l

=" ListBox |
[ "~ Window J

Lo T - I
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MPLAB X Directory Structure on successful code generation

The project window on the MPLAB X on successful generation of code would look
similar to attached screen shot below.

The driver files would be under Drivers.

. Proj... <0 = |: Files

: Services

£ [g Header Files

BoardSupportPackage
Common

Drivers

-]
=)
= (E]
----- =
----- =
----- =
= (E]
----- &

il

¥l

GOD_GraphicsConfig.h
GDD_Resource.h
GDD_Screens.h
Graphics
GraphicsConfig.h
HardwareProfile.h
Main.h

G- [l§f Important Files
- B Linker Files
= [gF] Source Files

BoardSupportPackage
Common

Crivers

GDD_Resource.C
GDD_Screens.c
GOD_X_Ewent_Handler.c
Graphics

Mairn.c

- [f8¥ Libraries
- [ Loadables
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6. Uninstalling Plug-in from MPLABX

1. Navigate to Tools -> Plug-ins.

Updates | Avalable Plugins (11) | Dowrloaded (1) | Instaled (23) | settngs
.' Rekoad Cataiog ] cearch:
Update  Name Category ¥ :
|
|
|
I
— — —
Page 16
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2. Select “Installed” tab and check for “Graphics Display Designer X”.

‘ Plugins

| Updates | Available Plugins (10) | Downloadedl Installed (24) | Settings|

Search:
4
Select MName Category ¥ Active - . o
— oy = "| Graphics Display Designer X
[[] Subversion Base IDE o -
[7] Spelichecker Base IDE (V] Version: 1.0 -
[C] IDEPlatform Base IDE (V] Source: com-microchip-mplab-modules-gdd. nbm b I
[7] Spelichecker English Dictionaries Base IDE & [
[ Hudson Base IDE (V] in D -
[ Team Base IDE (V] Plugin ription |
[ cvs Base IDE 7]
[] PeripheralAndSFRs MPLAE DECore V] The Graphics Display Designer ¥ (GDD X) is a MPLAB X IDE plug-n that provides youa |
[[]  toolchainCommon MPLAB IDE V] quick and easy way of creating graphical user interface (GUI) screens for embedded I
[[]  toolchainMPASMWIN MPLAB IDE (V) applic_aﬁons on Micro_d1i|3 micr_ocoph'ollers. The GDD X is a visual design tool created for
[ toolchainXcs MPLAB TDE o use with the Microchip Graphics Library.
[ toolchainASM30 MPLAB IDE @ |= __ o
I [ toolchainHI-TECH MPLAB IDE (V) A
[] toolchainXCis MPLAB IDE V] Version
[ toolchainC30 MPLAB IDE (V)
[ toolchainC32 MPLAB IDE (V)
[ toolchainC1g MPLAB IDE (V)
[ toolchain¥c3z MPLAB IDE (V) GDD X v1.00
[7] MPLAB Hidden Menu Filter MPLAE IDE (Optional) &
— " . > February 2013
Graphics Display De: MPLAB Plugin v ([
[[] RCP Platform RCP Platform 9 - >
Activate [ Deactivate ] [ Uninstall ] 1 plugin selected

Microchip Technology Inc.
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3. Click “Uninstall” button and restart the MPLAB X IDE by selecting “Restart
Now” option.

rn Plugin Installer =~ - ﬁj

Restart application to complete deactivation
Restart application to finish plugin deactivation.

The Plugin Installer has successfully uninstalled the following plugins:

Graphics Display Designer X
(@ Restart Mow

(71 Restart Later

| Finish H Cancel Help

This will uninstall and remove the plug-in from MPLAB X IDE.
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