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Introduction

Sage welcomes you to Sage Estimating.

Read the supporting documentation carefully to make sure you understand the process before you install
and configure Sage Estimating.

l This Installation and Administration Guide includes a system overview, installation and configuration
instructions, and information about managing your Sage Estimating license.

l The Release Notes provide details about new features, database changes, known issues, and fixes.

l The Getting Started Guide provides an operational overview of the Sage Estimating software.

l The Sage 100 Contractor Integration Guide describes how to integrate Sage Estimating with Sage
100 Contractor, making certain data in that program available in Sage Estimating, and it explains
how to use the interface wizards to send proposals, budgets, and change orders you create in Sage
Estimating to Sage 100 Contractor.

l The Sage 300 Job Cost Integration Guide provides installation, setup, and operating instructions for
Sage 300 Job Cost integration.

l The Means Integration Guide provides installation, setup, and operating instructions for Means
Integrator.

Notes:

l For current information about supported operating systems, Internet browsers, Microsoft®
SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 101824, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

l Documentation for all supported versions of Sage Estimating (SQL) is available at
http://cdn.na.sage.com/Docs/en/customer/estimating/DocumentationEss.htm.

l Documentation for all supported versions of Sage 100 Contractor is available at
http://cdn.na.sage.com/docs/en/customer/100contractor/Documentation.htm.
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Conventions Used in this Document
This document uses the following conventions:

l Information you type into the software is shown in bold font. For example: Type Miscellaneous in the
box.

l The names of screens, windows, fields, and other features displayed by the software are shown in
bold font.

l Names of keys are also shown in bold font. For example: Enter or Tab. A plus sign (+) between two
key names indicates you should press the keys simultaneously.

l The names of buttons you can click are shown in bold font and enclosed in brackets. For example:
[OK] or [Post].

l Variable names or names that are specific to your installation may appear in italics and brackets. For
example: [Drive]\\[Server].

Notes, Tips, and Cautions

Note: This style shows that the information supplements the adjacent text.

Tip: This style indicates helpful points about using the software.

Caution! This style indicates important information to help you avoid a loss of critical data.

Important! This styles indicates critical information that you need to understand or important steps you
need to take.

Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font
with square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."
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Ways to Get Help
Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. You can
also call Customer Support.

TheHelp System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the
mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating displays Help in your default browser. If you have an Internet connection, it displays the
most current Help for your version of Sage Estimating available from a hosted Help server. If you have no
connection (you are working offline), it displays Help that was current when the software was released, and
is installed on your computer when you install Sage Estimating.

Important! Because the Microsoft Edge browser does not display locally installed help properly, we
recommend that you select a different default browser when working offline.

To get Help on a window option

To display Help for an option in a window, do one of the following:

l Click What's This? on the toolbar or on the title bar, and then click the option.

l Select What’s This? from the Help menu, and then click the option.

l Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window's purpose and what tasks you can perform in it, click
[Help] at the bottom of the window.

The Window Help Button
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To use Help to learn how to do tasks

1. Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu >
Help topics in classic view).

The Help Window

2. Use one of these tabs on the navigation pane to begin looking for a topic.

a. Contents contains Help subjects organized within books.

b. Click the Glossary heading on the Contents tab to view an alphabetical list of definitions of
terms used throughout the Sage Estimating software.

c. Index contains an alphabetical list of Help subjects.

When you see the topic you want, double-click it to display it.

3. Use the Search box to find articles that match the keywords you enter.
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Additional Self-help Resources

The Help menus available in ribbon view and in classic view provide convenient links to a variety of self-
help resources.

The Help menu in Ribbon view

The Help menu in Classic view
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Training
Sage University provides a series of training videos to help you get the most out of your Sage Estimating
software. To visit Sage University, go to www.sageu.com.

You can also click File > Help > Sage University.

Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click the File
menu button and then select Help > Submit Product Idea.
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Chapter 1: System Overview

Before you can run Sage Estimating, you need to activate your license, and install and configure the
components on which the Estimating system relies.

This chapter provides an overview of the Sage Estimating system, including:

l Installed components

l Tools you use to configure your system after installation

l The Sage online licensing system

Sage Estimating Components

With Sage Estimating Essential, the SQL Server, the Sage License Server, and the Sage Estimating
programs all reside on the same machine.
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Your On-Premise Sage Components

Your Sage Estimating system includes these components:

l Your purchased Sage Estimating applications

l Your Sage license server

l Your SQL Server instance

You set up all three components on a single machine.

The Sage Estimating application

The Sage Estimating application is the main component of the Sage Estimating suite of programs. It
includes the Sage Estimating Configuration Wizard, which you use to connect Sage Estimating to your
license server and to your SQL Server instance.

When it is connected to your Sage license server, Sage Estimating:

l Acquires a license use while you have it open.

Sage Estimating must maintain a connection to your Sage license server.

l Releases the license use when it is closed.

Your License Server

Your Sage license server communicates with the Sage online licensing system. It performs the following
tasks:

l It obtains licenses from Sage for your purchased products based on your registered Company name
and Sage Client ID, which must exactly match the Company name and Sage Client ID in your
account.

l It provides available license uses to your networked Sage Estimating computers.

Because it attempts to connect periodically to Sage, the license server must have continuous Internet
access.

Your SQL Server Instance

Your SQL Server instance serves up, stores, and processes Sage Estimating data (including estimates,
standard databases, address book, and so on).

The SageOnline Licensing System

Sage Estimating uses a convenient online system to activate and verify your Estimating license.
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The Sage online licensing system resides at Sage, and it:

l Maintains a list of your purchased modules and number of license uses.

l Provides information to your Sage license server (at your company) about the modules and license
uses to which your company is entitled.

You use the License Administration window to connect to the Sage online licensing system. When you
submit your registered Company name and Sage Client ID to Sage, the Sage online licensing system
determines the number of license uses and the features that your purchased license provides, and it
allocates the licenses to your license server for use in your environment.

Configuration Tools in Sage Estimating
After installation, you use the following configuration tools to set up Sage Estimating:

l License Administration. You use the License Administration window to activate and view your
product license on your designated Sage license server. For more information, see Activate your
license on the Sage license server and "Managing Your License" (page 32).

l Configuration Wizard. You use the Configuration Wizard to connect Sage Estimating to the
designated Sage license server and SQL Server instance. For more information, see D. Connect
Workstations to Your License Server (Configuration Wizard) and D. Connect Workstations to Your
License Server (Configuration Wizard) in Chapter 3—Installing and Configuring Sage Estimating.

l Estimating Management Console. You use the Estimating Management Console to manage your
SQL databases, estimates, custom reports, contacts, and security.
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Chapter 2: System and Other
Requirements

Before you install Sage Estimating, you should:

l Confirm your registration information:

1. Log into the Sage Customer Portal at:

https://customers.sagenorthamerica.com/

2. Confirm that the Company name used to register your Sage Estimating software exactly
matches the Company name used to activate your standard database.

3. If these names do not match, contact Customer Support before you install and activate Sage
Estimating.

l Ensure that your system meets the minimum hardware and software requirements.

As with any software, as we continue to enhance Sage Estimating, you will realize optimal system
performance by using up-to-date computer hardware (memory as well as overall hardware
specifications).

For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 101824, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

l Ensure that you have sufficient Windows permissions to install the software.

If you are upgrading from an earlier version of Sage Estimating, or you plan to use an existing SQL
Server instance, you must also have sufficient permissions on the SQL Server instance.

For more information, see "AccessRights" (page 10), later in this chapter.

Access Rights
The following sections describe the access rights you need to install and use Sage Estimating.
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Elevate Permissions

During installation, you may be prompted to elevate your privileges. If you do not acknowledge each
message within two minutes, the installation process will quit the task. If this occurs, you may receive a
separate message asking you to retry the task. To retry the task, click [Retry] and then elevate your
privileges when prompted.

SQLServer Permissions

Always use the Security feature in the Estimating Management Console to configure security for Sage
Estimating.

Important! Do not use SQL Server Management Studio to modify security settings.

For more information on setting up SQL Server security for Sage Estimating, see G. Set Up Estimating
Security.

Full Control of Specific Files and Folders Required

To use Sage Estimating, you must have full control of the following files and folders on your file server,
terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all the subfolders and files.

Caution! Incorrectly modifying Microsoft Windows security may severely impair your system operations.
Sage is not responsible for operation problems caused by incorrectly modifying your Microsoft Windows
security settings. To set permissions on your network or Windows operating system, you must have
advanced knowledge of your network. Contact your system administrator for assistance.

Product Operating
Systems

Required Folders
and Files

Location and Specifications

Sage
Estimating

64-bit Windows
systems

[Drive]:\Program
Files (x86)\Sage\
Estimating

This folder is the default installation
location for Sage Estimating.
However, your company may have
renamed this folder or installed it to
a different location.

Sage
Estimating

Windows 7,
Windows 8.1,
Windows 10

[Drive]
:\Users\Public\Sage\
Estimating
-and-
[Drive]

Sage Estimating installs necessary
files to these folders and requires
that the user has full control of
them.

Folders and Files Requiring Operator Control
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Product Operating
Systems

Required Folders
and Files

Location and Specifications

:\ProgramData\Sage\
Estimating

Note: Some of these folders may be hidden. To view them:

l In Windows 7: Open Windows Explorer, and then click Organize> Folder and Search Options>
View tab > Show hidden files and folders.

l In Windows 8.1 and Windows 10: Open Windows Explorer, click the View tab, and then select the
Hidden items check box in the Show/hide group.

Full Control and Read Access to Specific Registry Keys Required

To use Sage Estimating, you must have full control of the following Windows registry key on your file
server, terminal server, and workstations that have Sage Estimating installed. Make sure that your system
administrator also gives you full control of all subkeys.

l HKEY_CURRENT_USER

You should also have read access to the following registry keys and associated subkeys:

l HKEY_Local_Machine\Software\ODBC

l HKEY_Local_Machine\Software\Wow6432Node\Sage

Caution! Incorrectly editing the Microsoft Windows registry may severely damage your system. Sage is
not responsible for damage to your system caused by editing the registry. Before making changes to the
registry, contact your system administrator for assistance and make a backup copy of all valued data.
System administrators, see Microsoft Registry Editor Help topics for detailed instructions.
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Chapter 3: Installing and Configuring Sage
Estimating

You can set up Sage Estimating on a single computer.

Note: Sage Estimating Essential does not support a networked configuration.

The following sections step you through the installation and configuration of a Sage Estimating Essential
system on a standalone workstation.

Tip: For information on the other supported configurations of Sage Estimating, see "Installing and
Configuring Sage Estimating " (page 13).

Before You Install or Upgrade Sage Estimating

l Read and understand the information in this guide.

l If you are installing Sage Estimating on a new computer, make sure that .NET 3.5 is enabled.

l Install the appropriate operating system service pack, make sure that there is sufficient hard disk
space available, and ensure that your server and workstations meet all other hardware and
software requirements.

For current information about supported operating systems, Internet browsers, Microsoft®

SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 101824, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

l Make sure that you have full control of the necessary folders, files, and registry keys on your file
server, terminal server, and workstations that will have Sage Estimating installed.

For a list of the required folders, files, and registry keys for your operating system, see the chapter
on "System andOther Requirements" (page 10).

l Close all programs and services for the duration of the installation. This includes programs that
may be running in the background such as antivirus, email, and backup programs.

l You must have the appropriate permissions to perform certain tasks described in this chapter.

13Sage Estimating Essential v19.12 Installation and Administration Guide

https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824


Installing on a standalone workstation (overview)
You install Sage Estimating on a single computer that will store your Estimating data and also act as your
License Server.

On the workstation where you will run Estimating:

1. Install Sage Estimating (Section A)

2. Install and configure the SQL Server Instance (Section B)

3. Configure your license server (Section C)

4. Connect to the Sage license server (Section D)

5. Connect to SQL Server (Section E)

6. Install standard databases (Section F)

7. Set up roles and permissions as needed (Section G)

A. Install Sage Estimating
If you have not already done so, download the Sage Estimating installation files according to the
instructions provided in the software notice.

Note:

l The installation process may restart your computer during the installation. Ensure you close all
programs and applications before starting the installation to avoid losing any data. If your
computer restarts, log on to your computer again.

l If you choose to upgrade data from a previous version of Sage Estimating, the process may take
up to four hours, depending on the size of your databases. Plan accordingly.

Important!

l Do not install Sage Estimating unless you have sufficient hard disk space available.

l For current information about supported operating systems, Internet browsers, Microsoft®
SQL Server®, and other software, and about system requirements for servers and client
workstations, refer to our Knowledgebase article ID 101824, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.
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1. Double-click the SetMeUp.exe file in your local Sage Estimating Install folder.

The Sage Estimating Installfolder is at the location you specified during the Sage Estimating
download process. For example, if you downloaded the installation files to C:\Users\Public\Public
Documents\Sage Estimating, look in this folder for the SetMeUp.exe file.

2. When prompted by the User Account Control dialog box, click [Yes] to allow the program to make
changes to the computer.

3. Read the terms of the Sage License Agreement, and then click [Accept] to accept them.

4. On the Sage Estimating installation window that appears, select Install Sage Estimating.

Selecting this option alone installs the Sage Estimating software and support components.

SQL Server Express may be adequate if you are installing for demonstration or trial purposes and
for small databases. However, for large databases, Sage strongly recommends implementing your
Sage Estimating system with a standard version of SQL Server.

5. Follow the remaining steps as prompted by the installation process, which guides you through the
installation of Sage Estimating products and required support software.

B. Install and Configure SQL Server 
If you are installing Sage Estimating for the first time or if you need to create a SQL Server instance, Sage
recommends that you select the Create a new local SQL Server instance option when installing Sage
Estimating. This option will install a new instance of SQL Server Express with the settings that Sage
Estimating requires.

Notes:

l At the instance name prompt, type a name for the new SQL Server instance (database server) in
the box, and then click [OK].

The default instance name is SAGE_ESTIMATING, but you can give the instance any name you
want provided you do not give it the same name as any existing SQL Server instance on the
computer.

l SQL Server allows an unlimited database size. However, SQL Server Express limits the database
size to 10 gigabytes (GB). Sage Estimating warns you if your database size nears the limit.

If you select the option to create a new SQL Server instance in the Select installation options for
Sage Estimating window, the installation process automatically configures a new Sage
Estimating-compatible instance for you.

l The installation process may restart your computer. If your computer restarts, log back onto your
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computer at the prompt.

l You can install an approved instance of SQL Server side by side on a computer where other
versions of SQL Server are installed. Be aware that installing Sage Estimating may result in an
"Install completed with errors" message. However, the resulting Sage Estimating installation
operates correctly.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®,
and other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 101824, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

C. Configure Your License Server (License Administration)

Before configuring your license server

Make sure you have an active Internet connection.

Activate your license on the Sage license server

To activate your license:

1. On the computer where you installed Sage Estimating Essential, open the License Administration
window.

Click Start > All Apps > Sage Estimating > License Administration.

2. Ensure that the computer named in the License server box is the same machine where Sage
Estimating is installed.

If it is not the same, click Change server, and then enter the correct name or IP address of your
computer.

3. In the Registration Information section, submit your registration details as follows:

a. Click the Edit registration information link.

b. In the Sage client ID box, type your client number.

c. In the Registration name box, type your registered company name exactly as provided by
Sage.

d. Click [OK]
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If the activation was successful, the Licensed Modules grid displays the modules that you
have purchased.

For more information, see "Managing Your License" (page 32).

D. Connect to the Sage license server(ConfigurationWizard)
The Configuration wizard is installed automatically during Sage Estimating installation.

To connect to your Sage license server

1. Start the Configuration wizard as follows, depending on your operating system:

l For Windows 7: Click Start >  All Programs > Sage > Estimating 19.12 > Configuration
Wizard.

l For Windows 8.1 or Windows 10: Click the Configuration Wizard tile on the Start menu, or
right-click outside the tile area, and then click All apps >  Sage > Configuration Wizard.

Important! Depending on your version of Windows, you may need to elevate your permissions
before starting the Configuration wizard. On the Start menu, right-click Configuration Wizard, and
then select Run as administrator.

2. In the navigation pane of the Configuration Wizard, click Licensing.

3. In the right-hand pane, select the License Server option, and then click [Change].

4. In the Specify License Server window that opens:

a. In the Computer box, type localhost.

b. In the Port number box, ensure that the port is set to 48650.

c. Click [OK].

Note: A green check mark appears beside the Licensing item in the navigation pane if you configured
the license server successfully.

For more information, see "Managing Your License" (page 32).

E. Connect to SQL Server (ConfigurationWizard)
As a final step in configuring the workstation, connect to the SQL Server instance ("server"), as follows:
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1. Start the Configuration wizard as follows, depending on your operating system:

l For Windows 7: Click Start >  All Programs > Sage > Estimating 19.12 > Configuration
Wizard.

l For Windows 8.1 or Windows 10: Click the Configuration Wizard tile on the Start menu, or
right-click outside the tile area, and then click All apps >  Sage > Configuration Wizard.

2. In the navigation pane of the Configuration wizard, click Data Server.

3. Beside the Server box, click [Select] (or click [Change] to select a different instance).

The Select a SQL Server window appears.

4. In the Server box, type localhost.

Tip: If you are not sure of the name, click [Search], and then select the server from the list.

5. Click [Verify].

A green check mark beside the Data Server item(in the navigation pane indicates a successful
connection to your SQL Server Instance.

6. Click [Close] to exit the Configuration wizard.

For more information, see "Configuring SQL Server" (page 23).

F. Install Standard Databases
Estimating enables you to keep one or more standard databases that store all the standard cost items you
use to prepare estimates—including labor, material, and equipment items and prices, takeoff formulas, and
more.

You can build a standard database from scratch or purchase an industry-standard one and customize it to
suit your needs.

If you have been maintaining your own items list that you want to continue to use, you can install a “shell”
database that comes with Sage Estimating so that you do not have to set up your own database from
scratch. These databases contain CSI industry phases codes, but no items. After installing a shell
database, you enter an item list manually, or you can import items from an Excel spreadsheet.

Install standard databases

If you have purchased standard databases, you can install and activate them when you finish setting up
Sage Estimating (SQL). You install Standard databases using the Estimating Management Console.
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1. In the Estimating Management Console, click the Standard DB tab.

2. On the toolbar, click Install Databases.

3. From the dropdown list, select Optional Databases, and then double-click each standard database
you want to install from the Available Databases pane.

Alternatively, if you want to install one of the shell databases (with no items, only phases), select
Shell Databases from the dropdown list.

4. In the Databases to install box, type the activation code for each standard database. (The activation
code must match your registration name exactly.)

Note: Shell databases that come with Sage Estimating do not have activation codes.

5. Click [Install].

G. Set Up Estimating Security
There are two aspects to security in Sage Estimating: feature security and estimate security.

As a Sage Estimating administrator, you manage security by maintaining users, roles, and permissions on
the Security tab of the Estimating Management Console.

Note: At least one operator must be assigned to the administrator role at all times. Typically, the person
who Installs SQL Server is the first Sage Estimating administrator. That person can then assign roles
and permissions to others.

l If you install SQL Server as part of the Sage Estimating installation, you are automatically
assigned the administrator role.

l If you install SQL Server outside the Sage Estimating installation process, you should assign
yourself or another user to the sysadmin role for the instance.

About feature security

Important! Only a Sage Estimating administrator can set up and manage roles and permissions.

In the Security window, you use the Users tab to add Estimating users and the Roles tab to assign
predefined roles to those users. Each role is associated with certain types of permissions. By assigning
different roles to users, you control who can:

l Change estimate security

l Create estimates
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l Edit a shared catalog

l Edit a standard database

l Manage custom reports

l Manage shared layouts

l Run the Management Console

l View databases and allow takeoff

About estimate security

Important! Only administrators and users who have Change estimate security permission can modify
estimate security.

By default, all users can view and edit your estimates. If you want to restrict access to estimates, you must
turn off the Allow all users to view and edit all estimates option on the Estimates tab in the Security
window.

You grant View and Edit access individually for each estimate and for each user.

Setting up roles and permissions

Setting up roles and permissions involves the following general steps:

1. Adding roles and assigning features.

2. Adding users and assigning roles.

To add roles and assign features:

1. Start the Estimating Management Console.

l For Windows 7: Click Start > Programs >  Sage Estimating 19.12 > Estimating Management
Console.

l For Windows 8.1 or Windows 10: Click the Estimating Management Console tile from the Start
menu, or right-click outside the tile area, and then click All apps > Sage Estimating
Management Console.

2. In the Estimating Management Console, click [Security].

3. In the Security window, click the Roles tab.

4. Click [Add] to open the Add Role window.
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5. In the Add Role window:

a. In the Name and Description boxes, type a name and description for the new role.

b. In the Select Features for Role box, select feature permissions that comes with this role.

6. Click [OK].

To add users and assign roles:

1. Start the Estimating Management Console.

l For Windows 7: Click Start > Programs >  Sage Estimating 19.12 > Estimating Management
Console.

l For Windows 8.1 or Windows 10: Click the Estimating Management Console tile from the Start
menu, or right-click outside the tile area, and then click All apps > Sage Estimating
Management Console.

2. In the Estimating Management Console, click [Security].

3. In the Security window, click the Users tab.

4. Click [Add] to open the Add User window.

5. In the Add User window:

a. In the User Id box, select the user you want to add from the list, or search the network for the
user.

b. In the Role box, select the role that you want to assign to this user.

6. Click [OK].

Note:

l If you know the user Id you’re trying to add, key it into the User Id field and select the role you’d like
to assign to that user.

l If you don’t know the User Id, you can click [Search] to retrieve a list of domain users (and groups)
to choose from.

l Depending on your domain user count, the search method could take some time.

l Selecting a User Id will add that user. Selecting a Group Id will add all users contained in that
group.

Managing Security

You can manage the user / role relationship using either the User tab or the Role tab. Changes you make
on one tab are reflected on the other tab .
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You can manage estimate security permissions from the Estimates tab, as well as the Estimate Info
window if you have Change estimate security permission.

H. After You Complete Your Setup
Restart all programs and services that you shut down for the installation.

The Sage Estimating software performs a series of checks the first time you start it. If the Sage Estimating
software notifies you of any error conditions, correct the condition before continuing.

Supporting documentation for Sage Estimating is available at
http://cdn.na.sage.com/Docs/en/customer/estimating/DocumentationEss.htm, or by clicking Help
> Product Documents on the ribbon in Sage Estimating. These documents are in Adobe Acrobat (PDF)
format. If you do not already have Adobe Acrobat or Acrobat Reader, you can download Adobe Acrobat
from www.adobe.com.

Important! For performance reasons, if you plan to run a virus scanner on the machine that hosts the
SQL Server instance, you should exclude files that have MDF, LDF, NDF, BAK, TRN, and TRC
extensions. You should also exclude additional processes for the version of SQL Server that you are
running. For more information about the files and processes to exclude, see Microsoft Knowledgebase
article 309422 at http://support2.microsoft.com/kb/309422.
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Chapter 3: Configuring SQL Server

Follow the instructions in this section to install and configure a SQL Server instance manually for use with
Sage Estimating.

For current information about supported operating systems, Internet browsers, Microsoft® SQL Server®,
and other software, and about system requirements for servers and client workstations, refer to our
Knowledgebase article ID 101824, available at
https://support.na.sage.com/selfservice/viewdocument.do?externalId=101824.

Setting Up a SQL Server Instance for Use with Sage Estimating
If you already use a supported version of Microsoft SQL Server, you can set up another instance to work
with Sage Estimating. (Options described in this section may vary slightly depending on the version you are
installing.)

Note: If you choose to uninstall your existing instance first, restart your server before reinstalling to avoid
problems with the new installation.

Caution! Do not change the owner of any databases in the Sage Estimating instance.

Configure your new SQL Server instance using the settings outlined in the following sections.
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Named Instance

Instance Configuration Settings

You must use a named instance. You can give the instance any name you want. However, if you have
installed a previous version of Sage Estimating (such as version 11.2), give the new instance a different
name that is easily recognizable (such as SAGE_EST_19_11).
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AuthenticationMode

AuthenticationMode Settings

The instance must support Mixed Mode authentication (Windows Authentication and SQL Server
Authentication). This means either Windows authentication or SQL Server authentication can be used to
access the database information.

When you use Windows authentication, the operator requires permission to use SQL Server or be a
member of a group that has permission. In Windows authentication mode, SQL Server validates the
account name and password using information from the Windows operating system.

When you use SQL Server authentication, the operator requires system administrator (sysadmin) rights in
SQL Server. SQL Server authentication is used for backwards compatibility and requires a strong
password.

Collation Settings

Collation settings must be Latin1_General, case-sensitive, and accent-sensitive (Latin1_General_CS_
AS).

You customize the collation settings during the server configuration portion of the SQL Server installation.
In the SQL Server collation customization window, make the following selections:
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1. Select the Windows collation designator and sort order option (instead of SQL collation, which is the
default):

l Latin1_General (for the collation designator)

l Case-sensitive

l Accent-sensitive

2. Clear all other options.

Setting Up Security
You use the Security feature in the Estimating Management Console to set up user access to your
estimates and standard databases.

For more information on setting up SQL Server security for Sage Estimating, see G. Set Up Estimating
Security.

Setting Firewall Exceptions
If you experience communication issues with a remote SQL Server instance, you may be using a firewall
that is set up to block network traffic between your computer and the SQL Server instance. To allow
communication, you need to set two firewall exceptions:

l The SQL Server Database Engine service. (You need to set a SQL Server Database Engine
exception for each instance of SQL Server you use with Sage Estimating.)

l The SQL Server browser service

Notes:

l The following instructions apply to Windows Firewall. If you are using another firewall for your
system, contact the firewall manufacturer for instructions on setting service exceptions.

l If you are using SQL Server on a workgroup server, you must set separate firewall exceptions to
allow your workstations to communicate with the SQL Server instance. Refer to Setting the
Firewall for Workgroups instructions.

l Sage recommends contacting your system administrator if you need to change firewall settings.

Setting the SQL Server Database Engine exception

1. Determine the path to your SQL Server computer.

2. On the computer or server where SQL Server is installed, open the SQL Server Configuration
Manager.
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3. Start the SQL Server Configuration Manager.

In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

The SQL Server Configuration Manager opens.

4. In the left-hand pane of the SQL Server Configuration Manager, select SQL Server Services.

5. In the right-hand pane, right-click on SQL Server (INSTANCE), where (INSTANCE) is the
SQL Server instance for which you are creating the firewall exception, and select Properties.

6. In the SQL Server Properties window, click the Service tab.

7. In the Binary Path entry, note or record the path described within the quotation marks. This is the file
path to the SQL Server instance binary files (the path is contained only within the quotation marks—
ignore the text outside the quotes).

8. Open Windows Firewall.

If you are using Windows 7, select Start > Control Panel > System and Security > Administrative
Tools > Windows Firewall with Advanced Settings.

If you are using Windows 8.1 or Windows 10, select Start > All apps > Windows System > Control
Panel > System and Security > Administrative Tools > Windows Firewall > Advanced Settings.

a. In the left-hand pane of the Windows Firewall with Advanced Security window, right-click
Inbound Rules, and then select New Rule.

b. In the New Inbound Rule wizard, select the Program option, and then click [Next].

c. Select the This program path option.

d. Click [Browse] and locate the sqlservr.exe file at the binary file path you recorded in step 1,
and then click [Open].

e. Select the Allow the connection option, and then click [Next].

f. Select the Domain, Public, and Private check boxes, and then click [Next].

g. Type the name of your SQL Server instance in the Name box.

h. Click [Finish] to create the firewall exception for the SQL Server Database Engine service.

The Windows Firewall with Advanced Security window opens.
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Setting the SQL Server browser service exception

1. Open Windows Firewall.

If you are using Windows 7, select Start > Control Panel > System and Security > Administrative
Tools > Windows Firewall with Advanced Settings.

If you are using Windows 8.1 or Windows 10, select Start > All apps > Windows System > Control
Panel > System and Security > Administrative Tools > Windows Firewall > Advanced Settings.

2. In the left-hand pane of the Windows Firewall with Advanced Security window, right-click Inbound
Rules, and then select New Rule.

3. In the New Inbound Rule wizard, select the Port option, and then click [Next].

4. Select UDP as the protocol type.

5. Select the Specific local ports option, and then type 1434 in the corresponding box.

6. Click [Next].

7. Select the Allow the connection option, and then click [Next].

8. Select the Domain, Public, and Private check boxes, and then click [Next].

9. Type SQL Server Browser Exception in the Name box.

10. Click [Finish] to create the firewall exception for the SQL Server browser service.

Setting the Firewall for Workgroups

If you are using SQL Server with a workgroup, you must set the firewall on the workgroup server to allow
workstation computers to connect to the instance.

Note: If you are using SQL Server on a domain-based server, you may still need to configure your
firewall to allow remote communication. Refer to the SQL Server Guide for instructions.

Firewall Settings (Windows 7, Windows 8.1, and Windows 10)

1. Open Windows Firewall.

l In Windows 7: Click Start > Control Panel > System and Security > Windows Firewall
> Advanced Settings.

l Windows 8.1 or Windows 10: Click Start > Windows System > Control Panel > System and
Security > Windows Firewall > Advanced Settings.
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2. Set rules for inbound and outbound TCP connections:

a. Right-click Inbound Rules, and then select New Rule.

b. In the Inbound Rule wizard, select Port, and then click [Next].

c. Select TCP, and then select Specific local ports.

d. In the Specific local ports box, type 8005, 49385, and then click [Next].

e. Select Allow the connection, and then click [Next].

f. Select the Domain, Private, and Public check boxes, and then click [Next].

g. In the Name box, type Sage Estimating Service (or other appropriate name), and then click
[Finish].

h. Repeat steps a through g for outbound TCP connections, selecting Outbound Rules in step a.

3. Set rules for inbound and outbound UDP connections:

a. Right-click Inbound Rules, and then select New Rule.

b. In the Inbound Rule wizard, select Port, and then click [Next].

c. Select UDP, and then select Specific local ports.

d. In the Specific local ports box, type 1433, 1434, and then click [Next].

e. Select Allow the connection, and then click [Next].

f. Select the Domain, Private, and Public check boxes, and then click [Next].

g. In the Name box, type Sage Estimating Service (or other appropriate name), and then click
[Finish].

h. Repeat steps a through g for outbound UDP connections, selecting Outbound Rules in step a.

Additional Recommendations
To ensure accurate performance, Sage strongly recommends making changes and verifications to the
following settings in SQL Server Management Studio and SQL Server Configuration Manager. Failure to
make these changes may result in poor Sage Estimating performance or communication difficulties
between Sage Estimating and your SQL Server instance.

Memory

Determine the amount of available memory on the server or workstation where SQL Server is installed. To
prevent SQL Server from consuming all available memory, use SQL Server Management Studio to set the
maximum amount of memory (in the instance properties) to a reasonable limit (such as 4 GB ) as follows:
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1. Right-click the SQL Server instance, and then select Properties.

2. In the Server Properties window, click Memory (left-hand pane).

3. Set the Maximum server memory amount to 4000 (or whatever limit you determine).

Recovery Model

Sage recommends that you use the Simple recovery model for your Estimating database.

During the upgrade process, the program now shrinks the existing log file, which can become very large,
and it removes invalid estimates. However, it does so only if the database recovery model is set to Simple
in the SQL Server software. We do not recommend that you change the recovery model unless your
business requires features available only in a different model.

Communication Protocol

Set the communication protocol settings for the Sage Estimating SQL Server instance as follows:

1. Start the SQL Server Configuration Manager.

l In Windows 7: Click Start > All Programs >Microsoft SQL Server > Configuration Tools
> SQL Server Configuration Manager.

l In Windows 8.1 or Windows 10: Click Start > All apps > Microsoft SQL Server >  SQL Server
Configuration Manager.

2. In the left-hand pane of the SQL Server Configuration Manager window, click the arrow next to
SQL Server Network Configuration to display all local SQL Server instances.

3. Select the instance associated with Sage Estimating (SAGE_ESTIMATING, by default).

4. In the right-hand pane right-click a communication protocol, and then select Disable.

5. Repeat step 4 for all communication protocols except TCP/IP. Leave this protocol Enabled.

6. In the left-hand pane of the SQL Server Configuration Manager window, click the arrow next to
SQL Native Client 10.0 Configuration.

7. Click Client Protocols (left-hand pane).

8. In the right-hand pane right-click a communication protocol, and then select Disable.

9. Repeat step 8 for all communication protocols except TCP/IP. Leave this protocol Enabled.

10. Close the SQL Server Configuration Manager and restart the service.

Copying Databases fromOther Instances
Sage Estimating allows the use of just one active SQL Server instance at a time. This instance is a "closed"
SQL Server instance. Sage Estimating does not recognize databases (Address Book or standard
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databases) transferred or copied from other SQL Server instances unless they are added by way of the
Search For feature in the Estimating Management Console.

For example, if you have two Sage Estimating installs, Install A and Install B, you cannot copy Address
Book databases by copying them from Install A's SQL Server instance to Install B's SQL Server instance
alone (using SQL Server Management Studio's built-in Copy Databases wizard, for example). You must
also open the Estimating Management Console and use the Search For button in the Address Book
Companies/Contacts toolbar.

Copying Databases FromOne SQL Server Instance to Another

Any database you add to an instance must have the same Sage Estimating version as the other operating
databases. For example, if you are using Sage Estimating 19.12, and you want to add a standard
database from a previous Sage Estimating installation, upgrade the standard database to version 19.12
before adding it to the new instance. Refer to the Estimating Management Console in-product Help for
instructions on using the Search For feature.

You can switch active SQL Server instances at any time for Sage Estimating by starting the Configuration
wizard, selecting Server from the left-hand pane, and clicking [Change] from the right-hand pane.
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Chapter 4: Managing Your License

This chapter provides detailed information about the Sage online licensing system.

About the License Server and the SageOnline Licensing
System
You must have a license to use Sage Estimating.

When you activate your product license on the license server, your Sage products and features are
registered on and managed from that computer. As you purchase or remove licenses, the Sage online
licensing system updates this information on your License Server.

The license server communicates with Sage daily, keeping your licenses up to date automatically.

You can view your licenses and (if necessary) update registration information manually using the License
Administration window. The License Administration window displays your Sage Estimating Essential
license, and it lists any additional modules and features you have purchased.

EstimatingModules
Used as a standalone application, Sage Estimating Essential is a powerful, flexible tool for estimating all
types of construction projects.

You can also purchase the eTakeoff add-on module to extend the functionality of Sage Estimating to suit
the needs of your business. This module is licensed separately from the Sage Estimating Essential
product.

Note: Certain capabilities, menus, and icons described in help are available only with the CORESage
Estimating product. Contact your Sage sales representative for more information about modules and
feature bundles.

General Licensing Steps
After installing Sage Estimating Essential, you need to:
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1. Configure your License Server using the License Administration window.

l Designate the computer where you installed Sage Estimating (SQL) as the Sage license
server.

l Enter and send registration information to Sage to activate the licenses for the products and
features you have purchased.

2. Connect Sage Estimating Essential to the Sage license server using the Configuration Wizard.

The following sections describe these steps in more detail.

Designating a Sage License Server
One of your first tasks when setting up your Sage Estimating system is to designate as your Sage license
server the computer where you installed Sage Estimating Essential. You must supply the full name of the
computer or its IP address.)

Note: The Sage license server must remain connected to the Internet for daily validation of your license.

To determine the computer name of the server:

1. Open the Windows Control Panel.

l In Windows 7, click Start > Control Panel.

l In Windows 8 and Windows 10, on the Start menu, click All Apps >Windows System > Control
Panel.

2. From the Control Panel, click System and Security > System to display the System Properties
window.

3. Under Computer name, domain, and workgroup settings, locate Full computer name, and then
make a note of the name.

4. Close the Control Panel.

To designate the Sage license server:

Important! A license use is allocated to the designated computer when you submit your registration and
activate your license. If you need to move your Sage Estimating Essential installation to a different
computer, later, you must first deauthorize the license on the License Information tab on the old
computer before you can activate the license on a new server.

1. On the computer where you plan to activate your license, start License Administration.

2. Click Change server.
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3. In the Specify License Server window:

a. In the Computer box, type localhost.

b. In the Port number box, type 48650 if that is not the port number displayed in the box.

4. Click [OK].

Registering the Software and Activating Licenses

To activate your license:

1. On the computer where you installed Sage Estimating Essential, open the License Administration
window.

Click Start > All Apps > Sage Estimating > License Administration.

2. Ensure that the computer named in the License server box is the same machine where Sage
Estimating is installed.

If it is not the same, click Change server, and then enter the correct name or IP address of your
computer.

3. In the Registration Information section, submit your registration details as follows:

a. Click the Edit registration information link.

b. In the Sage client ID box, type your client number.

c. In the Registration name box, type your registered company name exactly as provided by
Sage.

d. Click [OK]

If the activation was successful, the Licensed Modules grid displays the modules that you
have purchased.

Connecting to the License Server from Sage Estimating
Before you can use Sage Estimating, you must connect Sage Estimating to the Sage license server. Then,
when you start Sage Estimating, the program automatically acquires a license use for the workstation.
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To connect to the license server:

1. On your workstation, open the Specify License Server window:

a. Start the Estimating Configuration Wizard.

b. In the navigation pane, click Licensing.

c. In the right-hand panel, select the License Server option.

d. Click [Change].

2. In the Specify License Server window:

a. In the Server box, type localhost.

b. In the Port box, type 48650 if that is not the port number displayed in the box.

3. Click [OK].

Updating License Information
The Sage license server automatically retrieves license information from Sage every day. The license
gives you access to Sage Estimating Essential.

You can also update the licensing information manually, as follows:

1. Open License Administration.

2. Ensure that License Administration tool is pointing to your designated License Server machine.

3. On the License information tab, click the Update license information link.

Your Sage license server then contacts the Sage online licensing system to update your license
information, as needed.

Deauthorizing a License Server
When you set up your Sage license server, the Sage online licensing system allocates a license use for
your purchased Sage Estimating Essential modules to that computer.

At some point in the future, you might need to designate a different computer as the license server (for
example, if you want to upgrade to a new computer) or change your registered company name. However,
you cannot allocate your license to a new computer or a new company while it is allocated to the original
server.
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Before you can reallocate your license to a different license server, you must release the allocated licenses
to the Sage online licensing system. You do so by deauthorizing the original license server, enabling you to
configure the new license server and register the license to that machine.

Caution! Do not deauthorize your license server if you have a license use checked out. Doing so can
lock your license, requiring Sage Customer Support to resolve.

To deauthorize your Sage license server:

1. Check your current license server information:

a. Start License Administration.

b. Ensure that the License server box contains the name of the computer you want to
deauthorize.

2. Deauthorize your current license server:

a. Ensure that no other users are working with Sage Estimating.

b. Click Deauthorize license server.

You should receive a message saying that deauthorization was successful.

Changing Your Company's Registration Information

Caution! Do not change registration information if you have checked out a license use. Doing so can
lock the licenses, requiring Sage Customer Support to resolve.

To change your registration information:

1. Deauthorize your current license server.

Important! This step is crucial. You must release your allocated license to the Sage online
licensing system so it is available to reallocate to the "new" company. Make sure you receive a
message saying that deauthorization was successful before you proceed.

2. Change your company's registration name:

a. Click Edit registration information.

b. Enter your new registration information in the Sage client ID and Registration name boxes.

c. Click [OK].
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If the new registration is successful, the Licensed Modules grid displays your licensed modules and
license uses with your new registration information.

Note: If you are using licensed standard databases, you need to obtain new activation codes for these
databases after changing your registration information.

Moving Your Sage License Server to Another Computer

Caution! Do not try to change your license server if you have checked out a license use. Doing so can
lock the license, requiring Sage Customer Support to resolve.

To move your license server to another computer.

1. Verify the full computer name of the computer you want to use as the new license server.

2. Deauthorize your current license server.

Important! This step is crucial. You must release your allocated license to the Sage online
licensing system so that it is available to reallocate to the server. Make sure you receive a
message saying that deauthorization was successful before you proceed.

3. Click Change server, and then, in the Specify License Server window:

a. In the Computer box, type the full name of the computer you want to use as the license server.

b. Click [OK].

Important! Entering a new computer name in the Specify License Server window points the
License Administration window to a different machine, enabling you to administer licenses on that
license server.

4. To update your registration information, click Edit registration information, type your Sage client ID
and registration name in the boxes provided, and then click [OK].

If the new server is authorized successfully, the Licensed Modules grid displays your licensed
modules and license uses with your new registration information.

Troubleshooting License Server Issues
This section provides suggestions to resolve some of the common issues that can occur with your Sage
Sage Estimating (SQL) licenses.
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TheRegistration Information Does Not Match

The Sage client ID and Registration Name on the License Administration windowmust match the
information on the Sage license server. Ensure the information is entered correctly here.

Network Cable Unplugged

When the network cable is unplugged from your workstation, you cannot perform license administration
functions using the License Administration tool.

To check whether a network cable is unplugged:

1. Check the notification area, at the far right of the taskbar, for the message A network cable is
unplugged.

l If you see this message, reconnect the network cable to the workstation.

l If you do not see this message, check the network connections:

a. Click [Start > Control Panel > Network Connections.

b. In the LAN or High-Speed Internet section, check the Status of the Local Area
Connection.

l If the Status is Network cable unplugged, reconnect the network cable to the
workstation.

l If the Status is Connected, the network cable is connected to the workstation.

2. Try to use the License Administration tool.

38Sage Estimating Essential v19.12 Installation and Administration Guide



A

activating Estimating products 16

activation 16

addon modules

licenses for 32

assigning database permissions 26

authentication mode 25

C

collation settings 25

computer name

determine 33

Configuration Tools 9

Configuration Wizard

using to connect to Sage license server 35

D

database permissions 26

deauthorizing a license server 35

E

Estimating Essential

license 32

eTakeoff

license 32

exceptions, firewall 26

F

firewall, workgroup exceptions 26

folder control requirements 11

H

help

using the in-product Help 3

I

installation

activating Estimating products 16

collation settings 25

Estimating products 14

scenarios 13

SQL Server Express 15

installing Estimating products 14

installing SQL Server Express 15

L

License Administration

overview 32

Index

39Sage Estimating Essential v19.12 Installation and Administration Guide



license server 34

licenses 34

activating licenses 34

M

mixed mode authentication 25

modifying existing instances 23

N

network 38

network cable 38

unplugged 38

R

Recovery Model 30

registry keys 12

requirements

folder control 11

S

Sage license server 32

about 32, 34

name 33

SQL Server

installing SQL Server Express 15

modifying existing instances 23

selecting a new instance 31

W

Windows authentication 25

workgroup firewall exceptions 26

40Sage Estimating Essential v19.12 Installation and Administration Guide


	Introduction
	Conventions Used in this Document
	Ways to Get Help
	Training
	Submitting Enhancement Requests

	Chapter 1: System Overview
	Sage Estimating Components
	Configuration Tools in Sage Estimating

	Chapter 2: System and Other Requirements
	Access Rights

	Chapter 3: Installing and Configuring Sage Estimating
	Installing on a standalone workstation (overview)
	A. Install Sage Estimating
	B. Install and Configure SQL Server
	C. Configure Your License Server (License Administration)
	D. Connect to the Sage license server(Configuration Wizard)
	E. Connect to SQL Server (Configuration Wizard)
	F. Install Standard Databases
	G. Set Up Estimating Security
	H. After You Complete Your Setup

	Chapter 3: Configuring SQL Server
	Setting Up a SQL Server Instance for Use with Sage Estimating
	Setting Up Security
	Setting Firewall Exceptions
	Additional Recommendations
	Copying Databases from Other Instances

	Chapter 4: Managing Your License
	About the License Server and the Sage Online Licensing System
	Estimating Modules
	General Licensing Steps
	Designating a Sage License Server
	Registering the Software and Activating Licenses
	Connecting to the License Server from Sage Estimating
	Updating License Information
	Deauthorizing a License Server
	Changing Your Company's Registration Information
	Moving Your Sage License Server to Another Computer
	Troubleshooting License Server Issues

	Index

