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Chapter 1: About the Sage 300 Job Cost 
Integration Guide

If you use Sage 300 Construction and Real Estate Job Cost, you can transfer estimate information directly into 
your job costing application. This enables you to access budget and transaction data without reentering the 
information. This guide covers the interface between Sage Estimating and Sage 300 Construction and Real 
Estate Job Cost, which enables the information transfer.

Read the Supporting Documentation Before You Begin
This Sage 300 Job Cost Integration Guide provides installation, setup, and operating instructions for  Sage 300 
Construction and Real Estate Job Cost Integration. Be sure to read it, as well as the following supporting 
documentation, before you install and configure Sage Estimating: 

 l The Installation and Administration Guide includes an overview of this release, installation instructions, 
system requirements, and contact information.

 l The Release Notes  provide details about new features, database changes, known issues, and fixes. 

 l The Getting Started Guide provides an operational overview of the Sage Estimating software. 

 l The SQL Server Guide gives you an overview of the significant differences between the new 
SQL Server databases and the Pervasive databases used in previous Sage Estimating releases. 

Conventions Used in this Guide
This guide uses the following conventions:

 l Information you type into the software is shown in bold font. For example: Type Miscellaneous in the 
box.

 l The names of screens, windows, fields, and other features displayed by the software are shown in bold 
font.

 l Names of keys are also shown in bold font. For example: Enter or Tab. A plus sign (+) between two key 
names indicates you should press the keys simultaneously.

 l The names of buttons you can click are shown in bold font and enclosed in brackets. For example: [OK] 
or [Post].

 l Variable names or names that are specific to your installation may appear in italics and brackets. For 
example: [Drive]\\[Server].

1Sage Estimating v23.1 Sage 300 Job Cost Integration Guide



Menu Paths

In this document, menu paths show you the steps required to start a task. Menu paths appear in bold font with 
square brackets around buttons. For example:

"If the program does not automatically start, click [Start] > Run."

Need help?
Use Sage Estimating Help or a variety of self-help resources to get answers to your questions. 

The Help System

Sage Estimating Help provides more efficient access to information than most manuals. With a click of the 
mouse or a keystroke, you can easily get Help for a command, a field, a window, or a procedure.

Sage Estimating displays Help in your default browser. If you have an Internet connection, it displays the most 
current Help for your version of Sage Estimating from the Sage Estimating Help website. If you have no 
connection (you are working offline), it displays Help that was current when the software was released and 
installed on your computer when you install Sage Estimating.

Important! Because the Microsoft Edge browser does not display locally installed help properly, we 
recommend that you select a different default when working offline.

To get Help on a window option

To display Help for an option in a window, do one of the following:

 l Click  What's This? on the toolbar or on the title bar, and then click the option.

 l Select What’s This? from the Help menu, and then click the option.

 l Select the option, and then press F1.

To get Help for the whole window

For information about the window, such as the window's purpose and what tasks you can perform in it, click 
[Help] at the bottom of the window.

To use Help to learn how to do tasks

 1. Click [Help] on the toolbar, or select the Home tab > Help group > Help (or select Help menu > Help 
topics in classic view). 
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The Help Window

 2. Use the navigation pane to begin looking for a topic. 

 l Help subjects are organized under headings. Select the heading for the type of task you want to 
perform to view a list of topics.

When you see the topic you want, double-click it to display it.

 l Select the Glossary heading to view an alphabetical list of definitions of terms used throughout the 
Sage Estimating software.

 3. Use the Search box to find articles that match the keywords you enter.

Additional self-help resources

The Help menu available from on the ribbon also provides convenient links to a variety of self-help resources.
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The Help menu in Ribbon view

Get help by: Recommendation* To access:

Reading product 
documentation  

View documents and reference material from the 
Estimating Product Documents website.   

Visit the Sage Estimating 
Product Documents page.

Searching the 
Knowledgebase

Search the Sage Knowledgebase, which provides 
24/7 access to support articles as well as the latest 
software downloads and updates.

Visit the Knowledgebase at 
Sage Knowledgebase.

Asking the 
community

Join industry peers, certified partners, and Sage 
pros online 24/7 at the Sage Community Hub—the 
best place to ask questions and share product 
experiences, tips, and tricks.

Visit the Sage Estimating 
General Discussion forum.

Checking the 
latest product 
alerts

Keep up with the latest product information with 
Sage Estimating Announcements at the Sage 
Community Hub forum.

See Sage Estimating 
Announcements.

Submitting a 
web ticket 

Submit your issue directly to our support team using 
Online Case submission.

Visit the Sage Customer Portal.

Exploring 
training options

Learn how to harness the full power of your software 
through videos and classes at Sage University.

Visit Sage University.
You can also get access to Sage 
University from the Estimating 
File menu by selecting Help  > 
Sage University.

* Customer Service hours vary by product line. Access to some resources require an active Sage 
Business Care support plan.

How to Get Additional Help
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Submitting Enhancement Requests
We want to hear your suggestions for improving the software. To send us your comments, click the File menu 
button  and then select Help >  Submit Product Idea.
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Chapter 2: Sage 300 Construction and 
Real Estate Job Cost Integration

If you use Sage 300 Construction and Real Estate Job Cost, you can transfer estimate information directly into 
your job costing application. This allows you to access budget and transaction data without reentering the 
information. This guide covers the interface between Sage Estimating and Sage 300 Construction and Real 
Estate Job Cost, which enables the information transfer.

Overview   
When Sage Estimating sends estimate information to Sage 300 Construction and Real Estate Job Cost, it 
sends the information directly to the Job Cost  New.jct file. Sage 300 Construction and Real Estate Job Cost 
can then access the estimate data without having to import it first.

The Sage Estimating-Job Cost Interface

For detailed information about Job Cost concepts, see the in-product Help in Sage 300 Construction and Real 
Estate Job Cost.
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Chapter 3: Setup Guidelines   

To help ensure a smooth data transfer between Sage Estimating and Job Cost, follow these guidelines:

Sage 300 Construction and Real Estate Job Cost
Before you export data from Sage Estimating, ensure that in Job Cost:

 l Standard cost codes exist for each cost code sent from Sage Estimating.

 l If you use categories, standard categories exist for each category sent from Sage Estimating.

 l Operators working with estimate data have the appropriate security permissions for the following:     

 l Job Cost Enter Estimates or Import tasks

 l File access (to the .jct file)

 l Company security

 l Job record security

Sage Estimating
Before you create an estimate to send to Job Cost, make sure the database settings for phases, items, and 
addons are set up correctly for your needs. Any changes you make to these settings after creating an estimate 
do not affect existing phases, items, or addons. You need to change existing phases, items, and addons 
individually if you want Job Cost to reflect the new settings.

Before you send estimate information to Job Cost, make sure that:

 l Database Phase settings are mapped to the desired Job cost phase.

 l Database Item settings are mapped to the desired Job Cost Phase and Job Cost Category.

 l Database Addon settings are mapped to the correct Job Cost Phase and Category.

Prepare Sage 300 Construction and Real Estate Job Cost to 
Receive Estimates
You need to verify two items in Sage 300 Construction and Real Estate Job Cost to successfully transfer 
estimate information from Sage Estimating:
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 l All needed standard cost codes are set up. To see a list of standard cost codes that are already set up in 
Job Cost, from the Job Cost Reports menu, select Lists > Standard Cost Codes. If you do not see a cost 
code that you know exists in the estimate or estimates, select Setup > Standard Cost Codes to set up 
the standard cost code.

 l Standard categories are set up (if your company uses categories). Using categories is optional. If you do 
not use categories, you do not need to verify that they exist. To see a list of standard categories that are 
already set up, from the Job Cost Reports menu select Lists > Standard Categories. If you do not see a 
standard category listed that you know exists in the estimate or estimates, select Setup > Standard 
Categories to set up that category.

Prepare Sage Estimating to Send Estimates
Perform the following tasks in the Sage Estimating software to send estimate information  to Sage 300 
Construction and Real Estate Job Cost.

 l Enable the Job Cost interface.

 l Verify standard database phase settings.

 l Verify the standard database item settings.

 l Verify the standard database addon settings.

Enable the Job Cost interface

Set up standard databases individually to interface with Sage 300 Construction and Real Estate Job Cost by 
enabling the interface in the Sage Estimating Estimating Management Console:

 1. Click the Estimating Management Console desktop icon .

 2. In the Estimating Management Console, click the Standard Databases tab.

 3. Select the desired standard database from the list of standard databases in the Standard Database 
Catalog pane.

 4. If desired, you can also create a new standard database by clicking [New Standard Database]. Fill out 
the new standard database details on the provided tabs in the detail pane and click [Create].

 5. Select Sage 300 Construction and Real Estate as the job cost interface in the Job Cost Info area of the 
detail pane.
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The Job Cost Area

 6. Click [Setup] (Job Cost Info area) to open the Job Cost Integrator window in Sage 300 Construction and 
Real Estate Job Cost.

 7. In the Job Cost Integrator window, select the Sage 300 Construction and Real Estate company you 
want to associate with the standard database.

The Job Cost Integrator Window
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 8. Select a default JC category cost code in the Labor, Material, Subcontractor, Equipment, and Other 
boxes. 

Sage Estimating prefills the JC category box in each new item you create with the applicable selected 
default category.

For example, if you select a labor cost code of 03-0100 for the Labor box, each time you create a new 
labor item for the estimate or standard database, the item's JC category box automatically displays a 
cost code of 03-0100.

 9. If you want to overwrite the cost code information in existing items in your standard database, select the 
Add Job Cost categories to items checkbox. 

 10. Click [OK] to return to the Estimating Management Console.

 11. Verify that the Sage 300 Construction and Real Estate company you selected in step 6 appears in the 
Company name box of the Job Cost Info area of the Estimating Management Console.

Verify standard database phase settings

Both Sage Estimating and Sage 300 Construction and Real Estate Job Cost use the concept of phases. 

Note: In Job Cost, phases are often called cost codes. 

It is possible that the phase structure used in Sage Estimating is not the same as the cost code structure used 
in Job Cost. Using the Database Phase window in Sage Estimating, you tell the software how you want the two 
structures to align. In essence, you create a map for the software to use when you transfer data from a phase 
in Sage Estimating to a cost code in Job Cost.

To verify standard database phase settings:

 1. Open the Database Phase window.

 l On the ribbon, from the Elements group on the Data tab, click Phases, and then click [Database].

 l In classic view, click Database   > Phases.

 l From the spreadsheet,   right-click a phase row header, click Edit Phase on the shortcut menu, and 
then click [Database].
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The Database Phase Window

 2. Click the list button located to the right of Job cost phase to select the Sage Estimating phase to be 
mapped to a cost code in Job Cost. 

The Database Phase List window opens.

The Database Phase List Window
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 3. Double-click the desired phase. 

You are returned to the Database Phase window. The selected Phase, its Description, Unit description, 
and any previously selected Job Cost phase display in the Database Phase window initially.

Note: You can use the same Job Cost phase number for many different estimating phases.

 4. Click [Close] when you are finished.

Verify standard database item settings

The Database Item window is where you define the Job Cost phase and Job Cost Category to use with a 
standard database item, and specify which quantity to send to Job Cost.

To verify standard database item settings:

 1. Open the Database Item window:

 l On the ribbon, from the Elements group on the Data tab, click Items.

 l In classic view, click Database   > Items.

 2. In the Database Item window, click the Job Cost tab.

The Job Cost Tab of the Database Item Window

12Sage Estimating v23.1 Sage 300 Job Cost Integration Guide



The information you enter on this tab creates a map for the software to use when you transfer 
information from Sage Estimating to Job Cost. For each item in the standard database, you can select a 
Job Cost phase (remember, in the Job Cost application, phases are often referred to as cost codes) and 
a Job Cost category. When Sage Estimating sends this estimate item to Job Cost, the item and its 
associated information appears under the cost code and category you select on this tab.

Note: As with phases, you can use the same Job Cost Phase and Job Cost Category for any number of 
estimate items.

 3. Click in the Job Cost Phase field, and then click the list button. 

The Database Job Cost Phase List window opens.

 4. Locate and double-click the Job Cost phase you want to receive the item information when Sage 
Estimating interfaces with Job Cost. 

When you double-click on an item, the Database Job Cost Phase List window closes and you are 
returned to the Database Item window. The Job Cost phase you selected appears in the Job Cost Phase 
box.

Note: You can also manually enter a phase. Be sure to follow the format set up in Job Cost. If the phase 
does not exist in Job Cost, you can create it during the import.

 5. Click in the Job Cost Category box and then select the  category from the list to receive the Sage 
Estimating item information.

The Job Cost Category List
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Note: You can also manually enter a category.

Be sure to click in the Job Cost Category box, not the standard database item Category box. The 
database item Category box is used for pricing and does not have any impact on the Job Cost interface.

 6. Select the item quantity to send to the selected Job Cost category by selecting the item quantity from the 
Qty to Job Cost list. 

Your cost accounting needs should dictate which option you choose.

 l Takeoff qty sends to Job Cost the takeoff item quantity for the category.

 l Order qty sends to Job Cost the order item quantity for the category.

 l None sends to Job Cost the total dollar amount for the job cost phase and job cost category. It 
does not send quantities, so the unit price field in Job Cost will be blank.

 7. Click [OK] and [Close] when you are done.

Note: You can also make changes to the Job Cost phase and category from the estimating 
spreadsheet itself.

Verify standard database addon settings

To view the database addon settings:

 1. Open the Database Addonswindow:

 l On the ribbon, from the Adjustments group on the Data tab, click Addons.

 l In classic view, click Database menu > Addons.

 l From the Totals   window, click  or select   Edit Addon from the shortcut menu.

 2. In the Database Addon window, select the Allocatable checkbox to make an addon cost eligible for 
allocation when the estimate information is sent to Job Cost.

Note: To actually allocate the addon, select the Allocate addons checkbox in step 2 of the Job Cost 
Export wizard (in the Sage Estimating software).

 3. To send the addon costs to a specific Job Cost cost code and category, click [Job Cost] and select the 
Job cost phase and category to receive the addon information.
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Selecting a Phase and Category for Job Cost
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Chapter 4: Exporting Data to Sage 300 
Construction and Real Estate Job Cost

Use the Export to Job Cost  wizard to send the following estimate data to Sage 300 Construction and Real 
Estate Job Cost:

 l Each phase for which you have entered a phase quantity in the spreadsheet.

 l Each item category with an amount. The item setup determines whether the transaction includes the 
takeoff quantity or order quantity.

 l Each addon that is not allocated. The cost of allocated addons is found in the items used to calculate 
those addons.

To export to Job Cost:

 1. Open the Job Cost Transfer wizard in one of the following ways:

 l On the ribbon, from the  Export to Job Cost on the Advanced tab, click Export to Job Cost.

 l In classic view, click Interface > Job Cost).

Job Cost Export Wizard Introduction

 2. Click [Next].
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Job Cost Export Wizard Step 1

 3. Enter (type or click the calendar button next to the Transaction date box) the date to appear on the 
transactions contained within the transaction file.

The Sage 300 Construction and Real Estate JC job number box displays the job number entered in the 
Estimate Information window in Sage Estimating.

 4. Click [Next].

 5. Select how you want item quantities to be rounded and how to allocate addons.
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Job Cost Export Wizard Step 2

 6. Click [Next].

Job Cost Export Wizard Step 3

 7. Select the Map estimate information to extras in Job Cost checkbox if you want to map estimate 
information to Job Cost extras.

If you do not use extras in Job Cost you do not need to do anything on this tab.
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In Job Cost, extras are sub-jobs of the main job. Extras allow you to track cost, revenue, and 
commitments separately from the main job, while still being able to accumulate to the main job.

Some reasons you might need to use extras in Job Cost are:

 l The owner or architect requested additional work after the original contract was signed.

 l You need to track income from certain cost codes separately from the main job.

 l Certain costs are billed and tracked separately from the main job.

In Job Cost, you can change the name "extra." For information about how to change the name of this 
item, refer to "custom descriptions" in the Job Cost in-product Help.

 8. If desired, attach information from a work breakdown structure or location to an item as an extra:

 9. Select the Map estimate information to extras in Job Cost checkbox. 

Each item is mapped to a specific cost code and category in Job Cost using the Database Item window 
in Sage Estimating. The mapping you enter sends a location or work breakdown structure (WBS) code 
to Job Cost as an extra.

In Sage Estimating, WBS codes enable you to attach additional information to each item. Each WBS 
code has values underneath it. For example, if you had a WBS code of CSI Phase, the values 
underneath that WBS code might be field supervision, project administration, safety coordination, and 
so forth.

In Job Cost, the Extra ID entry is limited to 10 characters.

Additionally, you can use a location to relate an item to a specific job area. For example, if you build an 
office, you might want to assign one item to the first floor and another item to the second floor.

 10. Select the WBS code or location from the Sort Level list to send to Job Cost as an extra.

When you select a Sort Level, you receive a warning. If you choose a sort level, non allocatable add-ons 
will not be exported. Select [Cancel] instead to export all. Also, if you want all addons included in the 
export, click [Cancel].

If you select a WBS code for the Sort Level, the WBS values area becomes available.

If you selected Location as the Sort Level, the name of this area is Location Selection. Its function is the 
same no matter which Sort Level you select.

 11. Under WBS values, choose whether to send all WBS values to Job Cost or only selected WBS Values.

 12. Click [Finish] to export the specified estimate data to Job Cost.

Sage Estimating sends the exported estimate information directly to the Sage 300 Construction and Real 
Estate Job Cost New.jct  file.
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