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Getting started with STM32CubelL1 for STM32L1 Series

Introduction

STMCube™ is an STMicroelectronics original initiative to ease developers’ life by reducing
development efforts, time and cost. STM32Cube is the implementation of STMCube™ that
covers STM32 microcontrollers.

STM32Cube Version 1.x includes:

e The STM32CubeMX, a graphical software configuration tool that allows the generation of
C initialization code using graphical wizards.
e A comprehensive embedded software platform, delivered per series (such as
STM32Cubel 1 for STM32L1 series):
— The STM32Cube HAL, an STM32 abstraction layer embedded software ensuring
maximized portability across STM32 portfolio. The HAL is available for all peripherals
— The Low Layer APIs (LL) offering a fast light-weight expert-oriented layer which is
closer to the hardware than the HAL. The LL APIs are available only for a set of
peripherals.
— A consistent set of middleware components such as RTOS, USB, STMTouch, FatFS
and Graphics
— All embedded software utilities coming with a full set of examples

This user manual describes how to get started with the STM32CubelL1 firmware package:

Section 1 describes the main features of STM32Cubel 1 firmware, part of the STM32Cube
initiative. Section 2 and Section 3 provide an overview of the STM32CubelL1 architecture
and firmware package structure.
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1 STM32CubelL1 main features

STM32Cubel 1 gathers together, in a single package, all the generic embedded software
components required to develop an application on STM32L1 microcontrollers. In line with
the STM32Cube initiative, this set of components is highly portable, not only within
STM32L1 Series but also to other STM32 Series.

STM32Cubel1 is fully compatible with STM32CubeMX code generator that allows the user
to generate initialization code. The package includes a low level hardware abstraction layer
(HAL) that covers the microcontroller hardware, together with an extensive set of examples
running on STMicroelectronics boards. The HAL is available in open-source BSD license for
user convenience.

STM32CubelL 1 package also contains a set of middleware components with the

corresponding examples. They come in very permissive license terms:

e  Full USB Device stack supporting many classes: Audio, HID, MSC, CDC and DFU,

e  CMSIS-RTOS implementation with FreeRTOS open source solution,

e  FAT File system based on open source FatFS solution,

e  STMTouch touch sensing library solution,

e  STemWin, a professional graphical stack solution available in binary format and based
on ST partner solution SEGGER emWin.

Several applications and demonstrations implementing all these middleware components
are also provided in the STM32CubelL1 package.

The block diagram of STM32Cube is shown in Figure 1.

Figure 1. STM32Cube firmware components

User
application

Application level demonstrations

Middleware level" Utilities

Board Support Package (BSP) LowLayer (LL) Hardware Abstraction Layer (HAL)

HAL and LL APls

(1) The set of middleware components depends on the product Series. MS41448V2
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2 STM32CubelL1 architecture overview

The STM32Cube firmware solution is built around three independent levels that can easily
interact with each other as shown in Figure 2.

Figure 2. STM32CubeL1 firmware architecture

Level 2 Evaluation board and Discovery Kit demonstration

Applications

Level 1 v @

Library and protocol based components
(for example FatFS, FreeRTOS, USB Device)

Examples
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Level 0 <:] BSP drivers
Hardware abstraction layer (HAL)
Core drivers (optional) Low Layer (LL)
HAL
MSv34990V3
21 Level O

This level is divided into three sub-layers:
e  Board Support Package (BSP)
e  Hardware Abstraction Layer (HAL)
—  HAL peripheral drivers
—  Low Layer drivers
e Basic peripheral usage examples

211 Board Support Package (BSP)

This layer offers a set of APIs relative to the hardware components in the hardware boards
(such as LCD, Audio, microSD, MEMS drivers). It is composed of two parts:

e Component
This is the driver relative to the external device on the board and not related to the

3
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STM32. The component driver provides specific APIs to the BSP driver external
components and can be portable on any other board.

BSP driver

It permits to link the component driver to a specific board and provides a set of friendly
used APls. The APIs naming rule is BSP_FUNCT _Action().

Example: BSP_LED_Init(),BSP_LED_On()

The BSP is based on a modular architecture allowing an easy porting on any hardware
by implementing the low level routines.

Hardware Abstraction Layer (HAL) and Low Layer (LL)

The Root part number 1 HAL and LL are complementary and cover a wide range of
applications requirements.

The HAL drivers offer high-level function-oriented highly-portable APIs. They hide the
MCU and peripheral complexity to end user.

The HAL drivers provide generic multi-instance feature-oriented APIs which simplify
user application implementation by providing ready to use process. As example, for the
communication peripherals (12S, UART...), it provides APIs allowing initializing and
configuring the peripheral, managing data transfer based on polling, interrupt or DMA
process, and handling communication errors that may raise during communication.
The HAL driver APls are split in two categories:

—  Generic APlIs providing common and generic functions to all the STM32 Series

—  Extension APlIs, which provide specific and customized functions for a specific
family or a specific part number.

The Low Layer APIs provide low-level APIs at register level, with better optimization but
less portability. They require a deep knowledge of MCU and peripheral specifications.
The LL drivers are designed to offer a fast light-weight expert-oriented layer that is
closer to the hardware than the HAL. Contrary to the HAL, LL APIs are not provided for
peripherals where optimized access is not a key feature, or for those requiring heavy
software configuration and/or complex upper-level stack (such as FSMC, USB or
SDMMC).

The LL drivers feature:

— Aset of functions to initialize peripheral main features according to the parameters
specified in data structures

— A set of functions used to fill initialization data structures with the reset values
corresponding to each field

—  Function for peripheral de-initialization (peripheral registers restored to their
default values)

— Aset of in-line functions for direct and atomic register access

—  Full independence from HAL and capability to be used in standalone mode
(without HAL drivers)

—  Full coverage of the supported peripheral features.

Level 1

This level is divided into two sub-layers:

Middleware components
Examples based on the middleware components

3
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221 Middleware components
The middleware is a set of Libraries covering USB Device library, STMTouch touch sensing
library, graphical STemWin library, FreeRTOS and FatFS. Horizontal interactions between
the components of this layer is done directly by calling the feature APIs while the vertical
interaction with the low level drivers is done through specific callbacks and static macros
implemented in the library system call interface. As example, the FatFs implements the disk
I/O driver to access microSD drive or the USB Mass Storage Class.
The main features of each middleware component are as follows:
e USB Device Library

—  Several USB classes supported (Mass-Storage, HID, CDC, DFU, AUDIO, MTP)

—  Supports multi packet transfer features: allows sending big amounts of data
without splitting them into max packet size transfers.

—  Uses configuration files to change the core and the library configuration without
changing the library code (Read Only).

— RTOS and Standalone operation,

—  The link with low-level driver is done through an abstraction layer using the
configuration file to avoid any dependency between the Library and the low-level
drivers.

e  STemWin Graphical stack

—  Professional grade solution for GUI development based on SEGGER’s emWin
solution.

—  Optimized display drivers.

—  Software tools for code generation and bitmap editing (STemWin Builder...).

e FreeRTOS

—  Open source standard,

—  CMSIS compatibility layer,

—  Tickless operation during low-power mode,

— Integration with all STM32Cube middleware modules.

e  FAT File system

—  FATFS FAT open source library,

—  Long file name support,

—  Dynamic multi-drive support,

— RTOS and standalone operation,

—  Examples with microSD.

e  STM32 Touch Sensing Library

— Robust STMTouch capacitive touch sensing solution supporting proximity,
touchkey, linear and rotary touch sensor using a proven surface charge transfer
acquisition principle.

222 Examples based on the middleware components

3

Each middleware component comes with one or more examples (also called Applications)
showing how to use it. Integration examples that use several middleware components are
also provided.
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2.3 Level 2

This level is composed of a single layer, which is a global real-time and graphical
demonstration based on the middleware service layer, the low level abstraction layer and
the basic peripheral usage applications for board based functionalities.

3
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3.1

3

STM32CubelL1 firmware package overview

Supported STM32L1 devices and hardware

STM32Cube offers highly portable Hardware Abstraction Layer (HAL) built around a generic
architecture, allows the build-upon layers, like the middleware layer, to implement its
functions without knowing, in-depth, the MCU used. This improves the library code
reusability, guarantees an easy portability on other devices.

In addition, thanks to its layered architecture, the STM32Cubel 1 offers full support of all
STM32L1 Series. The user has only to define the right macro in stm32l1xx.h.

Table 1 gives the macro to be defined depending on the used microcontroller. This macro
must also be defined in the compiler preprocessor.

Table 1. Macros for STM32L1 series

Macro in stm32l1xx.h

STM32L1 devices

STM32L100xB STM32L100C6, STM32L100R, STM32L100RB
STM32L100xBA STM32L100C6-A, STM32L100R8-A, STM32L100RB-A
STM32L100xC STM32L100RC
STM32L151xB STM32L151C6, STM32L151R6, STM32L151C8, STM32L151RS,
STM32L151V8, STM32L151CB, STM32L151RB, STM32L151VB
STM32L151xBA STM32L151C6-A, STM32L151R6-A, STM32L151C8-A, STM32L151R8-A,
STM32L151V8-A, STM32L151CB-A, STM32L151RB-A, STM32L151VB-A
STM32L151xC STM32L151CC, STM32L151UC, STM32L151RC, STM32L151VC
STM32L151xCA STM32L151RC-A, STM32L151VC-A, STM32L151QC, STM32L151ZC
STM32L151xD STM32L151QD, STM32L151RD, STM32L151VD, STM32L151ZD
STM32L151xE STM32L151QE, STM32L151RE, STM32L151VE, STM32L151ZE
STM32L151xDX STM32L151VD-X
STM32L152xB STM32L152C6, STM32L152R6, STM32L152C8, STM32L152R8,
STM32L152V8, STM32L152CB, STM32L152RB, STM32L152VB
STM32L152xBA STM32L152C6-A, STM32L152R6-A, STM32L152C8-A, STM32L152R8-A,
STM32L152V8-A, STM32L152CB-A, STM32L152RB-A, STM32L152VB-A
STM32L152xC STM32L152CC, STM32L152UC, STM32L152RC, STM32L152VC
STM32L152xCA STM32L152RC-A, STM32L152VC-A, STM32L152QC, STM32L152ZC
STM32L152xD STM32L152QD, STM32L152RD, STM32L152VD, STM32L152ZD
STM32L152xE STM32L152QE, STM32L152RE, STM32L152VE, STM32L152ZE
STM32L152xDX STM32L152VD-X
STM32L162xC STM32L162RC, STM32L162VC
STM32L162xCA STM32L162RC-A, STM32L162VC-A, STM32L162QC, STM32L162ZC
STM32L162xD STM32L162QD, STM32L162RD, STM32L162VD, STM32L162ZD
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Table 1. Macros for STM32L1 series (continued)

Macro in stm32l1xx.h STM32L1 devices
STM32L162xE STM32L162RE, STM32L162VE, STM32L162ZE
STM32L162xDX STM32L162VD-X

STM32Cubel 1 features a rich set of examples and applications at all levels, making it easy
to understand and use any HAL driver and/or Middleware components. These examples are
running on the boards listed in Table 2.

Table 2. Boards for STM32L1 series

Board Supported devices
STM32L152D-EVAL STM32L152xD
STM32L152C-Discovery STM32L152xC
STM32L100-Discovery STM32L100xC
NUCLEO-L152RE STM32L152xE

STM32CubelL1 supports Nucleo-64 boards.
e Nucleo-64 boards support Adafruit LCD display Arduino™ UNO shields, which embed
a microSD connector and a joystick in addition to the LCD.

The Arduino™ shield drivers are provided within the BSP component. Their usage is
illustrated by a demonstration firmware.

The STM32CubelL 1 firmware is able to run on any compatible hardware. That means user
can simply update the BSP drivers to port the provided examples on his own board, if this
later has the same hardware functionalities (LED, LCD Display, Buttons...etc.).

3
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3.2 Firmware package overview

The STM32CubelL1 firmware solution is provided in one single zip package having the
structure shown in Figure 3.

Figure 3. STM32CubeL1 firmware package structure
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For each board, a set of examples is provided with pre-configured projects for EWARM,
MDK-ARM™, TrueSTUDIO® and SW4STM32 toolchains.

3
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Figure 4. Projects for STM32L152RE-Nucleo board
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The examples are organized depending on the STM32Cube level they apply to, and are

named as described below:

e Examplesin level 0 are called Examples, Examples_LL and Examples_MIX. They use,
respectively, HAL drivers, LL drivers and a mix of HAL and LL drivers without any

middleware component.

e Examples in level 1 are called Applications. They provide typical use cases of each

middleware component.

The Template project available in the “Templates” and “Templates_LL” directories allow the

user to quickly build any firmware application on a given board.

14/26 DoclD026721 Rev 5
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3

All examples have the same structure
. \Inc folder contains all header files
. \Src folder for the sources code

o \EWARM, \MDK-ARM, \TrueSTUDIO and \SW4STM32 folders contain the
pre-configured project for each toolchain

e readme.txt describing the example behavior and needed environment to make it

working

Table 3 provides the number of projects available for each board.

Table 3. Number of examples for each board

Level STI\_I|32L152C STM32L1 00C | STM32L152D | STM32L152RE Total
-Discovery -Discovery -EVAL -Nucleo
Templates 1 1 1 1 4
Templates_LL 1 1 1 1 4
Examples_MIX 0 0 0 12 12
Examples LL 0 0 0 73 73
Examples 7 7 28 27 69
Demonstrations 0 1 0 1 2
Applications 1 1 19 3 24
Total 10 1" 49 118 188
DoclD026721 Rev 5 15/26
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Getting started with STM32Cubel1

Running your first example

This section shows how simple is to run a first example within STM32Cubel1, using as an
example the generation of a simple LED toggle running on STM32L152RE Nucleo board:

1.

o gk v

Download the STM32Cubel1 firmware package. Unzip it into a directory of your
choice. Make sure not to modify the package structure shown in Figure 4. Note that it is
also recommended to copy the package at a location close to your root volume (i.e.
C\Eval or G:\Tests) because some IDEs encounter problems when path length is too
high.

Browse to \Projects\STM32L152RE-Nucleo\Examples

Open \GPIO, then \GPIO_EXTI folder

Open the project with your preferred toolchain

Rebuild all files and load your image into target memory

Run the example: each time you press the USER push button, the LED2 toggles (for
more details refer to the example readme file).

3
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Getting started with STM32CubelL1

To open, build and run an example with the supported toolchains, follow the steps below.

e EWARM
a) Under the example folder, open \EWARM subfolder
b) Launch the Project.eww workspace(a)
c) Rebuild all files: Project->Rebuild all
d) Load project image: Project->Debug
e) Run program: Debug->Go (F5)
¢ MDK-ARM™
a) Under the example folder, open \MDK-ARM subfolder
b) Launch the Project.uvproj workspace(a)
c) Rebuild all files: Project->Rebuild all target files
d) Load project image: Debug->Start/Stop Debug Session
e) Run program: Debug->Run (F5)

e  TrueSTUDIO®

a) Open the TrueSTUDIO® toolchain

b) Click File->Switch Workspace->Other and browse to TrueSTUDIO workspace
directory

c) Click File->Import, select General->'Existing Projects into Workspace' and
then click Next.

d) Browse to the TrueSTUDIO workspace directory, select the project

e) Rebuild all project files: select the project in the Project explorer window, then
click Project->build project menu.

f)  Run program: Run->Debug (F11).

e SW4STM32

a) Open the SW4STM32 toolchain.

b) Click File->Switch Workspace->Other and browse to the SW4STM32
workspace directory.

c) Click File->Import, select General->'Existing Projects into Workspace' and
then click "Next".

d) Browse to the SW4STM32 workspace directory and select the project.

e) Rebuild all project files: select the project in the "Project explorer” window then
click Project->build project menu.

f)  Run program: Run->Debug (F11).

a. The workspace name may change from one example to another.

3
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Developing your own application

HAL application

This section describes the steps needed to create your own application using
STM32Cubel1.

1.

Create your project

To create a new project you can either start from the Template project provided for each

board under \Projects\<STM32xxx_yyy>\Templates or from any available project under

\Projects\<STM32xxy_yyy>\Examples or \Projects\<STM32xx_yyy>\Applications

(<STM32xxx_yyy> refers to the board name, such as STM32L152D_EVAL).

The Template project is providing empty main loop function, however it's a good

starting point to get familiar with project settings for STM32CubelL1. The main

characteristics are listed below:

a) It contains sources of HAL, CMSIS and BSP drivers which are the minimal
components to develop a code on a given board

b) It contains the include paths for all the firmware components

c) Itdefines the STM32L1 device supported, allowing to configure the CMSIS and
HAL drivers accordingly

d) It provides ready to use user files preconfigured as follows:
— HAL initialized with default time base with ARM® Core SysTick;
—  SysTick ISR implemented for HAL_Delay() purpose;

—  System clock configured with the minimum frequency of the device (HSI) for an
optimum power consumption.

When copying an existing project to another location, make sure to update the include
paths.

2.

Add the necessary Middleware to your project (optional)
The available Middleware stacks are:

— USB Device Library

—  STMTouch touch sensing
— STemWin

—  FreeRTOS

- FatFS.

To know which source files you need to add in the project files list; refer to the
documentation provided for each Middleware, you may have a look also to the
Applications available under \Projects\STM32xxx_yyy\Applications\<sMW _Stack>
(<MW _Stack> refers to the Middleware stack, ex USB_Device) to have better idea on
the sources files to be added and the include paths.

Configure the firmware components

The HAL and middleware components offer a set of build time configuration options
using macros “#define” declared in a header file. A template configuration file is
provided within each component, it has to be copied to the project folder (usually the
configuration file is named xxx_conf_template.h, the word “_template” need to be
removed when copying it to the project folder).

The configuration file provides enough information to evaluate the impact of each
configuration option; more detailed information is available in the documentation
provided for each component.
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4. Start the HAL Library

After jumping to the main program, the application code needs to call HAL_Init() API to

initialize the HAL Library, which does the following tasks:

a) Configuration of the Flash prefetch and SysTick interrupt priority (configured by
user through macros defined in stm32I1xx_hal_conf.h)

b) Configuration of the Systick to generate an interrupt each 1 msec at the SysTick
interrupt priority TICK_INT_PRIO defined in stm32L1xx_hal_conf.h, which is
clocked by the HSI (at this stage, the clock is not yet configured and thus the
system is running from the internal HSI at 8 MHz)

c) Setting of NVIC Group Priority to 4

d) Call of HAL_Msplnit() callback function defined in user file stm32l1xx_hal_msp.c
to perform global low level hardware initializations.

5. Configure the system clock

This is done by calling the two APIs described below:

a) HAL_RCC_OscConfig(): configures the internal and/or external oscillators, PLL
source and factors. User may select to configure one oscillator or all oscillators, in
addition PLL configuration may be skipped if there is no need to run the system at
high frequency

b) HAL_RCC_ClockConfig(): configures the system clock source, Flash latency and
AHB and APB prescaler.

6. Initialize the peripheral

a) Start by writing the peripheral HAL_PPP_Msplnit function. For this function,
proceed as follows:

— Enable the peripheral clock.

—  Configure the peripheral GPIOs.

—  Configure DMA channel and enable DMA interrupt (if needed).

—  Enable peripheral interrupt (if needed).

b) Edit the stm32xxx_it.c to call required interrupt handlers (peripheral and DMA), if
needed.

c) Write process complete callback functions if you plan to use peripheral interrupt or
DMA.

d) In your main.c file, initialize the peripheral handle structure then call the function
HAL_PPP_Init() to initialize your peripheral.

7. Develop your application

At this stage, your system is ready and you can start developing your application code.

a) The HAL provides intuitive and ready to use APIs to configure the peripheral, and
supports polling, IT and DMA programming model, to accommodate any
application requirements. For more details on how to use each peripheral, refer to
the rich examples set provided.

b) If your application has some real time constraints, you can found a large set of
examples showing how to use FreeRTOS and its integration with all Middleware
stacks provided within STM32CubelL1, it can be a good starting point for your
development.

Caution: In the default HAL implementation, Systick timer is the source of time base. It is used to

3

generate interrupts at regular time intervals. Take care if HAL_Delay() is called from
peripheral ISR process. The SysTick interrupt must have higher priority (numerically lower)
than the peripheral interrupt. Otherwise, the caller ISR process is blocked. Functions
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affecting time base configurations are declared as _weak to make override possible in case
of other implementations in user file (using a general purpose timer for example or other
time source). For more details refer to HAL_TimeBase example.

LL application

This section describes the steps needed to create your own LL Application using
STM32Cubel1.

1. Create your project
To create a new project you can either start from the "Template_LL" project provided for
each board under \Projects\<STM32xxx_yyy>\Templates_LL or from any available project

under \Projects\<sSTM32xxy_yyy>\Examples_LL (<STM32xxx_yyy> refers to the board
name, such as STM32L152D_EVAL).

The Template project is providing empty main loop function, however it's a good starting
point to get familiar with project settings for STM32Cubel 1.
The main characteristics are listed below:

a) It contains sources of LL and CMSIS drivers which are the minimal components to
develop a code on a given board

b) It contains the include paths for all the firmware components needed

c) Itdefines the STM32L1 device supported, allowing to configure the CMSIS and LL
drivers accordingly

d) It provides ready to use user files preconfigured as follows:
main.h: LED & USER_BUTTON defines abstraction layer

main.c: System clock configured with the minimum frequency of the device (HSI)
for an optimum power consumption.

2. Port an existing project to another board
To port an existing project to another targeted board, you must start from the "Template_LL"
project provided for each board under \Projects\<STM32xxx_yyy>\Templates_LL
a) LL Example selection
To find the board on which LL examples are deployed, refer to LL examples list in
"STM32CubeProjectsList.html", table section "Examples_LL" or in AN4706
“STM32Cube firmware examples for STM32L1 Series”
b) LL example porting
Copy / Paste the Templates_LL - to keep the initial source - or directly update
existing Template_LL
Then, the principle will be to replace Templates_LL files by Example_LL targeted
and to keep all board specific parts
In order to help, board specific parts have been flagged by specific Tags
/* ============== BOARD SPECIFIC CONFIGURATION CODE BEGIN

/* ============== BOARD SPECIFIC CONFIGURATION CODE END

3
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Thus, the formal steps are

e Replace file stm32l1xx_it.h

e Replace file stm3211xx_it.c

¢ Replace file main.h, with updates

e Keep LED and user button definition of the LL template under tags

e Replace file main.c with updates

e Keep clock configuration of the LL template: function "SystemClock_Config()" under
tags

e Depending of LED availability, replace LEDx_PIN by another LEDx (number) available
in file main.h

At this step, the example should be functional on the targeted board.

4.3 Using STM32CubeMX to generate the initialization C code

An alternative to steps 1 to 6 described in Section 4.2 consists in using the STM32CubeMX

tool to generate code for the initialization of the system, the peripherals and middleware

through a step-by-step process.

e  Select the STM32 microcontroller that matches the required set of peripherals;

e Configure each required embedded software thanks to a pinout-conflict solver, a clock-
tree setting helper, a power consumption calculator, and the utility performing MCU
peripheral configuration (for example GPIO, USART) and middleware stacks (for
example USB);

e  Generate the initialization C code based on the configuration selected. This code is
ready to use within several development environments. The user code is kept at the
next code generation.

For more informations, refer to UM1718, available on www.st.com.

4.4 Getting STM32CubelL1 release updates

The STM32CubelL1 firmware package comes with an updater utility: STM32CubeUpdater,

also available as a menu within STM32CubeMX code generation tool.

The updater solution detects new firmware releases and patches available from st.com and

proposes to download them to the user’s computer.

4.4.1 Installing and running the STM32CubeUpdater program

3

e  Double-click the SetupSTM32CubeUpdater.exe file to launch the installation.
e Accept the license terms and follow the different installation steps.

Upon successful installation, STM32CubeUpdater becomes available as a
STMicroelectronics program under Program Files and is automatically launched.
The STM32CubeUpdater icon appears in the system tray:

¢ Right-click the updater icon and select Updater Settings to configure the Updater
connection and whether to perform manual or automatic checks (see STM32CubeMX
user guide - UM1718 Section 3 - for more details on Updater configuration).
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What is the license scheme for the STM32CubelL1 firmware?

The HAL is distributed under a non-restrictive BSD (Berkeley Software Distribution) license.
The Middleware stacks made by ST (USB Device, Touch Sensing and STemWin libraries)
come with a licensing model allowing easy reuse, provided it runs on an ST device.

The Middleware based on well-known open-source solutions (FreeRTOS and FatFS) have
user-friendly license terms. For more details, refer to the license agreement of each
Middleware.

What boards are supported by the STM32CubelL1 firmware
package?
The STM32CubelL1 firmware package provides BSP drivers and ready-to-use examples for

the following STM32L1 boards: STM32L152D-EVAL, STM32L152C-Discovery,
STM32L100-Discovery and NUCLEO-L152RE.

Are any examples provided with the ready-to-use toolset
projects?

Yes. STM32Cubel1 provides a rich set of examples and applications (around 90 in total).
They come with the pre-configured project of several toolsets, namely IAR™, KeiI® and
GCC.

Is there any link with Standard Peripheral Libraries?

The STM32Cube HAL and LL drivers are the replacement of the standard peripheral library.

e  The HAL drivers offer a higher abstraction level compared to the standard peripheral
APIs. They focus on peripheral common features rather than hardware. Their higher
abstraction level allows defining a set of user-friendly APIs that can be easily ported
from one product to another.

e The LL drivers offer low-level APls at registers level. They are organized in a simpler
and clearer way than direct register accesses. LL drivers also include peripheral
initialization APls, which are more optimized compared to what is offered by the SPL,
while being functionally similar. Compared to HAL drivers, these LL initialization APIs
allows an easier migration from the SPL to the STM32Cube LL drivers, since each SPL
API has its equivalent LL API(s).

Do the HAL drivers take benefit from interrupts or DMA?
How can this be controlled?

Yes, they do. The HAL supports three APl programming models: polling, interrupt and DMA
(with or without interrupt generation).
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How are the product/peripheral specific features managed?

The HAL offers extended APIs, i.e. specific functions as add-ons to the common API to
support features available on some products/lines only.

How can STM32CubeMX generate code based on embedded
software?
STM32CubeMX has a built-in knowledge of STM32 microcontrollers, including their

peripherals and software. This enables the tool to provide a graphical representation to the
user and generate *.h/*.c files based on user configuration.

How to get regular updates on the latest STM32CubelL1
firmware releases?
The STM32CubelL1 firmware package comes with an updater utility, STM32CubeUpdater,

that can be configured for automatic or on-demand checks for new firmware package
updates (new releases or/and patches).

STM32CubeUpdater is integrated as well within the STM32CubeMX tool. When using this
tool for STM32L1 configuration and initialization C code generation, the user can benefit
from STM32CubeMX self-updates as well as STM32CubelL 1 firmware package updates.

For more details, refer to Section 4.4: Getting STM32CubelL 1 release updates.

When should | use HAL versus LL drivers?

HAL drivers offer high-level and function-oriented APIs, with a high level of portability.
Product/IPs complexity is hidden for end users.

LL drivers offer low-level APls at registers level, with a better optimization but less
portability. They require a deep knowledge of product/IPs specifications.

How can | include LL drivers in my environment?
Is there any LL configuration file as for HAL?

There is no configuration file. Source code shall directly include the necessary
stm3211xx_II_ppp.h file(s).

Can | use HAL and LL drivers together? If yes, what are the
constraints?

It is possible to use both HAL and LL drivers. One can handle the IP initialization phase with
HAL and then manage the 1/O operations with LL drivers.

The major difference between HAL and LL is that HAL drivers require to create and use
handles for operation management while LL drivers operates directly on peripheral
registers. Mixing HAL and LL is illustrated in Examples_MIX example.
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5.12 Are there any LL APIs that are not available with HAL?

Yes, there are.

A few Cortex® APIs have been added in stm32l1xx_II_cortex.h e.g. for accessing SCB or
SysTick registers.

513 Why are SysTick interrupts not enabled on LL drivers?

When using LL drivers in standalone mode, you do not need to enable SysTick interrupts
because they are not used in LL APlIs, while HAL functions requires SysTick interrupts to
manage timeouts.

5.14 How are LL initialization APIs enabled?

The definition of LL initialization APls and associated resources (structure, literals and
prototypes) is conditioned by the USE_FULL_LL DRIVER compilation switch.

To be able to use LL APIs, add this switch in the toolchain compiler preprocessor.

3
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6 Revision history

Table 4. Document revision history

Date Revision Changes
02-Sep-2014 1 Initial release.
04-Feb-2015 5 Added STM32L151xDX, STM32L152xDX and STM32L162xDX
macros in Table 1: Macros for STM32L1 series.
11-Jun-2015 3 Added SW4STM32 in Section 3.2: Firmware package overview and

Section 4.1: Running your first example.

Updated Introduction, Section 1: STM32CubelL1 main features,
Section 3: STM32Cubel 1 firmware package overview and Section 5:
FAQ.

Updated Section 2: STM32Cubel 1 architecture overview with
introduction of Section 2.1: Level 0, Section 2.2: Level 1, Section 2.3:
01-Jun-2016 4 Level 2 and their subsections.

Updated Figure 1: STM32Cube firmware components, Figure 2:
STM32Cubel 1 firmware architecture, Figure 3: STM32CubelL 1
firmware package structure and Figure 4: Projects for STM32L152RE-
Nucleo board.

Updated Table 3: Number of examples for each board.

Updated Section 3.2: Firmware package overview and Section 4.2:
Developing your own application with introduction of Section 4.2.1:
HAL application and Section 4.2.2: LL application.

Updated Figure 1: STM32Cube firmware components and Figure 4:
Projects for STM32L152RE-Nucleo board.

Updated Table 3: Number of examples for each board.

10-Apr-2017 5
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IMPORTANT NOTICE — PLEASE READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and
improvements to ST products and/or to this document at any time without notice. Purchasers should obtain the latest relevant information on
ST products before placing orders. ST products are sold pursuant to ST’s terms and conditions of sale in place at the time of order
acknowledgement.

Purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or
the design of Purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.

Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

ST and the ST logo are trademarks of ST. All other product or service names are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2017 STMicroelectronics — All rights reserved
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