
Introduction
The STSW-S2LP-SFX-DK is an evaluation SW package for Sigfox networking with the S2-LP high performance, ultra-low power 
RF transceiver. It is designed to operate in the majority of radio configuration zones (RCZ) described by Sigfox.

The STSW-S2LP-SFX-DK SW package supports the STEVAL-FKI868V1, STEVAL-FKI868V2, STEVAL-FKI915V1 and the      
X-NUCLEO-S2868A1 kit platforms.

In addition, the package includes the support for the STEVAL-IDB007V2 and STEVAL-IDB008V2 kits to be used in conjunction 
with the shields included in the above mentioned kits. The latter solution enables the support for BlueNRG1/2 System-on-Chip 
alternatively to the STM32 microcontroller.

It provides an S2-LP Sigfox library with a complete set of APIs to develop embedded applications.

The S2-LP - Sigfox Demo GUI PC application provides an interactive interface to transmit messages to the Sigfox network and 
program the STEVAL-FKI nodes with the Sigfox ID to set the node for network communication.

For details regarding the BlueNRG-1 hardware and software development kit, refer to STSW-BLUENRG1/2-DK.

Getting started with the Sigfox S2-LP kit
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1 Sigfox S2-LP kit content

The package includes:
• the Sigfox Demo GUI and corresponding firmware to:

– prepare the board with ID/PAC/Key from the pool assigned to ST devices (see Section 4 Demo
description)

– run a demo that transmits user defined messages to the Sigfox network (see Section 5 Push button
demo description)

• a framework to develop embedded Sigfox-enabled applications, with examples in the source code.
• an application note which describes the Sigfox firmware framework based on the S2-LP transceiver and on

both STM32 MCU and BlueNRG1/2 SoC, with guidelines on how to develop solutions that are optimized for
power.

• a tool and related software APIs to store Sigfox credentials and manufacturing calibration values (frequency
offset and RSSI), in a secure way, into the MCU internal Flash.
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2 Requirements

2.1 Hardware requirements
A Windows® PC with:
• 2 USB ports
• 125 MB free hard disk space

At least one of the following ST evaluation kits:
• STEVAL-FKI868V2 (and STEVAL-FKI868V1) (for RCZ1 and RCZ3) kit with:

1. STEVAL-FKI868V2 (and STEVAL-FKI868V1) evaluation board featuring the S2-LP sub-1 GHz
(860-940 MHz) ultra-low power low data-rate transceiver

2. STM32 Nucleo-64 development board or STEVAL-IDB007V2/IDB008V2 board
• STEVAL-FKI915V1 (for RCZ2 and RCZ4)

1. STEVAL-FKI915V1 evaluation board based on the S2-LP sub-1 GHz (860-940 MHz) ultra-low power
low data-rate transceiver, with external power amplifier

2. STM32 Nucleo-64 development board or STEVAL-IDB007V2/IDB008V2 board

2.2 Software prerequisites
• Microsoft Windows 7 or later
• Adobe Acrobat Reader 6.0 or later

One of the following integrated development environments (to develop embedded sigfox-enabled applications):
1. IAR EWARM 8.22.1 or later
2. Keil MDK-ARM µVision 5.17 or later
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3 Board registration

3.1 ST-side registration
This registration procedure need only be performed once via the ST GUI.

Step 1. Connect the STM32 Nucleo-64 development board to a PC via USB
Windows should automatically recognise the board as a hard drive

Figure 1. NUCLEO disk drive

Step 2. Flash the development board by simply dragging the appropriate bin file (in the Binary folder) to the
NODE drive.
Choose the bin file according to your STM32 Nucleo-64 development board:
– SIGFOX_CLI_DEMO_NUCLEO_XX.bin

Table 1. Sigfox radio configuration zone

Frequency range Zone RC

862-876 1 - EMAEI RC1

902-928
2 - APAC1 (Americas) RC2, 4

3 - APAC2 (Japan and South Korea) RC3a, RC3c, RC5

Step 3. Open the ST Sigfox GUI and open the COM port associated with the STM32 Nucleo-64 development
board.
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Figure 2. Sigfox Demo GUI main window

Step 4. Click on the Open button.
If the board does not contain Sigfox data, a Board Preparation wizard appears.
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Figure 3. ST Registration procedure 1/3

Step 5. Click the Next button
You will be prompted to complete a short form with your:
– name
– company name
– e-mail address
– radio configuration zone (RCZ) number

Note: You must specify the correct RCZ to avoid generating an incorrect ID.
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Figure 4. ST Registration procedure 2/3

Step 6. Click on the Generate mail button
A window appears with the e-mail data you need to send.

Figure 5. Generated mail pop-up

Step 7. Send an email with the Destination Address, Subject and e-mail text shown in the popup window.
You will receive an answer (at the e-mail address you specified previously) with an activation string.

Step 8. Paste the activation string you receive in the text box and click Next.
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Figure 6. ST Registration procedure 3/3

Step 9. If the activation string is correct, the board is programmed with the Sigfox account data and the ID and
PAC is shown on the final page.
The board is now ready and you can register the board in its own Sigfox backend.

3.2 Sigfox side registration
Visit htpps://buy.sigfox.com/activate for ST development kit registration.

Step 1. Insert the country where the board should operate the ID and PAC of the board.
Step 2. Then fill a form to obtain an account on the sigfox backend.

An e-mail will be sent to the specified e-mail address.
Step 3. Choose a password and sign in to its own backend from https://backend.sigfox.com.
Step 4. Go to the DEVICE section.

This section provides a list of registered devices and other data.

Figure 7. Sigfox device page
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Step 5. Click on the device ID to access a node summary page:

Figure 8. Sigfox device information

Step 6. Click on messages to show a list of all sent messages.
For each message, the following information is shown:
– the date and time
– the data in hex (so if the transmission occurred with the S2-LP Sigfox GUI, the data should be the

transmitted message in hex)
– the location of the node (link to a map)
– a link quality indicator (SNR bar)

Figure 9. Sigfox device messages
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4 Demo description

The demo can run either on a kit connected to a PC running the Sigfox Demo GUI (Section 4.1 Sigfox Demo
GUI ), or on a kit supplied via USB in standalone mode (Section 4.2 Demo without connection to a PC).

4.1 Sigfox Demo GUI
After board registration, you can transmit messages using the GUI.

Step 1. Connect the STM32 Nucleo-64 development board to a PC via USB.
Step 2. Ensure jumper JP1 (near the USB connector) is open so the PC to assign a COM port to it.

LEDs LD1 and LD3 on the board should both be lit.

Figure 10. JP1 position on STM32 Nucleo board

Step 3. Launch the Sigfox Demo GUI on your PC
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Figure 11. Sigfox Demo GUI main window

Step 4. Click on the TX button to transmit data.
In adherence with protocol, the frame is repeated three times with a 500 ms interval; the duration of
each frame is shown in the Frame duration box.
The frames received by the base-stations are shown in the DEVICE > Messages section of the sigfox
backend.

Note: The maximum length of a message is 12 bytes, as per the sigfox protocol.
Step 5. Check the Ask for response checkbox and then click TX again.

The message is sent with a response request and the transmission is followed by a reception phase of
up to 50 s. The received message is shown in the Messages section of the GUI.

Step 6. To set the response for each device from the sigfox backend, log-in, go to the DEVICE TYPE tab and
click on the device type description.

Figure 12. Sigfox DEVICE TYPE tab

Step 7. Click Edit to change the Downlink data parameters.
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Figure 13. Sigfox DEVICE TYPE parameters

Step 8. Check the uC goes to low power checkbox to set the microcontroller in low power mode during radio
transactions.

4.1.1 Sigfox Demo GUI menu items
The File menu can be used to access the Demo firmware and Sigfox library version information.
For radio configuration zones 2 and 4, there is also the Set Std Configuration option described in Section
4.3.3 node_set_std_config command description.
The Help menu provides GUI version information.

4.2 Demo without connection to a PC
In this mode, the board is not connected to a PC

Step 1. Close jumper JP1 in Figure 10. JP1 position on STM32 Nucleo board.
This allows the STM32 to execute the firmware program without being enumerated to a USB host
device.
LED LD1 will blink and LD3 will remain lit.

Step 2. Press the blue button repeatedly.
The node transmits a 32-bit counter to the network representing the number of times this button has
been pressed since the last reset.

4.3 Using the command line
The SIGFOX_CLI_DEMO_NUCLEO firmware lets send simple commands using a serial terminal.

Step 1. Open the COM port with a baudrate of 115200
A simple command shell opens.

Step 2. Press the reset button.
The STM32 Nucleo board resets and a string containing ID and PAC in hex format is printed.

Figure 14. Command line terminal box

Step 3. Type help.
A list of all commands is shown.
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Figure 15. Command line function list

4.3.1 Command line function description

Table 2. Available command line functions

NAME ARGUMENTS DESCRIPTION

fw_version None Return the firmware version

get_id None Return the sigfox ID of the board

get_pac None Return the sigfox PAC of the board

get_rcz None Return the RCZ

node_open None
Open the sigfox library

Must be called before performing any
send operation

node_close None Close the sigfox library

node_send_frame

list-of-bytes: must be enclosed
between { } brackets and
represented in hex without spaces.

tx_repetitions: integer

require_downlink: integer

See Section 4.3.2 node_send_frame
command description

node_set_std_config

conf_word0,conf_word1,
conf_word2 : 3 conf words

of 32bits each

default_sigfox_channel can be from
1 to 82

Set the standard channel configuration.

This function is only for RCZ2 and 4.

See Section 4.3.3 node_set_std_config
command description
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NAME ARGUMENTS DESCRIPTION

node_reset None Reset the sigfox library state

node_reduce_power reduction: the reduction factor in
0.5 dB (approx)

Reduces the output power of the
transmitted signal by a factor.

= reduction argument * 0.5 dB

set_low_power 1: enable_low_power (default)

0: disable_low_power

Enable or disable microcontroller low
power mode during transmission and
reception operations

switch_public_key 1: switch to the public key

0: use the key of this specific node.
The public key is [00, 11, 22, … , FF]

reboot None Reboot the device

node_get_version None Returns the version of the Sigfox Library

node_get_std_config None Returns the standard channel
configuration in memory

node_test_mode RCZ: integer

Test_Mode: integer
Executes a specified test mode

get_lib_version

Lib_ID: Integer

0=Sigfox

1=MCU_API

2=RF_API

5=MONARCH_API

6=DEVICE_CONFIG_API

Get version of specified module.

VENDOR_set_payload_encription 1: enable payload encryption

0: disable payload encryption
Enables payload encryption

VENDOR_set_frequency_offset Offset: real Overrides default offset calibration

VENDOR_set_rssi_offset Offset: real Set RSSI calibration value

VENDOR_get_rssi_offset None Returns the last RSSI offset in memory

node_send_bit Bit to send: 1 or 0

Number of repetition: integer
Send a single bit n times

node_open_with_zone RCZ: integer Open Sigfox Library with a specified RC
zone (see Table 7. Sigfox RC zones)

switch_test_credentials 1: Enable test credentials

0: Disable test credentials
Enable credentials to be used during
Sigfox verified tests

4.3.2 node_send_frame command description
To send a frame, call the node_open command and then the node_send command specifying the following
parameters:
1. The list of bytes to be transmitted: given as a hexadecimal string (12 bytes max.).
2. tx_repetitions:

– If require_downlink is set, the frame is sent tx_repetitions + 1 times (tx_repetitions ≤ 2)
– If initiate_downlink_flag is not set, tx_repetitions is forced to 2.

3. require_downlink: Request a downlink frame from the base-station and wait for reception.

Note: The behavior of the node is different in uplink (require_downlink=0) and downlink
(require_downlink=1).
The following procedures are initiated in the different cases:
• uplink :
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– Send uplink frames (3)

Command example: node_send_frame {012345} 0 0

Command response: {{(node_send_frame)} API call...{sfx_error:00}}

• downlink :
– Send uplink frames (1 to 3)
– Receive downlink frame
– Send out of band frame (Voltage, temperature and RSSI)

Command example: node_send_frame {012345} 2 1

Command response: {{(node_send_frame)} API call...{sfx_error:00}

{customer_resp: 0x00,0x00,0x00,0x50,0x6C,0x75,0x74,0x6F}}

4.3.3 node_set_std_config command description
FCC allows the transmitters to choose different macro channels to implement a frequency hopping pattern
allowed by the standard. These macro channels can be chosen through three 32-bit configuration words.
Each bit of the config_words[0,1,2] array represents a macro channel according to the following mapping:

Table 3. Macro channel mapping - config_words[0]

Macro Ch. 1 2 3 4 5 6 7 … 32

Frequency (MHz) 902.2 902.5 902.8 903.1 903.4 903.7 904.0 … 911.5

config_words[0] bit 0 1 2 3 4 5 6 … 31

Table 4. Macro channel mapping - config_words[1]

Macro Ch. 33 34 35 36 37 38 39 … 64

Frequency (MHz) 911.8 912.1 912.4 912.7 913.0 913.3 913.6 … 921.1

config_words[1] bit 0 1 2 3 4 5 6 … 31

Table 5. Macro channel mapping - config_words[2]

Macro Ch. 65 66 67 68 69 70 71 … 86

Frequency (MHz) 921.4 921.7 922.0 922.3 922.6 922.9 923.2 … 927.7

config_words[2] bit 0 1 2 3 4 5 6 … 21

A macro channel is only enabled when the corresponding config_words[] bit is set to 1. At least 9 macro
channels must be enabled to meet the FCC specifications.
The last argument is an integer representing the sigfox_default_channel. It should be set as follows:
• For RCZ2, the operational frequency should be 902.2MHz and the default channel is 1.
• For RCZ4, it is necessary to keep the 902.2 MHz frequency in the open function but, since the sigfox

operational channel is at 920.8MHz, we need to set the default channel to 63.

By default the GUI uses the following std_config:

UM2169
Using the command line 

UM2169 - Rev 2 page 15/30



Table 6. Default STD config

Parameter RCZ2 RCZ4

config_words[0] 0x000001FF 0x00000000

config_words[1] 0x00000000 0xF0000000

config_words[2] 0x00000000 0x00001F

sigfox_default_channel 1 63

Note: This command is ineffective for RCZ1.
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5 Push button demo description

This is an ST-Sigfox demo showing how to use the Sigfox protocol for a message to a base station each time the
blue button on the STM32 Nucleo board , or the button 2 of the STEVAL-IDB007V2/STEVAL-IDB008V2 board, is
pressed. The data sent is a number representing the number of times the button has been pressed since the last
boot sequence.
If something goes wrong during initialization, the green LED on the STM32 Nucleo board or the red lLED on the
STEVAL-IDB007V2/STEVAL-IDB008V2 board will blink continuously. This may be due to:
1. The firmware configuration used is not coherent with the board type (ETSI fw used with the STEVAL-

FKI915V1 or FCC fw used with the STEVAL-FKI868V1).
2. The board is not ready because ID/PAC and KEY have not been loaded on the board.
3. The sigfox library open function returns an error.
The root folder of the project is in Projects/Projects_Cube/Sigfox_Applications/Sigfox_PushButton_Demo_Project.
The same example is provided for MDK-ARM Keil and IAR Embedded Workbench integrated development
environments.

5.1 KEIL project
To use the project with KEIL µVision 5 for ARM®:

Step 1. Open the KEIL µVision 5 for ARM and select Project→Open Project.
Step 2. Open the KEIL project

.../Projects/Projects_Cube/Sigfox_Applications/Sigfox_PushButton_Project/MDK-ARM/
Sigfox_PushButton_Project.uvprojx

Step 3. Select desired configuration to build
NUCLEO_XX_ETSI for RCZ1 or NUCLEO_XX_FCC for RCZ2/4

Step 4. Select Project→Rebuild all target files.
This will recompile and link the entire application

Step 5. Select Project→Download to download the corresponding binary image.

5.2 IAR project
To use the project with IAR Embedded Workbench for ARM®:

Step 1. Open the Embedded Workbench for ARM and select File→Open→Workspace.
Step 2. Open the IAR project

.../Projects/Projects_Cube/Sigfox_Applications/Sigfox_PushButton_Project/EWARM/
Sigfox_PushButton_Project.eww

Step 3. Select desired configuration to build
NUCLEO_XX_ETSI for RCZ1, NUCLEO_XX_FCC for RCZ2/4, NUCLEO_XX_ARIB for RCZ3 or
NUCLEO_XX_ALL to include all.

Step 4. Select Project→Rebuild All.
This will recompile and link the entire application

Step 5. Select Project→Download and Debug to download the corresponding binary image.
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6 Sigfox CLI demo description

This ST-Sigfox demo shows how to use a command line interface (CLI) to send commands which use the Sigfox
protocol to send messages and perform pre-certification tests (for the available commands refer to Section
4.3 Using the command line).

6.1 STEVAL-IDB007V2/STEVAL-IDB008V2 limitations
As described in Section 6.4 BlueNRG-1/2 support, the STEVAL-IDB007V2/STEVAL-IDB008V2 evaluation boards
cannot use the UART and the external EEPROM at the same time, so the EEPROM cannot be used in this
project.
For this reason, in the CLI Project, you should use the define USE_FLASH for the MCU Flash to store credentials
and any other Sigfox nonvolatile data.

6.2 Sigfox pre-certification tests
The CLI project includes the SIGFOX ADDON library that allows performing the entire test suite before the official
certification.
The test procedure requires the RSA-SDR-Dongle kit from Sigfox.
Test can be performed calling the node_test command specifying RCZ and Test ID.

6.2.1 Sigfox RCZ values

Table 7. Sigfox RC zones

RCZ ID RCZ Name Description

0 SFX_RC1 Radio Configuration 1

1 SFX_RC2 Radio Configuration 2

2 SFX_RC3A Radio Configuration 3A

3 SFX_RC3C Radio Configuration 3C

4 SFX_RC4 Radio Configuration 4

5 SFX_RC5 Radio Configuration 5

6 SFX_RC101 Radio Configuration 101

6.2.2 Sigfox test ID values

Table 8. Sigfox suitable test ID values

Test ID# Test name

0 SFX_TEST_MODE_TX_BPSK

1 SFX_TEST_MODE_TX_PROTOCOL

2 SFX_TEST_MODE_RX_PROTOCOL

3 SFX_TEST_MODE_RX_GFSK

4 SFX_TEST_MODE_RX_SENSI

5 SFX_TEST_MODE_TX_SYNTH

6 SFX_TEST_MODE_TX_FREQ_DISTRIBUTION

7 SFX_TEST_MODE_RX_MONARCH_PATTERN_LISTENING_SWEEP
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Test ID# Test name

8 SFX_TEST_MODE_RX_MONARCH_PATTERN_LISTENING_WINDOW

9 SFX_TEST_MODE_RX_MONARCH_BEACON

10 SFX_TEST_MODE_RX_MONARCH_SENSI

6.3 IAR project
To use the project with IAR Embedded Workbench for ARM©:

Step 1. Open the Embedded Workbench for ARM©.
Step 2. Select [File]>[Open]>[Workspace].
Step 3. Open the IAR project

../Projects/Projects_Cube/SigFox_Applications/SigFox_CLI_Demo_Project/EWARM/
SigFox_CLI_Demo_Project.eww

Step 4. Select the desired configuration.
Step 5. Select [Project]>[Rebuild All]
Step 6. Select [Project]>[Download and Debug] to download the corresponding binary image.

6.4 BlueNRG-1/2 support
The STSW-S2LP-SFX-DK SW package supports the STEVAL-IDB007V2/STEVAL-IDB008V2 platforms.
To use them, you have to download and install the latest STSW-BLUENRG1-DK software package from
www.st.com to install the USB-to-serial driver needed for the applications requiring the serial port.
Some hardware modifications are also needed to ensure compatibility with S2-LP evaluation kits.

6.4.1 Hardware requirements
To run the demo of this package you need:
• a BlueNRG-1 STEVAL-IDB007V1/2 or a STEVAL-IDB008V1/2 kit based on BlueNRG-2 (for futher details,

see UM2071 on www.st.com).
• an S2-LP STEVAL-FKI868V1 or STEVAL-FKI915V1 kits depending on the operating band (for futher details,

see UM2149 on www.st.com).

Figure 16. STEVAL-IDB007V1 platform
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6.4.2 Changes to the STEVAL-IDB007V1/2 and STEVAL-IDB008V1/2 boards
To make the STEVAL-IDB007V1/2 or STEVAL-IDB008V1/2 boards compatible with the STEVAL-FKI868V1/
STEVAL-FKI915V1 boards, you have to apply some changes to the board, on the bottom layer:

Step 1. Remove R12 resistor.
Step 2. Create a short-circuit between pin 8 and pin 7 of CN3 connector.
Step 3. Remove R25, R21, R19, R16 resistors.
Step 4. Set a short between the internal pad of R21 and R17 resistors.
Step 5. Set a short between pin 6 of CN4 connector and the internal pad of R19 resistor.

Figure 17. STEVAL-IDB007V1/2 or STEVAL-IDB008V1/2 hardware modification

6.4.3 BlueNRG-1 SoC connections
After applying the modifications, the STEVAL-IDB007V1 platform pin connection is as described the following
table.
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Table 9. STEVAL-IDB007V1 platform pin description with board function

Pin
name

Pin
num.

Function

LEDs S2-LP Buttons FKI_E2PROM Pressure
sensor

3D
accelerometer

and
gyroscope

JTAG

Arduino connectors

CN1 CN2 CN3 C4

DIO10 1 JTMS-
SWTDIO

DIO9 2 JTCK-
SWTCK

DIO8 3 SPI_CS pin 1
(IO8)

pin 2
(TX)

DIO7 4 DL2 pin 2
(IO9)

pin 6
(SCL)

DIO6 5 DL1 SDN pin 7
(IO6)

pin 5
(SDA)

DIO5 7 PUSH2
SDA

(PUSH2
button)

pin 9
(SDA)

DIO4 8 SCL pin 10
(SCL)

DIO3 9 SPI_SDO SPI_SDO SPI_SDO pin 5
(MISO)

pin 6
(IO5)

DIO2 10 SPI_SDA SPI_SDA SPI_SDA pin 4
(MOSI)

pin 5
(IO4)

DIO1 11 SPI_CS JTAG-
TDO

pin 3
(CS)

DIO0 12 SPI_SCL SPI_SCL SPI_SCL JTAG-
TDI

pin 6
(SCK)

pin 4
(IO3)

DIO14 13 DL3 SPI_CS pin 4
(AD3)

RESET 25 RESET RESET RESET pin 3
(NRST)

pin 8
(IO7)

DIO13 29 GPIO3 PUSH1 pin 3
(AD2)

DIO12 30 INT1 pin 1
(AD0)

DIO11 32

pin 1
(RX)
pin 3
(IO2)

pin 2
(AD1)

6.4.4 S2-LP
The S2-LP is placed in the STEVAL-FKI868/915V1 boards connected to the STEVAL-IDB007V1 through the
Arduino connectors (CN1-4) and can be driven by the BlueNRG-1 via SPI.
GPIO3 is connected to the BlueNRG-1 wake-up pin used to notify some events.
The BlueNRG-1 SoC acts as a SPI master and can be used to configure the device through registers and to
send/receive data to/from the sub-1GHz channels.

6.4.5 E2PROM
The E2PROM containing the manufacturing data of the S2-LP board can be accessed by the BlueNRG-1 using
the SPI bus.
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Important:
Since the EEPROM CS signal is shared with the TX signal of the BlueNRG UART port (IO8), UART and EEPROM should be
used in an exclusive way.

6.4.6 Hardware setup
Step 1. Connect a 2.4 GHz antenna to the STEVAL-IDB007V1 SMA connector.
Step 2. Connect an 868/915MHz antenna to the STEVAL-FKI868/915V1 SMA connector.
Step 3. Ensure the jumper configuration on the board is as described in Section 6.4.2 Changes to the STEVAL-

IDB007V1/2 and STEVAL-IDB008V1/2 boards.
Step 4. Connect the motherboard to the PC via a USB cable.
Step 5. Verify the PWR LED DL4 light is on.

6.5 Sigfox credentials
Sigfox board information (ID, PAC and KEY) can be stored in the device Flash memory using the
SIGFOX_FLASHER tool included with the STSW-S2LP-SFX-DK package.
Before proceeding, you need to obtain valid credentials from Sigfox (for further details, contact your local
reference for Sigfox).
However, you can use the test credentials for test purposes:
• ID = 0xFEDBCA98
• KEY = 0x0123456789ABCDEF0123456789ABCDEF

The SIGFOX_FLASHER is a tool to setup Sigfox credentials and board information related to Sigfox operations.
The output of this tool is a binary file and, optionally, the information stored in the file can be directly flashed to the
device.
All the examples included in this package can be programmed to read Sigfox credentials from Flash by simply
declaring the USE_FLASH define in the pre-processor defined symbols.
Together with ID, PAC and KEY, other information stored in the Flash memory is related to:
• RCZ
• frequency offset
• RSSI offset

6.5.1 Prerequisites
To save credentials in your device using the tool, ensure you installed the right version of ST-LINK utility,
according the device you want to flash (refer to the table below).

Table 10. ST-LINK utility and related devices

Device ST-LINK UTILITY

STM32 STSW-LINK004

BlueNRG1/2 STSW-BNRG1STLINK

When installed, check the application path with the one listed in the app.cfg file.
Default values for app.cfg are:

STM_32=C:\Program Files (x86)\STMicroelectronics\STM32 ST-LINK Utility\ST-LINK Utility\ST-LIN
K_CLI.exe

BLNRG1=C:\Program Files (x86)\STMicroelectronics\BlueNRG-1_2 ST-Link Utility V 2.0.0\ST-LINK_
Utility\BlueNRG-1_ST-LINK_CLI.exe
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6.5.2 Usage
After receiving your valid credentials, go to the SfxFlasher folder and open a Windows command window.
The SIGFOX_FLASHER tool supports a series of options as listed in the table below.

Table 11. SIGFOX_FLASHER parameters

Parameter Description

Data A string in the form of ID;PAC;KEY;RCZ;FrequencyOffset;RSSIOffset
-e Encryption mode: none, fixed, variable

-k key 16-byte long encryption key when fixed mode selected

-f [file name] Output file name

-w [address] Write directly in the Flash memory

Example:

> SIGFOX_FLASHER 
"FEDBCA98;0102030405060708;0123456789ABCDEF0123456789ABCDEF;1;1740;21" -e fixed
–k 995511775533664400AABBCCDDEEFF00 –f myCredentials.bin -w

Note: The values for RC Zone field are:
• 1 = RC1
• 2 = RC2
• 3 = RC3c
• 4 = RC4
• 5 = RC5
The command in the example generates the myCredentials.bin file which, through the –w option, is automatically
flashed at the default location according to the table below.

Table 12. Devices and related default Sigfox board data address

Device Default Sigfox board data address

STM32L0 0x08007000

STM32L1 0x08000200

STM32F0 0x08006CE0

STM32F4 0x08008000

BlueNRG-1 0x10065800

BlueNRG-2 0x1007D800

6.5.3 Encryption
The Sigfox key can be optionally encrypted using an AES 128 bit encoding algorithm, with a 16-byte long key.
There are three ways of handling key encryption:
• no encryption
• fixed encryption
• variable encryption

6.5.3.1 No encryption

With the -e none option, the key provided as input will be stored as is, without any encryption or elaboration.
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6.5.3.2 Fixed encryption

The term fixed identifies an encryption key used always as is for each board.
When fixed encryption is selected, using the -e fixed option, the custom key has to be provided with the -k option
as in the example above.

6.5.3.3 Variable encryption

The term variable identifies a different encryption key for every board based on its own unique ID.
To enable this type of encryption, type the option -e variable.
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IMPORTANT NOTICE – PLEASE READ CAREFULLY

STMicroelectronics NV and its subsidiaries (“ST”) reserve the right to make changes, corrections, enhancements, modifications, and improvements to ST
products and/or to this document at any time without notice. Purchasers should obtain the latest relevant information on ST products before placing orders. ST
products are sold pursuant to ST’s terms and conditions of sale in place at the time of order acknowledgement.

Purchasers are solely responsible for the choice, selection, and use of ST products and ST assumes no liability for application assistance or the design of
Purchasers’ products.

No license, express or implied, to any intellectual property right is granted by ST herein.

Resale of ST products with provisions different from the information set forth herein shall void any warranty granted by ST for such product.

ST and the ST logo are trademarks of ST. All other product or service names are the property of their respective owners.

Information in this document supersedes and replaces information previously supplied in any prior versions of this document.

© 2018 STMicroelectronics – All rights reserved
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