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Web Security Service Hosted Reporting

The Symantec Web Security Service solutions provide real-time protection against web-borne threats. As a cloud-based
product, theWeb Security Service leverages Symantec's proven security technology as well as theWebPulse™ cloud com-
munity of over 75million users.

With extensive web application controls and detailed reporting features, IT administrators can use theWeb Security Service
to create and enforce granular policies that are instantly applied to all covered users, including fixed locations and roaming
users.

This document describes how to send logs from an existing Symantec ProxySG appliance to theWeb Security Service for
security scanning and policy checks.

n "About Cloud Service Hosted Reporting" on page 7

n "Configure..." on page 9

n "About Reporting" on page 27

This document contains topics collected from theWeb Security Service online documentation. For the complete doc set,
see:

Symantec Support Site > WSS Documentation
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About Cloud Service Hosted Reporting

Hosted reporting provides an alternate to deploying andmaintaining Symantec Reporter or other reporting application. Rather
than directly processing employee web requests and applying policy checks for security andmalware, the Symantec Web
Security Service processes the access logs from an existing ProxySG appliance gateway deployment.

Instead of forwarding client Web requests directly to theWeb Security Service for processing:

n 1—The ProxySG performs its standard operation: it processes web requests (authorizes, checks policy).

n 2—The ProxySG records each web transaction in themain-format access logs. The upload client sends the access
logs to aWeb staging server (HTTP or FTP). A network manager configures a secure copy (SCP) link from the
staging server to theWeb Security Service service. The service checks every hour for new data.

n 3—WebSecurity Service administrators or other personnel in the Reporting User role log into the service to generate
and view reports (or have reports sent to them at scheduled times).
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TheWeb Security Service retains live reportable data for one year (in comparison, the Proxy Forwarding access method
retains web use data for 90 days).

First Step

Plan the hosted reporting deployment. See "Plan The Hosted Reporting Configuration" on page 10.



Configure...

The section describes how to enable Hosted Reporting on the Web Security Service.

Plan The Hosted Reporting Configuration 10

Initial Hosted Reporting Configuration 11

Send ProxySGAppliance Access Logs to Staging Server 15

Secure Copy Access Logs to theWeb Security Service 18

Access theWeb Security Service Hosted Reporting Interface 21

Specify Access Log Retention Duration 22

Download Access Logs 24

Scenarios That Require New SCP Keys 26
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Plan The Hosted Reporting Configuration

The Symantec Web Security Service supports hosted reporting, whichmeans forwarding web use access logs from a
ProxySG appliance to the cloud-based service and viewing reports in theWeb Security Service interface.

Before beginning device configuration, Symantec recommends that you pre-record the required information. The planning
sheet provides default information and forms for you to enter information specific to your network.

Component Comments Value

Welcome letter Provides the initial admin access
information.

E-mail: _____________________________________

Subscription ID:______________________________

Staging Server Type __ Linux

__Windows

Staging Server Protocol __ HTTP

__ FTP

Staging Server IP Address Servermust have Internet access. IP address:

Staging SeverCredentials Required if the server is password
protected.

Username:

Password:

Staging Folder Path(s) You might create different folders for
different gateway ProxySG appli-
ances, which helps identify logs by
site, building, and so on.

Example: c\Dailylogs4WSS\SanJose

Next Step

Proceed to "Initial Hosted Reporting Configuration" on the facing page.
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Initial Hosted Reporting Configuration

Accessing the Symantec Web Security Service for the first time displays the first page of the Initial ConfigurationWizard.

Prerequisite for New Web Security Service Accounts

1. In a browser, enter https://portal.threatpulse.com/register .

2. Perform the following:

a. Symantec strongly recommends reviewing the Blue Coat Cloud Service Agreement.

b. Enter the e-mail address to be associated with theWeb Security Service service; for example, the address
of theWeb Security Service administrator for your company.

c. Enter your subscription identification.

d. Click Next.

The first page begins the registration/initial configuration wizard. Proceed to the next section.

Follow the Initial Configuration Wizard

The following steps describe the purpose of each page in the wizard. Click Next after completing each wizard page. If you
are not currently logged in to the service, do so now.

1. To begin the initial configuration wizard, click theConfigure link in theHosted Reporting product row.

Tip: If you close the browser during the initial configuration process, then return to
https://portal.threatpulse.com, the Status column displays Config in
Progress. Click theConfigure link to resume the process from the previously
configured wizard page.

2. EachWeb Security Service customer account receives a private key command that is used to secure copy (scp)
your location's access logs to the service. The format of this command is:

scp -i privateKey *.log.gz scpUsername@upload.threatpulse.com:

where scpUsername is a unique customer identification value provisioned to you by Symantec.

https://portal.bluecoatcloud.com/register
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The command displays on the Hosted Reporting initial configuration page. Copy or record this scp command, as you
will need it when you are ready to forward logs to the service.

3. TheWeb Security Service supports ProxySGmain format (ELFF) log files. Before uploading access logs to theWeb
Security Service service from the staging sever, Symantec recommends running the LogChecker application to
verify that they are the correct format. You cannot do this until you have staged logs, but for now download the
LogChecker application to the staging server that contains the logs.

4. Click Create and Download SCP Key. This saves a text file that contains your Digital Signature Algorithm (DSA)
private key.
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Save the text file to the same server that contains the access logs.

Tip: The browser you are usingmight default the file type to something other than a
text file. For example, Firefox might default to a comma-separated view (CSV) format
file. Before saving the file, verify that it is saving as a text file.

5. Click theGo Back To Product Setup button in the lower-right corner.

6. That completes the Initial Configuration process.

To enter theWeb Security Service portal, click Continue.

Tip: For future reference or needs, your custom scp key is viewable on the ServiceMode
> Reporting > Hosted Reporting tab.
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Next Step

Verify and upload themain format access logs to an FTP or HTTP staging server. See "Send ProxySGAppliance Access
Logs to Staging Server" on the facing page.
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Send ProxySG Appliance Access Logs to Staging Server

After completing the Hosted Reporting Initial ConfigurationWizard, (see "Initial Hosted Reporting Configuration" on
page 11), the next step is configure the gateway ProxySG appliance log upload client to send its access logs to an FTP or
HTTP staging server. This server (Windows or Linux) must have Internet access because the next step involves sending
the logs from this server up to the Symantec Web Security Service.

Note: The following procedure references the Proxy Edition SGOS 6.2.x Management Con-
sole. Other editions or OS versionmight slightly differ.

Step 1—Create a main log format for the Web Security Service.
From the ProxySGManagement Console, select theConfiguration > Access Logs > Logs > Logs tab.

1. Click New. The device displays the Create Log dialog.

2. Name the log. For example, ThreatPulse Hosted.

3. From the Log Format drop-down, select main.

4. (Optional) Provide aDescription.
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5. Click OK to close the dialog.

6. Click Apply.

Step 2—Configure the ProxySG appliance upload client to send logs to a staging
Windows or Linux FTP or HTTP server.
This example uses FTP.

1. Select theConfiguration > Access Logs > Logs > Upload Client tab.

2. From the Log drop-down list, select the log that you created inStep 1.

3. From theClient Type drop-down list, select an uploadmethod. This example uses FTP Client.

4. Click Settings. The device displays the FTP Client Settings dialog.
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a. Enter the FTP serverHost IP address.

b. Enter thePath on the server to where the logs are staged. Using location names as folder names helps you
differentiate locations. However, this only applies to organizing on the staging server. TheWeb Security
Service does not provided information based that correlates to individual ProxySG appliances.

c. Enter theUsername required to access the FTP server.

5. Click Change Primary Password. The device displays Change Primary Password dialog. Enter the password
required to access the FTP server.

6. Click OK in each dialog to close.

7. Click Apply.

Step 3—Specify the upload schedule for Web Security Service processing.

When planning this, consider that theWeb Security Service checks your account every hour for new access logs that
were secure-copied from the staging server (described in the next step of this solution). You determine how often the
ProxySG appliance sends logs to the staging server. Youmight elect to send them once a day or every hour for more fre-
quent data processing and current report viewing.
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1. Select theConfiguration > Access Logs > Logs > Upload Schedule tab.

2. From the Log drop-down, select the log that you created inStep 1.

3. Select Periodically.

4. Specify the upload schedule. For example, send onceDaily orEvery hour.

5. Click Apply.

Next Step

Verify log compatibility and secure copy (scp) the logs up to theWeb Security Service. See "Secure Copy Access Logs to
theWeb Security Service" below.

Secure Copy Access Logs to the Web Security Service

After you configure the ProxySG appliance to upload logs to a staging server, the next step is copy them up to your
Symantec Web Security Service account. First, run the LogChecker application that you downloaded during the Initial Con-
figurationWizard task (see "Initial Hosted Reporting Configuration" on page 11).

Prerequisite—Verify that the log formats are compatible with the Web Security
Service.

Run the LogChecker application that you downloaded during the Initial ConfigurationWizard task (see "Initial Hosted
Reporting Configuration" on page 11).

1. On the Linux orWindows staging server containing the logs, navigate to the folder where you downloaded the
LogChecker application.

2. Double-click the LogChecker program to launch it. The program searches for files with the proper extension.

n If the test passes, proceed the next section.

n If the test fails, youmust return to your gateway ProxySG appliance deployment and ensure that you are
forwarding the access logs in themain format.

The logs must contain the following fields.

n Required Fields

n date

n time

n cs-host

n cs(Referer)

n sc-status

n cs-uri-scheme

n Recommended Fields

n c-ip

n cs-username

n x-exception-id
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n cs-categories

n s-action

n rs(Content-Type)

n cs-uri-path

n cs-uri-query

n x-virus-id

Step 1—Linux Option: Secure copy the log files.

1. Access the command line.

2. Navigate to the folder/directory that contains the logs.

3. Enter the following command, which you copied/recorded during the initial configuration task:

scp -i privateKey *.log.gz scpUsername@upload.threatpulse.com:

where scpUsername is a unique customer identification value provisioned to you by Symantec (customer###).

Step 1—Windows Option: Secure copy the log files.

To use aWindows scp client, youmust modify the privateKey file. If you do not have the PuTTYgen and PSCP tools,
download them here: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html.

1. Modify the key:

a. Launch the PuTTYgen tool.

b. Select File > Load Key.

c. In the dialog, navigate to the saved key location and open it.

d. Save the private key.

2. Copy the files:

a. Launch a command prompt window.

b. Enter the following command, which you copied/recorded during the initial configuration task:

pscp.exe -i privateKey *.log.gz scpUsername@upload.threatpulse.com:

where scpUsername is a unique customer identification value provisioned to you by Symantec
(customer###).

Step 2—Post-upload Tasks

To avoid duplicate data in reports, remove the logs from the staging server before uploading new logs because theWeb
Security Service cannot distinguish between previously processed log files and new ones. As theWeb Security Service
currently checks for new data every hour, you can write a script to move the current logs before the next ProxySG appli-
ance upload occurs.

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
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Next Step

After the next processing window, generate reports. See "Access theWeb Security Service Hosted Reporting Interface" on
the facing page.
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Access the Web Security Service Hosted Reporting Interface

After you secure copy the access logs to yourWeb Security Service account, log in to view dashboards, generate reports,
define roles, andmanage the service.

1. TheWeb Security Service displays theOverview dashboard in Solutions Mode; various report summaries display
on the Dashboard.

Tip: The service processes hosted log files every day at midnight (00:00) UTC time. If
you do not see any data, wait until after the next processing window.

2. To learnmore about the dashboard, see "What Can I Do From aHosted Reporting Dashboard?" on page 28.

3. To learnmore about reports, see "What Can I DoWith Reports?" on page 32
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Specify Access Log Retention Duration

Depending on the product, the Symantec Web Security Service retains accumulated access log and report database data
that spans a finite number of days or years.

n WebSecurity: 100 days.

n Hosted Reporting: 1 year.

Youmight have a personal concern or a corporate edict on how long user data should remain in the cloud. TheWeb Security
Service allows you set a limit for how long stored data remains in the reporting database. Before setting the limit, consider
the following warning and best practice.

n Reducing a current limit forces the web to purge all older-than-the limit data (chunked in days). You cannot generate
reports from the expired data nor can you restore data following a delete action.

n Because of this limitation,Symantec recommends that before you limit retention and expire older data you download
the current access logs and archive them. If you have a need to generatemore reports from that data, you can re-
upload the data; however, consider how the service processes the data.

n TheWeb Security Service considers the hardened data as new content; the data remains until the expiration
time has passed.

n The reporter database looks at the log dates. At midnight GMT, theWeb Security Service expires that content
out again.

Generate the new reports against the uploaded data as soon as possible.

To download the access log files, navigate toReporting > Log Download. See "Download Access Logs" on
page 24.

n Review any scheduled reports. If you limit the retention to 15 days and you have a report that generates every 30
days, the report will not contain 50% of the user-generated data because theWeb Security Service deleted the logs.

Procedure

1. In ServiceMode; select Reporting > Log Retention.
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a. Move the slider to adjust the retention limit.

Tip: The initial value varies—100 days to 1 year—depends on theWeb Security
Service product).

As youmove the slider, the Log Retention Time fields (the Log Retention Time field and the field hovering
over the slider) display the limits.

b. When you are satisfied with the limit, click Save.

2. For a verificationmechanism, the portal displays the Delete Access Logs dialog.

The dialog reminds you of the log download best practicementioned above. The dialog also indicates how many
days of data the service will delete if you enact the limit. To enact the limit, youmust enter the word DELETE in the
field and click OK. If you enter any other characters and click OK, the service does not enact the limit.

As stated on the screen, the servicemight require up to 24 hours to adjust to the new limit.

Reset

TheReset link on the pagemoves the limit to the previously set limit before you click Save. To restore the service
default, move the slider fully to the right.
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Download Access Logs

As the Symantec Web Security Service processes web traffic requests and transactions, it stores the hourly access logs in
the service. The services allows you to download these raw log files as zip files that contains selected one-hour log files or
daily log files that contain all 24 one-hour log files. There are two use cases for this:

n For theWeb Security ServiceHosted Reporting service, the logs are retained for 100 days in the reporting
databaseone year in the reporting database. When this milestone is reached, theWeb Security Service begins
deleting log file data on a daily basis, beginning with the oldest day. Download the logs for your own archiving
purposes.

n You use the Symantec Reporter product and you want to use it to reprocess specific logs. Youmust use Symantec
Reporter 9.x Enterprise Edition or Symantec Reporter 10.1.5.

The log files are aggregates of all configured locations that feed into theWeb Security Service.

Tip: If you have access to the Hosted Reporting product, you can re-upload the logs back to
theWeb Security Service. Be advised that the service cannot recognize data it has previous
processed. If you upload logs that contain previously processed data, the result is bloated
data—that is, the reports display double the previous values. Take care tomanage your
download log files.

Tip: As a Hosted Reporting user, you can re-upload the logs back to theWeb Security Ser-
vice. Be advised that the service cannot recognize data it has previous processed. If you
upload logs that contain previously processed data, the result is bloated data—that is, the
reports display double the previous values. Take care tomanage your download log files.

Download Raw Access Log Files

In ServiceMode, select Reporting > Log Download.

By default, the portal lists the log files by Day in the order that the service receives them beginning with the oldest date (in
UTC). The service display ten days per page. To view more selectable days, click the arrow keys in the footer.

a. If necessary, select aDate Filter (select theStart Date andEnd Date, which correspond to the date range of the
received logs, not necessarily the dates of the actual Web transactions).

b. (Optional) Change the view by selectingHour from the Type drop-down.
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c. Select the files on displays pages; you cannot select files across multiple pages.

d. Click Download.

e. Given your browser vendor, the zip download/open dialog displays or the zip download displays (for example, in
Chrome). Save the File to a staging or archive server or directly to the Reporter 9.x server or 10.1.5+ appliance, if
using that option (see next section).

For Use With Symantec Reporter 9.x or 10.1.5+

The zip file contains *.log.gz files. Each one of those files represents an hour (received timestamp) of data. and can be
directly imported into Reporter. To use Reporter to process raw Web Security Service log files, Symantec recommends
the following steps:

1. Save or FTP the raw access logs to the server from which Reporter is configured to process. Consider creating
folder names that identifies the files; for example, Cloud_Archive.

2. In Reporter, create a new database (Administration: General Settings > Reporter Settings > Data Settings
> Databases).

3. Set the Log Source as the folder you created for theWeb Security Service logs.
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Scenarios That Require New SCP Keys

Forwarding ProxySG appliance access log files to the Symantec Web Security Service for reporting requires you to gen-
erate a digital security algorithm (DSA) key that is used during the secure copy (scp) process. You create and download this
during the configuration process as described in "Initial Hosted Reporting Configuration" on page 11.

Some circumstances might require you to recreate this key. They include:

n Your company security best practices require you to frequently change encryption keys.

n Youmisplaced or deleted the original key file.

To recreate a new key:

1. In ServiceMode, select Reporting > Hosted Reporting.

2. Click Create and Download SCP Key.

3. Save the key on the access logging staging server.
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What Can I Do From a Hosted Reporting Dashboard?

Each Symantec Web Security Servicemodule—Content Filtering, Threat Protection (malware), andSearch Controls
(Web Application reports and search engine policy)—provides a report Dashboard, which displays high-level summaries of
web browsing activities as they apply to the selectedmodule. Additionally, theOverview dashboard provides commonly
monitored summaries from all modules.

Expand the following sections to learn about Dashboard features.

Analyze Data

Dashboards present data in graphs and/or tables. You can change the date range (for the entire dashboard view), change the
graphic style for each report widget, and rollover or click report elements to view more details.

Customize Dashboard View

To display the datamost important to your monitoring goals, add, move, or delete summary reports.
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Access Other Reports

The upper-right corner of Dashboards contains a drop-down calledCommon Tasks. From this list, navigate to other report-
ing features. Create a custom report, investigate with a forensic report, and quickly access targeted summaries.
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What Can I Do With Reports?

Symantec Web Security Service reports display either information based on pre-defined criteria or custom criteria. Each
report contains several features that allow you tomanage how reports are analyzed and distributed.

Expand the following sections to learnmore about report features.

Change Report

Most predefined reports display results that include a wide scope of data. When reviewing reports results, you can apply fil-
ters to limit the scope of the results. Also, when you change the scope of the reports, the default graphic might not best rep-
resent the new data set.

View More Details

There are two ways to view more details.

n Select a row and click Drill; select an element to view. For example, you want to see which requested sites are
known spyware sites.
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n Click any blue link to seemore details related to the item, such as who performed requests, site names,
applications used, andmore. For example, click a user name to see

Manage Reports

Each reports contains options that enable you to schedule automatic generation times, save as a file, and send to others.
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Schedule Report Generation

If personnel in your company are required to see the same Symantec Web Security Service report on a periodic basis,
schedule when the reports generate and configure the service to save the file or e-mail it.

You can generate the report in one of three formats:

n PDF—Opens with Adobe Acrobat/Reader.

n CSV—Comma-delineated file that opens with a compatible spreadsheet application (such as Excel).

Tip: If the generated report begins with incorrect characters—for
example: ï»¿Category—switch to theCSV (Raw) format.

n XML—Exports report data in standard XML format to be opened by external applications.

Procedure

1. Click theSolutions link.

2. Two locations provide access to the scheduler:

n Individual report pages—click theSchedule icon.

n TheReport Center andReports links on the solution tabs—select Schedule from theActions drop-down
lists.
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3. Specify the schedule. 

a. Select the Format that the report saves as PDF, CSV orCSV (Raw), orXML.

b. Select theAction to take when the report generates:

n Archive report to server—TheWeb Security Service saves the generated report and displays it in the
Recent Archived Reports area on all Reports link tabs.

n Send report by email—TheWeb Security Service generates the report and sends it to the specified
recipient(s). This is an effective way to send targeted information to different personnel who are
responsible for managing or monitoring specific information.

c. Select the number of Rows. If using theE-mail action, consider size limitations of the recipient's inbox.

d. Specify when and how often the report generates.

n Select the Frequency: Daily,Weekly, orMonthly.

n Select theRun Time, which is the hour of the day.

n Select aRun Day option to specify on which day, in conjunction with the Frequency, the report runs
(this option does not display if the Frequency is Daily).
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n If you set the Frequency toWeekly, select a day of the week.

n If you set the Frequency toMonthly, select the First Day or Last Day of themonth or a
Custom day. Important: If you select the Last Day option, the report runs on the final day of
month regardless of the number of days. For example, February 28th or July 31st. If you
require a strict 30-day interval for the data, see the next option.

e. Select aDate Filter. ThePrevious option changes tomatch the Frequency selection. TheAll dates option
generates the report using the date filter that is applied to that report.

f. Accept the default Description or enter a custom one.

g. Click Schedule.
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Archive Report Results

As you generate and review Symantec Web Security Service reports, youmight decide to save the report results on the sys-
tem and return to the file at a later time. For example, you are generating several reports types and will determine which one
is themore relative to forward at the conclusion of your analysis.

You can save the archived report in one of three formats:

n PDF—Opens with Adobe Acrobat/Reader.

n CSV—Comma-delineated file that opens with a compatible spreadsheet application (such as Excel).

Tip: If the generated report begins with incorrect characters—for
example: ï»¿Category—switch to theCSV (Raw) format.

n XML—Exports report data in standard XML format to be opened by external applications.

Archive Procedure

1. In Solutions Mode, generate any report.

2. In the upper-right corner, click Archive. The portal displays the Archive dialog.

a. Select the report Format.
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b. Specify how many Rows the report displays. For example, you are only concerned with the top 20 results.

c. Click Archive. TheWeb Security Service generates the report in the selected file format.

The portal displays the report in theRecent Archived Reports area on theReports link. Click the View All Archived
Reports Link to display a dialog in which you can navigate these reports.

From here, you have the option sort by process, toDelete the report, Download the report for yourself or to send to others,
orView the report in the saved format (requires Adobe Acrobat/Reader, a spreadsheet application, or an application that
reads XML).
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E-mail a Report

The Symantec Web Security Service allows you to e-mail a copy of any report to one or more recipients. For example, you
notice an unusual spike in a particular traffic type and you want to inform others in your organization.

You can e-mail the report in one of three formats:

n PDF—Opens with Adobe Acrobat/Reader.

n CSV—Comma-delineated file that opens with a compatible spreadsheet application (such as Excel).

Tip: If the generated report begins with incorrect characters—for
example: ï»¿Category—switch to theCSV (Raw) format.

n XML—Exports report data in standard XML format to be opened by external applications.

Procedure

1. In Solutions Mode, generate any report.

2. In the upper-right corner, click Email. The Email dialog displays.
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a. Select the report Format.

b. Specify how many Rows the report displays. For example, you only want to send the top 10 results.

c. Enter To whom receives the e-mail. Enter commas to separatemultiple recipients.

d. The default Subject is the title of the report. Accept the default or add/replace text. For example, Requires
immediate attention: social media traffic spike.

e. Click Email.
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Examine Detailed User or Client Activity

The Symantec Web Security Service provides a forensic report option that displays information about a specific user, client,
category, or website.

Use Cases

n Someone at your company observed a visiting vendor, who was logged into your guest network, browsing offensive
web locations. You want to run a report for that day so you can forward it to the vendor and ask that future visitors
refrain from such activity.

n You suspect a particular client is infected with malware and you want to see a detailed report for all activity as it
relates to that client.

n Youwant a browsing behavior breakdown for one specific user.

Procedure

1. In Solutions Mode, two locations provide access to the Forensic Report:

n Any Dashboard link, select Common Tasks > Report Tasks > Forensic Report.

n TheOverview > Report Center page, click Forensic Report.

n Any Reports link, click Forensic Report.

2. In the New Forensic Report dialog, enter the generation criteria. You can select any or all of the options.
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a. Select aUser; if you know the username, begin typing to use auto-fill. This examples looks for
unauthenticated users.

b. To restrict the report to a single client, select or enter aClient IP.

c. To restrict the report to singleCategory, select or enter one. This example displays results for
unauthenticated users who browsedAdult/Mature Content sites.

d. To restrict the report to a known destinationSite, select or enter one.

e. To specify a time frame of user activity, select aDate is option. This example uses theCustom option and
isolates the day when the visitor was on campus.

f. Click Run Report.

Using the specified criteria, theWeb Security Service generates and displays The Full Log Detail report.

n If the report does not display the desired data set, select Reports > Close Current and repeat the procedure with
other search criteria.

n If the report satisfies your needs, save and disperse as required. See "What Can I DoWith Reports?" on page 32.
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Add a Report to a Web Security Service Dashboard

Each Symantec Web Security Servicemodules—Content Filtering, Threat Protection, and Search Controls—provide
report Dashboards. Additionally, theOverview dashboard provides commonly monitored summaries from all modules.
Each Dashboard displays its own set of default reports, which are high-level summaries. To customize your Dashboard
view, add other reports.

1. Access any Dashboard—Content Filtering, Threat Protection, orOverview.

Tip: TheOverview > Add Reportmenu contains more high-level choices.

2. Click Add Report and select the report to add.

3. If necessary, move reports or delete other reports, as described in "What Can I Do From aHosted Reporting
Dashboard?" on page 28.
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Apply a Filter to Report Data

Most predefined Symantec Web Security Service reports display results that include a wide scope of data. When review-
ing reports results, you can apply filters to limit the scope of the results.

Use Case

You run theBlocked Requests by Category report, which by default displays all categories that were blocked by policy
(verdict = denied). You are curious to see the top ten users who were denied because they attempted to browsemature
content websites.

Procedure

1. From the reports, select Options > Report.

The service displays the Report Options dialog.

2. In theSummarize By area, determine by what criteria the report summarizes.

a. For the above use case, keepCategory as the primary summary datapoint. Define how many rows (per
selection) per page display.
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b. (Optional) You can add one additional summary level by clickingAdd Level. In this example, you want to see
the top ten users per category.

3. In the Filter area, specify the date range and additional criteria.

a. For the Date is criteria, specify what date range the report covers (if theWeb Security Service did not process
data for the specified date range, the report is blank).

b. The filter automatically contains the default intent of the original report. In the above example, theBlocked
Requests per Category report applies theVerdict contains denied (policy denied) filter. Click Add
Criteriato add a new line. You can addmultiple lines; themore you add, themore targeted the report
becomes.

c. Select the filter category. To continue with the example, select Category, is, andAdult/Mature Content.
Click the + icon to addmoreCategory filters. This examples searches for all denied verdicts because of four
specific mature content categories.

4. Click Save. The filtered report generates and displays. If the filter did not result in useful data, select Report
> Options again and adjust the filter.

5. Click links within the report, such as user names, to view evenmore detailed information.

6. To change the report graphic, select Options > Chart.

7. If the report is useful and you want to retain it or disseminate it, see "What Can I DoWith Reports?" on page 32
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Change the Graphic Within a Report

Each generated SymantecWeb Security Service report displays a graph that Symantec selected as themost effective for
the data. You have the option to change not only the graphic, but the data that theWeb Security Service uses to generate
the graphic.

Use Case

TheSearch Engines > Reports > Web Applications report by default generates a pie chart based on total requests for
each application; however, you want to change the report to view the data in terms of costs.

Procedure

1. In Solutions mode, generate any report.

2. Next to the report name, select Options > Chart (gear icon). The portal displays the Options dialog.

3. In the Options dialog, select the components of the new graph.
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a. From theChart Type drop-down, select a graph style.

b. TheChart the currently-sorted column optionmeans the graphic compiles using the default data point. For
example, a ...Per User reports yields a graph based on user names but the report also contains other data
columns. To change the graph source data, select Chart the following column and select an option or
options.

c. Click Save.

Some graph types, such as Pie, cannot contain more than one data element. TheWeb Security Service
displays an error dialog if it cannot comply with your selections.
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The service displays the new graph.

4.

a. Name the new report.

b. Select whichGroup to save it in. If you save it inMy Groups, only you can generate the report. If you save
it inShared Groups, anyone with access to this Web Security Service account sees the link and is able to
run the report.

c. Click Save.
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View Detailed Report Information

Every generated Symantec Web Security Service report contains dynamic elements that when accessed provide greater,
more targeted data.

Links

Click any blue-colored link.
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Drill Down to a Specific Element in a Report

1. Select a data row and click theDrill drop-down list. 

2. Select an element to view (not all elements are available for all reports). For example, in theWeb Browsing per
Category report, you see there were several requests forShopping category sites and you want to see which
users requested them. Select Drill > User.
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Required Log Fields

Before uploading access logs to theWeb Security Service service from the staging sever, Symantec recommends running
the LogChecker application (downloaded during the initial configuration and saved to the access log staging server) to
verify that they are the correct format. This section provides the log field reference.

n Required Fields

n date

n time

n cs-host

n cs(Referer)

n sc-status

n cs-uri-scheme

n Recommended Fields

n c-ip

n cs-username

n x-exception-id

n cs-categories

n s-action

n rs(Content-Type)

n cs-uri-path

n cs-uri-query

n x-virus-id
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