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C H A P T E R  1
Unified CCX Introduction

Unified CCX provides a multimedia (voice, data, and web)



ವ Unified CCX ServerಧContains the Unified CCX Engine that runs applications, including Cisco script
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Step 3 After logging in to the Unified CCX Administration web interface, follow these steps to update the AXL
password:
a) Log in to Unified Communications Manager Administration web interface and update the password for

the application user (AXL provider).
b) Navigate back to System > Cisco Unified CM Configuration weband





Modify RmCm Provider Information
The list of all CTI Managers available in a cluster are saved as a part of the bootstrap information. You can
change to any available CTI Managers listed in the Available CTI Managers list box in this page.

The RmCmProvider specified through the Unified CCXAdministration is automatically created in Unified
Communications Manager. You do not need to use the Unified Communications Manager web interface
to create the user.

Note

To change previously configured RmCmprovider information or to configure a newRmCmProvider, complete
the following steps.
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Step 18 Click Update to apply the changes.
The specific Application Information page for this user appears,
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Add New Cisco Script Application
To add a new Cisco script application, complete the following steps:

Procedure

Step 1





DescriptionField

This field is available only for Cisco Script
Application type.

Note

The default script executes when an error occurs with
the configured



The Add a New Application web page opens.

Step 3 From the Application Type drop-down menu, choose



Procedure

Step 1 From the Unified CCX Administration menu bar, choose Applications > Application Management.
The Application Management web page opens, displaying the details of existing applications, if any.

Step 2 Click Add New icon that is displayed in the tool bar in the upper, left corner of the















The file is saved to the specified directory.

Refresh Scripts









Media resources are licensed and sold as Unified IP IVR ports. Although you can





your Unified CCX server to handle Cisco Unified Communications requests, you must provision the Unified
CM
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the list of call control groups displayed in the Cisco Unified CMTelephony Call Control Group



Step 2 Click the Add New icon that is displayed in the tool bar in the upper left corner of the window or the Add
New button that is displayed at the bottom of the window.
The Unified CM Telephony Trigger Configuration web page opens.

Step 3 Use this web page to specify the following mandatory
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DescriptionField

Check one of the following options:

VoiceMailಧCheck this box to use settings in the Voice Mail Profile Configuration
window.

When this box is checked, Unified CM ignores the settings in the wiΕ i to



the identical setting (4). This will cause Unified CM to forward the next

iden uwm g



The built-in grammars and grammar options that are supported by Unified CCX when using an MRCP
dialog channel is determined by the MRCP speech software you purchase. See the software vendor for
information about what built-in grammars and features are supported.

Note

To enable your Unified CCX applications to handle simple DTMF-based dialog in'

�S00H�307 Tm
(�015)Tj
1 0 0 1307 Tm
(�S00HP307 l
S
Q
0V00H000015)Tj
1 06�307 Tm
(�S00HS0R)
1 0 0R.307 Tm
(L.307 Tm
(�'�X�W)Tj
1 0 206519307 Tm
(�S00H\000&�3)Tj
1 0 0 1 30 6799307 Tm
(�S00H&Tm
(L.307 Tm
(F000G�O�H)Tj2.3m24307 Tm
(�S00H� m
547.805 63�LTj
1 0 0 1 3057627.310G)Tj
1 0 0 1 384.695 67E 0 015)Tj
S
Q
0V00H�547.8P0 0 1 342.775 )Tj307 Tm
(�S00H\000&�O�H)Tj
31.T
/07 Tm
(�S00HF 1 297.Tj
1 0 �&�;J000D�U�H) 0 0 1 389.975 666307 Tm
(�S00H&Tm
(0 142.362 627.307 396085307 Tm
(�S00H Tm
(�L�Q�
1 0 0 1 449.522 627 6208307 Tm
(�S00HJ0R)
1 0 0R.3070 J
0.567 V5 639.307 l
S
Q
q16.2 0 0 16.98  0 .641/I3 Do
Q
Q
0 G
0 g
q
0 J
0.567 w4Tj3
Q
Q
 .6.307 m
547.505 687.3
q
0 J
0.567 w
663098  00.641/
11563098  00.641/Note)T1 1 389.975 663098  7 62.30000S00H$000Q�
1 200.995 663.440954  7 62.30000S00HP7 m
547.805 63�LTj
1 0 0 1 3191.89  7 62.30000S00H� 663.307 Tm
(�E�\)Tj
�D�E�R�X�W)Tj
1 0 213m246  7 62.30000S00H0V00H�U000Q)Tj
1 0 0 10 0 1 308.002 627..30212  7 62.30000S00HE5 663.307J000D�P�P�D�5 6728  7 62.30000S00H@05�D�O�R/F8 82 627.307 Tm20 .804  7 62.30000S00HD000D�W)000&�O135.002 627.307 Tm3w4T32  7 62.30000S00HD000D�W�X�U�31.066  7 62.30000S00HF 1 297.Tj
1 0 W00HD000D�P�P�D� 0 .472  7 62.30000S00H� 66K000H) 0 0 1 389.97576298  7 62.30000S00HV.307 Tm
(�D�R�U)Tj
L�4  7 62.30000S00H,GH1 0 �&D000D�WO000O�W��1.498  �4�S00HP7 m
547.805 63�LTj
1 0 0 1 3207 Tm8  �4�S00H\000&3.307 Tm
(�E�\)Tj
�D�E�R�X�W�FI1 449.522 627.62058  �4�S00HI
(�R)
1 0 015





http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX
http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX
http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX
http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX














Support for High Availability and remote servers is available only in multiple-server deployments.Note









C H A P T E R  7
Provision of Unified CCX

To provision the Unified CCX subsystem, you must provision your telephony and media resources (see the
Provision Telephony and Media Resources, on page 57).

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_installation_and_configuration_guides_list.html
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Step 3 In the Skill Name field, enter a description of a relevant skill (for example, French).
Step 4 Click Add.

The Skills web page opens, showing the skill in the Skill Name column and the total number





Implications of Deleting Agents in Unified CM
If you modify an agent's record in Unified CM (for example, changing the Unified CCX extension or deleting
the agent), ensure to refresh the user page onUnified CCXAdministration interface so that
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DescriptionField

Algorithm used to order the





b) Choose the resource group for this CSQ from the Resource Group drop-down menu.
c) Click Show Resources icon to show all agents who meet the specified criteria.
d) If you selected Linear or Circular as





Delete a Contact Service Queue

Existing Email Contact Service Queues can be deleted.Note

When



Table 1: Agent Skill and Resource Group Settings



Table 2: Resource Skill Selection Criteria
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Provision of Unified CCX
Delete a Team





You need to provision a particular subsystem only if you are using Unified CCX



DescriptionField

The relative URL.

For example:

/hello

URL

Select an application for which you want to add a HTTP trigger from this list box.Application Name

The maximum amount of simultaneous sessions (instances) that the application can
handle.

Sessions

Click the required radio button to accept - Yes (the default).

If you disable the trigger, the user receives an error message when browsing
to the defined trigger URL.

Note



http://docwiki.cisco.com/wiki/Compatibility_Matrix_for_Unified_CCX








1)







Manage Grammar Files
The Unified CCX system uses specific grammars when recognizing and responding to caller response to
prompts. A grammar is a specific set of all possible spoken

∂Ң asesand







Create New Language
Follow this procedure to create a new Prompt, Grammar, or Document language folder in the





Step 5 By default, the files are unzipped after uploading. If you want to change this option, uncheck







Specify Custom Classpath Entries
Use the Custom Classes Configuration web page to specify the available classpath entries.

Procedure

Step 1 From the Unified CCX Administration menu bar, choose System > Custom File Configuration.
The Custom Classes Configuration web page opens. You can:

ವ Select required entries from the Available Classpath Entries list and arrange them in the order you want.

ವ Use the arrow icons to move items between the Available Classpath Entries and Selected Classpath
Entries lists.

Step 2 Click Update when your selections areѯ ickѯ iU ѯ icom



Palette-List: Custom1 Custom2
Custom1-Palette-Name: Category1
Custom2-Palette-Name: Category2
Custom1-Step-List: step1.mf

























Changing some system parameters like IP address, Network Time Protocol (NTP) and so















configured in UCCX Administration
under System -> Servers then you must change
the IP address



















Continue (y/n):
Continue (y/n)?y
*** W A R N I N G ***
This command will cause the







C H A P T E R  11
Unified CCX Reporting

ವ Reporting Administration on Unified CCX, page 157

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/prod_maintenance_guides_list.html




The configuration changes take effect- f







Procedure

Step 1 From the Unified CCX Administration menu bar, choose Tools > Historical Reporting > Purge Now.
The Purge Now web page opens. The Purge data older than field is displayed in the Purge Now web page.
You can specify this field in months and days.

Step 2 From the









Procedure

Step 1 Run a report.
Step 2 From the Application Reporting menu, choose Tools > Open Printable Report.

A printable version of the report opens in a separate window.

Step 3 Print the report using your browser print functionality.

Reset Report Statistics
The Unified CCX system automatically resets all statistics each day at midnight. You can reset the accumulated
statistics manually at any time. Resetting statistics does not reset active statistics, such as active contacts and
active tasks.

To reset report statistics, complete the following steps.

Procedure

Step 1 From the Application Reporting menu bar, choose Tools > Reset All Stats.
The Reset Stats dialog box opens for you to confirm the reset.

Step 2 Click Yes.
Accumulated statistics are reset.

Clear Contact Option for Stuck Calls
You may sometimes see a Contact/Call as













Engine Tasks Real-Time Report
Use the Engine Tasks real-time report to view information about currently active Engine tasks.

To access the Engine Tasks report, choose Reports > Engine Tasks from the Application Reporting menu
bar.

The following fields are displayed on the Engine Tasks report.













Unified CCX reports contain information for calls that have been queued in one or more CSQs. If a call
is not queued (for example, the caller hangs up before being queued), the reports do not display data for
that call.

Note

Unified CCX reports retrieve the following statistics:

ವ Unified CCX statistics from the current Master node.

ವ Unified IP IVR statistics from all nodes in the cluster.

To access the Overall Unified CCX Stats report, choose Reports > Overall Cisco Unified Contact Center
Express Stats from the Application Reporting menu bar.

Preview Outbound durations are updated when the preview outbound call disconnects and all agents

























DescriptionField�7�K�H�W�R�W�D�O�Q�X�P�E�H�U�R�I�2�X�W�E�R�X�Q�G�F�D�O�O�V�W�K�D�W�Z�H�U�H�D�E�D�Q�G�R�Q�H�G�E�\�W�K�H�F�X�V�W�R�P�H�U�R�U�G�L�V�F�R�Q�Q�H�F�W�H�G�E�\�W�K�H�D�J�H�Q�W���&�X�V�W�R�P�H�U�$�E�D�Q�G�R�Q�H�G�7�K�H�W�R�W�D�O�Q�X�P�E�H�U�R�I�2�X�W�E�R�X�Q�G�F�D�O�O�V�W�K�D�W�Z�H�U�H�D�E�D�Q�G�R�Q�H�G�E�\









Clear Stuck Calls from CSQ Cisco Unified CCX Stats
To clear stuck calls or contacts from the





The following fields are displayed in the Options dialog box.

DescriptionField

Time between two requests to the server for new statistics by the client.Polling Interval

The number of times that the Unified CCX Administration web interface
should attempt to reconnect to

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_user_guide_list.html
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Create a User
To create a user, perform the following procedure:

Procedure

Step 1 Navigate to Security > User







b) In the Description field, enter or modify text to describe this group

Step 3 Under the Groups tab, perform the following:
a) Default GroupಧFrom the drop-down list, enter the default group.
b)



















Scenario 1:

If your Contact Center is already utilizing maximum licensed IVR ports supported for your hardware model,
then:

ವ Inbound calls will take precedence over the configured Outbound IVR calls.

ವ If IVR ports are dedicated for a campaign, then the Outbound IVR ports available for the campaign will
be









DescriptionField

The time range during which











DescriptionField

Type of the campaign to be used for outbound calls. You can specify any one of the
following two campaign





















ವ FirstName - The first name of a contact. The first name can be a maximum length of 50 characters.

ವ LastName - The last name of a contact. The last name can be a maximum length of 50 characters.

ವ Phone1





Add Area Codes

Area code and long diw nd











Failover and System Restarts
Outbound contacts with an Active call status during a failover indicate that these contacts were retrieved from
the database but the system went down either before they could be dialed or after they were







Administrator Privileges
A Unified CCX Administrator is a user with complete access to the Unified CCX Administration and has the
authority to configure the entire system. An Administrator can also be assigned a combination of other roles.

The Administrator can turn on/off the authority of a Supervisor to manage the teams and agents.

Supervisor Privileges
Supervisors can additionally modify and view skills, view the list of all teams for which this user is the
supervisors

siew

she

suills,

s ,snd

s

s

s

shessu siewsndsanage
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Custom File Configuration
Use the Custom Classes Configuration web page to specify the classpath for custom classes.

Choose







C H A P T E R  15
Applications Menu

The Applications menu on the top contains the following menu options:

ವ Application Managementಧto add, configure, copy, delete, or refresh a specific application



The Applications Configuration web page opens, displaying a list of applications that are currently configured
on











the Unified CM Telephony Call Control Group Configuration web pages to display, add, modify, and delete
information about the call control group.

To add a new Unified CM Telephony Call Control Group, click the Add New icon or button on the Unified
CM Telephony Call Control Group Configuration web





Click theUpdate icon that displays in the toolbar in the upper left corner of the window or theUpdate button
that displays at the bottom of the window to save the changes. Restart the Unified CCX
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Mail Server Configuration
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Table 13: CSQ TypeಧChat



The chosen skill and the minimum competence level for that skill are displayed in the right pane under









The List Chat Web Forms web page opens, displaying the information for existing Chat Web Forms,
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eMail Menu
The Unified CCX system uses the eMail subsystem of the Unified CCX Engine to communicate with your
email server and enable your applications to create and send email. The email configuration identifies the
default email address and server to be used for sending email (including e-pages and faxes) and for receiving



MRCP ASR Servers
Choose Subsystems >MRCP ASR >MRCP ASR Servers from the Cisco Unified CCX Administration



MRCP TTS Servers
Use the MRCP TTS Server Configuration web page to display, add, modify, and delete the
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Tools Menu

The Tools menu of the Unified CCX Administration web
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To access the different Historical Reporting Configuration options, choose Tools > Historical Reporting
and click any of the following submenu options from the Unified CCX Administration menu bar:

ವ Database





Procedure

Step 1 Choose Tools > Historical Reporting > File Restore from the Unified CCX







Supervisor Capability View Menu
From the Unified CCXAdministrationmenu bar, chooseTools >UserManagement >
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Help Menu

The Help Menu of the Unified CCX Administration web interface



http://docwiki.cisco.com/wiki/Troubleshooting_Unified_Contact_Center_Express
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About Menu
To access Unified CCX version information, choose Help > About from the Unified CCX Administration
menu bar. The Unified CCX Administration web page opens, displaying
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C H A P T E R  20
Cisco Mobile Skill Manager

The Unified CCX supervisor can use the Cisco Mobile Skill







View Resources Assigned to Supervisor
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.

The Resources page launches to display all resources assigned to the supervisor.

Search Resources Using Cisco Mobile Skill Manager
Procedure

Step 1 Login to Cisco Mobile Skill Manager using supervisor credentials.
Step 2 Click Resources.
Step 3 In the Resources page, enter the name of the agent, that you want to ~



Assign Skill Competency to Resource
Procedure

Step 1 Login to Cisco MobileStep 1 �/�R�971�F�RStep 1�/�Ruw
140F�RStep 1 �/�Rhw
140F�RStep 1Step 1Step 1Step 1Step 1Step 1Step 1Step 1�37200R�850OÕ459.535w70.3.0HStep 1Step 1MoP P LŶ
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Cisco Mobile Skill Manager
Unassign Skill Competency of Resource
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Cisco Finesse

ವ Introduction, page 315

ವ Cisco Finesse Administration Console, page 316

ವ Cisco Finesse Agent and Supervisor Desktop , page 384

ವ Call Manager-Based Call Recording Using Cisco MediaSense, page 384

Introduction
Cisco Finesse is a next-generation agent and supervisor desktop designed to provide a collab experience for q e v ious communities q at interact with experience of a design en ance customer e sP C faction w ll. Cisco provides: A single, customizable "cockpit", or interface, q at g e providers quick and easy access to multiple assets and information sources. s s: red = v s adM = ag V omt ac inesse in ol in ce = i i in nistration console M cos oic¨ co¨ coM co¨ coŞ v co¨ coM esse nistration co¨ = coŞ rdn r Ŷ re e a a se a inistration 15 194(�D)Tj
1 0Q0G�X�F:1 Tm
D4 368.6�2.�0QTj
1 01c000V



Cisco Finesse Administration Console

Getting Started
This chapter describes the interfaces that you use to configure, administer, and maintain



A successful sign-in launches an interface with defined administration gadgets and a Sign Out link.

https://help.webex.com/community/context-service


Context Service Network Connectivity Requirements

Context Service is a cloud-based service and requires call center components using Context Service to be able

http://docwiki.cisco.com/wiki/Context_Service






Add ECC Variables to Call Variables Layout

Cisco Finesse only supports Latin1 characters for ECC variables. Other





Default Layout XML
The Finesse default desktop layout XML for Unified CCX contains optional tabs and gadgets for





</columns>
</tab>
<tab>

<id>teamData</id>
<label>finesse.container.tabs.supervisor.teamDataLabel</label>
<columns>

<column>
<gadgets>



-->
</gadgets>

</column>
</columns>

</tab>
<tab>

<id>manageCustomer</id>
<label>finesse.container.tabs.supervisor.manageCustomerLabel</label>
<gadgets>

<gadget>/desktop/gadgets/CustomerContext.xml</gadget>
</gadgets>

</tab>
<!--

The following Tab and Gadget are used



</layout>
</finesseLayout>

Update Default Desktop Layout
When you modify the layout of the Finesse desktop, the changes



ḳ



<xs:element name="page"> <!-- Grouping of a set of persistent gadgets -->
<xs:complexType>

<xs:sequence maxOccurs="unbounded">
<!-- No limit to number of gadget URIs for now -->
<xs:element ref="gadget"/> <!-- URI of the gadget xml -->
</xs:sequence>

</xs:complexType>
</xs:element>

<xs:element name="tab">
<xs:complexType>

<xs:sequence>
<xs:element ref="id"/> <!-- Id of the tab selector in the desktop -->
<xs:element ref="label"/> <!-- Label of the tab





</columns>
</tab>

Step 5 Remove the comments and comment characters (<!-- and -->) that



</column>
</columns>

</tab>

Step 15 Remove the comments and comment characters (<!-- and -->) that surround the tab.
Step 16 Replace my-socialminer-server in the gadget URL with the fully-qualified domain name (FQDN) of your

SocialMiner server.
Step 17 Optionally, change the height of the Manage Chat and Email







Step 5 Copy the code for the Live Data gadgets for Agent Chat Statistics and Chat Queue Statistics and











Query Parameter
<gadget>https://localhost:8444/cuic/gadget/LiveData/LiveDataGadget.jsp?
gadgetHeight=200&viewId=5C626F9C10000140000000600A4E5B33&filterId=ResourceIAQStats.resourceId=CL</gadget>

Add Live Data Gadgets to Desktop Layout

The Cisco Finesse default layout XML contains commented XML code for the Live Data gadgets available
for Cisco Finesse desktop. Perform the following steps to add Live Data



</tabs>
</layout>
<layout>
<role>Supervisor</role>
<page>
<gadget>/desktop/gadgets/CallControl.jsp</gadget>
</page>

Step 6 Click Save. Cisco Finesse validates the XML file to ensure that it is valid XML syntax and conforms to the
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After you add the gadget, sign in to the Finesse desktop and make sure it appears the way you want.
If you use a report with a large number of rows, you may want to adjust the gadget height or the
screen resolution on the computer used to access the desktop to make the report easier to read or
make more rows appear on the screen without the need to scroll.

Agents who are signed in when you change the desktop layout must sign out and sign back in to see
the change on their desktops.

Note

Manage Phone Books
On the Phone Books tab of the Cisco Finesse administration console, you can create and manage global and
team phone books







Procedure

Step 1 In the Manage Phone Books gadget, select the phone book into which you want to import a list of contacts.
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The New Contact area appears.

Step 3 Complete the fields. The First Name, Last Name,







Procedure

Step 1 In the Manage Reason Codes (Not Ready) gadget, select the reason code that you





Sign Out reason code labels are limited to 40
characters.

Note

Step 3 In the Reason Code box, enter a reason code.
The code must be between 1 and 999 and must be
unique.

Ensure there are no leading or trailing spaces.

Note

Step 4 If the reason code is global, select the Global? check box. If the reason code is specific to a team, clear the
Global? check box.

By default, the Global? check box is
selected.

Note

Step 5 Click Save.

Edit Sign Out Reason Code

Perform the following procedure to







Procedure

Step 1 In the Manage Wrap-Up Reasons gadget, select the Wrap-Up reason that you want to delete.
Step 2 Click Delete.

A question appears asking you to confirm that you want to delete the selected Wrap-Up reason.

Step 3 Click Yes to confirm the deletion of the selected Wrap-Up reason.





Tabs for each available resource appear.

Step 2 Click the tab for the resource you want to assign for the selected team.
The List of <resource> area appears.

Step 3 Click Add.
The Add <resource> popup appears.

Step 4 Select one or more resources from the list to assign them to the team.
Resources you assign are highlighted in blue in the Add <resources> popup and added to the List of <resources>
area.

Step 5





The List of Workflows area appears.

Step 3 Click the red X next to the workflow you want to



ExplanationField

The type of workflow.







Add Browser Pop Workflow Action
The Browser Pop workflow action opens a browser window or tab on the user's desktop when workflow
conditions are met.

Whether the action opens a newwindow or tab on the desktop depends on the target user's browser settings.Note

Procedure

Step 1 In the Manage Workflow Actions gadget, click New.
The New Action area appears.

Step 2 In the Name box, enter a name













D e s c r i p t i o nO p t i o n







f) Click Upload File.

Step 3 Restart Cisco Tomcat on the primary Unified CCX node.
Step 4 Restart











Step 6 EnsureEnt h a t Ent h e En e ɰ





Procedure

Step 1 FromCisco Unified CommunicationsManager Administration, select the Finesse phone service (underDevice
> Device Settings > Phone Services).

Step 2 Click New to the right of the Parameters



When you save the last parameter, click Save and Close.





In a two-node Finesse setup with two services configured, the agents must enter their credentials on both
the primary and secondary Finesse services.

Note

CTI Failover
Finesse follows the active/standby model of Unified CCX. Finesse on the active Unified CCX node is
"IN_SERVICE" and Finesse on the standby node is "OUT_OF_SERVICE".

A loss of connection to the CTI server can occur due to the following:

ವ Finesse misses three consecutive heartbeats from the connected CTI server.

ವ Finesse encounters a failure on the socket opened to the CTI server.

ವ The CTI server is not active on the node
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To add the customized announcement ID, see the"Upload customized announcement" procedure in the Cisco
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