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Disclaimer  

The following is intended to outline our general product direction. It is intended for information 
purposes only, and may not be incorporated into any contract. It is not a commitment to deliver any 
material, code, or functionality, and should not be relied upon in making purchasing decisions. The 
development, release, and timing of any features or functionality described for Oracle’s products 
remains at the sole discretion of Oracle. 
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Executive Overview 

Oracle Application Express 4.2.2 has introduced report printing enhancements and a new option for 
PDF printing. You can now use APEX Listener release 2.0.2 or above to enable PDF printing for 
your classic reports, interactive reports, and report queries. The FOP libraries for PDF printing are 
built into the APEX Listener. Therefore, with this new PDF printing option, you do not need to 
configure an external printing engine such as BI Publisher or Apache FOP anymore. 
 
This white paper provides an overview of different options for PDF printing in Oracle Application 
Express. The focus of this document is how to configure and use APEX Listener as a print server 
with Oracle Application Express. This white paper outlines the steps to create custom report layouts 
using third party tools such as Altova StyleVision or Stylus Studio, and then how to use these 
custom report layouts for PDF printing. 

Prerequisites 

Before performing the examples and steps discussed in this white paper, you should: 

 Install Oracle Database 11g 

 Install Oracle Application Express 4.2.2 or above 

 Install and configure Oracle Application Express Listener 2.0.2 or above as a web listener 
for Oracle Application Express 

 Download and install any of the following third party tools: 
o Altova StyleVision: http://www.altova.com/stylevision.html 
o Stylus Studio: http://www.stylusstudio.com  

Note: APEX Listener 2.0.2 supports only the Base-14 fonts. To configure additional fonts, see this 
document: http://xmlgraphics.apache.org/fop/0.95/fonts.html 
 
The examples provided in this document use Oracle Application Express 4.2.2. The screenshots 
might be different for later versions of Oracle Application Express 4.2.2. 
 

Oracle Application Express PDF Printing Architecture 

Oracle Application Express allows you to configure a classic report region to print by exporting it to 
an Adobe portable document format (PDF), Microsoft Word rich text format (RTF), Microsoft 
Excel format (XLS), or Extensible Markup Language (XML). By taking advantage of region report 
printing, your application users can view and print reports that have a predefined orientation, page 
size, column headings, and page header and footer. 
 
In the releases prior to Oracle Application Express 4.2.2, the report printing functionality requires 
an externally defined print server such as Oracle BI Publisher, Oracle Application Server Containers 
for J2EE (OC4J) with Apache FOP, or any other standard XSL-FO processing engine. PDF 
printing using APEX Listener as a print server has been added as a third option in APEX 4.2.2. 
 

All of the PDF printing options in APEX share the same underlying architecture. When an 
application user clicks a print link on a report, the request is sent to the Oracle Application Express 

http://www.altova.com/stylevision.html
http://www.altova.com/stylevision.html
http://www.altova.com/stylevision.html
http://www.stylusstudio.com/
http://www.stylusstudio.com/
http://www.stylusstudio.com/
http://xmlgraphics.apache.org/fop/0.95/fonts.html
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engine. The APEX engine then generates the corresponding report data in XML and transfers this 
XML to a print rendering engine along with an XSL-FO or an RTF stylesheet. Based on the 
stylesheet, your data gets formatted, rendered in PDF and then downloaded to your browser. 

Configuring PDF Printing in Oracle Application Express 

With the latest addition of APEX Listener based printing, now you can use any of the following 

three different options for PDF printing in Oracle Application Express: 

 Oracle APEX with Apache FOP 

 Oracle APEX with BI Publisher 

 Oracle APEX with APEX Listener 

Oracle APEX with Apache FOP 

To use this option, you must configure your Oracle Application Express instance to use the FOP 
print server. Oracle Application Express includes a supported configuration of Apache FOP in 
conjunction with Oracle Containers for J2EE. The Apache FOP installation is included in the 

Oracle Application Express distribution under /home/oracle/utilities/fop/fop.war. 
After installing this war file, you need to configure Oracle Database to enable network services for 

APEX to call out to the FOP rendering engine through utl_http. Oracle Application Express 
Instance administrator has to enter the server URL and script information under the Manage 
Instance > Instance Settings > Report Printing in the APEX instance administration. Once this is 
setup, developers can enable PDF printing on their classic, interactive reports, and report queries. 
With the Apache FOP option, you can use either the generic built-in XSL-FO layout or a custom 
report layout. 
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Oracle APEX with BI Publisher 

This option requires a valid license for Oracle BI Publisher. With this configuration, you have all the 
capabilities available with Apache FOP configuration plus the ability to define RTF-based report 
layouts developed using the BI Publisher Word Template Plug-In. This provides easy graphical 
control over every aspect of your report. You can add logos to your pages, add complex control 
breaks, and have full pagination control. You can even embed charts and create reports that look 
exactly like standard government forms. 
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Oracle APEX with APEX Listener 

 
APEX Listener 2.0 and above includes FOP support. Oracle Application Express generates report 
XML data with XSL-FO stylesheet in single document. APEX Listener intercepts this file and 
renders PDF document that is downloaded straight into your browser. With the APEX Listener 
option you can either use the built-in generic report layout that allows for limited customization or 
your own custom report layout. 
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Configuring APEX Listener as a Print Server 

The APEX Listener based printing option loads your reports straight to the APEX Listener. Then 

the APEX Listener renders these reports in PDF format and downloads them to your browser. 

Therefore, unless you are calling APEX Print APIs directly in your custom PL/SQL code, you do 

not need to enable networking services in Oracle Database 11g anymore. You need to perform the 

following simple steps to enable APEX Listener as the print server in Oracle Application Express: 

1. Log in to Oracle Application Express instance administration 

2. Click Manage Instance > Instance Settings 

3. Select Report Printing 

4. Select Oracle APEX Listener for Print Server and then click Apply Changes. 
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When using the PL/SQL Print APIs (apex_util.get_print_document and 

apex_util.download_print_document), it is still necessary to enable networking 
services in Oracle Database 11g. If you are using the PL/SQL Print APIs, perform the following 
two additional steps: 
 

1. Enable networking services in Oracle Database 11g. For instructions on how to enable 
networking services in Oracle Database 11g, see Oracle Application Express 4.2 Release 
Notes: http://docs.oracle.com/cd/E37097_01/doc/doc.42/e35121/toc.htm#HTMRN119 
 

2. Configure the APEX Listener to enable FOP based PDF rendering via http requests from 

the database. To enable FOP, navigate to the /apex directory of the APEX Listener 

configuration folder, edit the defaults.xml file and add the following code: 
<entry key="misc.enableOldFOP">true</entry> 

 
 

Printing a Simple Classic Report as PDF 

This example shows how to quickly create a classic report and print the report data as PDF. 

1. First, create a database application with a classic report implementation on the EMP 

table. In the Create Application wizard, specify the following: 

 Name: Employees 

 Select Page Type: Report 

 Page Source: Table 

 Table Name: EMP 

 Implementation: Classic 

2. Edit the Print Attributes of this classic report. Click Printing and select Yes for Enable 

Report Printing. Then, click Apply Changes. 

http://docs.oracle.com/cd/E37097_01/doc/doc.42/e35121/toc.htm#HTMRN119
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3. Now, run the page and click the Print link. You should see the PDF format of the 

report. 

 

 

Creating and Using a Fully Custom Report Layout 

Oracle Application Express 4.2.2 includes improved support for custom XSL-FO layouts. You can 

now easily customize your PDF reports to your requirements using third-party tools such as Altova 

Stylevision or Stylus Studio that allow for drag and drop layout of XSLT stylesheets. If you have a 

Report Query or a Classic Report Region, you can simply download your report data in XML format 

and use this XML data as the data source for any of these tools. Once loaded into the tool, all 

components of your report data, including information about your application, page, report region, 

user name as well as session state can be easily included in the layout via drag and drop. 
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The screenshot above shows the three steps that you need to perform to create and use a fully 

custom report layout: 

1. Create an XML Data Source: First, download your report data in XML format 

2. Create a custom report layout using a third-party tool: In this step, you load the XML data 

source into a third-party tool, drag and drop components of your report data into the empty 

layout and finally save the report layout as an XSLT 1.0 file 

3. Associate the custom report layout to your report:  Finally, you upload the XSLT 1.0 file as a 

report layout into APEX under Shared Components > Reports > Report Layouts. Then, 

update your report query or classic report region to use this custom layout when exporting 

your report in PDF format 

 

Creating an XML Data Source 

You need to first create an XML data source for your report layout. In this example, you use the 

database application that you created in the previous section. Perform the following steps: 

1. Edit the employees classic report page 

2. Under Print Attributes, set the output format to XML and click Apply Changes 
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3. Run the page. Click the Print link at the bottom of the page and then save the XML 

document on your desktop folder. 

Creating a Custom Report Layout Using a Third party Tool 

Once you have the XML data source, you need to load this XML into a third party tool such as 

Altova StyleVision or Stylus Studio.  After loading the XML, you add elements to the empty layout 

by using the drag and drop functionality and then make some formatting changes to the layout. 

Finally, you save this report layout as an XSLT-FO file. 

This document shows examples of creating a custom report layout using both Altova StyleVision 

and Stylus Studio. You can choose to use either of this third party tools. 

Using Altova StyleVision 
 

To create a custom report layout using Altova StyleVision, perform the following steps: 
 

1. Open Altova StyleVision and click File > New > New from XML 

Schema/DTD/XML… 

2. Select the EMP.xml file that you created in the previous section and click Open 

3. Select Generate new XML Schema and click OK. Save the XML Schema file on your 

desktop folder 

4. Select Create a free-flow document and click OK. Now you see a tree view of the XML 

document (Schema Tree) at the left side bar.  

5. FOP currently supports only XSLT 1.0 version.  Click the XSLT 1.0 icon to set the XSLT 

version for your layout. 

Note: If you do not see this icon on the tool bar, click Customize > Add or Remove Buttons 

> Standard and then select Generate XSLT Version 1.0. 
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6. You can drag and drop XML elements from this Schema Tree to the empty layout. Drag and 

drop the USER_NAME element from the Schema Tree to the layout and then select 

Create Contents. 
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7. In this example, you create a table based on your report data. Navigate to the Schema Tree 

and then drag and drop the ROW element to the layout. Select Create Table and then in 

the Create Dynamic Table window click OK. 

8. Now apply some formatting options to the layout. For example, increase the font size, and 

then change the background color and foreground color of the column header. 

9. Click Add Header/Footer to add a header and footer for all pages. 

10. You can add an image to your layout. Click the Insert Image icon and point to the location 

on the layout where you want the image to be displayed. Click Browse and then click 

Switch to URL. For File URL, enter a fully qualified URL of an image. This URL needs to 
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be accessible from the instance where the APEX Listener is running. 

 

11. Click the HTML tab to preview your report layout. You need to save this generated file. 

Click File > Save Generated Files > Save Generated XSLT-FO File. Enter a file name 

and click Save. In this example, enter employees1 for file name. 

Using Stylus Studio 

 
To create a custom report layout using Stylus Studio, perform the following steps: 
 

1. Open Stylus Studio and click File > New > XML Report 

2. Select XSL-FO (PDF) and click OK. 

3. Click the Add Data Source icon, locate and then double click EMP.xml. 

 

4. The XML document is now displayed on the tool and you can drag and drop elements to the 

empty layout. First, drag and drop the Title element. Then click Insert Value. 

5. Now you want to add your report data to the layout. Drag and drop the ROW element and 

click Insert Table > Populate Columns. 

6. You need to create a report row header. Right click the first row and select Add Row 

Before. Then enter appropriate text for each of the empty fields as shown in the screenshot 

below. 
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7. Make some formatting changes such as applying background and foreground colors to the 

column headers, changing the font size etc.  

8. You might want to preview the report now. Select Report > Preview, enter employees2 

.report and click Save. 

9. Select Report > Generate, choose an appropriate folder location for Save Into and click 

OK. The report layout is generated as an XSLT 1.0 file. You can also review the XSLT file 

within the Stylus Studio tool. 

 

Associating the Custom Report Layout with a Classic Report 

Once you have the custom report layout ready as an XSLT-FO file, you need to load this file to 

Oracle Application Express and then associate the layout with your report query or region. 

1. Navigate to your application Home page > Shared Components > Reports > Report 

Layouts 

2. Click Create. Select Named Columns (XSL-FO) for Report Layout Type. 

3. Enter a name for Layout Name and click Browse to select the XSLT-FO file that you have 

saved in the previous section. If you select the XSL file generated by Altova StyleVision, 

enter employees1 for Layout Name and enter employees2 if you select the XSL file 

generated by Stylus Studio. Click Create Layout. 

4. Now edit your employees report page. Right click the report region and select Print 

Attributes. 

5. Under Printing, select PDF for Output Format 

6. Select your report layout name for Report Layout and click Apply Changes.  
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7. Now run your report. Click the Print link and open the PDF document. 

If you have selected employees1 report layout (layout created using Altova StyleVision), the PDF 

document output would look like: 

 

Note: If you do not see the header and footer in the printed PDF document, edit the XSLT file to 

locate the attributes such as overflow="hidden" under page master section. Remove these 

attributes and save the file. Then load this XSLT file to APEX associate it to your report. The 

following code snippet shows an example of the page master section in the generated XSLT file. 

  <fo:layout-master-set> 

   … 

    <fo:region-before region-name="even-page-header" 

overflow="hidden" extent="0.49in"/> 

                   <fo:region-after region-name="even-page-footer" 

overflow="hidden" extent="0.49in"/> 

   … 

       <fo:region-before region-name="odd-page-header" 

overflow="hidden" extent="0.49in"/> 

      <fo:region-after region-name="odd-page-footer" 

overflow="hidden" extent="0.49in"/> 

   </fo:simple-page-master> 
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If you have selected employees2 report layout (layout created using Stylus Studio), the PDF 

document output would look like: 

 

Summary 

Oracle Application Express 4.2.2 has introduced a new PDF printing option by using APEX 
Listener. You can now build a custom report layout using third-party tools and associate the layout 
with your report. 
The key benefits of using APEX Listener as a printing option are: 

 No separate external printing engine is required 

 Using a supported Oracle product, APEX Listener 

 Single step configuration as a print server for Oracle Application Express 
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