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Introduction: 
 
This set of guidelines is designed to provide users of the Adobe Lens Profile Creator 
with a procedure for running a set of calibration chart images through the tool to 
generate a lens correction profile (LCP). 
 
Calibration chart images must be captured by printing a calibration chart PDF file 
and shooting the printed chart with the camera body and lens combination that you 
wish to generate a lens profile for.  For optimal results with captured calibration 
chart images, please read the companion document titled “Calibration Chart 
Shooting Guide for the Adobe Lens Profile Creator”. 
 
Once the calibration chart images have been captured, the calibration tool analyze 
data from the images to create a customized lens profile for correcting geometric 
distortion, chromatic aberration, and vignette. 
 
The procedure involves three basic steps: 
 

1. Open up one or more sets (shooting iterations) of captured chart images 
from a single camera/lens combination. 

2. Enter the proper camera and lens pretty names to identify the new lens 
correction profile. 

3. Input the chart dimension parameters. 
4. Run the “Generate Profiles” command. 
5. Create a new LCP or for appending to an existing LCP, and place it inside the 

lens profiles folder that Photoshop can find and load it. 
 
These guidelines are written for the photographer who wishes to create a lens 
profile to make optical corrections to the images of the camera body and lens 
combination that the given lens profile represents.  While written for the novice 
user, a basic knowledge of photographic and optical terms (listed below) is useful 
for understanding these guidelines. 
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Terminology: 
 
Adobe Lens Profile Creator: The Adobe application used to generate Lens 
Correction Profiles (LCP files). 
 
Lens Correction Profile (LCP): A file that contains information for Adobe 
applications on how to apply lens corrections to a specific camera body and lens 
combination. 
 
Geometric Distortion: An optical aberration that bends the light rays that pass 
through the lens, particularly along the periphery of the image plane, to create a 
distorted-looking image.  The most common forms of distortion are referred to as 
“barrel distortion” and “pincushion distortion”, because of the characteristic shape 
of the distortion as it appears in the image. 
 
Lateral Chromatic Aberration: An optical aberration that gives the appearance of 
color fringing, particularly along high-contrast areas of the image.  This aberration is 
caused by different wavelengths that make up white light being magnified at 
different positions of the same focal plane. 
 
Vignette: Light falloff at the periphery of an image, giving the appearance of a 
darker border along the edges of the image. 
 
Adobe Camera Calibration Chart: A checkerboard chart that is photographed by 
the user to create a set of images to be analyzed in the Adobe Lens Profile Creator. 
 
Shooting Iteration: A single “set” of images of the printed calibration chart, shot 
with the user’s desired camera/lens combination.  An iteration (set) of images 
should have constant camera settings throughout and be of a single camera body 
and lens model.  The lens should be set to a single aperture, focal length, and relative 
focus distance (focus should remain about the same from shot to shot) for a single 
iteration.  A typical iteration consists of nine images in the set.  Different iterations 
may be shot and profiled for the same camera/lens combination while using a 
different aperture, focal length, or focus distance for each respective shooting 
iteration. 
 
Focal Length: [non-technical definition] The “zoom” value of a zoom lens, or a fixed 
value for a lens, which indicates how close or far-away the subject or scene will 
appear when viewed through the viewfinder/display of a digital camera. 
 
Focus Distance: The actual distance of the camera from the subject being 
photographed. In technical terms, it is the distance of the subject to the sensor/film 
plane. 
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Zoom Lens: A lens with a range of focal lengths, typically adjusted by rotating a ring 
on the lens. 
 
Fixed Lens: A lens with a fixed (single) focal length. 
 
Rectilinear Lens: A lens that generates a “normal” looking image, matching closely 
to the perspective of the human eye; a non-fisheye lens. 
 
Fisheye Lens: A lens that generates a distorted image, bending light differently 
from a rectilinear lens, to encompass a very short, wide-angle focal length.  The 
corners of an image will appear distorted and “squeezed-in” on a fisheye. 
 
Circular Fisheye Lens: A special type of fisheye lens that creates a circular image, 
which covers only part of the whole image frame. 
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Procedures: 
 
Opening and Running Files through the Adobe Lens Profile Creator 
 

1. File > Add Images to Project… 
 

 
 

2. Set the file path and select the type of files (DNG, JPEG, or TIFF) to add to the 
project. 

 
3. Select the image files and press Open. 
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Note: Instead of opening images through the menu, images may also be dragged and 
dropped into the application itself.  If attempting to drag-and-drop a group of 
images that contain different file types (such as Jpeg and DNG files) a prompt will 
appear, asking which file type you wish to open.  All of the images for a single 
project must have matching file types. 
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4. Preview the opened images.  Click on an image in the thumbnails strip to see 
the image in the larger preview area.  Use the mouse wheel or arrow keys to 
scroll through the thumbnail strip. 

 

 
 

5. Use the zoom tool to zoom in on the chart information of the image. 
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6. Once zoomed in, note the checker “# of rows” X “# of columns” dimensions 
listed as the “Version” of the chart, and note the number of points for the 
“Square Print Dimension”.  Use the hand tool to click, hold, and drag on the 
zoomed image if you need to move the image to see this information. 

 
7. Type in the checkerboard info in the appropriate data fields: Version (Row x 

Column), and Print Dimension (Points). 
 

 
 

8. Select the ruler tool.  Of all the images in the set, find the image with the 
smallest checker and measure this checker on its shortest dimension (width 
or length) with the ruler tool. 

 
9. When prompted, click Yes to input this value into the Screen Dimension 

(Pixels) data field. If you checked the “Do not show again” option, then the 
program will remember your current automatic input preference and apply 
it when you use the ruler tool for the next time. You can reset the preference 
from the preference dialog. 
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10. Input the name of the profile and the names of the camera and lens model of 
the chart images in their respective Display Names data fields. Depending on 
the application, these are the names that are displayed at the lens correction 
tools. So be as specific as possible. For example, you should include the name 
of the creator and the lens when specifying the lens profile name.  When 
naming the camera name and lens name, use the make and model of both the 
camera and lens to distinguish each from profiles that use similar equipment.  
For example, if using a Canon EF 85mm f1.2 L USM Mark II lens, input the 
lens name “Canon EF 85mm f1.2 L USM II” to distinguish the lens from the 
Canon EF 85mm f1.2 L USM Mark I, or the Canon EF 85mm f1.8 USM. 
 

11. Input the correct data for the chart images in the Calibration Settings 
window. 

a. Select whether the lens is Rectilinear or Fisheye. 
i. Rectilinear includes all “normal” perspective fixed and zoom 

lenses, including extremely wide-angle rectilinear (non-
fisheye) focal lengths. 

ii. Fisheye includes fixed/zoom fisheye lenses and circular fisheye 
lenses. 

b. Check whether you wish to generate a correction model for chromatic 
aberration and vignette correction. 

 
12. If the images in an image set were shot at different focus distances, you 

should separate those images into separate focus distance groups manually. 
You can drag and drop images (but only one at a time) from one focus 
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distance to another. Alternatively, a more efficient method would be first 
placed the images in the Finder/Explorer into subfolders (appropriately 
sorted by focus distance group, mixed focal lengths and apertures in the 
group is ok in this case), then imported each subfolder of images separately, 
ALPC would automatically create a new focus distance group with each 
import. 
 

13. The calibration settings are hierarchical. If you have imported multiple image 
sets, you can specify the calibration settings at the top camera/lens image set 
level, or at the focal length/aperture image set level, or at the focus distance 
group image set level. The settings specified at the parent level will apply to 
its child image sets at all levels. You can override the parent settings at any 
child image set levels.  

 
14. Review your choices for profiling and click the Generate Profiles button. 

 

 
 

15. Check the status bar to watch the progress of profile generation. 
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16. Check to make sure no grid detection failures occurred during profile 
generation.  A red grid will appear on the failed chart image, along with a red 
warning icon next to the image file name. 

 
 

If you have at least three images in a set which passed grid detection then 
you may still save a profile.  Images that pass grid detection will have a cyan 
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grid appear over the yellow grid to show the calculated correction 
transformation.  The fewer images that pass grid detection, the lower the 
quality will be for the profile. 

 

 
 
Naming and Saving the LCP File 
 

1. Use the default generated name or enter a custom name for the LCP file when 
prompted in the Save Profile window. 
 

 
 

2. Select the file path you wish to save to.  The default save location will save 
the file to the location of the lens profile library that installs with Photoshop.  
The default save location can be changed in the preferences dialog, accessed 
through the Calibration > Preferences… menu command. 
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Appending an Existing LCP File 
 
A single shooting iteration of calibration chart images should cover a single camera 
body with a single lens, and all the images should be of a single focal length, 
aperture, and focus distance.  If you wish to make customized correction data by 
characterizing the optical behavior of a camera/lens combination at different focal 
lengths, apertures, or focus distances, you must shoot separate iterations for each 
change, run the shooting iteration image sets individually, and then append them to 
a single LCP file.  A single LCP file should represent one or more iterations that share 
the same camera body and lens model, and have the same image file format (DNG, 
JPEG or TIFF), color mode (RGB or grayscale) and image pixel bit depths. 
 
Follow these guidelines for appending an LCP file: 
 

1. Open one or more iterations of calibration chart images by selecting File > 
Add Images to Project.  Make sure the images you add are checked on, and 
any other images that were previously opened/profiled are checked off or 
closed. 
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2. Enter or keep the same camera model and lens model name in the Profile 
Display Names section as the profile that you wish to append to. 
 

3. Enter new information in the Checkerboard Info section if a different 
checkerboard was shot for the iteration. 

 
4. Click the Generate Profiles button after reviewing the new profiling settings. 
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5. If appending to an existing profile that was created during a different ALPC 
session, you will be prompted: “Do you want to append the camera model to 
the existing file instead?”  Click Append to add the new data to the existing 
profile.  Click Replace if you’d like to replace the existing LCP file with the 
new data. 

 

 
 
Note: If attempting to append to an existing profile that contains correction profile 
data for a different make, model, lens, color mode, or image type (dng, jpeg, tiff) you 
will be prompted with a warning that the new data is inconsistent with the target 
profile, and to save the data under a new and different profile name. 
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Preferences and Other Options in the Adobe Lens Profile Creator 
 

1. Go to Adobe Lens Profile Creator > Preferences… for Mac or Calibration > 
Preferences… for Windows. 

a. Profile Settings allows you to choose whether or not to prompt the 
save dialog, and the default location that LCP files are saved in. 

b. Camera Calibration Cache allows you to control options for caching 
DNG image data for speeding DNG preview times in the ALPC.  There 
are options for cache size, location, and for purging the cache. 

c. Toolbar Settings controls whether or not the prompt pops up for 
asking if you’d like to use the ruler measurement you made for the 
Screen Dimension calibration parameter. 
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2. Go to File > Send Profiles to Adobe… 
a. Send your saved and completed LCP file as email attachment to Adobe 

(lcpfiles@adobe.com) so that it can be posted on our LCP file server 
and be made available to the Photoshop user community. 

b. Select the proper option for the type of email application you use and 
follow the directions in the prompt to properly send the LCP file. 

 

mailto:lcpfiles@adobe.com�
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3. Go to Help > Browse Adobe® Lens Profile Creator Online… 
a. Opens up a browser window with a link to the latest version of the 

Adobe Lens Profile Creator at Adobe Labs. 
b. Download the latest version of the ALPC to stay up to date with any 

future changes and improvements. 
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4. Go to File > Batch Convert Lens Design Data… 
 
This is a feature made available to lens manufacturers for converting their lens 
design data into LCP files. For details, check out the companion document titled 
“Adobe Camera Model Lens Design Data Conversion Guide” on the lens design 
data interchange format and conversion steps. 
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Placing the LCP File In the CameraRaw\LensProfiles\1.0 Folder 
 

1. If you’ve saved or have LCP files located in a non-default path, they must be 
placed in the correct location for use in Adobe Photoshop.  Copy or move the 
LCP to one of the user specific or shared lens profiles folders, or any of their 
sub-folders, depending on the operating system: 

a. For Windows XP:   
 

C:\Documents and Settings\(User Name)\Application Data\Adobe\CameraRaw\LensProfiles\1.0 
C:\Documents and Settings\All Users\Application Data\Adobe\CameraRaw\LensProfiles\1.0 

 
b. For Windows Vista or Windows 7:  

 
C:\Users\(User Name)\AppData\Roaming\Adobe\CameraRaw\LensProfiles\1.0 
C:\ProgramData\Adobe\CameraRaw\LensProfiles\1.0 

 
c. For Mac:   

 
/Users/(User Name)/Library/Application Support/Adobe/CameraRaw/LensProfiles/1.0 
/Library/Application Support/Adobe/CameraRaw/LensProfiles/1.0 
 

2. You may choose this path as the default path to save your generated profiles.  
Placing the files in this path allows the LCP files to be automatically read by 
the Photoshop Lens Correction plug-in. 
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Conclusion 
 
By opening and running a shooting iteration of calibration chart images through the 
Adobe Lens Profile Creator, you have successfully created your own customized set 
of lens corrections for your camera body and lens, stored inside of a custom LCP file. 
 
Keep in mind that a single iteration for a camera/lens combination will optimally 
correct for the behavior of a single given lens setup (focal length, aperture, and focus 
distance).  Experiment with applying your initial LCP results to images of the same 
camera body and lens model that vary in focal length, aperture, and focus distance 
when compared to the LCP data.  To achieve optimal results, calibrate and append 
an LCP file with different shooting iterations that match the lens settings you use the 
most in your shooting workflow! 
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