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Installation Guide
Read the Supporting Documentation Before You Install
Be sure to read the following supporting documentation before you install:

n This Installation Guide includes an overview of this release, installation instructions, system
requirements, and contact information.

n The Installation Checklist contains a brief description of the steps involved in upgrading your software.

n The Important document is shipped with your software and contains critical late-breaking topics.

n TheRelease Notes provide details about new features, database changes, known issues, and fixes.

n TheUser's Guide contains information about systems, security, Crystal reports, ODBC, andmore.

To learn themore, log on to the Knowledgebase through the Sage Customer Portal at
https://customers.sagenorthamerica.com/irj/portal/anonymous/login

Introduction

About This Guide
This guide is designed to help you become familiar with the new features in this release, and learn about
system requirements and installation changes. Review the instructions in Chapter 3 and Chapter 4 to
install Accounting and Estimating. Chapter 5 contains an overview of the new server migration tool.

Conventions Used in this Document
This document uses the following conventions:

l The names of screens, windows, fields, and other features displayed by the software are shown in
bold type.

l Information you enter into the software is in bold type, as in the following example:
EnterMiscellaneous in theAmount Type box.

l Names of keys are shown in capitals; for example, ENTER, TAB. A plus sign (+) between two key
names indicates that you should press both keys at the same time; for example, SHIFT + TAB.

l The names of buttons you can click with your mouse are enclosed in bold type; for example, [OK]
and [ Post].

TIP: Helpful information tomake your experience better.
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NOTE: This symbol draws your attention to information of particular interest, such as information
not included in steps.

CAUTION: This symbol draws your attention to information that is important because it can help
you avoid a costly or time-consuming error.

IMPORTANT: This symbol draws your attention to information that is of critical importance.

Menu Paths
In this document, menu paths show you the steps required to start a task. Here is a samplemenu path:

PR:Tools > Download Taxes

To follow this path, open the Payroll module. From the Toolsmenu, select Download Taxes.

Support and Assistance

Online Help
Each Sage Timberline Office application includes Help, which provides answers to your questions about
procedures as well as items in the windows.

To access Help in Sage Timberline Office:

n In a window, click theHelp button or icon, or press [F1] to display the help topic for that window.

n In the Desktop, select Help > Search for help on, and then choose the desiredmodule.

To aid you in finding the information you need, Help for each application includes the following tabs:

n Contents The table of contents is an outline of the Help for each application.

n IndexContains keywords that link to help topics related to that keyword.

n Search Type a search term and click [Search] to locate that text in the Help topics.

For more information about using Help, see Sage Timberline Office Desktop Help (in the Desktop, select
Help > Sage Timberline Office Desktop Help).

Wewould like your feedback about Help so we canmake improvements. Each Help topic contains an
area where you can indicate whether the topic was helpful and provide additional comments. To protect
your privacy, all comments are anonymous.

Training
Sage University offers online and classroom training sessions to help you get themost out of your Sage
Timberline Office software. To access Sage University, from the Sage Timberline Office Desktop, select
visit www.sageu.com.
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You can also get access to Sage University from the Sage Timberline Desktop from Help > Sage
Timberline Office on the Web > Sage Software University.

Technical Assistance
Depending on your Sage Service Plan, youmay be able to take advantage of the following services:

Sage Customer Portal

Youmay log on to the Sage Customer Portal at
https://customers.sagenorthamerica.com/irj/portal/anonymous/login to access any of the following:

l Knowledgebase Find answers to your questions, access downloads, and subscribe to your
favorite articles. This service is available online 24/7.

l Live ChatChat online with a customer support analyst - a great option for quick questions. Chat
hours areMonday through Friday from 6 a.m. to 3 p.m. Pacific Time, with the same exceptions as
telephone support (see below).

l Online Support RequestSubmit an online support ticket when you have a non-urgent question.
One of our call center support analysts will assist you. Online support hours are the same as our
customer support call center hours (see below).

Sage Customer Support Call Center

Telephone SupportWhen you have amore urgent question or would prefer to speak to a customer
support analyst directly, call us at 800-551-8307. Telephone support is available Monday through Friday
from 6 a.m. to 5 p.m. Pacific Timewith the following exceptions:

l Every Thursday from 2 p.m. to 3 p.m. Pacific time (closed for customer support staff meetings)

l Standard United States holidays

l Quarterly company meetings

Upgrading Your Service Plan

If your service plan does not provide online or telephone customer support and you would like to add or
upgrade a service plan, please call 800-858-7098.

Phone Support for Australia and New Zealand
n For Support in Australia:Call 1800 120369 or send an email to support.pacific@sage.com. Support
hours areMonday through Friday from 9 a.m. to 5 p.m. AET (Australian Eastern time).

n For Support in New Zealand:Call 0800 904409 or send an email to support.pacific@sage.com.
Support hours areMonday through Friday from 9 a.m. to 5 p.m. AET (Australian Eastern time).

n For Support in Asia-Pacific and other International Areas:Call +503-533-2181. Support hours are
Monday through Friday from 8 a.m. to 5 p.m. AET (Australian Eastern time)

Upgrading Your Service Plan
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If your service plan does not provide online technical support assistance youmay add or upgrade a service
plan by calling:

     1300 222 722 in Australia

     0800 904409 in New Zealand

Youmay also email us at: softwareassurance.pacific@sage.com.

Submitting Enhancement Requests
Wewant to hear your suggestions for improving the software. To send us your comments, select Help >
Sage Timberline Office on the Web > Submit Enhancement Requests.
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Chapter 1: Release Overview
New Features in Accounting 9.8
Youwill find the following enhancements to Sage Timberline Office in this release:

Credit Card Management
The new Accounts Payable credit cardmanagement feature allows you to record and track credit card
purchases, bank fees, andmiscellaneous charges. You can record credit card receipts, reconcile the
credit card statement against the receipts, track your balances, and select how you will pay the credit card
issuer. In addition, you can record credit card payments or Electronic Funds Transfer (EFT) against
existing invoices.

For detailed instructions on setting up and working with the credit cardmanagement feature, open
Accounts Payable Help. Enter "credit cardmanagement" in the Index tab to access detailed Help topics.

To get started, set up a liability account for credit cards inGeneral Ledger, then add theCredit Card
Payable Account inAccounts Payable: AP Settings > GL Entry Settings.

Set up each credit card issuer as an AP vendor inSetup > Vendors, then set up one or more credit cards
for each account or cardholder inSetup > Credit Cards.

As your employees turn in credit card receipts, open Tasks > Record Payments by Credit Card to
record the transactions for each credit card. When you receive the billing statement from the credit card
company, use Tasks > Verify Statement Balance to reconcile the transactions for each card. Once
you’ve verified all the transactions on the statement, you can generate an invoice for the credit card
(issuer) vendor from theVerify Statement Balancewindow. The invoice can be paid later by check. If the
balance due is automatically deducted from your bank account, you can use Tasks > Record
Manual/Print Quick Checks to record an electronic payment (EFT). Click [Help] in each task for detailed
instructions.

NOTES:

l You can use the credit cardmanagement features described above if your accountingmethod is
accrual. If your accountingmethod is cash or cash and accrual, see the Help topics onmanaging
credit card transactions on a cash basis.

l Reports that use the AP Invoice Payment, Distribution Payment, Tax Distribution Payment and
LienWaiver records have beenmodified. If you have customized reports that use these records,
open the reports in Report Designer and resave them. If you run these reports prior to resaving
them, you will receive a prompt to resave them. The reports are upgraded and will run without error
even if you do not resave them. The prompts will no longer appear after you resave.
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l Lien waiver records are created and saved when you enter data and click [Finish] in Tasks >
Record Payments by Credit Card.

l Set up task security to allow users to access theSetup > Credit Cards, Tasks > Record
Payments by Credit Card and Tasks > Verify Statement Balance features.

Pervasive Update
For compatibility with the latest version of the Pervasive database, we have updated the file formats of
Sage Timberline Office files.

IMPORTANT: The upgrademay cause file sizes to increase up to 200% of the current size of your
data. Be sure and allow for increased disk space requirements when you upgrade to 9.8. Do not
install Sage Timberline Office products until you have sufficient hard disk space available.

Server and Data Migration Tools
The new server and datamigration tools allow you to easily transfer your Sage Timberline Office
Accounting customizations and data to a new server. Items such as reports and reports menu, inquiries,
formulas, macros, and custom fields can bemoved. Company data, security settings and attachments
can also bemoved with the server migration tool. You can select which companies you want to move,
giving you the flexibility to move all companies or only move selected companies.

To learnmore about the server and datamigration tools, see Chapter 5: Server Migration.

Journals Enhancements
Automatically Print Journals

Use this option to automatically print your journals to a file, rather than selectingPrint to file each time
you finish and print. This new option will save you time and keystrokes. You can set up the option and the
naming convention for journal folders and journal files in Tools > Options > Journals.

TIP: Add the date and time to the Journal File name to eliminate the possibility of overwriting
journals.

Forced Page Breaks Removed

Frequently used accounting journals have been updated to remove forced page breaks, allowing those
journals to be printed on one page.

NOTE: If the journal was created using Report Designer, the first page will print the design and the
second page will print the report.

Print Audit Activity
Select Tools > Options > Print audit activity to print a journal when changes aremade to fields
controlled by theAudit Setup Activity setting.
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Aatrix Updates
Human Resources Forms (US only)

You can now access many of the forms you need to provide documentation for every aspect of employee
relations and payroll management, as well as a sample handbook. You can set up alerts to remind you
when important tasks need to be performed; for example, when an employee reaches the end of their
probationary period or when COBRA letters need to be sent. You can customizemany of the forms to suit
your business. All forms can be printed. Employee and company data from Sage Timberline Office is used
to create the forms. You can also choose to create blank forms. To access Aatrix HR forms, open
Payroll: Tasks > Generate HR Forms.

NOTES:

n Set up Task Security to allow users to access the HR Forms feature.

n HR alerts will notify you when you are in one of the following tasks:

l Accounts Payable > Government eFile and Reporting Form 1099 (USA)

l Accounts Payable > Government eFile and Reporting > Form T5018 (CAN)

l Payroll > Tasks > Quarterly Reporting > State eFile and Reporting

l Payroll > Tasks > Federal Reporting > Federal eFile and Reporting

l Payroll > Tasks > Generate HR Forms.

Federal WH-347 (US)

You can now print theWH-347 Certified Payroll report through Aatrix. To access this andmany other state
and federal reports, openPayroll: Tasks > Federal Reporting > Federal eFile and Reporting or Tasks
> Quarterly Reporting > State eFile and Reporting.

Canadian ROE Form

You can now eFile a Canadian Record of Employment form through Aatrix. To access this andmany other
reports, openPayroll: Tasks > Federal Reporting > Federal eFile and Reporting.

Live Chat With a Support Representative
You can now access Live Chat with a Customer Support representative from within any application in the
software. Live Chat is a great option for quick questions. Click Help > Live Chat, then log in. Select
Support, then Live Chat to initiate a session.
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New InfoCenter tab in Desktop
You can now find all the information you need about Sage Timberline Office products and services,
including new enhancements, technical tips, training, special offers andmuch, muchmore. To access the
new InfoCenter, openDesktop and click the InfoCenter tab.

Use SMTP to Send Email
In Tools > Options > Mail Settings, you can set up your email system to use SMTP to send email. After
you set up your system, click the [Test SMTP mail] to send a test email. The system will continue to use
SimpleMAPI if you do not set up SMTP.

NOTES:

o Youmay need to change your anti-virus settings to allow Sage Timberline Office applications to
send email via SMTP. Click [Help] in theMail Settingswindow for instructions on adding
exclusions to your anti-virus software.

o Using SimpleMAPI causes a security warning to appear each time you send an email from Sage
Timberline Office. This message no longer appears if you use SMTP.

o Be aware that messages sent using SMTP do not appear in your "Sent" email folder, and therefore
cannot be attached to the Project Management Correspondence Log. To recordmessages you
send, enter your own email address in the Cc box of eachmessage you wish to attach to the
Correspondence Log.

Microsoft Office 2010 Compatibility
Sage Timberline Office 9.8 is compatible with 32-bit MS Office 2010. When you install Microsoft Office
2010, select to install the 32-bit version. Sage Timberline Office will not work with the 64-bit version.

NOTE: Sage Timberline Office 9.8 is required for Document Management and Project Management
Correspondence Log to work with MS Office 2010.

Performance Enhancements
Wehavemade general enhancements to the performance of Sage Timberline Office in the 9.8 release.
Youmay experience faster performance with 9.8.

New Change Request Task Security
Administrators can now secure theUpdate Job Estimate task which appears inProject Management:
Contract Control > Change Requests andChange Orders. If Allow Update Job Estimate is selected
in Task Security, the user can update the job estimate as pending. If Allow Update Job Estimate
Approved is selected, the user can approve the new estimate. If neither are selected, the user can not
update job estimates.
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Inquiry File Type Selections Persist
The system now remembers which file selections youmade in Inquiries, and opens those selections when
you next open that inquiry. This will save you time and keystrokes. For example, if you selected the
Current.jctwhen you last ran the Job Cost: Inquiry > Cost Control > Profit inquiry, Current.jct is
selected the next time you run the inquiry.

Create Tax Rate and Tax Group Records in ODBC
You can now create and update Tax Rate and Tax Group records in ODBC.

Sage Timberline Office now available as a Download
The 9.8 Accounting andManagement Products and 9.8 Estimating Products are delivered as a download.
Refer to Knowledgebase article KB980 for more information.

Installation Changes for 9.8
9.8 Available as a Download Only

As part of our ongoing efforts to “GoGreen”, we will deliver our 9.8 release via software download only. In
addition to beingmore environmentally conscientious, this approach also helps us get the release into your
hands more quickly than traditional shippingmethods. For more information, see Knowledgebase article
KB980.

Full Workstation Installations

The Accounting workstation install no longer includes an option to install partially in order to integrate with
Estimating. Full Accounting installations are now required.

Application Files Installed to Shared Location

To increase system performance, we havemoved the location of the .exe files to theX://Program
Files/Timberline Office/Shared folder. We have placed links in the Accounting folder so that shortcuts
youmay have in place will continue to work.

NOTE: If you set up a shortcut to Desktop, youmust re-create it after installing 9.8. Select the
Desktop.exe inC:\ProgramFiles\Timberline Office\Shared. All other applications' shortcuts will
continue to work after installing 9.8.
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New Features in Estimating 9.8
The following features are new for the 9.8 release.

Total Cost/Unit Adjustments
Previous releases required you to use theAdjust Column feature to edit a spreadsheet item's Total
Cost/Unit. With this release, you can now edit the Total Cost/Unit by typing a new value directly into the
spreadsheet cell.

Item Attachments
You can now attach an item, such as a PDF file, text file, image file, or hyperlink, to a database item. You
make such item attachments in either theDatabase Item window or the estimate spreadsheet Detail
window. You can also right-click on any item in an estimate spreadsheet and attach an item using the
shortcut menu.

If you take off an item with an attachment, the attachment is taken off with the item. You can view the
attachment at any time by right-clicking on it and selectingView Attachment from the shortcut menu.

Reprice Crews Using the Estimate Information Window
In previous releases, Sage Timberline Office Estimating required you to use the Reprice Crews feature to
change the crew rate table for those items already in a spreadsheet. You can now reprice estimate items
by selecting another rate table on theCrew Pricing tab of theEstimate Settingswindow.
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Chapter 2: System Requirements
Be sure you read and understand this section before you install.

Supported Operating Systems
Sage Timberline Office supports the operating systems and service packs listed below. The service packs
listed are theminimum required for installing Sage Timberline Office 9.8. You will realize optimal system
performance by using up-to-date computer hardware.

For more information about Sage Timberline Office and the system environments, see the section on
System Guidance in theUser's Guide.

For help in selecting the right business-class computers for your business-class software, contact your
authorized business partner.

Operating System Minimum
Service Pack

64-bit operating systems*

Windows Small Business Server 2008
Premium Edition** NOTE:Within this

document, “Windows
Server 2008” refers to all
supported editions
unless noted
specifically.

Windows Server 2008 Enterprise Edition** SP2

Windows Server 2008 Standard Edition** SP2

Windows Server 2008 R2 Enterprise
Edition**

Windows Server 2008 R2 Standard
Edition**
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Operating System Minimum
Service Pack

Windows 7 Professional NOTE:Within this
document, “Windows 7”
refers to all supported
editions unless noted
specifically.

Windows 7 Ultimate

Windows 7 Enterprise

Windows Server 2003 Small Business
Server

SP2 NOTE:Within this doc-
ument, “Windows
Server 2003” refers to all
supported editions
unless noted spe-
cifically.

Windows Server 2003 Enterprise Edition SP2

Windows Server 2003 Standard Edition SP2

Windows Server 2003 R2 Small Business
Server

NOTE:Within this
document, “Windows
Server 2003” refers to all
supported editions
unless noted
specifically.

Windows Server 2003 R2 Enterprise
Edition

Windows Server 2003 R2 Standard Edition

Windows Vista Business SP2 NOTE:Within this
document, “Vista” refers
to all supported editions
unless noted
specifically.

Windows Vista Ultimate SP2

Windows XP Professional SP3

* 64-bit compatibility– Sage Timberline Office Accounting andManagement Products, Estimating
Products, and Residential Management applications are compatible with 64-bit operating systems.
Some third-party software is not currently compatible. For a complete list, see “Sage and Third-Party
Compatibility with 64-Bit Operating Systems” on page 19.

NOTE: Sage Timberline Office 9.8 is compatible with 32-bit MS Office 2010. When you install
Microsoft Office 2010, select to install the 32-bit version. Sage Timberline Office will not work with the
64-bit version.

**Windows Server 2008 compatibility– Sage Timberline Office Accounting andManagement Products
applications, Estimating, Document Management, and Residential Management are compatible with
Windows Server 2008.
Estimating Cut and Fill 5.23.0 and some third-party hardware and software products are not currently
compatible. This includes GTCOTabletWorks 10.08 driver and Primavera Project Planner (P3) 3.0. For a
complete list, see “Sage and Third-Party Compatibility withWindows Server 2008” on page 20.

NOTE: Estimating Database Editor is not supported onWindows Terminal Services.
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Recommended Minimum Processor
A Pentium 4 (P4) or later processor with aminimum of 2 gigahertz (GHz) processing speed is
recommended for the server that hosts Sage Timberline Office and for the workstations using Sage
Timberline Office. Having a fast processor on both the server and workstations will improve your system’s
performance.

Recommended Minimum Random Access Memory (RAM)
A minimum of 2 gigabytes (GB) of RAM is recommended for the server that hosts Sage Timberline Office
and for the workstations using Sage Timberline Office. As a general rule, themore RAM you have on the
server and workstations, the better your performance will be. Workstations with Vista orWindows 7
operating systems usemorememory, so youmay want to increase the RAM on Vista orWindows 7
workstations.
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Hard Disk Space Required for Installation
The following tables list the hard disk space necessary to install Sage Timberline Office on a server,
stand-alone computer, and workstation. Use this information to calculate your hard disk space
requirements based on the applications that you install. Having adequate free space on the hard disk, a
fast processing speed, and adequate RAM can improve your performance.

IMPORTANT: Do not install Sage Timberline Office products until you have sufficient hard disk
space available.

Server or Stand-Alone Computer

Product Available Hard Disk
Space Purpose and Considerations

Accounting and
Management Products

Up to 2GB For program files. Depends on the
number of applications installed.

Estimating Products Up to 650MB For program files.

Residential
Management

Up to 580MB For program files.

Document Management Up to 200MB For program files. Depends on
configuration.

Third-Party Components Up to 400MB Installed by Sage Timberline Office
as necessary.

Workstations

Product Available Hard Disk
Space Purpose and Considerations

Accounting and
Management Products

Up to 450MB For program files. Depends on
the number of applications
installed. This assumes that a
server hosts Accounting and
Management data.

Estimating Products Up to 650MB For program files.

Residential Management Up to 580MB For program files.

Document Management Up to 100MB For program files. Depends on
configuration.

Third-Party Components Up to 400MB Installed by Sage Timberline
Office as necessary.
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Hard Disk Space Required for Database Growth
The following table lists general guidelines regarding the hard disk space necessary for the growth of the
Sage Timberline Office database. Use this information to calculate your hard disk space requirements per
year based on usage. Your actual requirements will vary based on your actual usage.

Product Hard Disk Space Per Year Usage Definitions and
Considerations

Accounting and
Management
Products

Active User: 1 GB 10 ormore data entry clerks.

Modest User: 400MB 1 or 2 active data entry clerks.

Estimating Products Active User: 6-9 GB Database size varies primarily
based on complexity and use.

Per Estimate: 10MB each No estimate archive.

Residential
Management

Active User: 500MB Database size varies primarily
based on use.

Modest User: 100MB

Document
Management

Active User: 50 GB Scans 1700 black and white
pages per week with 200-300
dots per inch (DPI).

Modest User: 10 GB Scans several hundred black
and white pages per week with
300 DPI.
Database size varies primarily
based on scanning resolution
and use. See theDocument
Management Technical
System Reference for more
information about predicting
your future disk space.
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Hardware Requirements
Sage Timberline Office requires the following hardware.

Hardware Purpose and Specifications

Network adapter Connects computer to a network.
Must be high quality.

Ports 443 and 80 For connecting hardware, such as a printer, to the computer.
Set up firewall to accept these ports.

Port 25 To send email with Sage InstallationManager, Sage Timberline
Office, and Document Management.

Printer A Microsoft Certified printer driver is recommended.

Sound adapter For audio playback.

Super VGA monitor For high-resolution color display.
1024 pixels by 768 pixels is recommended.

Sage Timberline Office 9.8.0 Installation Guide                                                                                                                          Page 16

Chapter 2: System Requirements



Software Requirements
Sage Timberline Office requires the following software:

Software Purpose and Specifications

Adobe Reader 5.0 or later For viewing software documentation in Adobe
PDF format. For faxing and sending documents
from Sage Timberline Office.
Free downloads are available at www.adobe.com.

Crystal Reports Professional 11.5
SP 3
or Crystal Reports 11.5 SP 3 for
Sage

Formodifying and creating Crystal Reports
designs.
Crystal Reports for Sage is installed as a
prerequisite.

Faxing service SimpleMail Transfer Protocol (SMTP) fax
solution, Vista fax solution.
For sending faxes in applications with this feature.

Microsoft Internet Explorer 6.0
Service Pack 1 or later

For software updates, customer support, and
Help.

Microsoft .NET 3.5 Service Pack 1 Installed as a prerequisite.
If not already installed, it will restart your server
and workstations after the prerequisites are
installed.

Microsoft Office 2003 SP 3 or later* For Correspondence Log features in Project
Management and for importing Sage Timberline
Office data into Microsoft Excel or Microsoft
Query.

Sage Timberline Office is not compatible with 64-
bit MS Office 2010.

Microsoft Outlook 2003 SP3
Microsoft Outlook 2007 SP2
Microsoft Outlook 2010*

For email features.

UniMessage Pro For online faxing in Purchasing and Inventory.

Windows Services Print service for printing.
Log Viewer for troubleshooting.
Print service and Log Viewermust be available on
the server and workstations.

* Sage Timberline Office 9.8 is compatible with 32-bit MS Office 2010. When you install Microsoft Office
2010, select to install the 32-bit version. Sage Timberline Office will not work with the 64-bit version.
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In order to useMS Office 2010 with Correspondence Log and Document Management, youmust have
installed Sage Timberline Office 9.8.

Supported Protocols

Protocol Purpose

Transmission Control Protocol/Internet
Protocol (TCP/IP)

Microsoft servers default to this protocol.

Remote Display Protocol (RDP) 5 Microsoft remote protocol, which is used in
its remote connection applications.

Independent Computing Architecture
(ICA)

Citrix remote protocol, which is used in its
remote connection application.

SMTP Email protocol used in Document
Management, Sage Timberline Office
applications, and Sage InstallationManager.

Additional Products Required for Estimating

Hardware or Software Purpose and Specifications

Digitizing tablet or USB port For Estimating Digitizer.
Connect to RS-232 serial port and configure as
COM1 or COM2.
NOTE:Document Management also requires a USB
port.

GTCOWintab digitizer software For Estimating Digitizer.
Supplied by your digitizer manufacturer.

SafeNet Sentinel SuperPro USB
hardware key (dongle)

For Estimating and LicenseManagement.

SafeNet Sentinel driver Installed as a prerequisite for Estimating license
management.
To install a driver manually, open ...\980_Rev2_
Estimating\Prerequisites\SafeNet\Sentinel
Protection Installer<version x.x>.exe.

NOTE: Estimating Database Editor is not supported onWindows Terminal Services.
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Sage and Third-Party Compatibility with 64-Bit Operating
Systems
At the time of this release, the following Sage and third-party software were not supported on 64-bit
operating systems. For more information, visit the website of the software in question.

Not Compatible with 64-Bit Operating
Systems

Primavera Project Planner (P3) 3.1 and earlier

SageMaster Builder v13.3 and earlier
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Sage and Third-Party Compatibility with Windows Server
2008
At the time of this release, the following Sage and third-party software were not supported onWindows
Server 2008.

For more information, visit the website of the software in question.

Not Compatible with Windows Server 2008

GTCOTabletWorks 10.08 driver

Primavera Project Planner (P3) 3.0

SageMaster Builder v13.3 and earlier

Sage Timberline Office - Estimating Cut & Fill
5.23.0

Required Privilege Settings
The following sections describe the access rights you need to successfully install and use Sage
Timberline Office.

Elevate Permissions on Windows Vista and Windows 7
Youmust elevate your permissions before upgrading Sage Timberline Office.

You can usually start a program with elevated privileges by right-clicking the application and selectingRun
as Administrator. In Sage Timberline Office open X:/Program Files/Timberline Office/Accounting.

During certain installation tasks, you will receive another prompt to elevate your privileges. If you do not
acknowledge each prompt within twominutes, the installation process will quit the task. If this occurs, you
will receive a separate prompt asking you to retry the task. Click [Retry] and then elevate your privileges
at the prompt.

Sage Timberline Office Program Files and Data Files
Youmust have full control access rights to all folders or shares that contain Sage Timberline Office
program files and data files.

Windows XP Professional, Windows Server 2003, Windows Vista, Windows 7, andWindows Server
2008 have stricter default access rights settings than earlier Microsoft operating systems.

When you create a share for a folder, users get read access instead of full control access. For example,
when you create a shared folder to which you will install Sage Timberline Office, youmust manually grant
full control access to users who will access this folder.
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Full Control of Specific Files and Folders Required
To use Sage Timberline Office, youmust have full control of the following files and folders on your file
server, terminal server, and workstations that have Sage Timberline Office installed. Make sure that your
system administrator also gives you full control of all the subfolders and files.

CAUTION: Incorrectly modifyingMicrosoft Windows security may severely affect your system
operations. Sage is not responsible for operation problems caused by incorrectly modifying your
Microsoft Windows security settings. To set permissions on your network orWindows operating
system, youmust have advanced knowledge of your network. Contact your system administrator for
assistance.

NOTE: Some of these folders may be hidden. To view them on:

n Windows XP Professional and Windows Server 2003–OpenWindows Explorer, select Tools >
Folder Options, and select theView hidden files and folders check box on theView tab.

n Windows Vista, Windows 7, and Windows Server 2008-OpenWindows Explorer and select
Organize > Folder and Search Options, then select Show hidden files and folders on theView
tab.

Product Operating
Systems

Required Folders
and Files Location and Specifications

Sage
Timberline
Office

All [Drive]:\Program
Files\Timberline
Office

This folder is located on the server,
terminal server, and workstations
where you installed Sage
Timberline Office. It is the default
installation location for Sage
Timberline Office. However,
depending on your system
configuration, your company may
have renamed this folder or
installed it to a different location.

Sage
Timberline
Office

Windows
Vista
Windows
7
Windows
Server
2008

[Drive]:\Users\
[username]

This folder is located on the
workstation or terminal server
where you use Sage Timberline
Office. Sage Timberline Office
installs necessary files to this folder
and requires that the user has full
control of it. Typically, the user has
full control of this folder by default.
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Product Operating
Systems

Required Folders
and Files Location and Specifications

Sage
Timberline
Office

Windows
XP
Windows
Server
2003

[Drive]:\Documents
and
Settings\[username]

This folder is located on the
workstation or terminal server
where you use Sage Timberline
Office. Sage Timberline Office
installs necessary files to this folder
and requires that the user has full
control of it. Typically, the user has
full control of this folder by default.

Accounting
and
Management
Products

All Company data folder Typically, the data folder is located
on the server where you installed
Accounting andManagement
Products.

Accounting
and
Management
Products

Windows
Vista
Windows
7
Windows
Server
2008

[Drive]
:\ProgramData\Sage\
Timberline Office

This folder is located on the server
or host machine where you use
Accounting andManagement
Products. This folder must be
shared. Sage Timberline Office
installs necessary files to this folder
and requires that all users have full
control permissions to this folder
and all of its subfolders.

Accounting
and
Management
Products

Windows
XP
Windows
Server
2003

[Drive]:\Documents
and Settings\All
Users\
Application
Data\Sage\
Timberline Office

This folder is located on the server
or host machine where you use
Accounting andManagement
Products. This folder must be
shared. Sage Timberline Office
installs necessary files to this folder
and requires that all users have full
control permissions to this folder
and all of its subfolders.

Estimating
Products

All Database and
estimates

Typically, these files are located on
the server and the workstation
where you installed Estimating
Products.
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Product Operating
Systems

Required Folders
and Files Location and Specifications

Estimating
Products

Windows
Vista
Windows
7
Windows
Server
2008

[Drive]:\Users\
Public\Estimating

This folder is located wherever you
use Estimating Products. Sage
Timberline Office installs
necessary files to this folder and
requires that all users have
read/write permissions to this folder
and all of its subfolders.

Estimating
Products

Windows
XP
Windows
Server
2003

[Drive]:\Documents
and Settings\All
Users\Estimating

This folder is located wherever you
use Estimating Products. Sage
Timberline Offices installs
necessary files to this folder and
requires that all users have
read/write permissions to this folder
and all of its subfolders.
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Full Control of and Read Access to Specific Registry Keys Required
To use Sage Timberline Office, youmust have full control of the followingWindows registry key on your
file server, terminal server, and workstations that have Sage Timberline Office installed. Make sure that
your system administrator also gives you full control of all subkeys.

n HKEY_CURRENT_USER

You should have read access to the following registry keys and associated subkeys:

n HKEY_Local_Machine\Software\ODBC

n HKEY_Local_Machine\Software\Pervasive Software

n HKEY_Local_Machine\Software\Timberline

CAUTION: Incorrectly editing theMicrosoft Windows registry may severely damage your system.
Sage is not responsible for damage to your system caused by editing the registry. Beforemaking
changes to the registry, contact your system administrator for assistance andmake a backup copy
of all valued data. System administrators should seeMicrosoft Registry Editor Help topics for
detailed instructions.

Compatible Versions
The following versions of Sage Timberline Office are compatible with each of the others:

n Accounting andManagement Products 9.8

n Document Management 9.8

n Estimating Products 9.8

n Estimating Products 11

n Residential Management 9.8

NOTE: If you use both Residential Management and Estimating, install Estimating before you install
Residential Management.
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Supported Upgrade Paths

Accounting
Youmust be running Accounting andManagement Products version 9.4 or later in order to upgrade to 9.8.
If you are running a version that is earlier than 9.4, we recommend that you upgrade to version 9.4 before
you upgrade to 9.8. Contact your Business Partner for assistance.

Upgrade
from Upgrade Path

9.4.1–9.7 Upgrade directly to 9.8.

8.3.x–9.3.x Upgrade to 9.4.x. Then, upgrade to 9.8.

7.5.0–8.2.3 Upgrade to 8.3.x or 9.1.x. Next, upgrade to 9.4.x. Then, upgrade to 9.8.

7.0.0–7.4.0 Upgrade to 7.5.x or 7.6.x. Next, upgrade to 8.3.x or 9.1.x. Next, upgrade
to 9.4.x. Then, upgrade to 9.8.

5.4.x or earlier 1. From TS-Main, select Tools > File Doctor and apply this utility to all
files before you upgrade your 5.4.x installation. You cannot wait until
after the upgrade to perform this check because later versions of File
Doctor are not compatible with 5.4.x data.
2. Upgrade to 7.5.x or 7.6.x.
3. Upgrade to 8.3.x or 9.1.x.
4. Upgrade to 9.4.x.
5. Upgrade to 9.8.

Estimating
You can upgrade any Windows-based version of Estimating Products (beginning with 1.0) to Estimating
Products 9.8.

For information about Estimating 11, see the accompanying documentation.

Required Data File Upgrades
Youmust upgrade all Accounting andManagement application data files after you install 9.8.

NOTE: You can upgrade the data files for Accounting applications—except for Service
Management, Purchasing, and Inventory—using TS Main > Tools > Upgrade files orSage
Timberline Office > Desktop > Tasks > Common Tasks > Tools > Upgrade files. Service
Management, Purchasing, and Inventory data files upgrade the first time you open those application.
Youmust open the application and perform the upgrade at the server. Upgrading this data on a
workstation will incorrectly set DSNs and cause data access errors after the upgrade is performed.
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Chapter 3: Install Accounting
A. Before You Install
n Read theRelease Notes for more information regarding this release of Sage Timberline Office.

n Read and understand the system requirements on page 11.

n Review the Installation Checklist.

n If you use Estimating products, install Accounting 9.8 before Estimating 9.8.

1 If you are upgrading, create a complete backup of all Sage Timberline Office data and program files.

2 Install the appropriate operating system service pack, make sure sufficient hard disk space is available,
and verify that your server and workstations meet all other hardware and software requirements. For
example, Accounting andManagement Products require up to 2 gigabytes (GB) of available hard disk
space in the following location on your server:

n XP andWindows Server 2003 - X:\Documents and Settings

n Vista, Windows 7, andWindows Server 2008 - X:\ProgramData

IMPORTANT: The upgrademay cause file sizes to increase up to 200% of the current size of your
data. Be sure and allow for increased disk space requirements when you upgrade to 9.8. Do not
install Sage Timberline Office products until you have sufficient hard disk space available.

3 Make sure that you have full control of the required folders, files, and registry keys on your file server,
terminal server, and workstations that will have Accounting andManagement Products installed. For a
list of the required folders, files, and registry keys for your operating system, see “Required Privilege
Settings ” on page 20.

4 Quit all programs and services for the duration of the installation. This includes programs that may be
running in the background, such as antivirus, email, and backup programs.

5 Windows Vista, Windows 7, and Windows Server 2008–Youmust elevate your permissions before
installing Sage Timberline Office. During certain installation tasks, you will receive another prompt to
elevate your privileges. If you do not acknowledge each prompt within twominutes, the installation
process will quit the task. If this occurs, you will receive a separate prompt asking you to retry the task.
To retry the task, click [Retry] and then elevate your privileges at the prompt.

6 If you are upgrading from Sage Timberline Office 9.4.x, use Report or Inquiry Manager to rename
duplicates of reports and inquiries within the same application so that each report has a unique report or
inquiry name. Starting in Sage Timberline Office 9.5, Security Administration applies security settings to
only one instance of a report or inquiry. By using unique report and inquiry names, you can ensure that
the security settings applied in previous versions of Sage Timberline Office are carried forward.
Otherwise, other instances of the report or inquiry will be unsecured after upgrading.
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7 If you have Estimating Products on the server or workstation, you should remove them before beginning
to install Accounting products. Go to [Start] > Settings > Control Panel > Add or Remove
Programs and select Estimating.

8 Determine which installation instructions to read in this document. Most users should start with “B.
Install to a Server or Stand-Alone Computer” on page 28. If you have a terminal server or peer network,
start with “D. Other Installation Scenario” on page 32. If you are installing Estimating only, see “Chapter
4: Install Estimating” on page 39.

B. Install to a Server or Stand-Alone Computer
IMPORTANT: Do not install Accounting andManagement Products unless you have sufficient hard
disk space available. See "Hard Disk Space Required for Installation" for more information.

The installation process may restart your server or stand-alone computer several times.

1 At the server or stand-alone computer, log on with full administrative rights. Full administrative rights are
defined as write access to theWindows registry and all folders on the computer (including rights to the
root of all hard drives). If you are unsure whether you have full administrative rights, ask your network
administrator for assistance. Alternately, you can ask your network administrator to log on with the
network administrator ID before you start the installation.

2 Download the software. For details about the download, see Knowledgebase article KB980.

3 In the Installationwindow, click Install Sage Timberline Office software. This step installs
prerequisite components necessary to run Sage Timberline Office applications.

NOTES ABOUT INSTALLING PREREQUISITES:

n If you receive a firewall warningmessage during the installation of the Pervasive database engine,
work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if a Microsoft Windows Firewall Security Alert
window lists theDatabase Service Manager by Pervasive Software Inc., confirm with your
network administrator that you wish to proceed. Then, select Unblock this program and click
[OK].

n Youmay receive a similar message during the installation of Sage Service Host. Follow the same
steps to proceed.

n If .NET 3.5 SP1 is not already installed, it will be installed with other prerequisites. If .NET 3.5 SP1
is installed as a prerequisite, the system will restart your server and workstations after the
prerequisites are installed.

n If you are required to restart your computer, remember to stop antivirus, backup, and other services
that may have automatically started again after you restart your computer.

4 Follow the on-screen prompts to install the software.

5 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until themessageAll configuration tasks for
Sage Timberline Office completed successfully. Do not attempt to start any Sage Timberline Office
applications until after you have received this message. It may take awhile before you see the
message.
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6 Some of the data and report folders and files will be hidden by default. At the end of the installation, you
can display hidden files and folders:

n OnWindows XP Professional orWindows Server 2003, openWindows Explorer, select Tools >
Folder Options, and select View hidden files and folders on theView tab.

n OnWindows Vista orWindows Server 2008, Windows 7, andWindows 2008, openWindows
Explorer and select Organize > Folder and Search Options, and then select Show hidden files
and folders on theView tab.

7 If you have not yet removed Estimating from the server, a message will appear that asks you to remove
it before proceeding. Remove Estimating Products from [Start] > Settings > Control Panel > Add or
Remove Programs. Then, continue with the installation of Accounting andManagement Products.
Afterwards, follow the instructions in “Chapter 4: Install Estimating” on page 39 to upgrade Estimating
Products.

Automatic Creation of Timberline Office Share
The installation automatically creates a shared Timberline Office folder on the server if one does not
already exist. Read and write permission are automatically granted to the Everyone group. If the
Timberline Office folder is already present and shared, the installation will skip this step. The system will
not change any permissions you have already set up.

You will connect your workstation to the shared Timberline Office folder in the next section.

C. Install to a Workstation Connected to a Network
After you install to a server (“B. Install to a Server or Stand-Alone Computer” on page 28), follow these
steps to set up your workstations.

IMPORTANT: Do not install Accounting andManagement Products unless you have sufficient hard
disk space available. See "Hard Disk Space Required for Installation" for more information.

NOTE: The installation process may restart your workstations several times.

Installing to a Terminal Server
If you are installing to a workstation that will be used as a terminal server, follow installation steps A, B,
and C, with these exceptions:

n UseAdd or Remove Programs to start an installation to a terminal server. This makes the software
available to remote operators.

n If you are installing Sage Timberline Office on aWindows Server 2008 terminal server, begin the
installation by selectingControl Panel > Install Application on Terminal Server. Follow the
prompts and browse to the install.exe file.
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NOTE: InWindows Server 2008 R2, "terminal services" is called "Remote Desktop".
Open Start > Control Panel > Install Application on Remote Desktop
orStart > Control Panel > Programs > Install Application on Remote Desktop.

Follow the prompts and browse to the install.exe file.

n If your terminal server does not host Sage Timberline Office programs and data files:

p Install to the server as if it were a workstation. Perform the steps in “C. Install to aWorkstation
Connected to a Network” on page 29.

p After you install Sage Timberline Office, verify that the Pervasive.SQL database service on the
terminal server uses an account with access rights to the Local System account and access to all
Sage Timberline Office program and data files. To verify your account and access rights, select Start
> Programs > Administrative Tools > Services on the terminal server. In theServiceswindow,
right-click thePervasive.SQL service and select Properties. Then, on the Log On tab, select [Use
this account]. Work with your network administrator to enter an account that has the access rights
of the Local System account and access to all Sage Timberline Office program and data files on the
file server.

p Formore information about using terminal services, see “C. Install to aWorkstation Connected to a
Network,” on page 29.

NOTE: The Local System account, which does not typically have access to files located on
another server, should not be selected on the Log On tab. If you use an account with insufficient
access rights, youmay receive a Pervasive status code 94 or 3119 error.

Installing to a Workstation
1 If you have Estimating Products on the workstation, you will need to remove Estimating Products
before you proceed. Remove Estimating Products from [Start] > Settings > Control Panel > Add or
Remove Programs.

2 At the workstation, log on with full administrative rights. Full administrative rights are defined as write
access to theWindows registry and all folders on the computer (including rights to the root of all hard
drives). If you are unsure whether you have full administrative rights, ask your network administrator for
assistance. Alternately, you can ask your network administrator to log on with the network administrator
ID before you start the installation.

3 Establish a connection with the shared Timberline Office folder on the server or peer server by
mapping a drive to it.

a InWindows Explorer, click Tools > Map network drive.

b Select a letter for the drive name.

c In the Folder box, browse to \\[Server Name]\Timberline Office.
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IMPORTANT: We strongly recommendmapping a drive to the location listed above. Mapping to a
different folder can cause unexpected errors. In addition, whenmapping a drive to the shared
Timberline Office folder, do not disconnect or redirect existingmapped drives for Sage Timberline
Office products to the new location.

While we recommend the use of mapped drives to establish a connection with the shared folder, you
may also use a UNC path. For example, if you choose to use a UNC path to the shared data folder,
the UNC path is \\[Server name]\Timberline Office\9.5\Accounting\WinInst\Install.exe. See step 5
below for instructions.

4 Click [Start] > Run.

5 In theRunwindow, click [Browse]. In theBrowsewindow, select Install.exe in theWininst folder on
the server.

n If you are usingmapped drives, select T:\9.5\Accounting\WinInst\Install.exe, where T is the drive
youmapped to the Timberline Office folder in step 3.

n Alternatively, if you are using UNC paths, select \\[Server name]\Timberline
Office\9.5\Accounting\WinInst\Install.exe. Click [Open]. Then, click [OK].

6 In the Installationwindow, click Install Timberline Office software. This step installs components
necessary to run Sage Timberline Office applications.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to
communicate through your firewall software. For example, if aWindows Firewall Security Alert
window lists theDatabase Service Manager by Pervasive Software Inc., confirm with your
network administrator that you wish to proceed. Then, select Unblock this program and click [OK].

Youmay also receive this message during the installation of Sage Service Host. Follow the same steps to
proceed.

7 Repeat steps 1–6 for each workstation.

8 At the conclusion of the installation, you will be prompted to restart your computer.

9 Some of the data and report folders and files will be hidden by default. At the end of the installation,
show hidden files and folders.

n OnWindows XP Professional orWindows Server 2003, openWindows Explorer, select Tools >
Folder Options, and select View hidden files and folders on theView tab.

n OnWindows Vista, Windows 7, orWindows Server 2008, select Organize > Folder and Search
Options, and then select Show hidden files and folders on theView tab.

10 If you set up a shortcut to Desktop, youmust re-create it after installing 9.8. Select Desktop.exe in
C:\ProgramFiles\Timberline Office\Shared. All other applications' shortcuts will continue to work
after installing 9.8.
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D. Other Installation Scenario

Peer Server Networks with Estimating Products
Follow installation steps A, B, and C, but perform this step after the installation:

At the peer server, map a drive to the same shared folder that the workstations use. Use this mapped drive
to access Address Book data.

E. Modify Security Settings
If you use security, modify the security settings tomeet your company’s requirements (Sage Desktop >
Tools > Security Administration > Security Settings). For more information, see the chapter on
Security in theUser's Guide.

F. Upgrade Data Files
If you upgraded to a new version of Accounting andManagement Products, read and follow the information
in this section. If this is a first-time installation of Accounting andManagement Products, skip to “G. Install
Crystal Reports XI (Optional)” on page 35.

NOTE: ServiceManagement, Purchasing, and Inventory have specific upgrade requirements. First,
remember to log on to the operating system as an administrator. Then, open and upgrade Service
Management, Purchasing, and Inventory data files at the server the first time you open these
applications. Upgrading this data on a workstation will incorrectly set DSNs and cause data access
errors after the upgrade is completed.

Prepare to Upgrade Files
For optimal performance, we recommend that you upgrade your data from the server. If you prefer to
upgrade your data from aworkstation instead, youmust install the software at both the server and the
workstation before starting theUpgrade Files process.

1 Back up your data files.

2 Make sure no one is using Sage Timberline Office applications.

3 Log in to Sage Timberline Office as the application administrator.

4 Open TS-Main.

a If you are prompted to select a company but you do not see your company, click [Specify Folders].

b In theSpecify Data Folders Path window, click [Browse]. Then, select the UNC path to the folder
that contains your Sage Timberline Office data and click [OK].

c Select your data folder from theSpecified Folders area and click [OK].

d Select your company from the list of companies in theSelect Companywindow and click [OK].
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5 If you use file locations and the path is not accessible from the server (for example, you usemapped
drives instead of specific paths), modify the locations to point to files on the local hard drive of your
server.

TIP: We recommend that you convert your mapped drives to the equivalent UNC paths using the
following instructions. If you convert now, you will not have to perform this step during future upgrades,
and you can skip to “Restore File Locations ” on page 34.

a In TS-Main, select File > Company Settings > File Locations.

b In the File Locationswindow, look for network paths in theData Folder column.

c If you have network paths, write them down. You need this information for a later step.

d In the File Locationswindow, modify each network path to point to the appropriate file on the local
hard drive of your server.

e Close the File Locationswindow.

6 Repeat steps 4 and 5 for each data folder you will upgrade.
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Upgrade Files

NOTE: Youmust upgrade ServiceManagement, Purchasing, and Inventory at the server. Files
cannot be used by other applications while they are being upgraded.

If you are upgrading from Sage Timberline Office 9.4.x, security changes will bemade during upgrade as
follows. See the chapter on security in theUser's Guide.

In 9.4.x Converted to the Following During
Upgrade

Customer Operators UserName_Role (for example, Karen_Role)

Operators Users

Unlimited Operators Both Security Administrator and Application
Administrator roles

Groups Roles

Mixed case alpha characters
in passwords

Lowercase alpha characters in passwords

1 In TS-Main, select Tools > Upgrade Files.

NOTE: To save processing time, theUpgrade Files feature only updates files that have dictionary
changes. You can, however, select the Force file upgrades check box (TS-Main: Tools >
Upgrade Files) if you want to upgrade all of your data files.

2 Select to upgrade the current data folder or all data folders.

If you select Current data folder, you upgrade files in the data folder in which you currently work.

If you select All data folders, you upgrade files in all data folders that appear in theOpen Company
window. This may include data folders on other drives. With this option, the upgrade process can take a
long time if you havemany data folders.

3 Select files to upgrade from the Files list. Youmust upgrade all data files after you install 9.8.

4 Click [Start]. ThePrint File Selectionwindow opens.

5 In the File name box, type a name for the upgrade report file and click [Save]. The upgrade process
begins in the background.

6 Review the report when the process is complete.

Restore File Locations
If youmodified file locations and the path is not accessible from the server (for example, you usemapped
drives instead of UNC paths), restore the previous file location entries.
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TIP: If you use UNC paths or converted to UNC in step 5 on page 33, you can skip this step now
and in future upgrades.

1 In TS-Main, select File > Company Settings > File Locations.

2 In the File Locationswindow, find the file locations you changed previously and change them back to
the original network path.

3 Close the File Locationswindow.

G. Install Crystal Reports XI (Optional)
If you ownCrystal Reports XI and have already installed it, you can skip this step. For more information
about setting up Crystal Reports with Sage Timberline Office, see theUsers Guide.

Crystal Reports XI is installed from three separate CDs. The first two CDs install the Crystal Reports XI
software. The third CD installs a service pack. This service pack ensures Crystal Reports XI is
compatible with Sage Timberline Office. Follow these steps to install Crystal Reports XI.

1 Ensure all Windows programs are closed. Insert the first CD into the drive of the server or workstation
where your report designs are kept.

2 When the setup wizard appears, click [Next]. Follow the on-screen instructions to begin the installation.

3 Insert the second CD when prompted. Click [OK] to continue.

4 Click [Finish] after the Crystal Reports installation is finished and remove the second CD.

5 Insert the service pack CD into the drive. OpenWindows Explorer and browse to the CD. Double-click
Setup.exe to begin the service pack installation.

NOTE: This step assumes you are installing Crystal Reports XI for Sage. If you are installing Crystal
Reports XI from aCD supplied by another vendor, contact themanufacturer for instructions on applying
the service pack update.

6 Follow the on-screen instructions to install the Crystal Reports service pack. Restart your computer
when prompted.

NOTE: Do not remove the CD; it must remain in your computer during restart for the installation to
continue.

7 Remove the service pack CD after the installation is finished.

H. After You Install
Some of the data and report folders and files will be hidden by default. At the end of the installation, show
hidden files and folders.

n OnWindows XP Professional orWindows Server 2003, openWindows Explorer, select Tools >
Folder Options, and select View hidden files and folders on theView tab.

n OnWindows Vista, Windows 7, orWindows Server 2008, select Organize > Folder and Search
Options, and then select Show hidden files and folders on theView tab.
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Elevated Permission Levels After Installing
If you install ServiceManagement (SM), Purchasing (PO), and Inventory (IV) onWindows Vista, Windows
7, orWindows Server 2008, you should elevate your permission level. Crystal Reports may not run
correctly in these applications if the permission level is set too low. If you encounter an error message
when starting SM, PO, or IV for the first time after installation, close the application, elevate your
permission level, and start the application again. To do this:

1 Close the PervasiveWorkgroup engine (Right-click the Pervasive Database icon in the systems tray
and select Stop Engines and Exit.)

2 Right-click SM.exe, PO.exe, or IV.exe.

3 Select Run as Administrator.

4 Open each company data set at the server.

5 Repeat these steps for each company data folder.

If You Have Purchasing, Inventory or Service Management Data Inside
Program Files
If, before upgrading, your company data folder was inside theProgram Files folder in Purchasing (PO),
Inventory (IV), or ServiceManagement (SM), follow these steps at the server to move your data to a
shared location and tomake the data available to your users.

1 Move your data to a shared location. The default shared location is \\[Server name]\Timberline
Office\Data.

2 At the server, remove all Pervasive System DSNs and User DSNs for each Sage Timberline Office
installation.

a Click [Start] > All Programs > ODBC > 32bit ODBC Administrator. TheODBC Data Source
Administratorwindow appears.

b From theSystem DSN tab, select the first Name associated with aPervasive ODBC Engine
Interface Driver and then click [Remove].

c Repeat for eachName associated with aPervasive ODBC Engine Interface Driver.

d From theUser DSN tab, select the first the first Name associated with aPervasive ODBC Client
Interface Driver and then click [Remove].

e Repeat step d for eachName associated with aPervasive ODBC Client Interface Driver.

f Click [OK].

3 At the server, delete theDBNAMES.CFG file.

a From \\[Server name]\WINDOWS, right-click DBNAMES.CFG and select Delete.

b On theConfirm File Deletewindow, click [Yes].

4 Add each company to the company list.

a In TS-Main, select File > Open Company.

b Click [Specify Folders].
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c Click [Browse] to browse to the location that you selected in step 1.

d Select a folder and click [OK].

e At the server, open the SM and PO or IV applications for each Sage Timberline Office company. See
Additional Steps for Network Installations That Have Accounting andManagement Products in “D.
Other Installation Scenario,” on page 32.

f Repeat for each company folder that you want to add.

5 If you use security, give the appropriate users rights to the companies (Sage Desktop > Tools >
Security Administration > User Setup > Companies). For more information, see the section on
security in theUser's Guide.

If You Have Estimating-Only Workstations
To access Address Book, Job Cost, and tax data on a server, see Additional Steps for Network
Installations That Have Accounting andManagement Products in “D. Other Installation Scenario,” on page
32. Workstations that have both Estimating Products and Accounting andManagement Products have
already been configured as part of the Accounting andManagement Products installation and do not
require these steps.The steps apply to both upgrades and first-time installations.

I. Final Steps
1 Restart all programs and services that you shut down for the installation.

2 Review the following guidelines for custom reports or custom third-party applications.

a If you have custom reports that use the Crystal Reports format, be sure to open these reports in
Crystal Reports Professional. Select theDatabase > Verify Database command, and then save the
report.

b If you use Inventory, Purchasing, or ServiceManagement custom Crystal reports, see the section on
Crystal Reports in the User's Guide for special information and detailed instructions about upgrading
these reports.

c As with any release, database changes in Sage Timberline Office applications may affect your
custom report designs or custom third-party applications. Contact your authorized business partner to
discuss any issues relating to custom reports or third-party applications.

3 Sage Timberline Office provides numerous supporting documents in Adobe Acrobat (PDF) format. If
you do not already have Acrobat Reader, you can download it from www.adobe.com.

4 To increase system performance, we havemoved the location of the .exe files to the X://Program
Files/Timberline Office/Shared folder. We have placed links in the Accounting folder so that shortcuts
youmay have in place will continue to work.

NOTE: If you set up a shortcut to Desktop, youmust re-create it after installing 9.8. Select the
Desktop.exe inC:\ProgramFiles\Timberline Office\Shared. All other applications' shortcuts will
continue to work after installing 9.8.
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Chapter 4: Install Estimating
A. Before You Install or Upgrade
Read theRelease Notes for more information regarding this release of Sage Timberline Office.

1 If you are upgrading, create a complete backup of all Sage Timberline Office data and program files.

2 If you use Accounting products, install Accounting 9.8 before Estimating 9.8.

3 Install the appropriate operating system service pack level, make sure that there is sufficient hard disk
space available, andmake sure that your server and workstations meet all other hardware and software
requirements. For example, Estimating Products require up to 650MB of available hard disk space. See
“Chapter 2: System Requirements” on page 11 for more information.

4 Make sure that you have full control of the necessary folders, files, and registry keys on your file server,
terminal server, and workstations that will have Accounting andManagement Products installed. For a
list of the required folders, files, and registry keys for your operating system, see “Required Privilege
Settings ” on page 20.

5 Quit all programs and services for the duration of the installation. This includes programs that may be
running in the background, such as antivirus, email, and backup programs.

6 Windows Vista, Windows 7, and Windows Server 2008: Youmust elevate your permissions before
installing Sage Timberline Office. During certain installation tasks, you will receive another prompt to
elevate your privileges. If you do not acknowledge each prompt within twominutes, the installation
process will quit the task. If this occurs, you will receive a separate prompt asking you to retry the task.
To retry the task, click [Retry] and then elevate your privileges at the prompt.

7 If you are upgrading, useAdd or Remove Programs to remove Estimating Products (if you have not
already done so when installing Accounting andManagement Products in the previous section).

8 If Sentinel protection devices are not already attached to your computer, delay attaching these devices
until after you install Estimating. If you already have Sentinel protection devices attached, you can
leave these devices in place during the Estimating installation.

9 Decide which installation instructions to read in this document. Most readers should start with “B. Install
to aWorkstation” on page 40. If you have Accounting andManagement Products, a terminal server, or a
peer network, start with “D. Other Installation Scenarios” on page 42.

10 Crystal Reports XI software is installed from three installation CDs. For more information, see “G.
Install Crystal Reports XI (Optional),” on page 35

11 You can upgrade any Windows-based version of Estimating Products (beginning with version 1.0) to
Estimating Products 9.8.
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B. Install to a Workstation
IMPORTANT: Do not install Estimating Products until you have sufficient hard disk space
available. See "Hard Disk Space Required for Installation" for more information.

NOTE: The installation process may restart your workstations several times.

1 At the workstation, log on with full administrative rights. Full administrative rights are defined as write
access to theWindows registry and all folders on the computer (including rights to the root of all hard
drives). If you are unsure whether you have full administrative rights, ask you network administrator for
assistance. Alternately, you can ask your network administrator to log on with the network administrator
ID before you start the installation.

2 Download the software. For details about the download, see Knowledgebase article KB980.

3 In the Installationwindow, click Install Timberline Office software. Follow the on-screen prompts to
install Estimating Products and decide whether you want to install databases. You can install
databases to your workstations, or you can install databases to a server. Install databases at your
server if you want to share databases across your network.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to
communicate through your firewall software. For example, if aWindows Firewall Security Alert
window lists theDatabase Service Manager by Pervasive Software Inc., confirm with your
network administrator that you wish to proceed. Then, select Unblock this program and click [OK].

4 When the installation has completed, you will be prompted to restart your computer.

5 If you are upgrading from Estimating 9.5 or later, you can skip to step 7. After restarting, Estimating will
automatically bring up theEstimating User Account Control and Configuration Setupwindow.
This process sets up all default User Account Control (UAC) compliant folders, transfers all Windows
registry settings, scans and copies any data found in Program Files, and copies relevant application
data to a UAC-compliant location.

n If this is the first time Estimating is being installed on your computer, this process ensures that your
data will be stored in a UAC-compliant location and your computer is configured properly.

n If you are upgrading from a previous version of Estimating, this process ensures any data stored in
a non-UAC compliant location is copied to a UAC-compliant location.

Select [Click to Begin] to start the upgrade process.

Windows Vista, Windows 7, and Windows Server 2008: Youmust elevate your permissions before
installing Sage Timberline Office. During certain installation tasks, you will receive another prompt to
elevate your privileges. If you do not acknowledge each prompt within twominutes, the installation
process will quit the task. If this occurs, you will receive a separate prompt asking you to retry the task. To
retry the task, click [Retry] and then elevate your privileges at the prompt.

NOTE: Formore information on User Account Control, see theUser's Guide or see the User Account
Control topics included in Estimating Help.

6 Repeat steps 1–6 for each workstation to which you want to install Estimating Products.
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7 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until themessageAll configuration tasks for
Sage Timberline Office completed successfully. Do not attempt to start any Sage Timberline Office
applications until after you have received this message.

NOTE: It may take awhile before you see themessageAll configuration tasks for Sage Timberline
Office completed successfully.

8 If you set up a shortcut to Desktop, youmust re-create it after installing 9.8. Select the Desktop.exe in
C:\ProgramFiles\Timberline Office\Shared All other applications' shortcuts will continue to work
after installing 9.8.

9 If you plan to install Estimating Products to a server or if you plan to share estimates and databases
from a server, continue with “C. Install to a Server,” on page 41. Otherwise, skip to “E. Set up Stand-
Alone Security Devices” on page 44.

C. Install to a Server
IMPORTANT: Do not install Estimating Products unless you have sufficient hard disk space
available. See "Hard Disk Space Required for Installation" for more information.

NOTE: The installation process may restart your server several times.

Many users choose to share databases and estimates across their network. They also install Estimating
Products to their server so they canmore efficiently perform file maintenance on their data. Follow these
steps if you want to install Estimating Products or share databases or estimates from your server. Even if
you do not install Estimating Products on your server, you still need to follow these steps to install required
components that allow you to access data.

1 At the server or stand-alone computer, log on with full administrative rights. Full administrative rights are
defined as write access to theWindows registry and all folders on the computer (including rights to the
root of all hard drives). If you are unsure whether you have full administrative rights, ask you network
administrator for assistance. Alternately, you can ask your network administrator to log on with the
network administrator ID before you start the installation.

2 Download the software. For details about the download, see Knowledgebase article KB980.

3 If you want to install Estimating on the server, skip to step 6. Otherwise, if you want to access
databases and estimates from the server, but you do not want to install Estimating, cancel the
installation when the License Agreementwindow appears. Pervasive SQLDatabase Engine and SQL
Server Express are automatically installed with the prerequisites.

n After you have canceled the installation, run the Sage System Verifier (SSV). This sets the
Pervasive settings to the Sage Timberline Office recommendedminimums. If Sage Timberline
Office is installed, you can run the Sage System Verifier (SSV) from Desktop > Tasks > Tools >
System Verification.

n Run SSV by browsing to and double-clicking [...\980_Rev2_
Estimating\AdditionalInstalls\SSV\SageSystemVerifierSA.exe.

4 In the Installationwindow, click Install Timberline Office software. In the resulting installation,
choose to install databases, Estimating Products, or both databases and Estimating Products.

Sage Timberline Office 9.8.0 Installation Guide                                                                                                                          Page 41

Chapter 4: Install Estimating

https://customers.sagenorthamerica.com/irj/portal/anonymous/login
https://customers.sagenorthamerica.com/irj/portal/anonymous/login
https://customers.sagenorthamerica.com/irj/portal/anonymous/login


You can install Estimating to a server in order to perform file maintenance, but you should not perform
other Estimating tasks at the server. These tasks should be performed at workstations.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if aWindows Firewall Security Alert window lists the
Database ServiceManager by Pervasive Software Inc., confirm with your network administrator that
you wish to proceed. Then, select Unblock this program and click [OK].

D. Other Installation Scenarios

Additional Steps for Network Installations That Have Accounting and
Management Products
To access Address Book, Job Cost, and tax data on a server, follow these steps on each Estimating-only
workstation. (Workstations that have both Estimating Products and Accounting andManagement
Products have already been configured as part of the Accounting andManagement Products installation
and do not require these steps.) The following steps apply to both upgrades and first-time installations.

1 For purposes of this installation, establish a connection (map a drive) to the shared Timberline Office
folder on the server or peer server where the Accounting andManagement Products data folder is
installed. This shared folder should be the parent to the folder where the application data is installed.

n ForWindows XP, Windows Server 2003, the path is [Drive]:\Documents and Settings\All
Users\Application Data\Sage\Timberline Office.

n ForWindows Vista andWindows Server 2008, the path is [Drive]:\ProgramData\Sage\Timberline
Office.

Map a drive to the Timberline Office shared folder.

a InWindows Explorer, click Tools > Map network drive.

b Select a letter for the drive name.

c In the Folder box, browse to \\[Server Name]\Timberline Office.
We strongly recommend mapping a drive to the location listed above. Mapping to a different folder can cause
unexpected errors. In addition, when mapping a drive to the shared Timberline Office folder, do not
disconnect or redirect existing mapped drives for Sage Timberline Office products to the new location.
While we recommend the use of mapped drives to establish a connection with a server, you may also use a
UNC path. For example, if you choose to use a UNC path to the shared data folder, the UNC path is \\[Server
name]\Timberline Office\9.5\Accounting\WinInst\Install.exe.

2 Click [Start] > Run.

3 In theRunwindow, click [Browse]. In theBrowsewindow, select Install.exe in theWininst folder on
the server.

n If you are usingmapped drives, select X:\9.5\Accounting\WinInst\Install.exe, where X represents
the drivemapped to the shared folder name in step 1.
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n Alternatively, if you are using UNC paths, select \\[Server name]\Timberline
Office\9.5\Accounting\WinInst\Install.exe. Click [Open]. Then, click [OK].

4 In the Installationwindow, click Install Timberline Office software and follow the instructions as
they appear in the windows.

NOTE: If you receive a firewall warningmessage during the installation of the Pervasive database
engine, work with your network administrator to allow the Pervasive database engine to communicate
through your firewall software. For example, if aWindows Firewall Security Alertwindow lists the
Database Service Manager by Pervasive Software Inc., confirm with your network administrator that
you wish to proceed. Then, select Unblock this program and click [OK].
Youmay also receive this message during the installation of Sage Service Host. Follow the same steps
to proceed.

5 Repeat steps 1–4 for each Estimating-only workstation. When finished, follow the steps in “B. Install to
aWorkstation” on page 40.

6 At the conclusion of the installation, you will be prompted to restart your computer. After you restart your
computer and log on with full administrative rights, wait until themessage All configuration tasks for
Sage Timberline Office completed successfully. Do not attempt to start any Sage Timberline Office
applications until after you have received this message. It may take awhile before you see themessage
All configuration tasks for Sage Timberline Office completed successfully.

7 Some of the data and report folders and files will be hidden by default. At the end of the installation,
show hidden files and folders.

n OnWindows XP Professional orWindows Server 2003, openWindows Explorer, select Tools >
Folder Options, and select View hidden files and folders on theView tab.

n OnWindows Vista orWindows Server 2008, select Organize > Folder and Search Options, and
then select Show hidden files and folders on theView tab.

8 If you set up a shortcut to Desktop, youmust re-create it after installing 9.8. Select the Desktop.exe in
C:\ProgramFiles\Timberline Office\Shared. All other applications' shortcuts will continue to work
after installing 9.8.

Terminal Server
Follow the installation steps for aWindows server, with these exceptions:

n Always useAdd or Remove Programs to start an installation to a terminal server.

n If you install Sage Timberline Office on aWindows Server 2008 terminal server, begin the
installation by selectingControl Panel > Install Application on Terminal Server. Follow the
prompts and browse to the install.exe file.

n InWindows Server 2008 R2, "terminal services" is called Remote "Desktop ".
Open Start > Control Panel > Install Application on Remote Desktop
orStart > Control Panel > Programs > Install Application on Remote Desktop.

Follow the prompts and browse to the install.exe file.
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n If you use another server to host Estimating databases, install only Estimating applications to the
terminal server.

NOTE: If you install Estimating Products on a terminal server that uses Windows Server 2003, you
must log on to the terminal server with full administrative rights when you use Estimating Products. This
ensures that Estimating Products have proper access to theWindows registry.

Pervasive Manual Installation
The Pervasive database engines are installed automatically with other prerequisite software when you
install Sage Timberline Office products.

Tomanually install this program, download the software and install the prerequisites. Then, cancel the
installation at the License Agreementwindow. Pervasive SQLDatabase Engine is automatically
installed with the prerequisites.

After you have canceled the installation, you should run the Sage System Verifier (SSV), which will set
Pervasive settings to the Sage Timberline Office recommendedminimums.

If Sage Timberline Office is installed, you can run the Sage System Verifier (SSV) from Desktop > Tasks
> Tools > System Verification.

If Sage Timberline Office is not installed, run SSV by browsing to and double-clicking ...\980_Rev2_
Estimating\AdditionalInstalls\SSV\SageSystemVerifierSA.exe.

NOTE: SomeSage System Verifier checks may not pass if Sage Timberline Office is not installed.
This is acceptable provided that you ensure theSage Timberline Office—Pervasive PSQL License
andSage Timberline Office—Pervasive PSQL Settings checks are completed successfully when
you run the Sage System Verifier.

E. Set up Stand-Alone Security Devices
If you use LicenseManager to provide license security, skip to “F. Set up LicenseManager” on page 45.

If you already use stand-alone security devices, skip to “G. Upgrade Estimates and Databases” on
page 47.

Install the Sentinel Driver
The Estimating installation program automatically installed a Sentinel driver if you did not have one. If you
need instructions to install the Sentinel driver manually, open the Customer Portal at
https://customers.sagenorthamerica.com/irj/portal/anonymous/login. Once you have logged on, in the
Knowledgebase Search box, type "KB156918."
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Attach Protection Devices to Workstations
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to
the parallel port of a workstation.

2 Plug a protection device into the parallel port or USB port of the workstation.

3 If you disconnected devices in step 1, reconnect these devices.

4 Repeat steps 1–3 for each workstation. Then, skip to “G. Upgrade Estimates and Databases” on
page 47.

F. Set up License Manager
If you use stand-alone security devices to provide license security, see “E. Set up Stand-Alone Security
Devices” on page 44.

Guidelines
Please note the following:

n Youmust install LicenseManager to aWindows server or workstation.

n All license-managed servers and workstations must use the same network protocol (TCP/IP).

n You cannot install LicenseManager to a terminal server. If you have a terminal server, install to a
workstation.

n If you use firewall software on your license server, youmay not be able to use theWlmAdmin or
WCommute applications to view or check out licenses. To resolve this issue, discuss the server’s
firewall security with your network administrator. If you are willing to adjust your firewall security
settings on the licensemanager server, consider granting access to the lservnt.exe file.

n Check in any licenses before upgrading.

For more information about LicenseManager, see:

n Getting StartedWith LicenseManagement

n Sentinel LicenseManager System Administrator Online Help (index.html). This file is in the ...\980_
Rev2_Estimating\AdditionalInstalls\LicenseManager\SysAdminHelp.

Install the Sentinel Driver
The Estimating installation program automatically installed a Sentinel driver if you did not have one. If you
need instructions to install the Sentinel driver manually, see Knowledgebase article KB156918 .

Attach a Protection Device to the Computer That Will Have License
Manager
1 If you have a parallel port protection device, disconnect any hardware or peripheral devices attached to
the parallel port.

2 Plug the protection device into the parallel port or USB port.

3 If you disconnected devices in step 1, reconnect these devices.
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Install License Manager
If you already have LicenseManager installed, skip to “Upgrade LicenseManager,” on page 47.

1 Log on with full administrative rights. Full administrative rights are defined as write access to the
Windows registry and all folders on the computer (including rights to the root of all hard drives). If you are
unsure whether you have full administrative rights, ask you network administrator for assistance.
Alternately, you can ask your network administrator to log on with the network administrator ID before
you start the installation.

2 Open and double-click ...\980_Rev2_
Estimating\AdditionalInstalls\LicenseManager\Server\Setup\Setup.exe.

3 Follow the on-screen prompts. The installation automatically installs the appropriate software for the
operating system.

NOTE: Be sure to accept the default installation path when you install LicenseManager. If you need to
change the default installation path, change it to a local drive. You cannot install LicenseManager to a
network drive.

Install License Codes
The number of network licenses purchased for an application indicates the total number of concurrent
network uses allowed for that application. To install license codes, follow these steps:

1 Verify that the Sentinel LicenseManager service is running. Click [Start]. Then select Settings >
Control Panel > Administrative Tools > Services (orStart > Control Panel > System and
Maintenance > Administrative Tools > Services inWindows Vista). Look for Sentinel RMS
License Manager in the list of services.

2 Open and double-click ...\980_Rev2_
Estimating\AdditionalInstalls\LicenseManager\Admin.net\Win32\WlmAdmin.exe.

NOTE: Consider copying the entire License Tools folder to your local hard drive. This makes License
Tools more accessible for futuremaintenance.

3 Expand "Subnet Servers".

4 Install license codes using one of the followingmethods.

n To enter license codes from a file: In theWlmAdminwindow, right-click your server and select
Add Feature > From a File > To Server and Its File. In theOpen window, select your license
file and click [Open]. This installs all license codes in the file.

n To type license codes: In theWlmAdminwindow, right-click your server and select Add
Feature > From a String > To a Server and its File. In theAdd feature to serverwindow, type
your license code exactly as it appears in the license file or on the packing slip. (The code is not
case-sensitive.) Be sure to select theAdd feature to server’s file check box.

When you enter a license code, the software adds this code to a file named Lservrc (which has no file
extension) in the Licensemanager installation path.

5 If you receive amessage that a license is invalid or already exists, review the information inGetting
StartedWith LicenseManagement
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6 Enter license codes.

Upgrade License Manager
To upgrade LicenseManager, youmust use the following steps to remove the previous version of License
Manager and then install the new version (version 8.3). Perform these steps at the computer where
LicenseManager is installed.

1 Check in any licenses before upgrading.

2 Run LoadLS.exe, located in the folder where you installed the previous version of LicenseManager
(typically, C:\Program Files\Rainbow Technologies\SentinelLM7x.x.xServer\English). Click [Remove],
and then click [OK] to remove the Sentinel LM licensemanager.

3 Remove the previous LicenseManager version (in XP: Start > Settings > Control Panel > Add or
Remove Programs; inWindows Vista: Start > Control Panel > Programs > Uninstall a Program).
RemoveSentinel LM x.x.x.x. Server.

4 Install the new version of LicenseManager. See "Install LicenseManager".

5 Copy the Lservrc file from the directory you identified in step 2 to the 8.1 directory of LicenseManager.
Typically, the 8.1 directory is C:\Program Files\Common Files\SafeNetSentinel\Sentinel RMS License
Manager\WinNT.

6 Click [Start] and then select Settings > Control Panel > Administrative Tools > Services. Find
Sentinel RMS License Manager in the list of services, right-click the service, and then select
[Restart].

G. Upgrade Estimates and Databases
If you upgraded to a new version of Estimating Products, read the information in this section. If this is a
first-time installation of Estimating Products, skip to “H. After You Install” on page 48.

NOTE: If youmanually create a backup, clear the check box to auto-create a backup.

1 If you access data on another computer, map a drive to the network shared folder in which you have
data. Use the same drive letter for all workstations. To avoid network disruptions and tomaximize
performance, upgrade files at the computer that hosts your data.

2 Back up your data files.

3 In Estimating Tools, select Upgrade Files.

4 In theUpgrade Fileswindow, select theUpgrade - For current users of Estimating for Windows
option.

5 Select the folder containing the estimates or databases that you want to upgrade. Click [Browse] to
browse for a folder.

6 Complete the remaining fields in the window.

7 Click [Finish] to upgrade the selected files. During the upgrade, a progress bar in the lower right corner
of theEstimating Toolswindow shows the name and path of each file as well as the name of each
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record type. Afterwards, you can print (File > Print Audit) or save (File > Save Audit) the information
shown in the window.

8 If you are prompted to upgrade Address Book data, follow the steps in “F. Upgrade Data Files” on
page 32.

TIP: Keep the following inmind if you are upgrading from an earlier version.

n If you are upgrading from a version earlier than 6.0, youmust upgrade databases before you upgrade
estimates. The update occurs automatically if the database and the estimates are in the same folder. If
Estimating Tools cannot upgrade an estimate because it cannot find the associated database, use File
> File Tools to move the estimate and database to the same folder; then, upgrade the single estimate.
Click [Yes] when asked if you want to use the database that is in the same folder as the estimate.

n When youmove a database to a different location, the estimates that were createdmust be re-
associated with the database’s new location.

H. After You Install
1 Restart all programs and services that you shut down for the installation.

2 If you access data on another computer, map a drive to the network shared folder in which you have
data. Use the same drive letter for all workstations. Youmay have already completed this step for one
workstation when you upgraded files (“G. Upgrade Estimates and Databases” on page 47). Be sure to
complete this step for all Estimating workstations that access data on another computer.

3 If necessary, configure Estimating Products to access an Accounting andManagement Products data
folder. For instructions, see “Selecting a company data folder for Address Book and Job Cost
information” in Estimating Help or “Select a company data folder for Address Book and accounting
information” in Buyout Help.

4 If you upgraded and your Estimating data resided in theProgram Files folder, your Estimating data was
copied to a shared location. Verify proper operation of your files after upgrading, and then delete the
original data in theProgram Files folder. Update any workstationmaps to point to the new shared
location.

5 Sage Timberline Office provides numerous supporting documents in Adobe Acrobat (PDF) format. If
you do not already have Adobe Acrobat or Acrobat Reader, you can download Adobe Acrobat from
www.adobe.com.

I. Upgrade Your Estimating Explorer Data
If upgrading from 9.4.x, perform a back-up and restore operation to upgrade your existing Estimating
Explorer data fromMSDE to SQL Server Express.

Backup Estimating Explorer Version 2 Data
1 Have all users close Estimating.

2 Log on to the computer where you store your Estimating data.

3 Start Explorer on the computer where the data source resides.
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4 Close any open data sources by selectingClose Data Source from the Estimating Explorer Filemenu.

5 From the Filemenu, select Data Source Tools. Click [Next] in theData Source Toolswindow.

6 Select the name or address of the SQL Server where the data source you want to back up resides. If
you do not see the server in the list, click [Refresh] to update the list of available servers or type the
server’s computer name; for example, [Server name] or [Server name]\instance.

7 Click [Next].

8 Select Back up the Explorer data source and click [Next].

9 Browse to the location of the folder where you want to create the backup. Youmust select a folder
located on the computer that hosts the data source.

10 Click [Start]. If a backup copy already exists in the folder, Estimating Explorer warns you that the
backup copy will be overwritten. If you get this warning, click [OK] to continue. Otherwise, click
[Cancel].

11 When you finish working with the data source tools, click [Finish].

Restore Estimating Explorer Data
1 Close any open data sources by selectingClose Data Source from the Filemenu.

2 From the Filemenu, select Data Source Tools.

3 In theRun Aswindow, select the user account to use withData Source Tools. Note that the user
account you select must be an administrator account on the local computer.

4 If you select Current user, clear theProtect my computer and data from unauthorized program
activity check box.

5 Click [OK], and then click [Next] in theData Source Toolswindow.

6 Select the name or address of the SQL server on the destination computer.
If you do not see the server in the list, click [Refresh] to update the list of available servers or type the
server’s computer name. For example, type [Server name]\SQLEXPRESS for the default instance of
SQL Server Express or [Server name]\instance for a named instance of SQL Server Express.

7 Click [Next]. Select Restore an Explorer data source from a previous backup and click [Next]
again.

8 Click [...] to browse to the folder that contains the data source backup. Then, click [Start].
If an Explorer data source already exists on the server, Explorer warns you that the existing data source
will be overwritten.

9 To overwrite the existing data source, click [OK]. Otherwise, click [Cancel].

10 Click [Finish] to closeData Source Tools.
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Chapter 5: Server Migration
The server and datamigration tool allows you to easily transfer your Sage Timberline Office Accounting
customizations and data to a new server. Items such as reports and the Reports menu, inquiries,
formulas, macros, and custom fields can bemoved. Company data, security settings and attachments
can also bemoved with the server migration tool. You can select which companies you want to move,
giving you the flexibility to move all companies or only move selected companies.

TIP: Click [Help] in any of the Server Migration windows for detailed instructions.

Things to Know Before you Begin
n Youmust first install Sage Timberline Office Accounting 9.8 on your new server to access the

server migration tool. You will need your registration name and activation codes to access the tool.

n You canmigrate data from Sage Timberline Office 9.6 or later.

n Youmust have administrative rights to the new server and aminimum of read permission to the old
server.

n Ensure that your new server has enough disk space to hold the information from the old server.

n Most of themigration tasks are performed in a few minutes. However, moving attachments can
takemore time. If you have a large number of attachments, consider transferring them during non-
business hours.

n Estimating and Document Management items are not included in themigration. The following
Knowledgebase articles contain additional information:

n Document Management - kb211550.

n Estimating - kb146500.

n Migration - kb241.

n We recommend that you perform a test migration, then validate that all of your data, reports,
macros and settings work properly on the new server. You can then stop work on the old server and
perform themigration again with the latest files.

n Themigration will overwrite companies and security on the new server. You should perform the
migration first, then set up companies and security (for example, if you start a new job).

n Set up existing or new printers on your new server. The TS PDF printer cannot be the only printer on
your system and cannot be selected as the default.

n Macros must be in the Company folder on the old server prior to migration. You can copy the
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macros to the Company folder, if necessary. If themacros are not in the Company folder, will need
to recreate them on the new server after themigration.

Recommended Procedure

Prepare Your System
If you have not already installed and run Sage Timberline Office, do so now.

1. Install Sage Timberline Office Accounting 9.8 on your new server. See for assistance.

2. Click Start > All Programs > Sage > Sage System Verifier 9.8.

3. In the Sage System Verifier window, click [Scan System]. When the system verification has
completed, click [Close].

4. Set up administrative rights on the new server.

Migrate Your Server
The following items aremoved from the old server to the new server during this step:

n Security settings

n Companies

n Custom fields

n User formulas

n Reports - via UNC andmapped drives

n Macros - Printers

n Attachments - via UNC andmapped drives

1. On the new server, open [Drive]:/Program Files/Timberline Office/Shared. Double-click
Sage.STO.ServerMigrator.exe. TheServer Migration Tool window opens.

2. In theOld server location box, enter or browse to the location where Sage Timberline Office is
installed on your "old" server. For example, \\servername\Timberline Office\9.5\Accounting\.

3. In the Log file path box, accept the default or enter the location on the new server and name for the
server migration log; for example, \\servername\Timberline
Office\9.5\Accounting\Migration\ServerMigrationLog1.pdf.
You can refer to the log after you have completed themigration to ensure all files transferred
correctly.

4. Click [Validate] to perform a test of the files to be transferred. Validation complete is displayed
when this process has finished.

5. When validation is successful, click [Migrate].Migration complete is displayed when this
process has finished.

6. Refer to the server migration log you set up in Step 2 to ensure all files have transferred correctly.
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Migrate Your Data Folders
1. If it is not already open on the new server, open [Drive]:/Program Files/Timberline Office/Shared.

Double-click Sage.STO.ServerDataMigrator.exe. TheServer Data Migration Tool window
opens.

2. In the Log file path box, accept the default or enter the location on the new server and name for the
data folder migration log; for example, \\servername\Timberline
Office\9.5\Accounting\Migration\DataFolderMigration.pdf.
You can refer to the log after you have completed themigration to ensure all files transferred
correctly.

3. Select the companies you wish tomove.

4. Click [Validate] to perform a test of the files to be transferred. Validation complete is displayed
when this process has finished.

5. When validation is successful, click [Migrate data folders].Migration complete is displayed
when this process has finished.

6. Refer to the server datamigration log you set up in Step 2 to ensure all files have transferred
correctly.

Migrate Your Macros
Macros must be in the Company folder on the old server prior to migration. You can copy themacros to the
Company folder, if necessary. If themacros are not in the Company folder, will need to recreate them on
the new server after themigration.

1. If it is not already open on the new server, open [Drive]:/Program Files/Timberline Office/Shared.
Double-click Sage.STO.ServerDataMigrator.exe. TheServer Data Migration Tool window
opens.

2. In the Log file path box, accept the default or enter or browse to the location on the new server and
the name for themacromigration log, for example, \\servername\Timberline
Office\9.5\Accounting\Migration\MacroMigration.pdf. You can refer to the log after you have
completed themigration to ensure all files transferred correctly.

3. Select companies. Macros for the companies you choose will be transferred to the new server.

4. Click [Migrate macros].

5. In theMacro Printerswindow, click [Change] to select different printers. If you will use the same
printers, no action is needed.

6. Click [Migrate macros].Macro migration complete displays when this process is finished.

7. Refer to themacromigration log you set up in Step 2 to ensure all macros have transferred
correctly.

Migrate Your Attachments

Migrating attachments can take some time. If you have a large number of attachments, youmay want to
consider moving them during non-business hours.
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1. If it is not already open on the new server, open [Drive]:/Program Files/Timberline Office/Shared.
Double-click Sage.STO.ServerDataMigrator.exe. TheServer Data Migration Tool window
opens.

2. In the Log file path box, accept the default or enter or browse to the location on the new server and
the name for the attachment migration log, for example, \\servername\Timberline
Office\9.5\Accounting\Migration\AttachmentMigration.pdf.
You can refer to the log after you have completed themigration to ensure all files transferred
correctly.

3. Select companies if you have not already done so. Attachments for the companies you choose will
be transferred to the new server.

4. Click [Migrate attachments].
Note: This stepmay take a long time, depending on the number of attachments in your system.
When complete, theAttachment Pathswindow displays.

5. In theAttachment Pathswindow, review the old and new location for each set of attachments.
Click [Change] to set up a new location or path for each line. If you want to change the location of
more than one directory in the path, use the Find and replace link.

6. Select the rows for the attachment paths you want to transfer.

7. Click [Migrate attachments]. Attachments migration complete displays when this process is
finished.

8. Refer to the attachment migration log you set up in Step 2 to ensure all attachments have
transferred correctly.
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