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Preface
An Introduction to LiveType
Welcome to LiveType, a special-effects titling application 
that’s powerful, easy to use, and completely versatile—
whether you’re creating movie titles and credits, 
broadcast ads, or web banners. 
Producing dynamic video titles—titles that really pop—can be a painstaking process, 
fraught with manual adjustments and keyframe stacks daunting even to experienced 
animators. With LiveType, you can create phenomenal results, in the output format you 
require, with a fraction of the effort.
How Does Titling Work?
Traditionally, titling was the term for adding text to film. The evolution of digital 
graphics and video technologies has expanded the definition, which now includes just 
about any combination of text and images you want to add to a movie. Titling is the 
process of creating a digital overlay, which is added to edited footage in your nonlinear 
editor (NLE), or compositing program. LiveType is the design studio where you 
generate titles to import into Final Cut Pro.
Alpha channel technology is the basis of titling. Most compositing and animation 
programs allow you to create art with an alpha channel. In addition, most NLEs use 
alpha channels they detect in an image or movie to properly lay the element over video.
An alpha channel represents eight bits of grayscale pixel information in a 32-bit file. The 
eight grayscale bits determine which portions of the image to superimpose over other 
layers. White alpha-channel pixels make the superimposed image completely opaque, 
while black pixels make the overlay completely transparent, or invisible. Gray levels 
represent varying levels of opacity.
LiveType automatically creates an alpha channel for your project when you render it 
with a transparent background.8 Preface    An Introduction to LiveType
A Realm of Creative Possibilities
LiveType has revolutionized titling in two major ways. First, it introduced 32-bit 
LiveFonts, a new approach to text animation in which every character of a font is a 
separate, animated movie. Second, LiveType handles effects and animation with greater 
ease than any other titling application.
Animated Fonts, Objects, and Textures
Three types of animated media are included in LiveType:
Â LiveType objects are animated graphics.
Â LiveType textures are moving images used to fill backgrounds, text, or objects.
Â LiveFonts are complete, animated character sets. 
All of these elements move inherently, even before you apply motion paths and special 
effects to them.
LiveType comes with dozens of LiveFonts and hundreds of objects and textures. What’s 
more, you can create your own animated fonts using the LiveType FontMaker utility, 
building characters using virtually any graphical object—from 3D animations and 
images created in Photoshop to video clips—and apply effects to them, just as you 
would to words.
Effects Handling
Effects in LiveType are handled as separate entities—“packages” encompassing 
movement, transformation, and timing parameters—that can be applied to any 
number of elements in the Canvas. You can take advantage of more than 100 
customizable effects that come with LiveType, including fades, zooms, rotations, and 
motion paths. Or you can create your own styles by adjusting existing effects or 
building them from scratch. 
From an animation standpoint, LiveType is easier to work with than other titling 
applications, since one keyframe marker contains all the parameters for an element at a 
point in time, eliminating the complexity of long keyframe stacks.
And powerful timing features allow you to control every aspect of your animation. In 
addition to basic functions such as loop, speed, and duration, LiveType allows you to 
sequence your effects. Sequencing lets you animate characters in a line of text 
individually, with their own timing elements, so you’re not constrained to blocks of text 
that fly around the screen as a unit.
Whether you’re combining prebuilt elements or generating all the pieces yourself, you 
can create wholly original, eye-catching compositions with surprisingly little effort.Preface    An Introduction to LiveType 9
Workflow for Creating Titles
Video production is typically approached in layers from back to front, starting with 
shooting and editing the footage, then building in effects, then applying titles and 
sound. Likewise, your approach to title creation should be loosely approached from 
back to front. Of course, because the design process is fluid, there is no hard-and-fast 
prescription, but the following steps give you a sense of what’s involved for a 
typical project.
Step 1:  Configure the working environment
Â Set the output resolution, frame rate, and other project properties.
Â Set up the grid, guides, and rulers in the Canvas, according to your working 
preferences.
Step 2:  Apply a background, if any
Step 3:  Create elements (text or objects) in the Canvas, one by one
Â Position and shape a track for the element.
Â Add an element to the track.
Â Select a font.
Â Adjust attributes and apply styles to the element.
Step 4:  Animate the elements
Â Define the movie duration.
Â Apply effects and adjust the timing.
Â Customize the animation with keyframe adjustments.
Step 5:  Preview and fine-tune the movie
Step 6:  Render the final movie for compositing into your video
Step 7:  Export the movie to an alternative format, if needed
You may be able to save considerable time by taking advantage of LiveType 
templates—project files provided with the software that offer many examples of titling 
formats. One might suit your needs with few changes, or you may find that certain 
elements within a template are useful, which you can copy into your own project. More 
about templates can be found in Chapter 2, “Setting Up a Project,” on page 31.10 Preface    An Introduction to LiveType
About This Manual
Because LiveType is a creative tool, documentation can only go so far in describing its 
potential. This manual provides a detailed description of the LiveType interface, 
features, and functionality, and introduces you to the built-in resources and templates 
to give you a sense of the versatility of this product. In the end, you are limited only by 
your own creative vision, and the way to push the limits of LiveType is to jump in and 
start creating. 
This manual begins with a description of the interface, followed by a series of chapters 
that explain the tasks you’ll need to perform, as well as advanced techniques. 
Note:  This user manual is written for people with a rudimentary understanding of film 
or video production. Experienced users will be quite familiar with all such terminology 
herein. Others will find that most terms are defined in context, and the glossary at the 
end of this manual may be helpful as well.
LiveType Onscreen User Manual
The LiveType onscreen user manual allows you to access information directly onscreen 
while you’re working in LiveType. To view the onscreen user manual, choose Help > 
LiveType User Manual. The onscreen user manual is a fully hyperlinked version of the 
user manual, enhanced with many features that make locating information quick 
and easy.
Â The home page provides quick access to various features, including Late-Breaking 
News, the index, and the LiveType website.
Â A comprehensive bookmark list allows you to quickly choose what you want to see 
and takes you there as soon as you click the link.
In addition to these navigational tools, the onscreen user manual gives you other 
means to locate information quickly:
Â All cross-references in the text are linked. You can click any cross-reference and jump 
immediately to that location. Then, you can use the navigation bar’s Back button to 
return to where you were before you clicked the cross-reference.
Â The table of contents and index are also linked. If you click an entry in either of these 
sections, you jump directly to that section of the user manual. 
Â You can also use the Find dialog to search the text for specific words or a phrase.
LiveType Help also contains information about issues with third-party software and 
known bugs. This information is found in the Late-Breaking News section of 
LiveType Help.Preface    An Introduction to LiveType 11
To access Late-Breaking News:
m Choose Help > Late-Breaking News.
Note:  You must be connected to the Internet to download the Late-Breaking News file.
Additionally, LiveType Help contains a link to the Creating LiveFonts PDF file. This 
document details the process of creating custom LiveFonts for use with LiveType.
To access the Creating LiveFonts PDF file:
m Choose Help > Creating LiveFonts.
Apple Websites
There are a variety of discussion boards, forums, and educational resources related to
LiveType on the web.
LiveType Website
For general information and updates, as well as the latest news on LiveType, go to: 
Â http://www.apple.com/finalcutpro/livetype.html
Apple Service and Support Website
For software updates and answers to the most frequently asked questions for all Apple 
products, including LiveType, go to:
Â http://www.apple.com/support
You’ll also have access to product specifications, reference documentation, and Apple 
and third-party product technical articles. 
For LiveType support information, go to:
Â http://www.apple.com/support/livetype/index.html
Other Apple Websites
Start at the Apple homepage to find the latest and greatest information about Apple 
products:
Â http://www.apple.com
QuickTime is industry-standard technology for handling video, sound, animation, 
graphics, text, music, and 360-degree virtual reality (VR) scenes. QuickTime provides a 
high level of performance, compatibility, and quality for delivering digital video. Go to 
the QuickTime website for information on the types of media supported, a tour of the 
QuickTime interface, specifications, and more:
Â http://www.apple.com/quicktime12 Preface    An Introduction to LiveType
FireWire is one of the fastest peripheral standards ever developed, which makes it great 
for use with multimedia peripherals, such as video camcorders and the latest highspeed hard disk drives. Visit this website for information about FireWire technology and 
available third-party FireWire products:
Â http://www.apple.com/firewire
For information about seminars, events, and third-party tools used in web publishing, 
design and print, music and audio, desktop movies, digital imaging, and the media arts, 
go to:
Â http://www.apple.com/pro
For resources, stories, and information about projects developed by users in education 
using Apple software, including LiveType, go to:
Â http://www.apple.com/education
Go to the Apple Store to buy software, hardware, and accessories direct from Apple 
and to find special promotions and deals that include third-party hardware and 
software products:
Â http://www.apple.com/store1
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1 The LiveType Interface
The LiveType interface consists of four primary 
windows—the Canvas, the Inspector, the Media Browser, 
and the Timeline.
Â Canvas:  This is where projects take shape. You use it to position text and objects, 
create motion paths, and view the results as you design.
Â Inspector:  A toolbox of settings and parameters, including virtually every option for 
building and customizing your titling creations.
Â Media Browser:  This area provides access to all the fonts, textures, objects, and effects 
you’ll use to create your titles.
Â Timeline:  This is where you manage the frame-by-frame action of your titling 
projects. Animation keyframes are created and adjusted in the Timeline, allowing you 
to orchestrate the movement of your titling elements.
Canvas Inspector Media Browser
Timeline14 Chapter 1    The LiveType Interface
The four windows float freely, and can be moved and resized to suit your 
working preferences.
To restore the default layout of LiveType:
m Choose Window > Apply Default Layout.
Canvas
The Canvas is your creative working environment, reflecting the output dimensions you 
configure in the Project Properties dialog. (See “Setting Project Properties” on page 34.) 
Whether you are working in HDTV, NTSC, PAL, or any other format, the Canvas is 
designed to help you lay out and view your titling project easily. 
About the Canvas Interface
There are various interface elements and controls in the Canvas, outlined below.
Background
When you first open LiveType, the default checkerboard pattern in the Canvas 
represents a transparent background, allowing alpha channel titles to overlay video 
footage when composited in a nonlinear editor (NLE) such as Final Cut Pro. You can set 
the background as any combination of the following:
Â Transparent
Â Solid color
Â Animated texture or object
Â Still image
Â Movie
Background (transparent) Action safe guidelines
Track, showing multiple
lines of text on one track
Zoom pop-up menu
Title safe guidelines
Transport controlsChapter 1    The LiveType Interface 15
Backgrounds often cover the entire Canvas. However, when used with the matte 
feature in the Attributes tab of the Inspector, an element can appear to “punch 
through” an underlying element to reveal the background color, image, or movie. See 
“Creating a Matte” on page 72 for more about creating mattes. 
Tracks
The dark blue horizontal line that appears in the default Canvas is a track. Tracks are the 
foundation of any LiveType composition. Every element of a project resides on a track. 
Tracks define:
Â The position of text and objects in the Canvas
Â The layering of elements
Â In some cases, the path taken by moving elements
Tracks have two endpoints, and can have any number of “control points,” which are 
nodes that create angles and curves in the track. When more than one track is in the 
Canvas, only the endpoints of the selected, or active, track are visible. This identification 
is helpful when you’re applying attributes to a track.
Action Safe and Title Safe Guidelines
The green hairline boxes in the Canvas represent the “action safe” and “title safe” areas. 
The action safe area, defined by the outer line, is the extent of the screen where the 
image is readily visible, given the curvature of the cathode-ray tube (CRT). The title safe 
area, represented by the inner line, is the boundary beyond which text is not easily read.
To turn the action safe and title safe guidelines off or on:
m Choose View > Title Safe.16 Chapter 1    The LiveType Interface
Canvas Zoom Pop-up Menu
At the bottom of the Canvas is a pop-up menu for changing the magnification of the 
Canvas.
To change the Canvas zoom, do one of the following:
m Open the Canvas zoom pop-up menu at the bottom of the Canvas and choose one of 
the magnification options.
m Choose Fit to Window from the Canvas Zoom pop-up menu, then resize the Canvas 
window to a new magnification.
m Choose View > Zoom In or Zoom Out.
m With the Canvas active, use the Command-Z keyboard shortcut for Fit to Window.
m With the Canvas active, use the Command-+ or Command-– keyboard shortcut to 
zoom in or out.
Transport Controls
The transport controls allow you to generate a RAM preview of your project so you can 
preview your titling movie right in the Canvas. When you click the Play button, LiveType 
renders each frame into RAM memory. This feature is referred to as a RAM preview. 
Canvas Zoom
pop-up menu
Previous frame
Play Next Frame
LoopChapter 1    The LiveType Interface 17
To render a RAM preview of your project in the Canvas:
1 Click the Play button (or press the Space bar when the Canvas or Timeline is active). 
The preview renders each frame, then runs through the preview in real time.
2 Stop the preview by clicking anywhere in the Canvas.
The Play icon turns into a Pause icon when the RAM preview is playing. The Loop 
button is a toggle that gives you the choice of a single run-through or repeating the 
preview in a continuous loop. 
See Chapter 8, “Previewing and Fully Rendering Your Titling Movie,” on page 109 for 
more about previewing your work.
Customizing the Canvas
Most Canvas settings can be customized from the View menu, allowing you to 
configure guidelines and magnification, and choose which elements appear in the 
Canvas. The grid, rulers, and guides are helpful for precisely aligning and positioning 
elements in the Canvas. 
To show the rulers or the grid:
m Choose View > Rulers.
m Choose View > Grid.
You can set the number of pixels between each grid line in the Project Properties dialog.
Grid
Ruler for 
vertical guides
Ruler for
horizontal guides18 Chapter 1    The LiveType Interface
To customize the grid:
1 Choose Edit > Project Properties.
2 In the Ruler and Grid Settings area at the bottom, enter a new value in the Grid Width 
field.
To add a guide to the Canvas:
m Click inside one of the rulers to insert a guide marked by its horizontal or vertical 
pixel position.
To add crosshairs to the Canvas:
m Click inside one of the rulers and drag the pointer onto the Canvas.
To remove guides from the Canvas, do one of the following:
m Drag guide markers off either end of the ruler.
m Choose View > Clear Guides, which removes all guides.
You can isolate a single track and display all other elements as bounding boxes—
rectangles that roughly show the size, position, and orientation of an element. This 
option is useful for cleaning up the Canvas as you work on a single track, and it saves 
preview-rendering time, because only one item of your composition is being rendered.
Guide marker showing 
pixel position
Crosshair guideChapter 1    The LiveType Interface 19
To isolate a single track in the Canvas:
m Select the track you want to continue working on, then choose View > Selected Only.
Revert to the normal view by choosing View > Selected Only again.
The Proxy Frame Only option in the View menu–which applies only when you’re using 
installed LiveType media—renders LiveFonts, textures, and objects as proxy frames in 
the Canvas, essentially freezing their inherent animation.
Particularly when the animated element has highly variable content from frame to 
frame (such as Particles objects, which contain few if any pixels in the beginning and 
ending frames), the proxy frame is easier to work with, because it shows a more 
representative shape of the object regardless of the playhead position.
Bounding boxes show the size
and position of deselected
elements.
Choose View > Selected Only
to view only the contents of
the selected track.20 Chapter 1    The LiveType Interface
Inspector
The Inspector is your toolbox for transforming elements—text, objects, or images. 
There are unlimited combinations of parameters and attributes you can use to make 
your titles dynamic and original.
The Inspector consists of a text-entry box and Live Wireframe Preview at the top of the 
window, and five tabs of parameters. Inspector settings always apply to the track, 
character, or effect that is currently selected in the Canvas or Timeline.
Text-Entry Boxes
There are two areas in the Inspector where you can add text to a track. One of these is 
in the upper-left corner of the Inspector. Because this text-entry box is visible no matter 
which Inspector tab is selected, it is a convenient way to identify the active track, as 
well as to add or change the text on a track, as you can type directly into it. The textentry box at the bottom of the Text tab is larger, making it easier to insert and edit 
larger amounts of text.
The text-entry boxes also allow you to select individual letters or words on a track. 
When you highlight text in the text-entry box, those characters are selected in the 
Canvas. This is particularly useful when the text you want to modify is obscured in the 
Canvas by other elements.
Text-entry box
Live Wireframe
Preview
Inspector tabs
Text-entry box 
(in the Text tab only)Chapter 1    The LiveType Interface 21
Live Wireframe Preview
In the upper-right corner of the Inspector, the Live Wireframe Preview continually plays 
your titling movie, with small bounding boxes indicating the movement of each 
character or object. This feature gives you a quick indication of how your adjustments 
have changed the overall animation, without rendering a full preview with every 
change you make. 
To freeze or unfreeze the Live Wireframe Preview:
m Click inside the preview area.
Inspector Tabs
There are five tabs in the Inspector.
Â Text tab:  This is where you enter text and adjust the size, alignment, and spacing of 
text on the active track. 
Preview playhead
Small bounding boxes
depict the movement of
the Canvas elements.
Click to turn the 
preview on or off.
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Â Style tab:  This tab provides options for the Shadow, Glow, Outline, and Extrude 
treatments, which can be applied to text or objects. These are often used to add 
depth and highlight the text or object, although a wide variety of graphical 
outcomes are possible.
Â Effects tab:  This tab lists the effects that have been applied to the active track, and is 
used to view and change effect parameters at any point in your titling movie. Effects 
are combinations of movement and transformation that can be applied to any track. 
The On column of the Effects tab allows you to turn an effect off or on for individual 
characters on the track.
Style tab settings
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Â Timing tab:  Timing parameters for tracks and effects are controlled in this tab. While 
the Timeline provides a frame-by-frame diagram of tracks and effects with their 
associated keyframes, the Timing tab is a single pane that allows you to adjust the 
overall timing and modify the parameters of your animation. 
Some timing adjustments are made more easily by moving elements in the Timeline, 
rather than entering values in the Timing tab. However, the Timing tab gives you 
access to the full range of timing variables, as well as effect parameters that let you 
fine-tune your animation, creating exactly the look you want.
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Â Attributes:  This is where you assign a variety of attributes—opacity, blur, scale, offset, 
rotation, and color—to elements in the Canvas. Attributes can be applied to entire 
tracks or individual characters on a track. 
The Attributes tab also contains options for creating a matte effect, in which an 
element appears as a cut-out window that reveals the element below it. A simple 
line of text, for example, can be matted to a movie clip, which essentially “fills” the 
text. The Matte to Texture option lets you fill track contents—even individual 
characters—with an animated texture, without having to add the texture to your 
project as a separate element.
Matte settings are variables
for creating cutouts and
textured fills.
Glyph settings include
attributes such as the
shape, color, and position
of text and objects.
Attributes tab in the 
Matte pane
Attributes tab in the
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Media Browser
Most of the installed resources available for your titling projects are available through 
the Media Browser—except for LiveType templates and images and movies you import 
from other sources. There are various tabs representing different elements installed on 
your computer:  LiveFonts, system fonts, textures, objects, and effects. Using the 
Media Browser, you can scroll through and view representations of all these elements 
before you apply them to your project.
The Media Browser preview is the only way to see how LiveType media—LiveFonts, 
textures, and objects—move and transform until you install the full data file onto 
your computer. When you first apply one of these elements to the Canvas, a single 
representative frame is displayed, not the entire animated sequence. Installing the 
data component allows you to see a true representation of the LiveFont in each 
frame of your movie. See “LiveType Media Files” on page 28 for more about LiveType 
file management.
Browser preview
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Timeline
The Timeline depicts the frame-by-frame orchestration of your titling project, and 
provides many tools for designing the movement and timing of your titles. The 
Timeline allows you to do the following:
Â Set the timing and duration of tracks and effects
Â Manage the track order, or layers
Â Group tracks to maintain their relative position
Â Enable and disable tracks and effects
Â Work with keyframes to customize your animation
Â Select specific frames to view or adjust
Â Set markers to render only a portion of your movie for previews or final output
About the Timeline Interface
The following are the interface elements and controls in the Timeline.
Project Tabs
Tabs at the upper-left corner of the Timeline indicate which projects are currently open, 
and which one is active.
Playhead, Timecode, and Frame Ruler
The playhead and timecode on the frame ruler indicate which frame is showing in the 
Canvas. The playhead moves along the frame ruler when you play your project, and it 
can be dragged to any given frame. 
To view a specific frame, do one of the following:
m Drag the playhead to the desired frame.
m Click a frame in the frame ruler.
The Canvas always reflects the frame under the playhead.
Playhead
Timeline zoom slider
Project tab
Grouping buttons
Keyframe Background bar
Timecode
Enable/Disable
buttons
Track
Effect
Frame ruler
Render Selection
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Render Selection Markers
The In Point and Out Point markers in the frame ruler allow you to determine the 
portion of your movie you want to render. Using these markers, you can:
Â Save time rendering previews when you don’t need to see the entire movie
Â Choose the precise number of frames you want to include in your final output
To change the render selection, do one of the following:
m Drag the In Point and Out Point markers in the frame ruler.
m Position the playhead and press the I key on your keyboard to set the Render Selection 
In Point, or the O key to set the Render Selection Out Point. The Timeline must be 
active for these hot keys to work.
As you constrain the range of frames to be rendered, the information box in the upperleft corner of the Timeline reflects the modified duration and number of frames.
Note:  To quickly locate the Out Point marker when it is beyond the end of the visible 
Timeline, move the Timeline zoom slider all the way to the right. 
Tracks and Effects
Tracks are numbered according to their layer position in the left column of the 
Timeline, and Track 1 is always the top layer.
Effects are depicted as separate bars underneath the track they apply to. An effect may 
extend for the entire duration of the track, or only a portion of it. One track may have 
several effects applied to it, in sequence or overlapping.
Background Bar
Any item that falls below the background bar is a background element. You can drag 
the background bar up or down to any position between tracks in the Timeline. For 
more information, see “About the Background Bar” on page 43.
Keyframes
The basis of most digital animation, keyframes contain the parameters that elements in 
the Canvas reflect at a specific point in time. When a movie is rendered, LiveType 
interpolates the movement of the elements in between keyframes for smooth, 
continuous motion. When an effect is increased in duration, or stretched, the keyframes 
spread out with it, and the effect takes longer to complete. See Chapter 7, “Working 
With Effects and Keyframe Animation,” on page 87 to learn more about keyframes.
Grouping Buttons
Grouping buttons let you group tracks together in the Canvas, locking their relative 
position while allowing you to move the group as a unit.28 Chapter 1    The LiveType Interface
Enable/Disable Buttons
The Enable/Disable buttons turn tracks and effects off or on. When a track is disabled, its 
contents are removed from the Canvas, although the blue track line remains. Disabled tracks 
are not rendered in previews or movies. Similarly, effects can be disabled.
Timeline Zoom Controls
Typically you use the zoom controls to adjust the amount of time represented in the 
Timeline window. This is helpful to do while working with timing a long or complex 
composition. 
The main zoom control is the Timeline zoom slider, which zooms in and out around the 
playhead as you drag.
You can also use the Command-+ or Command-– keyboard shortcut to zoom in or 
zoom out on the playhead when the Timeline is active. Another helpful command is 
Shift-Z, which adjusts the Timeline to show the entire project at once.
LiveType Media Files
LiveType includes hundreds of media and effects files, which are the resources available 
to you within the Media and Template Browsers. Animated files include LiveFonts, 
objects and textures. Preset effects and templates, as well as various other LiveType 
resources, are also included with the application. These files are collectively known as 
LiveType media files.
LiveType now uses a single file format for media such as LiveFonts, textures, and 
objects, but media using the earlier “pair format” is still supported.
Shortcuts and Hot Keys
The LiveType interface includes numerous menu items and shortcuts to help you use 
the application easily and efficiently. It’s important to note that the function of these 
options depends on which LiveType window is active. 
For example, when the Canvas is active, the arrow keys nudge the active track in 
small increments. However, when the Timeline is active, the right and left arrow keys 
advance the playhead or move it back one frame.Chapter 1    The LiveType Interface 29
Locating LiveType Media Files
When you install LiveType, a folder hierarchy is placed in the following location: 
Library Application Support/LiveType/. This is where LiveType looks first for media files 
such as LiveFonts, objects, textures, effects, images, movies and templates. LiveType 
media files can also be installed on other hard disks including a network server. You can 
assign any location for media files from the Preferences dialog.
About Installing LiveType Media Files
The LiveType installation process allows you to install LiveType media files in any 
location. For more details concerning installing LiveType and the LiveType media files, 
see the Installing Your Software document that is enclosed with the installation discs.
Managing LiveType Media Files
Any element in the LiveFonts, Textures, Objects, and Effects tabs of the Media Browser 
has a corresponding media file, which contains the components needed to work with 
LiveType. Once these media files are installed in the /Library/Application Support/
LiveType folder, you can move them to a different disk.
To use LiveType media that is located outside the application support folder:
m Assign the location of the media files from within LiveType using the Preferences 
dialog. Choose LiveType > Preferences.
Note:  To use LiveType media that is located outside the application support folder, 
assign its location from within LiveType using the Preferences dialog. If you have media 
installed from a previous version of LiveType, the Media Browser reads “Yes” or “No” in 
the Installed column for that media which indicates whether or not the media files are 
installed. This convention only applies to earlier “file pair” formats. New content comes 
in the form of media files that appear in the Media Browser with a double dash in the 
Installed column indicating they are installed. The Install and Uninstall buttons in the 
lower-left corner of the Media Browser do not apply to the newer content, only to 
LiveType media files from previous versions of the application.
Media file types Media filenames Media file contents
Effects LTFX Contains effects files and sample 
movies for each effect.
LiveFonts LTLF Animated font characters
Objects .LTOB Pre-rendered animations with 
an alpha channel
Templates LTTM LiveType projects
Textures LTTX Full screen animated 
backgrounds. These animations 
can also be matted to any font 
character or element on the 
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Creating Custom Categories for LiveType Media files
You can create custom categories for LiveType Media by simply creating a new folder 
within the Media folder, such as LiveFont/My folder/My font.
LiveType only recognizes one folder level after the original media category. 
You can move “file pair” media files from previous versions of LiveType to another disk, 
but they must be in the same folder hierarchy that they were previously located in.
Using Imported Files
When you use graphics or movies from other sources in your project, LiveType needs 
to refer to the source files for these external elements. Therefore, once you’ve placed an 
image or movie, it’s best not to move or rename the source file. The Images folder in 
the LiveType folder hierarchy is a convenient place to store images associated with 
your projects.2
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2 Setting Up a Project
The most important step as you begin any LiveType 
project is to configure the project properties. 
As tempting as it may be to jump right in and start designing, you should define your 
output parameters and save the project to disk at the outset, to be sure your titles are 
generated at the size and resolution you need.
If you go ahead and generate a titling movie without initially configuring the project, 
you’re bound to run into trouble. Although these settings can be changed at any time, 
a titling composition created for standard broadcast, for example, will fill only a portion 
of the screen if it’s changed to high definition format after the fact.
First, you need to open a new project. You have two options:
Â Start with a LiveType template.
Â Start with an existing LiveType project you’ve already created.
Templates
LiveType includes dozens of templates, which are LiveType project files organized by 
category. You can use templates in several ways:
Â As the starting point for your own creations
Â As repositories of preconfigured elements you can paste into your own projects
Â As a resource for sparking ideas and seeing what’s possible with LiveType
The templates comprise many types of prebuilt projects, all of which you can revise for 
your own purposes.32 Chapter 2    Setting Up a Project
To open a template:
1 Choose File > Open Template. 
2 Browse the categories of templates in the Template Browser.
3 In the Template Browser, choose NTSC, PAL, or HD from the Format pop-up menu.
4 Choose a template, then click OK. 
Whenever you open a template, make sure to set your project properties immediately. 
See “Setting Project Properties” on page 34.
You can save your own projects as templates, so they’re accessible through the 
Template Browser. 
To save your project as a template:
1 Place the project file (.ipr) in a folder in this location:  /Library/Application Support/
LiveType/Templates. 
2 Generate a short QuickTime movie of the project (with the same name but an 
appropriate movie extension, such as .mov or .mp4).
Once you do this, the template will appear in the preview window of the 
Template Browser. 
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Starting a New Project and Setting Defaults
When you open LiveType, an untitled default project appears in the interface. 
If you want to start a new project when LiveType is already open, you need to open a 
new default project.
To open a new project:
m Choose File > New.
A new project with an empty Canvas appears and an “Untitled” project tab is added to 
the Timeline.
Note:  At least one LiveType project must be open at any time, so if you close the only 
open project, a new default project automatically opens.
You can configure your LiveType interface and save your settings as the default. Default 
settings include project properties, font and media choices, Canvas options, the tabs 
that are revealed, and various other settings. This is particularly useful for saving your 
preferred output format, so you don’t have to reconfigure the project properties each 
time you open a project. 
To save your default settings:
1 Set up a LiveType project with the settings and configuration you want.
2 Choose LiveType > Settings > Remember Settings.
Every time you subsequently open a new project or open LiveType, the current default 
settings apply. Content elements in the original project are not saved as part of the 
default project.
It is possible to find yourself with a default configuration that’s undesirable and 
difficult to get out of. You can easily wipe clean your settings and revert to the original 
LiveType settings.
To erase your project settings:
m Choose LiveType > Settings > Clear Settings.34 Chapter 2    Setting Up a Project
Setting Project Properties
Once you’ve opened a new project and saved it to disk, you need to define the output 
you want to create. All of the essential project settings are accessed through the 
Project Properties dialog.
To open the Project Properties dialog:
1 Choose Edit > Project Properties.
2 Make the desired changes, then click OK.
For detailed information, see the next section, “Settings in the Project Properties 
Dialog.”
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Settings in the Project Properties Dialog
There are various pop-up menus, colors, and settings you can select when specifying 
the properties for your project.
Presets
Presets establish the width, height, frame rate, and pixel aspect defined by the 
selected standard. 
Â Presets:  This pop-up menu lists the most common output formats. After you select a 
different preset, you’ll notice how the settings change. You can also see how 
selecting different presets affects the shape and size of the Canvas.
If none of the presets conform to your project, you can configure the dimensions and 
frame rate manually. “Custom” will then automatically appear in the Presets field. 
Note:  Web banner and multimedia options are included among the presets, since 
LiveType is effective for building animations for the web or for Keynote, for example, 
which imports QuickTime movies directly. Keep in mind that web banners are 
typically created in GIF format. To create a GIF, you need to use another program to 
translate your LiveType output.
Â Width:  This is the width, in pixels and inches.
Â Height:  This is the height, in pixels and inches.
Â Frame Rate:  This is the frame rate, in frames per second.
Preset properties automatically
set the project resolution, frame
rate, and so on, for the most
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Â Field Dominance:  When your project is intended for interlaced video output, choose 
either Upper (Odd) or Lower (Even) for the smoothest animation. After the proper 
option is chosen, LiveType renders fields with either the upper or the lower field first. 
Choose None for footage that is non-interlaced. DV footage is typically Lower Field 
First, while certain video capture cards may need to be rendered with the Upper 
(Odd) option chosen. In all cases, use the fielding option that matches your video 
system settings. For more about this, see “Choosing a Field Order” on page 38.
Â Pixel Aspect:  The ratio of width to height of a single pixel, or pixel aspect, can differ 
from format to format. The pixel aspect is set by preset properties, or you can enter a 
custom pixel aspect value.
Â Start Time:  You can map the start time of your project to a precise point in your 
edited video, making it easy to overlay your video at the compositing stage. Start 
Time units reflect the time format entered in the field to the right.
Â Time Format:  This setting defines how the position of audio or video is marked in 
time. There are several choices—Frames, SMPTE, and SMPTE Drop.
Description Field
The description field is a useful place to store notes about the project, as well as 
a description of any nonstandard output parameters you’ve configured, for 
future reference.
Quality Settings
Quality settings can have a big impact on the amount of time you invest in a project. 
As you design your titling animation and try out different effects, you will preview 
your movie many times. And each time, your system has to render the movie, frame 
by frame. 
Time Format options
Quality options for the
Canvas, movie renders,
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These settings in this area allow you to configure the quality of three different items:
Â Canvas:  A RAM preview in the Canvas
Â Movie Render:  A full movie render
Â Preview:  A standard preview accessed via the File menu
How you preview your movie depends on where you are in the design process. You 
may find yourself changing these settings several times as you design your titles, 
particularly if it’s a complex composition that takes considerable time to render.
A Wireframe preview, which displays rectangular bounding boxes representing each 
character, renders very quickly. When you’re focusing on the motion of your Canvas 
elements, not their visual attributes, previewing in Wireframe mode is highly efficient. 
The Wireframe, Draft, and Normal settings render your project at increasing 
resolution levels. 
Background Settings
These settings allow you to select a Canvas color and its opacity level. 
Â Color:  This allows you to choose a background color in the Canvas.
Â Opacity:  This setting reflects the opacity of the color selected above. An opacity level 
of 0 equates to no background color, and the Canvas shows the checkerboard 
pattern indicating a transparent background. 
Â Render Background:  When this checkbox is selected, any background color, as well as 
other background elements, render in previews or final movies.
Important:  The Render Background checkbox applies to all elements that fall below 
the background bar in the Timeline, as well as the background color, which is not 
represented in the Timeline. If the checkbox is not selected, the background color 
and other background elements are not rendered in previews or final movie renders. 
For more information, see Chapter 3, “Adding a Background,” on page 41 which 
presents a complete explanation of working with backgrounds in LiveType.
Ruler and Grid Settings
You can display or hide the Canvas rulers and grid, and set the space between gridlines 
at the bottom of the Project Properties dialog. See “Customizing the Canvas” on 
page 17 for more about the rulers and grid.
The gridline frequency, or grid
width, is set in the Project
Properties dialog.38 Chapter 2    Setting Up a Project
Choosing a Field Order
You can run a simple test to determine the proper field order for your system. 
When you make a movie, the rendering order (upper field first or lower field first) 
should correspond to the method used by your equipment, or your movie will 
appear distorted.
Note:  The field order with which you record to video equipment can be altered by 
changes in the hardware or software of your production setup. For example, changing 
your video board, device control software, or VCR after setting the field order can 
reverse your fields. Therefore, any time you make a change to your setup, you should 
run this test for field rendering order.
To test your system, render two LiveType projects, one rendered with upper field first 
and one with lower field first.
Important:  You may need to familiarize yourself with the basic functions of LiveType 
before you go through these steps.
To test the field rendering order:
1 Start a new LiveType project. 
2 Choose Edit > Project Properties.
3 In the Project Properties dialog, do the following:
a Choose an NTSC or PAL setting from the Presets pop-up menu. 
b Choose Lower (Even) from the Field Dominance pop-up menu. 
Do not choose Upper (Odd). In this case, you are rendering the lower field first.
4 In the Inspector, do the following:
a Type a capital “O” in a system font on Track 1. 
b Increase its size to fill most of the Canvas. 
c Color the letter red, then choose black as your background color. 
5 Apply a fast-moving effect to the track, such as Jumpy, in the Caricature effect category 
in the Media Browser. 
6 In the Timing tab, set the speed of the effect to 100 percent. 
7 Choose File > Render Movie. 
8 Enter lower.mov as the filename in the Save As field, then click Save.
The movie renders to your chosen location.
9 Now change the color of the capital “O” to blue. Select Upper (Odd) in the Project 
Properties dialog.
10 Save the file, naming it upper.mov.
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12 Import the rendered files into Final Cut Pro, then play back both movies on an 
NTSC monitor.
One of the two movies will look distorted; the other movie will play correctly, with 
sharply defined edges. Whenever you render a LiveType movie for that system, use the 
settings you used for the undistorted output.3
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3 Adding a Background
Backgrounds in LiveType generally serve one of two 
purposes:  Either they are an integral part of the titling 
composition, or they are used as an aid to position 
elements and key the timing of the titling movie. 
Although anything can be a background, a background is usually a uniform color, 
animated texture, still image, or movie that fills the Canvas. While background images, 
movies, and textures tend to fill the Canvas and aren’t extensively manipulated, they 
can be sized, positioned, and transformed in many ways. For more information, see 
Chapter 6, “Working With Objects, Textures, and Imported Elements,” on page 79.
Setting a Background Color
The most basic kind of background is a background color, which covers the Canvas and 
cannot be manipulated except for its opacity level. It’s best to think of the background 
color as a project property, not an element that can be moved or changed.
The default background has an opacity of 0 percent, which means the Canvas displays 
a transparent background, represented by the white and gray checkerboard pattern. 
Background settings in the
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To choose a background color:
1 Choose Edit > Project Properties.
2 Click the Color button in the Project Properties dialog.
3 In the Colors window, choose a color, then close the window.
Note:  Make sure you always close this window after you have selected a color.
4 Drag the opacity slider or enter a value in the field greater than 0 percent. Click OK.
The background color appears in the Canvas.
Adding a Background Texture
LiveType textures make vibrant, animated backgrounds. They are also frequently used 
with the matte feature, which allows you to apply a textured fill to text or an object. 
See Chapter 5, “Working With Text,” on page 57 for information about creating a matte.
To create a textured background:
1 Click the Textures tab in the Media Browser.
2 Browse the texture categories and select a texture. 
3 Click the Apply To New Track button. 
The texture fills the Canvas and appears as a background track in the Timeline.
Selected texture
Category pop-up menu
Background texture 
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Importing a Background Movie or Still Image
You can import images or movies from other sources and use them as backgrounds for 
your titling project. For any given project, you might choose to use the following:
Â A single frame or movie clip as a temporary background, to accurately position and 
time the action of your titles
Â A movie to embed as part of your titles
Â A static image or graphic
LiveType can import background elements in a variety of formats:
Â AVI
Â BMP
Â DV
Â GIF
Â JPEG
Â MPEG-2 and MPEG-4
Â Photoshop
Â PICS
Â PICT
Â PLS
About the Background Bar
The background color is different from background elements in your project. 
Background elements are represented in the Timeline and can be manipulated in 
various ways. A project can have many background elements, or none. The only 
definitive way to distinguish a background element, be it a LiveType object or texture, 
a movie, or an image, is that it falls below the background bar in the Timeline.
You can drag the background bar up or down to any position between tracks in the 
Timeline. Any element below the background bar is subject to the Render 
Background checkbox in the Project Properties dialog.
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Â PNG
Â QuickTime image file
Â QuickTime movie
Â SGI
Â Targa
Â TIFF
To import a background movie:
1 Choose File > Place Background Movie.
2 Locate the movie file you want to place, then click Open. 
Note:  When you import a background movie, the project dimensions and frame rate 
adjust automatically to conform. It’s a good idea to review your project properties 
when you import a new background movie.
To import a background image:
1 Choose File > Place.
2 Locate the file you want to place in the Canvas, then click Open.
3 In the Timeline, do one of the following:
Â Drag the image track below the background bar.
Â Drag the background bar above the image track.
Note:  Placing an image or movie using File > Place does not affect the resolution or 
frame rate of the project. That is, the image or movie conforms to the project settings.
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Importing a Background Movie With Timing Markers
Final Cut Pro allows you to save movies that include timing markers, which can be 
useful when setting the precise timing of your titles. When you place a Final Cut Pro 
movie in LiveType, the markers appear in the frame ruler of the Timeline. Markers 
cannot be repositioned in the Timeline. Clicking them, however, moves the playhead to 
the marked frame.
Considerations for Rendering the Background
You have the option of rendering or not rendering the background in your project. The 
background settings in the Project Properties dialog—Color, Opacity, and Render 
Background—provide several options that affect your working environment and the 
final result of your project. 
If you’re creating a standalone animation, web banner, or multimedia component, for 
example, you might want to include a full background as part of your movie output. If 
you’re creating a titling overlay, you won’t want to render the background in most cases. 
Consider these options:
Â To include a background image, movie, or animated texture in your final output, leave 
the background color opacity at 0 percent and select the Render Background 
checkbox. 
Â If you want an opaque or semitransparent solid color background in your final output,
choose a color and opacity level, and select the Render Background checkbox.
Â If you don’t want background elements in your final output, deselect the Render 
Background checkbox. This option allows you to do the following:
Â Import a background movie or image for placement and timing reference only, 
without incorporating it into your titling output.
Â Define a Canvas color other than the default checkerboard pattern, according to 
your working preferences.
Marker imported as part of
a Final Cut Pro movie4
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4 Working With Tracks
To create anything in LiveType, you need to be familiar 
with tracks. Every element of a titling composition is part 
of a track, and each track can contain one or more lines of 
text, an image, a movie, or an animated object or texture.
Tracks are “containers” of content, represented by dark blue lines in the Canvas with 
corresponding bars in the Timeline. A track comprises all of the information about its 
content:
Â Position, shape, and baseline
Â Attributes such as color, shadow, font, and spacing
Â Effects and timing
This chapter explains how tracks are moved and shaped in the Canvas, and how they 
can be manipulated in the Timeline. The next three chapters describe in detail how to 
apply text, objects, and effects to tracks to assemble your composition.
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Positioning Tracks in the Canvas
When you first open LiveType, the default Canvas contains a single empty track with 
two endpoints.
The shape of a track defines the default baseline on which its contents sit. Tracks can 
be manipulated at any time, whether or not they contain an element. If you’re creating 
a track along which to slide text, or if you want your text to conform to a specific shape, 
you might want to shape and position the track before you add text to it. 
To position a track:
m Drag a track to move it anywhere in the Canvas, or partially off the Canvas. 
Tracks can extend beyond the boundaries of the Canvas, allowing elements to slide in 
and out of the viewable area.
To create a sloping track or to resize it:
m Drag one of the track’s endpoints.
Note:  Hold down the Shift key when you position an item in the Canvas to constrain its 
horizontal, diagonal, or vertical position. This applies to tracks, endpoints, objects, 
and characters.
Active track, extending off the Canvas
Endpoint
Title safe boundary
Action safe boundary
White Canvas
background
Canvas Zoom pop-up
menu set to 50 percent
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Creating Angles and Curves
Tracks can take any linear path. You can even link the endpoints of a track so that an 
element can flow around it in a continuous loop.
To add an angle to a track, you must add a control point to it. A track can have any 
number of control points. 
To create an angle on a track:
1 Hold down the Control key and click the track anywhere between the endpoints, then 
choose Add Control Point from the shortcut menu.
2 Drag the new control point and the endpoints to create the angle you want.
Control points are also necessary for creating curves. If you’re familiar with Bezier 
curves, this will be a snap. If not, it may take a bit of experimentation.50 Chapter 4    Working With Tracks
To create a curved track:
1 Follow steps 1–2 above to create an angle on a track.
2 Hold down the Control key and click the control point, then choose Curve In from the 
shortcut menu. 
3 Drag the Bezier handle to adjust the curve.
4 Hold down the Control key and click the same control point, then choose Curve Out 
from the shortcut menu. 
Another Bezier handle appears, and the curve is smooth at the control point.
A Bezier handle appears
as a small point on
the track near the
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Note:  You can apply a curve to an endpoint as well, but clicking an endpoint brings up 
only the Curve In or Curve Out option—not both—since the track extends in only one 
direction away from the endpoint.
Linking Endpoints
The Slide parameter, used in several preset effects, allows text to move along a track. If 
the endpoints are linked, the text can move around the track on a continuous path. See 
Chapter 7, “Working With Effects and Keyframe Animation,” on page 87 for more about 
effects and motion paths.
To create a motion path that is a continuous loop, you need to link the endpoints of a 
track. The endpoints do not need to overlap. In fact, they can be positioned at opposite 
ends of the Canvas, and still be linked. Linking the endpoints allows text or objects to 
loop immediately from the end to the beginning of the track when an effect using the 
Slide parameter is applied to them. 
To link the endpoints of a track:
m Control-click one of the endpoints of any track, then choose Link Endpoints from the 
shortcut menu.
You can unlink endpoints using the same method.52 Chapter 4    Working With Tracks
Adding, Copying, and Deleting Tracks
There are numerous ways to add a track to the Canvas. 
To add a new, empty track, do one of the following:
m Choose Track > New Text Track (or press Command-T).
m Choose a font in the Media Browser, then select Apply To New Track.
Sometimes it’s useful to create a duplicate track, with the identical position, shape, 
contents, timing, and effects as a track you’ve already built. 
To duplicate a track:
1 Select the track you want to duplicate.
2 Choose Track > Duplicate Track (or press Command-D).
The duplicate overlays the original track precisely, so at first, you can only tell that a 
duplicate has been made by the addition of a new track in the Timeline. Overlaying 
tracks with identical elements but different effects and parameters is a great way to 
produce sophisticated title animations. Drag the duplicate off the original to see 
both tracks.
To delete a track:
1 Select the track you want to delete.
2 Do one of the following:
Â Choose Track > Delete Track.
Â Press the Delete key.
You can also copy a track from another project, such as a LiveType template or a 
project you’ve created previously, into your current project. 
To copy a track from one project to another:
1 Open both the source and destination projects.
A tab for each of the projects appears in the Timeline.
2 In the source project, select the track you want to copy, then choose Edit > Copy.
3 Click the tab of the destination project in the Timeline, then choose Edit > Paste.Chapter 4    Working With Tracks 53
Working With Tracks in the Timeline
As you add tracks to the Canvas, they appear as numbered bars in the Timeline. As you 
apply effects to each track, they appear as unnumbered bars below the track. 
Adjusting the Timing of a Track
When you add a track to the Canvas, by default it begins at the frame indicated by the 
playhead. The duration of a track varies, depending on its contents. A track containing 
text in a system font or a static image defaults to a duration of two seconds. The 
duration of a track containing LiveType media or any imported movie depends on the 
length of the movie. 
These basic timing parameters are easily changed in the Timeline window by stretching 
and moving the track bars. Delay and duration can also be defined in the Timing tab of 
the Inspector, as can many other timing parameters.
Track 2
Track 1
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To adjust the duration of a track, do one of the following:
m Drag either edge of the track bar to the right or left. 
Note:  Changing the duration of tracks that contain movies or LiveType media changes 
the speed at which the movie plays. If you shorten the duration of a LiveFont track, for 
instance, it plays faster.
m Select the track and do one of the following:
Â For static content, adjust the Duration parameter in the Timing tab of the Inspector.
Â For movies and animated content, adjust the Speed parameter in the Timing tab.
If you like, you can make the track contents appear later than the first frame.
To delay the appearance of a track, do one of the following:
m Click inside the track bar and drag it to the right. 
m Select the track and adjust the Delay slider in the Timing tab of the Inspector.
You can also reposition more than one track at the same time, which is a useful way to 
maintain the relative position of tracks as you change their delay times. This is known 
as a ripple drag.
To move two or more tracks in the Timeline at once:
m Press the Option key, and drag the left-most track (the track with the earliest starting 
time) of the group you want to move. 
All tracks to the right of the selected track (tracks with later starting times), including 
their associated effects, move as a block with the selected track.
Playhead
Drag either end of a track to
adjust its duration or speed.
Drag a track to adjust
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Layers and Track Order
Elements in the Canvas invariably overlap, which is why it’s important to manage track 
layers. When you create a new track, it is always the top layer. Any content you add to 
that track is in front of all other elements in the Canvas.
Note:  In the Timeline, tracks are displayed in front-to-back order, with Track 1 in front.
To change a track’s front-to-back position, do one of the following:
m Click inside the track bar in the Timeline and drag it up or down, to a new position. 
m Select the track you want to move, either in the Canvas or in the Timeline, then choose 
one of the options from the Layout menu:  Bring to Front, Send to Back, Bring Forward 
[one layer], and Send Backward.
The tracks renumber to accommodate the new order.
Disabling Tracks
You can disable tracks, as well as effects applied to tracks, in the Timeline window. This 
can be useful in reducing clutter in the Canvas, and it saves preview-rendering time 
when you only need to preview one or a few elements. Deactivating elements is also 
useful for comparing different design choices.
To disable a track or effect:
m Click the Enable/Disable button immediately to the left of a track or effect in the 
Timeline. 
While the blue baseline of a disabled track remains in the Canvas, its contents no 
longer appear in the Canvas, are not represented in the Inspector’s Live Wireframe 
Preview, and do not render when you generate a preview or final movie.
Track 1 (top layer)
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Grouping Tracks
It is often useful to group two or more tracks together, to maintain their relative 
position in the Canvas. Grouped tracks can be moved in the Canvas, but they stay 
together as a group. When tracks are stacked on top of each other, grouping is the 
only way to move the stack as a unit.
For example, you might want to create a two-layer effect where a word fades out to 
nothing, revealing the same word underneath with an animated texture applied to it. 
To do this, you have to create a track that precisely overlays the original using the 
Duplicate Track command in the Track menu. Now, if you want to reposition the tracks 
in the Canvas, you need to group them together.
To group two or more tracks:
1 Make sure you have more than one track in the Canvas.
2 Select a track in the Canvas or Timeline. 
This is now the active track, and the grouping button to the far left of the track bar is 
dimmed.
3 Click the grouping button of a different track. 
The link icon appears, indicating that the track is grouped with the active track (the 
track you selected in Step 2).
4 In the Canvas, move either of the grouped tracks, and notice that they move together.
5 In the Timeline, click the grouping button of a third track. 
Now three tracks are grouped together.
To ungroup tracks:
m Select one of the grouped tracks, then click the grouping button of the track you want 
to ungroup. 
The link icon disappears, and the tracks can now be moved independently.
Note:  Grouped tracks maintain their relative position, but their contents can still be 
altered and moved. If you drag a grouped track, other tracks belonging to the group 
move too. However, if you drag a glyph that resides on one of the grouped tracks, the 
glyph moves independently. Its Offset parameter is being changed while the track 
itself stays put.
Active track
Grouping button5
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5 Working With Text
Titles can incorporate all kinds of visual elements, but 
their traditional function is to display text. This chapter 
describes how to insert and format text, including 
manipulating individual characters on the same track. 
Adding movement to text—that is, beyond the inherent animation of LiveFonts—is 
covered in Chapter 7, “Working With Effects and Keyframe Animation,” on page 87.
Inserting Text
Like any Canvas element, text must reside on a track. There are three approaches to 
adding text, in a particular font, to the Canvas:
Â Create a track, select a font, and then add text to the track.
Â Create a track, add text to it, and then apply a font. 
Â Choose a font first, click the Apply To New Track button in the Media Browser, and 
type in the text.58 Chapter 5    Working With Text
The steps below describe the first approach.
To add text to the Canvas:
1 Create a new track by choosing Track > New Text Track (or press Command-T).
Note:  A corresponding track in the Timeline appears. 
2 Choose a font:
a Click either the LiveFonts or Fonts tab in the Media Browser. 
LiveType comes with a variety of LiveFonts. Click the Category pop-up menu to 
access different sets of LiveFonts, including third-party and custom LiveFonts that 
you can create.
b Select a system font or LiveFont.
c Click the Apply button.
3 Enter text onto the active track by doing one of the following:
Â Type into one of the text-entry boxes in the Inspector.
Â Cut and paste text from another application into a text-entry box. (Formatting from 
other applications does not carry over into LiveType.)
Note:  If you add text to a track before selecting a font, the new text appears in the 
Canvas in the default font, size, color, and spacing. 
LiveFonts tab System Fonts tab
Options for 
applying fonts
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To change the font of an existing text track:
1 Select the text track.
2 Choose a font from the LiveFonts or Fonts tab of the Media Browser.
3 Do one of the following:
Â Click the Apply button.
Â Double-click the font name.
Note:  The Apply option does not cross genres of track content. That is, you cannot 
apply a texture or object to a track that already has text on it. Likewise, you cannot 
apply a font to a track that contains a texture, object, image, or movie.
Multiple lines of text can exist on a single track. This enables you to create a long text 
element governed by one set of parameters. If you’re designing credits, for example, 
you can generate the copy in another program, cut and paste it into the text-entry box, 
and apply the font and attributes along with a scrolling effect. 
LiveFonts vs. System Fonts
The two kinds of fonts available in LiveType are very different. LiveFonts have more 
“life” to them, because they are fully designed animations. System fonts, on the other 
hand, are more like blank slates you can modify to achieve a wide range of 
appearances. Both kinds of fonts can be transformed using all the parameters 
described in this chapter, but keep in mind that some parameters will not make 
much visual sense when applied to LiveFonts.
Note:  The Use LiveFont Defaults button in the Text tab of the Inspector restores the 
original attributes of LiveFonts, objects, and textures, including timing, color, and 
other characteristics. This can be a valuable way to revert to the original design of 
these LiveType elements when you’re experimenting with different formatting 
combinations.
LiveFonts and system fonts also have several practical differences in LiveType:
Â You can apply two or more system fonts to the same track, while only one LiveFont 
can be applied to a track.
Â LiveFonts are digital movies, and therefore have timing options you can control 
through the Timing tab of the Inspector. See “Adjusting the Timing of LiveFonts” on 
page 60.
Â System fonts are always vector-based, while LiveFonts can either be raster-based or 
vector-based. So it is possible to use LiveFonts at such a large size (in excess of 500 
point) that the edges begin to degrade.
Â LiveFonts have a much greater impact on previewing and rendering time.60 Chapter 5    Working With Text
To apply a second system font to text on a track:
1 Create a text track with one or two words on it, in a system font.
2 Select one or more characters on the track by highlighting them in the text-entry box 
or selecting them in the Canvas.
3 In the Fonts tab of the Media Browser, choose a system font different from the one 
you’ve already used.
4 Click the Apply button at the bottom of the Fonts tab.
LiveFont Character Set
The LiveFonts included in LiveType consist of 127 characters, which include all standard 
English, French, German, and Spanish characters:
To access characters that aren’t represented on your keyboard, use the Keyboard 
Viewer feature, which you can select in the Input Menu pane in the International pane 
of System Preferences.
Adjusting the Timing of LiveFonts
When you create a system font track, its default duration is always two seconds. 
LiveFonts, on the other hand, have various durations, as shown in the middle column in 
the LiveFonts tab of the Media Browser.
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Because they are movies, LiveFonts are subject to several timing parameters, available 
in the Timing tab of the Inspector. 
Settings for LiveFonts in the Timing Tab
Â Random and Sequence:  Let you apply the LiveFont movie to each character on the 
track in a different order, with a variable delay between each letter.
Â Speed:  Allows you to play the LiveFont movie more quickly or slowly. Notice that as 
you change the speed, the duration of the track in the Timeline increases or 
decreases. Likewise, if you change the duration of the track in the Timeline, the speed 
parameter changes in the Timing tab.
Â Delay:  Allows you to set the starting time of the track.
Â Loop:  Determines how many times the LiveFont movie plays through. The default 
setting is 1, meaning that the LiveFont plays one time. A value of 2 means that it 
plays through twice. The duration of the track doubles with a Loop value of 2, in 
most cases.
Note:  Several LiveFonts, including Burn Barrel, Cool, and Gutter, take advantage of 
“segmented animation,” which defines beginning, middle, and ending segments of 
the movie. When you adjust the Loop parameter for these fonts, only the middle 
segment of the animation is looped.
Â Duration:  Does not apply to LiveFont tracks.
Â Hold First and Hold Last:  Allow you to have the first frame of the LiveFont appear for a 
designated amount of time before the movie begins to play. Likewise, Hold Last 
perpetuates the last frame.
Settings in the
Timing tab62 Chapter 5    Working With Text
Formatting Text
After you’ve selected the font, you have countless formatting options, available 
through the Inspector, to change the appearance of the text. As you adjust formatting 
parameters, the contents of the active track change dynamically in the Canvas, making 
it easy to see what you’re doing. These options can apply to the entire track or to one 
or more individual characters on a track. 
To format any element in the Canvas, you must first select its track.
To select the entire track, do one of the following:
m Click the blue track line in the Canvas.
m Click the corresponding track in the Timeline. 
Note:  If you click the text itself, a bounding box appears around the character you 
clicked, and your modifications affect only that character. See “Modifying Individual 
Characters” on page 77.
After you have selected the track you want to format, use the Text, Style, and 
Attributes tabs of the Inspector to specify options such as alignment, size, tracking, 
leading, and color.
Alignment, Size, Tracking, and Leading
In the Text tab of the Inspector, you can adjust the size, tracking, and leading of a text 
track, as well as its horizontal and vertical alignment. Size values are in points, and 
tracking and leading values are percentages of the font’s default spacing.
Formatting options in the
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Â Alignment:  With the alignment options, text can be set to run horizontally as well as 
vertically on a track. The Left, Center, and Right Alignment buttons apply to both text 
orientations. The position of the track itself is not affected by alignment settings. The 
alignment options are also important to position text appropriately when the track is 
used with an effect that uses the Slide parameter. 
For example, if you want to slide text onto the screen from left to right, create a track 
that begins to the left of the Canvas. The text should be left-aligned, so that it starts 
from the left end of the track, off the Canvas. Then apply the Slide Right effect from 
the Motion Path category.
Â Size:  Text size is adjusted by dragging the slider, clicking within the slider track, or 
entering a value in the box to the right of the slider.
Note:  Because LiveFonts are raster images made up of pixels, their edges will start to 
degrade at very large sizes, usually 500 point and larger. System fonts are vectorbased, and therefore retain their integrity at any size.
Â Tracking:  Character spacing is adjusted with the tracking setting. The value for 
normal character spacing is 100 percent. A setting of 110 percent adds a modest 
amount of space between letters. When tracking is set to 0 percent, all characters 
overlay each other.
Â Leading:  Leading sets the amount of space between the baseline of one line of text 
and the next. This setting only applies to tracks with more than one line of text, not 
to the spacing between different tracks. The default leading value is 100 percent. At 
0 percent, all lines of text on a track overlay each other.64 Chapter 5    Working With Text
Color
Color options are in the Glyph pane of the Inspector’s Attributes tab. The lower portion 
of the tab contains the color controls.
Â Color:  The Color parameter replaces existing pixels of color in the selected element 
with the color indicated in the Color box, while keeping the luminosity values intact. 
A setting of 100 percent completely replaces the existing colors, whereas a Color 
setting of 20 percent combines some of the new color with the original. Click the 
Color box to choose a different color.
Note:  Once you have selected a color, close the Colors window. You need to reopen 
the Colors window to make any subsequent color choices.
Â Hue, Saturation, and Lightness (HSL):  These three sliders work together to establish 
the color of the selected element. Hue defines the shift in color value, in degrees, on 
a 360-degree spectrum. Saturation defines the intensity or vividness of the color, in 
percentage points. Lightness defines the intensity along the black and white axis, in 
percentage points.
The default color of a system font is black, which renders the Hue, Saturation, and 
Lightness sliders ineffective. HSL and Color are useful for adjusting raster-based 
elements such as LiveFonts while, as a rule of thumb, system fonts and other vectorbased elements should be colored using the Color feature.
Â Alpha pop-up menu:  When you have a clip or imported graphic in a LiveType 
composition, you can choose a type of alpha channel from this menu. Choose from 
Premultiply White, Premultiply Black, or Straight.
Color settings in the Glyph
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To change the color of a system font:
1 Select a track that contains a black system font.
2 In the Attributes tab, in the Glyph pane, click inside the Color box and choose a color 
from the Colors window (preferably a bright, primary color).
3 Set Color to 100 percent.
The contents of the track change to this color.
LiveFonts are typically built using primary colors, which means that the Hue, Saturation, 
and Lightness sliders can be used effectively, in addition to the Color parameter.
Transforming Text
Beyond basic text formatting, LiveType gives you many additional treatments with 
which to stretch, blur, fade, reposition, and rotate your text. These features are all in the 
Glyph pane of the Attributes tab.
Â Opacity:  Opacity defines how much of the underlying content shows through. An 
opacity setting of 0 makes text completely transparent and, in most instances, a 
setting of 100 makes it opaque. When the blur attribute is off (set to 0), a 50 percent 
opaque character has sharp edges and is somewhat transparent.
Note:  LiveType allows opacity values to be higher than 100 percent. This can be 
desirable when you’re working with glow parameters (Style tab), or LiveFonts and 
elements that are blurred or partially transparent. For example, the Charge LiveFont 
still reveals some of the background at 100 percent opacity. At 150 percent (which 
you must enter in the opacity field), the font reveals very little background.
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Â Blur:  The blur attribute is similar to opacity, but it fades and expands the outer edges 
as if the text is out of focus. Blur can be applied equally to the X and Y axes or 
unequally, for different outcomes. A blur setting of 0 is off, with no blurring effect. 
The maximum blur setting is 25.
Â Scale:  Scale stretches or squeezes text on the X and Y axes, with 100 being the same 
size as the original text. Note that scale parameters are applied independently to 
each character around its pivot point, not to the entire track as a unit. 
Note:  Unlike the Scale parameter, the Size parameter in the Text tab scales text from 
the baseline, and also takes text tracking into consideration.
Â Offset:  Offset repositions the text relative to its original position on the track. An 
offset of 0 indicates no position shift on that axis.
Â Rotate:  With the rotation dial, you can position an element not only in the 360 
degree range, but configure any number of revolutions in the context of an effect. 
A glyph sized using the Size parameter
keeps its original baseline and tracks
with adjacent characters.
A glyph sized using the Scale parameter
expands around its pivot point without
affecting the position of other glyphs
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For example, you can set an early keyframe at 45 degrees and set a later keyframe at 
four revolutions plus 180 degrees. When you play the movie, the element spins 
clockwise four times plus an additional 135 degrees between those two keyframes. 
Positive values reflect clockwise motion, and negative values reflect counterclockwise 
motion. Working with keyframes is defined fully in Chapter 7, “Working With Effects 
and Keyframe Animation.”
Text example set at 35 percent
opacity in the Attributes tab
Text example using the blur 
and scale options in the
Attributes tab
Text example with the 
default shadow
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Enhancing Text With Styles
The Style tab in the Inspector offers four options for enhancing your text. Styles allow 
you to add depth and emphasis to text—as well as to objects—mostly by altering the 
space around each character.
The Shadow, Glow, Outline, and Extrude buttons in the Style tab each reveal the 
settings applicable to that treatment.
Shadow and Glow
The Shadow and Glow styles are essentially two “flavors” of the same style, using 
identical parameters to create quite different looks.
Â Character:  The character setting allows you to make the original element invisible, 
isolating the style treatment in the Canvas. This can be a helpful way to eliminate 
clutter as you compose your treatment, or you may choose to leave the original 
element invisible in the finished product.
Â Enable:  The Enable checkbox allows you to turn a style on or off, without affecting 
the settings you’ve established. Again, this is a helpful tool for eliminating clutter as 
you design, or as you compare different styles and combinations of styles.
Â Layer:  The Layer pop-up menu allows you to place the shadow or glow treatment in 
front of or behind the original element. The In Front Only setting restricts the shadow 
or glow effect to the boundaries of the original element, without extending beyond 
the edges of the letters or object.
Shadow parameters in
the Style tab of the
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Â Opacity:  Opacity sets the intensity of the shadow or glow. An opacity setting of 0 
makes the shadow or glow completely transparent, that is, invisible, and completely 
opaque at 100, with no background showing through. If blur is turned off (set to 0), a 
50 percent opaque shadow has sharp edges that match the original element, but 
whatever lies behind the shadow shows through it.
Â Blur:  The blur parameter is similar to the opacity setting, but fades and expands the 
outer edges as if the glow or shadow is out of focus. A blur setting of 0 is off, with no 
blurring effect. The maximum blur setting is 25. Blur can be applied independently to 
the x and y axes. A y-direction blur creates the look of an up and down motion, even 
in a static image. 
Â Scale:  Scale stretches or squeezes the glow or shadow on the X and Y axes, with 100 
being the same size as the original element. Note that scale parameters are applied 
independently to each character of text on a track, not to the entire shadow or glow 
as a unit.
Â Offset:  Offset repositions the shadow or glow relative to the original element. An 
offset of 0 indicates no position shift on that axis.
Â Color:  The Color box lets you select the color of the shadow or glow.
Â Warp:  The warp area allows you to stretch and reshape the shadow or glow by 
dragging the four corner points, or inserting x and y coordinates for each corner. A 
simple application of the warp feature is to stretch shadows to represent different 
lighting situations.
Text example using glow
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Outline
This style adds an outline to the contents of any track. See the preceding section for a 
definition of the opacity, blur, color, and warp parameters. Click the Outline button at 
the top of the tab to adjust the outline settings.
Â Weight:  The weight value, which defines the thickness of the outline, is set in pixels. 
Â Show Outline Only:  Show Outline Only eliminates the original element, creating an 
outline effect that allows the background to show through.
Note:  The Show Outline Only setting is used with the character parameter set to 
Visible. Otherwise, the outline will be rendered invisible along with the character itself.
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Â Outline Extrusion:  When the text has been extruded (see below), selecting this 
checkbox extends the outline around the extrusion.
Extrude
Extrude settings consist of direction, length, and color. The direction setting determines 
which way to “pull” the extrusion and the length determines how far to pull it.
Â Length:  The length value is set in pixels.
Â Direction:  The direction value is set in degrees, from 0 to 360.
Â Color:  The Color box lets you select the color of the extrusion.
Text example using the Show
Outline Only and Outline Extrusion
options in the Style tab
Text example using X and Y scaling
options in the Attributes tab, with
an outline
Text example using the invisible
character option with the Shadow
and Glow styles in the Style tab
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Creating a Matte
The matte feature in LiveType allows you to reveal a background element in the area 
defined by a foreground element, seemingly cutting a hole through any layers in 
between. When you create a matte, every pixel of the foreground element is replaced 
by a corresponding pixel in the background element. In other words, a matte acts as a 
window into another layer.
In LiveType, you have three options for creating mattes, available in the Matte pane of 
the Attributes tab in the Inspector. The first option—Matte to Background—allows you 
either to fill the foreground element with a background element, or to create an empty 
window, which can remain transparent when you render your titling movie.
To create a matte with two project elements:
1 Create the background element by placing a texture, image, movie, or object as the 
bottom layer reflected in the Timeline. 
See Chapter 3, “Adding a Background,” on page 41 and Chapter 6, “Working With 
Objects, Textures, and Imported Elements,” on page 79 for information about placing 
these kinds of elements in the Canvas.
2 Make sure the background is beneath the background bar in the Timeline, and that no 
other elements are below the background bar.
3 Create a texture or any other element that obscures the background.
4 Create a foreground element, that is, the text or object you want the background to “fill.”
5 With the foreground track selected, click the Matte button in the Attributes tab of 
the Inspector.
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6 Choose Background from the “Matte to” pop-up menu. 
The background image appears to fill the foreground element.
To create a window into a transparent background:
1 Create a texture or any combination of elements that covers the Canvas. 
For information about placing textures and other elements in the Canvas, see 
Chapter 3, “Adding a Background,” on page 41 and Chapter 6, “Working With Objects, 
Textures, and Imported Elements,” on page 79.
2 Create a foreground element, that is, the text or object that defines the shape of 
your window.
3 If any elements are below the background bar in the Timeline, drag the bar below all 
elements.
4 With the foreground track selected, click the Attributes tab of the Inspector, then click 
the Matte button.
5 Choose Background from the “Matte to” pop-up menu. 74 Chapter 5    Working With Text
The transparent Canvas (or background color if defined in the Project Properties dialog) 
appears to fill the foreground element.
The other two matte options, Matte to Movie or Image and Matte to Texture, differ 
because the background doesn’t appear as a discrete project element that’s reflected in 
the Timeline. And, there’s no need for a layer that the matte has to “punch through.” 
Instead, the track contents are simply filled with the designated image.
These two matte alternatives have scale, speed, and sequencing options in the Matte 
pane. Scale adjusts the size of the background image, speed adjusts the speed of the 
background movie or texture, and sequencing allows you to offset the timing of the 
background for each letter residing on the foreground track.
Note:  When you matte a word to a movie or image, LiveType calculates which portion 
of the image “underlies” each letter, imitating a true window into a lower layer. When 
you reposition the letters on the track, they retain the same image content. This feature 
can create an interesting look as you apply movement to the text, particularly when 
the matte is with a movie.
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To fill the track contents with an image or movie:
1 Select a track that contains the text or object you want to fill with an image or movie.
2 Click the Attributes tab of the Inspector.
3 In the Matte pane, choose Movie or Image from the “Matte to” pop-up menu.
4 Locate the file in the Choose Movie or Image dialog, then click Open. 
The track contents fill with the background movie or image.
Note:  If you want to reveal a specific portion of the image or movie within your 
foreground element, you may find that this matte option is not appropriate, since you 
cannot adjust the relative position of the image and your foreground element. If this is 
the case, you must use the Matte to Background option described above, which allows 
you to position the two components independently.
Text track matted
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To fill the track contents with a texture:
1 Select a track that contains the text or object you want to fill with a texture.
2 Choose a texture from the Media Browser, then click the Apply to Matte button.
The default texture fills the contents of the active track.
Note:  A variety of mattes is available for use in the Objects tab of the Media Browser 
from the Category pop-up menu. The blue areas of a LiveType matte define the area 
where the texture will play back. Text or glyphs from the character palette may also be 
used as mattes.
Note:  Individual characters on the same track can be matted to different textures, 
movies, or images. See “Modifying Individual Characters,” next.
You can get a nice effect by combining the matte function with the outline style.
To fill an invisible element’s outline:
1 Create or select a text track.
2 In the Style tab of the Inspector, click the Visible button.
3 In this case, make sure the Enable checkbox is deselected for the Shadow, Glow, and 
Extrude styles.
4 Click the Outline button in the Style tab, and select the Enable checkbox.
5 Select the Show Outline Only checkbox, and increase the weight of the outline, so it’s 
fairly thick.
6 Choose a texture to fill the outline, then click the Apply to Matte button.
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Modifying Individual Characters
You can also assign attributes to individual characters on a track. All of the attributes 
discussed in this chapter can apply to only one, or more than one, character on the 
same track.
This is a powerful option in LiveType, particularly because it allows you to reposition 
individual characters, or glyphs, without breaking their relationship to the track.
For example, with individual character adjustments, you could make one word in a 
phrase float above the track, expand and glow, and then return to the track. This would 
take only a few moments to animate. Or you could make a series of characters do 
similar transformations, one after the other. 
To modify one or more characters on a track, try the following steps:
1 Select or create a track that contains some text.
2 Select one or more letters by doing one of the following:
Â Select one of the letters in the Canvas and, to modify more than one character at a 
time, hold down the Shift key while selecting additional, contiguous letters. A 
bounding box appears around the selected letter(s), with a handle in each of the 
upper corners. 
Â Highlight one or more letters in one of the text-entry areas of the Inspector. 
Bounding boxes appear around the selected letters in the Canvas.
Â Marquis-select one or more letters in the Canvas by dragging a box with the cursor. 
Any letter that touches the marquis area is selected, and reveals its bounding box.
3 Click inside the bounding box and drag the letter anywhere in the Canvas.
4 Drag the upper-left handle to rotate the letter.
Rotation handle
Sizing handle
All of the characters 
reside on a single track.
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5 Drag the upper-right handle to change the letter’s size.
Note:  You can restore a letter to its original size and placement by choosing 
Layout > Reset Position.
6 Change the letter’s attributes in the Attributes tab or the Style tab of the Inspector.
7 Click in the Canvas away from the track. 
The bounding box around the character disappears, but the track is still selected. 
8 Reposition the track in the Canvas and modify its attributes. 
Note:  These adjustments affect the entire track, including the letter you’ve just 
modified.
Disabling Fonts in Mac OS X
In Mac OS X v10.3, you can use the Font Book application to disable fonts. However, 
LiveType requires that certain fonts—Geneva and Helvetica—are always available, so 
these two fonts should not be disabled. If you disable these fonts, you may experience 
unpredictable behavior in LiveType. 6
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6 Working With Objects, Textures, 
and Imported Elements
Titling compositions often center around words, but all 
kinds of additional elements are used to frame, enhance, 
and accompany them. 
For the purpose of this manual, these elements fall into three categories:
Â Objects included with LiveType
Â Textures included with LiveType
Â Static images and movies originating from other sources
All of these elements are modified and moved around in the Canvas in the same way. 
They do not rest on a linear track, as text does, unless you add multiple, identical 
objects to a track (see “Creating Strings or Stacks of Elements” on page 84). Instead, 
when selected, they display a bounding box, like a single character selected on a text 
track. At the upper-right and upper-left corners of the bounding box are scale and 
rotation handles. 80 Chapter 6    Working With Objects, Textures, and Imported Elements
Working With LiveType Objects
Objects in LiveType are graphical elements with an alpha channel, designed to frame or 
emphasize text. Most of them are animated and, much like LiveFonts, can be sized, 
rotated, colored, and stretched. You can add a shadow, glow, or an extrusion. And you 
can apply effects to them.
Objects placed in the Canvas are represented as tracks in the Timeline, like any other 
titling element.
To add a LiveType object to the Canvas:
1 Click the Objects tab in the Media Browser.
2 Browse the categories of objects displayed in the Category pop-up menu, and select an 
object in the Name column of the Objects tab.
3 Click the Apply To New Track button. 
The object appears in the Canvas, and a corresponding track appears in the Timeline.
LiveType objects available
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Working With LiveType Textures
Textures in LiveType are colorful animated patterns that can be used as full-screen or 
partial backgrounds, or as animated fills when used with the matte function, described 
in Chapter 5, “Working With Text,” on page 57. Textures are versatile, and can be 
transformed in the same ways an object is transformed, particularly if the texture is 
reduced in size to take up only a portion of the Canvas.
To add a texture to the Canvas:
1 Click the Textures tab in the Media Browser.
2 Browse the categories of textures displayed in the Category pop-up menu, and select a 
texture in the Name column of the Textures tab.
3 Click the Apply To New Track button at the bottom of the Textures tab. 
The texture fills the Canvas, and a track appears in the Timeline, just above the 
background bar.
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Importing Graphics, Images, and Movies
Graphical elements in a wide range of formats can be incorporated into a LiveType 
project. Scanned images, photos, and illustrations, as well as movies and animations, 
can be used as part of your titling composition. And, like objects and textures, they can 
be modified and placed in numerous ways.
LiveType can import elements in a variety of formats. 
To import a graphic, image, or movie:
1 Choose File > Place.
2 Locate the file, then click Open. 
The element appears in the Canvas, and a corresponding track appears in the Timeline.
LiveType import formats
AVI JPEG PICT QuickTime movie
BMP MPEG-2 and MPEG-4 PLS SGI
DV Photoshop PNG Targa
GIF PICS QuickTime image file TIFF
Imported movie, scaled 
and rotated
LiveType texture, scaled 
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Transforming Objects, Textures, and Imported Elements
Imported elements can be positioned, changed, and animated as easily as text. A 
photo can be made to bounce around the Canvas, fade in and out, grow and shrink, or 
take on a purple hue, for example. 
Sizing and Positioning Objects, Textures, and Imported Elements
When you first place a movie or texture in the Canvas, its position is locked by default. 
These types of elements are frequently used as full-screen background elements that 
don’t need to be sized or moved. However, you can unlock them easily.
To unlock the position of a texture or imported movie:
1 Select the track you want to unlock. (Sometimes this is easiest to do in the Timeline.)
2 Choose Layout > Lock Position. 
The checkmark next to Lock Position disappears, and the bounding box handles on the 
element are now active.
When you select a non-text element in the Canvas, a bounding box appears around it, 
the same as an individual character on a text track. If you select a full-screen element, 
it’s easier to see the bounding box if you zoom out in the Canvas.
To resize, rotate, and reposition a non-text element in the Canvas:
m Drag the bounding box and its upper-left and upper-right handles.
Non-text elements can also be transformed with any of the attributes available to text 
characters:  shadow, color, blur, and so on.84 Chapter 6    Working With Objects, Textures, and Imported Elements
Creating Strings or Stacks of Elements
In a way, LiveType looks at textures, objects, and imported elements as special kinds of 
glyphs, or text characters. More to the point, individual elements are treated like fonts 
whose character set consists of only one glyph.
This allows you to do an unusual thing in LiveType:  You can create strings, or multiple 
copies, of these elements on what, for all intents and purposes, amounts to a text track. 
Anything you can do with one letter of a text font, you can do with objects, textures, 
and imported elements.
Note:  Objects cannot, however, be formatted as multiple lines on one track.
To create a string of elements on one track:
1 Add an object, texture, or imported element to the Canvas.
2 Make the object a reasonably small size to duplicate in the Canvas:
a Click the Attributes tab of the Inspector, then click the Glyph button.
b Make sure the lock icon next to the Scale sliders is closed, or locked, for proportional 
scaling. If it appears to be unlocked, click the icon to lock it.
c Adjust the Scale sliders, or enter a value in one of the Scale fields.
3 Click inside the text-entry box in the upper-left corner of the Inspector. Note that a 
single bullet is in the window, representing the object as a single glyph.
One imported graphic
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4 With the blinking cursor in the text-entry box, press the Space bar or type any key. 
A second bullet appears in the text-entry box, and now two identical objects are on a 
linear track in the Canvas. Add as many objects as you like.
5 Adjust the tracking and alignment in the Text tab of the Inspector, and any other 
attributes that you might apply to a string of letters, including formatting individual 
elements on the track separately.
Changing Attributes and Styles
Just as non-text elements can be treated as glyphs, they can take on all of the same 
styles and attributes available to text. Chapter 5, “Working With Text,” on page 57 
describes all the transformations available in the Inspector. 
You might want to try the following for a digital image or movie:
Â Reduce the size of the image, position it in the Canvas, and rotate it 20 degrees, 
using the Scale, Offset, and Rotate controls in the Glyph pane of the Attributes tab in 
the Inspector.
Â Add a shadow, outline, or extrusion to the image, using Style functions.
Â Shift the color of the image using the Color controls in the Glyph pane of the 
Attributes tab in the Inspector.
Â Apply a preset effect to the image, or animate it yourself by building your own effect. 
Chapter 7, “Working With Effects and Keyframe Animation,” on page 87 explains how 
to do this.
Other imported elements—logos, line art, or simple graphical elements—are even 
more versatile. They might lend themselves to a matte treatment, glow or blur, or an 
outline with the original element rendered invisible. There’s no end to the possibilities.
Replacing Media in a Track
You can easily replace any movie or image in a track on the Timeline at any time. 
To replace any movie or image with new content:
1 Control-click the chosen track, then choose > Reconnect Media from the shortcut 
menu.
2 Navigate to the new file in the Open dialog, then click Open.
The existing media is replaced with a new movie or image.7
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7 Working With Effects 
and Keyframe Animation
Effects are what make your Canvas elements move 
and transform. They are “packages” of animation, 
encapsulating the parameters that govern motion 
and timing, as well as an element’s attributes in any 
given frame. 
The key ideas about effects are as follows:
Â All motion and transformations built into your titling movie are controlled by effects, 
whether you create your own or take advantage of the preconfigured effects in 
LiveType.
Â Effects are applied to tracks. They appear in the Timeline as bars underneath the 
track they’re applied to.
Â More than one effect can be applied to the same track, even at the same time.
Â You can change an effect once it is applied to a track, and you can save the modified 
effect so it’s available to use on other tracks and in other projects.
Â When a track and an effect have conflicting parameters, the effect parameter 
overrides the track parameter. For example, if an effect specifically turns the Glow 
style off, the track’s glow settings are irrelevant.
Â When a track and an effect have complementary parameters, the two values are 
combined. For example, if a track has an opacity of 50 percent, applying an effect 
with 50 percent opacity will result in an opacity of 25 percent in the Canvas, or half of 
the track’s 50 percent opacity.
Â You can edit or build an effect outside of the LiveType interface. Instructions for 
writing EffectScript code are in Appendix B, “Creating and Editing EffectScripts,” on 
page 135.
Â Effects can be applied to individual characters on a track and managed from the 
Effects tab in the Inspector.88 Chapter 7    Working With Effects and Keyframe Animation
Preset Effects
Following is a table listing all of the 41 available preset effects found in LiveType. These 
effects are located in the Effects tab of the Media Browser. 
Applying Preset Effects
The preset effects in LiveType add personality to your titles and can be used to set the 
tone of your composition. Browse through the available effects in the Media Browser to 
get a sense of what they can do.
To apply a preset effect to a track:
1 Create a track that contains text or any other kind of element. Make sure it is the 
active track.
2 Click the Effects tab in the Media Browser. 
The Category pop-up menu reveals the categories of installed effects, corresponding 
to the subfolders on your computer located at
/Library/Application Support/LiveType/Effects. 
LiveType effects
Caricature
Â Baffle
Â Bounce Track
Â Bounce
Â Bouncy
Â Elastica
Â Quick Twist
Fades
Â Cluster
Â Foreground
Â Pile Up
Fantasy
Â Chatter Out
Â Dispersion
Â Expand
Â Ideas
Â Invent
Â Send Off
Â Z Space
Glows
Â Blue Light
Â Combustible
Â Exhale
Â Follower
Â Impression
Â Light Beam In
Â Light Beam Out
Â Morph
Â Peace
Â Rising Sun
Â Slider
Â Spectral
Â Zapper
Grunge
Â Text Static
Mechanical
Â Assembly
Â Buzz Saw
Â TV Off
Motion Path
Â Departing
Â Escape
Â Parting
Â Random Drop
Â Slide Hang
Â Vent
Shadows
Â Pit Stop
Zooms
Â ViewpointChapter 7    Working With Effects and Keyframe Animation 89
3 Choose an effect in the Name column of the Effects tab. 
The Browser preview depicts how the effect works, the Duration column shows the 
default effect length, and the Description field contains notes about how best to apply 
the effect.
4 Do one of the following:
Â Select the effect name and click Apply.
Â Double-click the effect.
Â Drag the effect into the Effects tab of the Inspector.
When you apply an effect, a bar appears under the active track in the Timeline, labeled 
with the effect name. 
If the effect includes motion, you immediately see the movement reflected in the Live 
Wireframe Preview in the Inspector. 
Depending on the position of the playhead in the Timeline, the Canvas itself may or 
may not change noticeably. Move the playhead to see how the track elements change 
at different points in time, or click the Play button in the Canvas to view a RAM render.
The effect also appears in the Effects tab of the Inspector. The Effects tab shows a list of 
the effects that have been applied to a track. The stack order does not affect the 
sequence, or timing, of any effect.
To disable an effect:
m Click the Enable/Disable button in the Timeline next to the effect.
The Effects tab 
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To disable an effect for one or more glyphs on a track:
1 Select the track.
2 Select the character(s) that you don’t want the effect to apply to, either by highlighting 
them in the text-entry box or selecting them in the Canvas. 
Because you cannot select noncontiguous characters at the same time, you may have 
to do these steps more than once.
3 In the Effects tab of the Inspector, deselect the checkbox next to the effect you want to 
turn off for the selected characters. 
Adjusting the Timing of an Effect
All of the timing parameters applicable to tracks that contain LiveType media elements 
also apply to effects. 
Just as you can drag a track in the Timeline to adjust its starting point and duration, 
you can do the same with an effect. Settings in the Timing tab of the Inspector 
determine how an effect is applied to each letter on a track, how fast it runs, and how 
many times the effect repeats.
The Timing tab includes an array of options that allow you to orchestrate the 
movement of your Canvas elements. Timing tab settings apply to the effect that is 
selected in the Timeline.
Canvas elements reflect the 
current frame, as determined 
by the playhead position.
The Effects tab of the
Inspector shows the effects
applied to the active track.
Preset effects are applied 
from the Effects tab of 
the Media Browser.
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To adjust an effect’s timing parameters:
1 In the Timeline, select an effect that has been applied to a track.
2 Click the Timing tab in the Inspector. 
The current timing parameters for the selected effect are reflected.
The Timing tab contains the following timing options:
Â Random:  A randomized effect treats each character on a track separately, as opposed 
to applying the effect parameters to the entire track at once. With this setting, the 
effect transforms each character in a random order, separated by the designated 
number of frames or seconds. The Seed field allows you to select alternative random 
orders, up to 255, if the order doesn’t look quite right.
Â Sequence:  A sequenced effect starts by transforming one character, then moves to 
the next adjacent character, and so on. A sequence value of 0 indicates that the 
effect plays simultaneously for all characters. With a value of 25, the effect begins to 
transform the first character, then when the effect is 25 percent into the 
transformation, it begins to transform the next character, and so on. The Start pop-up 
menu below the Sequence slider defines the direction from which the sequence 
begins.
Â Speed:  You can change the speed of an effect, as a percentage of its default speed. 
Increasing an effect’s speed decreases its duration. The Start pop-up menu below the 
Speed slider allows you to run the effect in reverse.
Â Delay:  The delay setting sets the start or end time of the effect in relation to the 
beginning or endpoint of the track. Using this setting is an alternative to positioning 
an effect directly in the Timeline.
The Timing tab 
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Â Loop:  The loop setting determines how many times the effect will repeat. A loop 
value of two doubles the duration of the effect. The To End checkbox makes the 
effect loop continuously for the duration of the track.
Â Duration:  This setting governs the duration of a track containing system font text or 
any other static element. The duration of effects, as well as tracks containing dynamic 
elements such as a movie clip or LiveFont, is adjusted with the Speed slider.
Â Hold First:  With this option, the parameters for the first frame of an effect are 
maintained for the designated period of time before the effect kicks in. For example, 
if you want a track to fade in after two seconds, you can choose Hold First for two 
seconds, during which time the track is invisible (or 0 percent opaque), before the 
Fade In effect begins.
Â Hold Last:  This works the same way as Hold First, but at the end of the effect, to 
extend the final-frame parameters of the effect for a designated amount of time.
To adjust the timing of an effect in the Timeline, do one of the following:
Â Drag in the middle of the effect bar (but not on a keyframe) to position the effect 
without changing its speed. This affects the effect’s Delay value, as seen in the Timing 
tab of the Inspector.
Note:  You can position an effect so that it extends beyond the boundaries of the 
track, in which case the extraneous effect parameters aren’t used.
Â Drag either edge of the effect to adjust its speed. An effect that is shorter in duration 
runs through its motions more quickly. 
Resizing from the left edge of an effect whose Delay Start value is set “From Start” 
changes the effect’s speed and delay. The same is true when resizing the right edge 
of a “From End” effect.
Repositioning Groups of Effects Within a Track to Adjust Timing
If you have multiple effects in a single track, you can move them in unison to adjust 
their timing.
To reposition groups of effects within a track:
m In a track with multiple effects, hold down the Option key as you drag any single effect.
The effects move up and down the Timeline in unison. All effects in the track maintain 
their relative positions but occur at an earlier or later point in time.Chapter 7    Working With Effects and Keyframe Animation 93
Changing the Order of Effects
In a track with more than one effect, you can change the order (precedence) of an 
effect by dragging it vertically. If the effect has timing information, its position in the 
new track may be adjusted.
To change the order an effect:
m Drag the effect up or down within the track.
The order of the effects has now been changed.
Duplicating Effects and Tracks
You can easily duplicate effects and tracks, including duplicating an effect from one 
track to another.
To duplicate an effect or track:
In the Timeline, Option-drag an effect or track to the new location or track. Holding 
down the Option key while dragging an effect makes a copy of the effect in a new 
effects track.
Modifying a Preset Effect
In addition to adjusting the timing parameters of an effect, you can change what the 
effect actually does; that is, how it transforms the track it’s applied to.
Altering an effect used in your project does not alter the original preset effect. Once 
you have applied the effect, you are free to adjust it, and the changes you make are 
saved as part of your project.94 Chapter 7    Working With Effects and Keyframe Animation
Keyframes and Sequencing Markers 
Computer animation is based on the concept of keyframes. Animators define a 
graphical element’s parameters—position, color, size, shape, and so on—at periodic 
intervals, and the software interpolates the parameters for each frame in between. 
Keyframes are represented in the Timeline as diamond-shaped markers in effects. When 
you select a keyframe, the playhead moves to that frame, and the Canvas reveals the 
state of the project elements at that point in time.
To view the parameters defined by a keyframe:
1 Select the keyframe in the Timeline.
2 Click the Effects tab in the Inspector. 
The parameters defined by that keyframe appear in the Active Parameters window.
The Clockwise effect, for example, only has one active parameter for its keyframes. 
Regardless of the track attributes or other effects that may affect the track, the 
Clockwise effect is concerned only with making the letters on the track spin. The 
sequence timing parameter for the effect applies the rotation to each character on the 
track one after the other, from left to right.
Sequencing markers, vertical lines in the light purple area of an effect bar, show when 
each glyph starts to be acted on by the effect. The number of sequencing markers, 
including the first frame of the effect and the beginning keyframe of the effect 
(depicted by half diamonds), always equals the number of glyphs on the track.
Note:  Not all effects are sequenced or randomized; therefore, not all effects have 
sequencing markers.
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Adjusting Keyframe Parameters
To change what an effect does, you have to alter its keyframes. While you can change 
an effect’s parameters through the Effects tab by entering numeric values, it is usually 
easier to make changes in a more visual way, using the full LiveType interface.
To adjust a keyframe by changing parameters in the Inspector:
1 Select a keyframe in the Timeline. 
The playhead moves over the keyframe and the Canvas reflects the appearance of the 
composition at that frame.
Note:  If you change an effect parameter when the playhead is not over a keyframe, a 
new keyframe is added at the current playhead position.
2 Adjust the attributes of the track. 
The LED indicators in the Inspector indicate which attributes can be changed in the 
context of an effect—they are all in the Text, Style, and Attributes tabs of the Inspector. 
3 Click the Play button in the Canvas to see the results of your modification.
LED indicators appear
when an effect is
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To adjust a keyframe by changing parameters in the Canvas:
1 Select a keyframe in the Timeline.
2 Click a letter or the object to reveal its bounding box.
3 Manipulate the selected glyph to change its position, rotation, or scale. 
When you drag the glyph, the entire word moves with it, and a motion path with small 
incremental dots appears. Each dot on the motion path represents the pivot point of 
the selected letter at every frame of the movie. Notice that if you select a different 
letter, a slightly different motion path appears, representing the center position of that 
letter for each frame.
4 Click the Play button in the Canvas to see the results of your modification.
LED Indicators in the Inspector
When you select an effect or keyframe, the Text, Style, and Attributes tabs in the 
Inspector reveal small round lights, or LEDs, to the left of all attributes that can be 
modified in an effect. The LEDs serve three purposes:
Â They indicate which parameters in the tab are active in the selected effect, allowing 
you to see the pertinent values at a glance.
Â They allow you to activate a new parameter for an effect.
Â They let you apply an attribute evenly across all keyframes in the effect. This is a very 
useful feature, as it lets you make global changes to an effect without having to 
select and modify each keyframe.
To apply an attribute evenly across all keyframes in an effect:
1 Select the effect.
2 Change an attribute in the Text, Style, or Attributes tab.
3 Hold down the Option key and click the LED indicator next to the attribute you 
just changed.Chapter 7    Working With Effects and Keyframe Animation 97
Active Parameters
The Active Parameters area of the Effects tab of the Inspector is a valuable resource for 
identifying which parameters are active in an effect, and what their values are at any 
point in time, as defined by the playhead position.
Active parameters are displayed with the values associated with the current frame. 
Parameter variables are further described in Appendix B, “Creating and Editing 
EffectScripts,” on page 135.
To change a parameter value in the Effects tab:
1 Select a keyframe.
2 Double-click a parameter in the Active Parameters stack. 
3 Enter a value in the parameter dialog, then click OK.
Note:  If you change a parameter when the playhead is not at a keyframe, a keyframe is 
added to the effect at the playhead position.
The Parameter pop-up menu lists all of the keyframe parameters. 
To add a new parameter to the Active Parameters stack of an effect:
1 Select the effect.
2 Do one of the following:
Â Click the LED next to the parameter in the Text, Style, or Attributes tab of the 
Inspector. The selected LED illuminates.
Â In the Effects tab of the Inspector, make a selection from the Parameter pop-up 
menu and click the + button. The parameter appears in the Active Parameters stack.
Â Change the parameter for one keyframe in the Text, Style, or Attributes tab of 
the Inspector.
Â Add Offset, Rotation, or Scale to the stack by modifying a glyph of the active track 
using the bounding box handles or dragging the glyph to a new position.98 Chapter 7    Working With Effects and Keyframe Animation
Example:  Modifying an Effect
The following example shows how easy it is to change an effect and create a 
dramatically different look. In this case, you want to add motion to the Fade In effect.
1 Set up a new project as follows:
a Choose File > New.
b Type “Adventure” into one of the text-entry boxes in the Inspector to add the word to 
the track.
c Apply any system font to the track, for simplicity.
d Set the Render Selection Out Point by positioning the playhead at one second, then 
pressing the O key.
2 Apply the Fade In effect to the track, which is in the Fades category in the Effects tab of 
the Media Browser. Notice the following changes:
Â The effect is immediately represented in the Live Wireframe Preview of the Inspector.
Â If your playhead is on the first frame, the text disappeared in the Canvas when you 
applied the effect. That’s because the Fade In effect begins with an opacity of 0. 
3 If your playhead is not at the first frame, move it there.
For this example, start
with a simple text track
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4 In the text-entry box of the Inspector, highlight the “A” of Adventure.
Even though the text is invisible in the Canvas, a bounding box appears, allowing you 
to adjust the glyph. Notice also that the first keyframe of the effect is now at the first 
frame, with the sequencing markers behind, representing the other letters in the word. 
5 Modify the glyph in the Canvas as follows, and watch the results in the Live Wireframe 
Preview as you go:
a Drag the sizing handle in the upper-right corner of the bounding box to make the 
glyph quite large, about one-third of the width of the Canvas.
b Using the rotation handle in the upper-left corner of the bounding box, tilt the glyph 
about 45 degrees counterclockwise.
c Drag the glyph so its pivot point is in the lower-left corner of the Canvas, allowing 
part of the glyph to extend off the Canvas.
Make sure the
playhead is on
the first frame.
Position the Render Selection
Out Point at one second.
Sequencing markers representing the
end of the effect for each remaining
letter in the word.
Duration of the
Fade In effect on
the “A” glyph
Resize, rotate,
and reposition the
bounding box of
the “A” glyph.
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The stack (in the Effects tab of the Inspector) has been changed automatically. The 
Scale, Rotate, and Offset parameters now apply to this effect, in addition to the original 
Opacity parameter.
6 Click the Play button in the Canvas or press the Space bar to play a RAM preview.
Moving, Deleting, Adding, and Copying Keyframes
The more you experiment with effects, the more you’ll want to create and change 
them to suit your own tastes. For example, you can change the placement of keyframes 
in an effect to make it play out differently. Or you can add or delete a keyframe entirely.
To move the position of a keyframe in the Timeline:
m Drag the keyframe marker left or right within the effect bar. 
To delete a keyframe:
1 Select the keyframe you want to remove.
2 Choose Track > Delete Keyframe. 
Note:  If you select a keyframe and press the Delete key, the entire effect is deleted.Chapter 7    Working With Effects and Keyframe Animation 101
To add a keyframe to an effect:
1 Select the effect you want to add a keyframe to.
2 Drag the playhead to the frame where you want to insert a keyframe, or click that 
frame’s position in the frame ruler.
3 Do one of the following:
Â With the playhead in position and the effect selected, choose Track > Add Keyframe 
(or press Command-K). 
Â Change any parameter in the Text, Style, or Attributes tab of the Inspector, or adjust a 
glyph of the active track using the bounding box handles or dragging the glyph to a 
new position.
A keyframe marker appears in the effect bar.
To copy a keyframe:
1 Select the keyframe you want to copy, then choose Edit > Copy.
2 Position the playhead over the frame where you want to insert the duplicate keyframe, 
then choose Edit > Paste.
You can copy and paste keyframes from other effects, even in other projects.
Copying and Pasting Keyframes, Effects, and Tracks 
Between Projects
You can easily copy and paste keyframes, effects, and tracks from one project 
to another.
To copy and paste a keyframe between projects:
1 Open the project you want to copy the keyframe from.
2 In the Timeline, do one of the following:
Â Select a keyframe, then choose Edit > Copy Keyframe (or press Command-C).
Â Control-click the keyframe, then choose Copy Track, Copy Effect, or Copy Keyframe 
from the shortcut menu.
3 Open the second project, and in the Timeline, position the playhead where you want 
the new keyframe to appear.
4 Do one of the following:
Â Choose Edit > Paste (or press Command-V).
Â Control-click the track, then choose Paste from the shortcut menu.
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To copy and paste effects or tracks between projects:
1 Open the project you want to copy from.
2 In the Timeline, do one of the following:
Â Select the effect or track, then choose Edit > Copy (or press Command-C).
Â Control-click the effect or track, then choose Copy Track or Copy Effect from the 
shortcut menu.
3 Open the second project, click in the Timeline, then do one of the following:
Â Choose Edit > Paste (or press Command-V).
Â Control-click a track, then choose Paste from the shortcut menu.
The new effect or track is copied into the second project.
Renaming and Saving Modified Effects
When you change an effect in a LiveType project, it no longer has the same attributes 
as the preset effect accessed through the Media Browser. You might even use different 
versions of the same preset effect in one project. There are two ways to keep track of 
these changes:  rename effects within your project to distinguish them from the 
original preset effects, or save them as new effects you can use any time.
To rename an effect within a project:
1 Select the effect or the track it’s applied to.
2 Click the Effects tab of the Inspector.
3 Select the effect whose name you want to change, and edit the name.
The new name is reflected in the Timeline.
To save a new or modified effect:
1 Select the effect.
2 Choose Track > Save Effect.
3 In the Save Effect dialog, name the effect and select the category you want to save it 
into, or create a new category. 
The effect appears in the Effects tab of the Media Browser.
Note:  For the Media Browser to display a preview of the saved effect, you must create a 
preview clip at 160 x 120 pixels, and give it the same name as the effect with the 
appropriate extension. Preview clips can be in any QuickTime format, but if you’re 
planning to create a lot of these, MPEG-4 is a good format choice, as it saves 
considerable disk space. Save preview clips into the Effects folder located at /Library/
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Creating a New Effect From Scratch
Sometimes the most efficient way to create the effect you want is to start from scratch, 
as opposed to changing an existing one. 
The workflow goes like this:
1 Decide, roughly, what you want to animate and how you want it to move and 
transform. 
2 Create a track that contains the element you want to animate, preferably in its firstframe state.
3 Configure the timing of the track—its starting frame and duration.
4 Add a new, blank effect to the track.
5 Add keyframes to the effect, and adjust the parameters for each.
6 Save the effect, if desired, for use with other tracks or in other projects.
To add a new, blank effect to a track:
1 Select the track you want to add the effect to.
2 Choose Track > New Effect (or press Command-E). 
A new effect appears in the Timeline below the active track.
3 Name the new effect, if you want, by double-clicking the New Effect name in the 
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Example:  Creating a New Effect
The following example demonstrates how to build a new effect. In this case, part of the 
text on a single track will bounce around the Canvas. 
This example highlights how motion paths are built into an effect.
1 Start a new default project, and add a few words of text to the empty track in any font. 
One of these words is going to move around the screen, independent of the other 
word(s) on the track.
2 Position the track in the Canvas as you like. This will not affect the movement of the 
bouncing word.
3 Set the duration of the track by dragging its right edge in the Timeline. Two or three 
seconds is plenty. 
4 Create a new, blank effect, which enables you to apply movement to the text. Make the 
effect duration match the track duration in the Timeline.
5 Now, even before you build the effect, make it apply to only one word on the track. 
That is, turn off the effect, as described in “Preset Effects” on page 88, for the words 
that won’t be moving.
6 Add the first of three or four keyframes spaced evenly across the effect.
a Click in the frame ruler to position the playhead.
b With the playhead in position and the effect selected, choose Track > Add Keyframe 
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7 The next step is to position the word at the point of its first “bounce.” You’re adding x 
and y offset parameters to the effect.
a With the keyframe selected, select one of the letters you want to move. A bounding 
box appears around it.
b Drag the letter to a new position in the Canvas. The entire word, or all the letters that 
the effect applies to in this case, moves with the selected letter. Notice that the 
motion path appears.
c If you like, change the size, color, or any other attribute of the text for this keyframe.
8 Create a second keyframe, and drag the text to another location. Now the motion path 
is a triangle. Create a few more “bounces” for the word.
Motion paths can also be curves. The process is similar to creating curved tracks as 
described in Chapter 4, “Working With Tracks,” on page 47.
9 Add curves to your motion path by doing the following:
a With the effect selected in the Timeline, click a keyframe, or move the playhead over 
a keyframe.
b Select one glyph in the “bouncing” word.
c Hold down the Control key and drag the pivot point of the glyph, which is over the 
keyframe point in the motion path.
Keyframe point
Motion path of
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d Bezier handles extend away from the point, allowing you to adjust the curve. 
10 Click Play in the Canvas, or press the Space bar, to see the results.
Creating Effects for Individual Glyphs
A unique and powerful feature of LiveType lies in the ability to instantly assign an effect 
to individual or selected groups of glyphs, or characters, on a track. This method can be 
used with new effects, as well as preset effects.
To assign an effect to individual characters:
m Select the character or characters you want to apply the effect to, then do one of the 
following:
Â Choose a preset effect from the Effects tab of the Media Browser, then click Apply.
Â Create your own effect by choosing Track > New Effect, then applying effects from 
the parameter menu in the Effects tab of the Inspector. 
The selected effect is automatically turned off for all characters that are deselected. If 
the track is selected and no characters are selected, the effect is applied to the entire 
group of characters on the track. You can reassign all characters to a single effect at 
any time. 
Hold down the Option key and
drag a keyframe point to pull
out Bezier handles, creating a
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Finding Effects and Media Using the Timeline
You can quickly find effects, movies, and images from the Timeline using a 
shortcut menu.
To find effects and media using the Timeline:
m In the Timeline, Control-click a track, then do one of the following:
Â To find effects, choose Reveal in Media Browser from the shortcut menu.
Â To find movies or images, choose Reveal in Finder from the shortcut menu.
The effect is selected in the appropriate tab in the Media Browser, or a Finder window 
appears with the movie or image selected.8
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8 Previewing and Fully Rendering 
Your Titling Movie
As your project progresses, you’ll want to view the results 
of your changes every step of the way, until you’re ready 
to generate the final output. 
LiveType offers several modes and choices for managing the time it takes to 
render previews. 
Previewing Your Work
Viewing a frame of your titling movie is as simple as moving the playhead in the 
Timeline to any frame marker and looking at the Canvas elements. Obviously, you also 
need to be able to see the action of your movie. LiveType offers several ways to do this.
Live Wireframe Preview
The Live Wireframe Preview window in the upper-right corner of the Inspector 
continually scrolls through your animation, with small bounding boxes indicating the 
movement of each character or object. This feature gives you an indication of your 
project’s motion and timing at any moment. 
To freeze or unfreeze the Live Wireframe Preview:
m Click inside the Live Wireframe Preview window in the Inspector.
Live Wireframe Preview 
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RAM Preview in the Canvas
The transport controls at the bottom of the Canvas allow you to play a preview of 
your titling movie right in your working environment. A RAM preview displays all 
elements that are visible and enabled in the Canvas, as well as the Canvas guides, 
rulers, and so on. Thus, it differs from a preview movie, which reflects the final movie 
output more closely.
To play a RAM preview, do one of the following:
m Click the Play button in the transport controls at the bottom of the Canvas. 
m Press the Space bar.
At first, the frames are rendered and loaded into memory one by one; then the preview 
plays in real time. The Pause button is displayed during this process.
The right-most transport control, the Loop button, is a toggle that sets the RAM 
preview to either play once through or continually loop through the movie. When the 
Loop button is activated, or blue, the RAM preview loops until you click anywhere in 
the LiveType interface.
To stop a looping RAM preview:
m Click anywhere in the LiveType interface.
To pause a RAM preview:
m Click the Pause button at any time during a RAM preview.
The Play button appears and the RAM preview stops. The RAM preview resumes when 
you click the Play button once more. 
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Preview Movie
A preview movie is basically a limited render of your titling movie.
To render a preview movie:
1 Choose File > Render Preview, then choose Wireframe or Normal.
The Normal setting renders your preview at the level defined in the Project Properties 
dialog. LiveType looks for the .afd files in your /Library/Application Support/LiveType/
LiveType Data folder if you have used any LiveType media in your composition. If the 
data files have not yet been installed, the Missing AFD dialog appears, giving you the 
option to install the full data files or to use proxy frames (from the corresponding .afp 
files) in the preview. 
2 Do one of the following:
Â Select “Install missing LiveType Data now.”
This allows you to install the .afd files at a location other than the LiveType Data 
folder, but still access them to render previews and final movies. See “Managing 
LiveType Media Files” on page 29 for instructions.
Â Select “Use Poster Frames for Tracks with missing Data.”
The preview appears in a separate window. You can save a preview movie by 
choosing File > Save As. Otherwise, LiveType deletes the preview movie when you 
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Optimizing Preview Performance
LiveType works with bitmapped elements that consist of pixels of information, as 
opposed to vector-based data. While this format is what makes possible the wide range 
of effects offered in LiveType, file sizes are inevitably large, and the time it takes to 
render a preview can become lengthy. 
Rendering time is affected by each layer of complexity added to a project, including 
the number and file size of project elements, the number of effects applied to each 
element, and the duration of the movie (that is, the number of frames to render).
Quality Settings for Previews and Movie Output
LiveType offers four levels of rendering quality, set in the Project Properties dialog, to 
help you manage the amount of time you spend generating previews. Naturally, a 
lower-quality preview takes less time to render. 
A wireframe-quality preview represents each element as an empty bounding box, 
much like the small Live Wireframe Preview in the Inspector. Draft, Normal, and High 
Quality settings differ only in the resolution of the preview. A draft-quality Canvas 
appears slightly grainy at 100 percent zoom. A draft-quality preview movie appears 
small on the screen.
You may find that, as you build your project, it is useful to adjust the quality settings 
several times, to suit your preferences.
To adjust the quality settings for viewing the Canvas, generating preview 
movies, and rendering a final movie:
1 Choose Edit > Project Properties.
2 In the Quality area of the dialog, choose the quality level for each of the three modes.Chapter 8    Previewing and Fully Rendering Your Titling Movie 113
Strategies for Improving Render Times
In addition to the quality settings, LiveType offers numerous strategies to avoid 
excessive waiting for frames and previews to render: 
Â The Render Selection markers in the frames ruler of the Timeline limit the number of 
frames that are rendered in preview movies and in the final output.
Â The Selected Only option in the View menu reveals only the contents of the active 
track in the Canvas, in preview movies, and in final movie output. This can be useful 
when you’re focusing on the movement of a single element.
Â The Enable/Disable buttons in the Timeline allow you to temporarily disable effects 
and remove tracks from the Canvas. This is another way to reduce complexity when 
you only require a partial preview.
Â The file size of imported elements affects system performance. For example, instead of 
importing a large movie as a background for keying titles, consider importing a 
single frame or small clip. If an imported element is to be used in your final output, 
generate the original file at or near the needed resolution, as opposed to bringing in 
a large image and shrinking it down in LiveType.
Â The amount of RAM memory on your system may be a factor. If saving time is critical, 
you may want to consider increasing your available RAM.
Rendering, Saving, and Exporting Your Titling Movie
There are a couple of different ways to handle rendering, saving, and exporting your 
LiveType project once you have completed it. The most practical method to choose 
largely depends on whether you are going to work with your project within 
Final Cut Pro or in another application.
Â If you are working with Final Cut Pro, import the LiveType project directly into 
Final Cut Pro for final rendering. 
Â If you are working with another application, render within LiveType first, then import 
the rendered movie to the application.
Importing a LiveType Project Into Final Cut Pro for Rendering
Typically, a saved LiveType project file is imported into Final Cut Pro for rendering. This 
saves time as, unlike third-party applications, you do not have to render the file in 
LiveType prior to importing it.
To import a LiveType project into Final Cut Pro for rendering:
1 Choose File > Import > Files (or press Command-I), select the LiveType project file, then 
click Choose.
The LiveType movie is imported into Final Cut Pro, appearing as a clip.
2 Edit the clip into a Final Cut Pro sequence. 
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Making Changes to a LiveType Movie from Final Cut Pro
If you have imported a LiveType movie into Final Cut Pro and need to make a change, 
you can make the change in LiveType and have it update in Final Cut Pro.
To make changes to a LiveType movie already imported into Final Cut Pro:
1 Select the LiveType clip in the Final Cut Pro Timeline.
2 Control-click the clip, then choose > Open in Editor from the shortcut menu.
LiveType opens with the movie ready for adjustment.
3 In LiveType, make any changes you want, then choose File > Save.
The change immediately updates in Final Cut Pro.
Note:  You will have to re-render any changes that you have made within Final Cut Pro.
Rendering a LiveType Movie for Export
When working with a third-party application, you will need to render your movie 
within LiveType prior to importing it.
To render a full-resolution movie of your project for export:
1 Choose File > Render Movie.
2 Choose a filename and location in the Save dialog, then click “Create new movie file.”
3 Just as with preview movies, LiveType requests that you install any missing LiveType 
Data files. Do one of the following:
Â Select “Install missing LiveType Data now.”
This allows you to install LiveType media files to a location other than the LiveType 
Data folder, but still access them to render previews and final movies. See “Managing 
LiveType Media Files” on page 29 for instructions. 
Â Select “Use Poster Frames for Tracks with missing Data.”
Note:  By default, a QuickTime movie with an alpha channel is created in the Animation 
codec. If another codec is preferred, use the options from File > Export Movie instead.Chapter 8    Previewing and Fully Rendering Your Titling Movie 115
Once LiveType has finished rendering your project, it appears in a new window.
LiveType Export Formats
LiveType natively generates QuickTime movies with the Animation 32-bit codec for 
proper keying to your video. If your NLE or compositing program imports QuickTime 4 
or later movies, you should be able to import these movies directly. You can also export 
to a variety of motion and still-image formats. Keep in mind, however, that if you want 
to retain the alpha channel, you must use a format that supports the 32-bit format, 
such as Photoshop, Targa, TIFF, and AVI.  
Your rendered movie 
appears in a separate 
viewer. (In this example, 
the background movie 
was rendered with the 
titles.)
QuickTime 
codecs
QuickTime 
codecs (cont.)
Image sequence 
formats
Other 
formats
Animation Motion JPEGA BMP AVI
BMP Motion JPEGB JPEG DV Stream
Cinepak None (No compression) JPEG 2000 Image FLC
Component Video PhotoJPEG MacPaint Heuris MPEG
DV/DVCPRO-NTSC Planar RGB Photoshop MPEG-2
DVCPRO-PAL PNG PICT MPEG-4
Graphics Sorenson Video PNG
H.261 Sorenson Video 3 QuickTime image
H.263 TGA SGI image
Intel Indeo Video r3.2 TIFF TGA
Intel Raw Video TIFF116 Chapter 8    Previewing and Fully Rendering Your Titling Movie
To export a rendered LiveType movie to a new format:
1 Open your movie output so it appears in the viewer window. 
If you just rendered your project, the QuickTime movie will be open already. If you 
previously rendered and saved the movie, open it using File > Open.
2 Choose File > Export Movie. 
The dialog prompts you for a new name and file location, and offers a variety of file 
formats to export to.
3 In the Export pop-up menu, choose the category of output you want to create.
4 In the Use pop-up menu, choose the appropriate file format or protocol.
5 Click the Options button to reveal additional settings pertinent to the format 
you selected.9
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9 Advanced Design Techniques
The key to designing great titles is to combine the 
capabilities and media in LiveType in creative ways. A few 
“recipes” for interesting looks are included in this chapter.
The following examples assume a general familiarity with the basic functions of 
LiveType. Because each step is not explained in great detail, you may need to refer to 
earlier chapters to perform some of the tasks.
Words Within Words
The Matte to Background option can be used to create some very interesting titling 
compositions. Unlike Matte to Texture and Matte to Movie or Image, this matting 
option creates a “window” into any background—even backgrounds composed of 
several elements.
For example, you can create words inside of words. In this case, foreground text defines 
a window into background text, which slides right to left behind it. Follow these steps:
1 Create the foreground text to define the shape of the matte.
a Add a text track in a heavy system font such as Helvetica Bold.
b Type a word onto the track, then set the size so the word fills the width of the Canvas.
2 Create an intermediate layer to obscure the background. 
a Choose a texture from the Media Browser, then click Apply To New Track.118 Chapter 9    Advanced Design Techniques
b Make sure the texture is underneath the text, but above the background bar in 
the Timeline.
3 Create a dynamic background that’s visible through the window created by the 
foreground word.
a Add a new text track to the Canvas, then enter some text that’s smaller than the 
foreground word you created in step 1.
b Position the track over the foreground text, and format the background text as 
you like.
c Apply a crawl or slide effect to the track, to make the text move right to left.
d Drag the track below the background bar in the Timeline.
e Temporarily disable the texture and the foreground text track in the Timeline.
f Define a background color in the Project Properties dialog, or place a different 
background behind the background text.
g Enable the texture and the foreground text track in the Timeline.
Foreground text to define
the shape of the “window”
into the background
Texture to obscure the
background elements
Background elements
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4 Select the foreground text and choose Background from the “Matte to” pop-up menu 
in the Matte pane of the Attributes tab of the Inspector.
Warping Shadows and Glows
The Warp feature in the Style tab of the Inspector can be used to create a surprising 
variety of shapes to enhance your titles. This section describes how the Needle Drop 
effect takes advantage of the Warp parameter, in combination with several other 
parameters, to create a unique look. 
1 Open a new project, and enter some text in a system font onto the track.
2 Change the text to a bright color in the Glyph pane of the Attributes tab of the 
Inspector, then close the Colors window.
3 In the Project Properties dialog, change the background color to black, at 100 
percent opacity.
Matted text reveals a
moving word in the
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4 Apply the Needle Drop effect to the track, which is in the Glows category in the Effects 
tab of the Media Browser.
5 Set the track and effect durations to 1 second, set the Render Selection Out Point at 1 
second, then click the Play button to render a RAM preview.
6 With the playhead over the effect in the Timeline, click the Effects tab of the Inspector 
to view the active parameters.
The essential parameters used to create the Needle Drop effect are as follows:
Â Glyph settings:  At the beginning keyframe, the glyphs on the track are small, 
transparent, and blurred. At the ending keyframe, the characters are normal. The 
middle keyframe simply makes the letters larger than normal.
Â Glow settings:  At the beginning keyframe, the glow is invisible, with a 0 percent 
opacity, and has a vertical offset of –200 pixels. At the middle keyframe, the glow 
opacity is set at 500 percent, with some Scale and Blur adjustments and no offset. 
And at the ending keyframe, the glow is invisible again, and the vertical offset is 
200 pixels.
Â Shadow settings:  The shadow is what creates the “needles.” The shadow color is set to 
white, and the scale is set to 10 percent on the x axis, making the shadows very thin. 
The warp settings accentuate the narrow tips of the needles. And the shadow blur is 
set to 2 percent, which is essential for this effect. At the ending keyframe, the 
shadow goes to 0 percent opacity.
Â Timing settings:  The Random parameter in the Timing tab is used to make this effect 
apply to each glyph in a random order.
The Needle Drop effect
applied to text on a black
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One track, one effect, three keyframes—it’s actually fairly easy to re-create this effect. 
And even with the numerous parameters involved, the LiveType Timeline is remarkably 
clean, since one keyframe encapsulates all the parameters at a point in time.
For another example showing an effective use of Warp parameters, take a look at the 
Screech effect, in the Caricature category of the Effects tab in the Media Browser. This 
effect is created by making the glyphs invisible and using the glow channel to display 
the letters, which are distorted using Warp parameters.
Track Curves
Using a Slide effect along a curved track can create a three-dimensional effect. 
This example explains how to combine these features to send text into a vortex in only 
a few steps.
1 Open a new project, and enter some text onto the track.
2 Left-justify the text on the track.
3 Move the track up toward the top of the Canvas.
4 Add a control point in the middle of the track by holding down the Control key and 
clicking the track line in the Canvas. Control-click the control point to choose Curve Out.
You want to leave the left half of the track more or less in the same position, and create 
a curved path arcing down and around clockwise from that point. Only a couple of 
additional control points are needed. See Chapter 4, “Working With Tracks,” on page 47 
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5 Add a new effect to the track.
6 Select the ending keyframe of the effect.
7 In the Effects tab of the Inspector, add the Slide parameter to the Active Parameters 
stack. Double-click the Slide parameter and set the value to 100, which is a percentage 
of the track’s length.
When you assign the Slide value to the ending keyframe, the beginning keyframe 
defaults to a Slide value of 0.
8 While you’re still on the ending keyframe, set the Size parameter to 0.
9 In the Timing tab of the Inspector, set the Sequence value to 10, and choose From Right 
from the Start pop-up menu.
Add parameters using the
Parameter pop-up menu and
the + button.
Change parameter values by
double-clicking an active
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10 Adjust the ending keyframe Slide value as needed for the right look, which can vary 
depending on the length of the track and the text sliding on it. 
Creative Use of Special Characters
Symbols and other kinds of special characters can be very useful and convenient as 
titling elements. Because these characters are vector-based shapes, they have very 
small file sizes, and no upper limit to their size in the Canvas. Plus, they’re easy to access.
This example shows you how to create a pattern of boxes, covering the Canvas, which 
randomly change colors and fade away to reveal a message or image behind them.
1 Open a new LiveType project, and click in one of the text-entry areas.
2 Open the Character Palette.
Â If your Character Palette is enabled in your Mac OS X System Preferences, it appears 
as a small icon on the right side of the LiveType menu.
The text appears to spiral
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Â To enable the Character Palette, open System Preferences, click International, click 
the Input Menu button, and select Character Palette.
Â Alternatively, in LiveType, you can Control-click inside one of the text-entry boxes in 
the Inspector, then choose Font > Show Fonts from the shortcut menu. The Font 
dialog appears. Choose Characters from the Extras pop-up menu located on the 
bottom-left corner of the Font dialog.
3 Choose a solid square character, then click Insert to add the character to the text-entry 
box. Insert three lines of four boxes on the same text track.
Enable the Character
Palette in your System
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4 Adjust the Size, Tracking, and Leading parameters in the Text tab of the Inspector to 
create a panel of evenly spaced squares.
5 In the Style tab, disable the shadow, and add a white outline thick enough for the 
outlines of each square to touch each other, obscuring the Canvas background.
6 Add a new effect, and set the duration of both the track and the effect to 1 second in 
the Timeline.
7 Select the beginning keyframe of the effect, and choose a glyph color in the Attributes 
tab of the Inspector. Change the ending keyframe to a different color. Then position the 
playhead at several intermittent points, changing the color each time.
If you change an effect parameter when the playhead is not on a keyframe, a new 
keyframe is automatically added to the effect under the playhead. This step shows how 
automatic keyframe insertion can be a convenient time saver.
8 Set the glyph opacity to 0 percent at the ending keyframe, so that squares fade out at 
the end.
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9 In the Timing tab, set the Random setting to 15.
10 Add text or another element behind the panel of squares, so it is gradually revealed as 
the squares fade away.
LiveFonts and Layers
Several LiveFonts that come with LiveType are designed to work in tandem with other 
fonts. One of these is the Nitro font, which can make text look like it explodes. These 
steps explain how to use such fonts effectively.
Note:  You need to install the Nitro data file to follow this example. See “Managing 
LiveType Media Files” on page 29 for information on installing LiveType media.
1 Create a text track, and apply a system font with any basic formatting you like.
2 Choose Track > Duplicate Track to create a copy positioned directly over the 
original track.
3 In the Timeline, lock the two tracks together using the grouping buttons.
4 Select Track 1, and apply the Nitro LiveFont.
5 In the Style tab of the Inspector, disable the shadow for Track 1.
6 In the Timing tab, set Sequence at 5 percent, then shorten the duration of the track, 
either by dragging the end of the track in the Timeline or by adjusting the Speed 
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7 Apply the Fade Out effect to Track 2, since you want the letters to disappear once 
they’ve exploded.
The trick is that you want the letters to fade out just as they explode, and because they 
are exploding in sequence, you need to align the timing of the sequencing markers for 
the two tracks.
8 Using the sequencing markers in the Timeline as your guide, adjust the speed of the 
Fade Out effect to line up the sequencing markers of Track 1 and the Track 2 effect.
Align the sequencing markers of the 
Nitro LiveFont and the Fade Out effect.
The combination of the top layer
of text in the Nitro LiveFont, and
the underlying text that fades
away, makes the letters appear 
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Creating Scrolls and Crawls
Scroll and crawl effects are used to create credit rolls, or to slide strings of text across 
the screen like a stock ticker. These two kinds of effects use the Canvas Offset 
parameter to create a vertical or horizontal motion path long enough to move text 
onto the Canvas and fully off the opposite side. 
The offset value, which defines the length of the motion path, is based on the length of 
the element that’s scrolling or crawling. So it’s best to enter and format the text before
applying the effect, so you don’t have to reposition the starting point of the element 
multiple times.
Note:  From a design standpoint, scrolls and crawls are best used with system fonts, as 
opposed to LiveFonts. If you do choose to scroll a LiveFont, you’ll need to work with 
the font’s timing parameters, including speed and the Hold First and Hold Last options 
in the Timing tab of the Inspector, to coordinate the LiveFont animation with the 
scrolling or crawling movement.
To create scrolling text:
1 Enter several lines of text onto a new track, using the Return key to create line breaks in 
the text-entry box.
2 Format the text, paying particular attention to any parameter affecting the total vertical 
length of the lines of text—font, size, leading, and so on.
3 Apply a scroll effect from the Scrolls and Crawls category in the Effects tab of the 
Media Browser.
4 Adjust the speed of the scroll, which is now visible in the Live Wireframe preview, by 
dragging the right edge of the effect bar in the Timeline, or by changing the Speed 
setting in the Timing tab of the Inspector.
5 In the Timeline, drag the right edge of the track to match the duration of the effect.
6 Move the text to its starting position.
a Make sure the playhead is over the first frame in the Timeline.
b Set the Canvas zoom to 25 percent, to see outside the boundaries of the Canvas.
c Drag the track in the Canvas to set the starting position of the scrolling text. (Text 
that is beyond the edge of the Canvas is represented by blue bounding boxes.) Hold 
down the Shift key as you drag to constrain the horizontal position of the track.
If you are using the Scroll Up effect, for example, you might want to set the starting 
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To create crawling text:
1 Enter text—typically several words or a sentence on one line—onto a new track.
2 Format the text, paying particular attention to any parameter affecting the total 
horizontal length of the text—font, size, tracking, and so on.
3 Apply a crawl effect from the Scrolls and Crawls category in the Effects tab of the 
Media Browser.
4 Adjust the speed of the crawl, which is now visible in the Live Wireframe preview, by 
dragging the right edge of the effect bar in the Timeline, or by changing the Speed 
setting in the Timing tab of the Inspector.
5 In the Timeline, drag the right edge of the track to match the duration of the effect.
6 With the playhead over the first frame, drag the track in the Canvas to adjust its 
starting position.      131
A Appendix
A Solutions to Common Problems 
and Customer Support
If you run into problems while working with LiveType, there are several resources you 
can use to find a solution.
Â This appendix:  This appendix includes information about some of the most frequent 
issues users encounter.
Â Late-Breaking News:  A late-breaking news page in the LiveType Help menu provides 
last-minute information that didn’t make it into the manual. Be sure to consult this 
help page as soon as you install LiveType.
Â AppleCare Knowledge Base:  AppleCare Support maintains a database of common 
support issues that is updated and expanded to include new issues as they arise. This 
is an excellent, free resource for LiveType users. To access the AppleCare Knowledge 
Base, go to the AppleCare support page at http://www.apple.com/support.
Â AppleCare Support:  There are a variety of support options available to LiveType 
customers. For more information, see the Apple Professional Software Service & 
Support Guide that comes with your Final Cut Pro documentation.
Frequently Asked Questions
Some fonts appear to shake in the preview movie.
Â Because LiveType uses a small sampling for low-quality previews, some images may 
be missing pixel data that provides smoother movement. Increase your quality 
settings in the Project Properties dialog to produce smooth results.
My images appear pixelated.
Â If you render a preview, your movie is displayed in low resolution and appears a bit 
pixelated. Also, if you size your elements beyond their original size, some pixelization 
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LiveType doesn’t open anymore.
Â It is possible to save a set of default settings that prevents LiveType from opening. 
Try erasing your default settings file:  /Library/Preferences/LiveType Pro 
Defaults.dat. Your configuration reverts to the original LiveType settings. This is 
essentially the same as choosing LiveType > Settings > Clear Settings within 
the application.
The motion is not smooth on my NTSC monitor.
Â Use the fielding option for the smoothest motion.
When I bring titles into my nonlinear editor (NLE) or compositing program, the 
characters appear squashed or the aspect is wrong.
Â Make sure to set the project properties in LiveType according to the size and pixel 
aspect your NLE uses. Some NLEs require the correct frame size even if the title 
doesn’t use the entire frame. Square pixels take a value of 1, and NTSC pixels take a 
value of .9.
A keyframe is “stuck” at the beginning or end of an effect, and I can’t select it, 
move it, or delete it.
Â Try increasing the Timeline zoom, to see whether you can select and drag the 
keyframe away from the beginning or end of the effect.
Because the beginning and ending keyframes cannot be deleted, it is possible to 
slide an internal keyframe to the far end of the effect so that it cannot be moved, 
regardless of the Timeline magnification. 
To select an obscured keyframe, do the following:
1 Select the beginning or ending keyframe that’s obscuring the other keyframe.
2 Choose View > Go To > Next Keyframe (or Previous Keyframe) to select the “lost” 
keyframe.
3 Choose Edit > Cut.
4 Move the playhead and choose Edit > Paste.
When I apply an effect with a glow or shadow change, I don’t see a change in 
the Live Wireframe Preview in the Inspector.
Â The wireframe boxes in the preview show the basic shape of each glyph, and aren’t 
changed by Style settings. Other preview options, such as a RAM preview or preview 
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When I change certain attributes of a track, they don’t seem to have any effect.
Â Because effect parameters override track parameters, you may be trying to adjust a 
parameter that is being overridden. Disable the effects associated with that track to 
see whether the attributes become active again. If so, the solution is to change the 
effect parameters.
I can’t select an element or character.
Â Make sure that Lock Position is not selected in the Layout menu. When you add a 
texture or background movie, it is locked by default.
Â Also, you may be clicking an element that uses the entire Canvas. Try zooming out to 
view beyond the edge of the Canvas to reveal its bounding box.
Â Consider the layer order, too, when you want to select an element on the Canvas. If 
one element gets in the way of selecting another, use the Timeline to select the track 
underneath, and highlight glyphs in one of the text-entry boxes in the Inspector.
I keep accidentally selecting the texture, image, or movie I created on a track 
as a background image.
Â Choose Layout > Lock Position to prevent the element from being selected.
When I have a lot of elements in the Canvas, everything slows down.
Â See Chapter 8, “Previewing and Fully Rendering Your Titling Movie,” on page 109 for 
ways to optimize preview performance.
Apple Applications Page for Pro Apps Developers
The Apple Developer Connection website includes an Apple Applications page that is a 
one-stop destination for developers creating content or extensions for professional 
applications. On this page, developers can find late-breaking news of interest and 
technical resources such as developer documentation, special articles, and SDKs. 
Developers can also sign up for a new Pro Apps Developer mailing list. The URL is 
http://developer.apple.com/appleapplications.
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Calling AppleCare Support
Included in your LiveType package is documentation about the support options 
available from Apple. Several levels of support are available, depending on your needs.
Note:  There are certain support situations in which AppleCare may require information 
about both your computer and how this particular application is configured. Choosing 
Help > Create Support Profile creates a file that contains the necessary information and 
can be emailed to AppleCare. You would not normally use this feature unless directed 
to by an AppleCare representative.
Whatever your issue, it’s a good idea to have the following information immediately 
available. The more of this information you have ready to give to the support agents, 
the faster they will be able to address your issue.
Â The Support ID number that came with Final Cut Pro. This number is different from 
the software serial number that is used to activate your copy of LiveType.
Â Which version of Mac OS X you have installed. This information is available by 
choosing About This Mac from the Apple menu. 
Â The version of LiveType you have installed, including updates if applicable. The 
version number can be viewed by choosing LiveType > About LiveType.
Â The model of computer you are using
Â How much RAM is installed in your computer, and how much is available to LiveType. 
You can find out how much RAM is installed by choosing About This Mac from the 
Apple menu in the Finder. 
Â What other third-party hardware is connected to or installed in the computer, and 
who are the manufacturers. Include hard disks, video cards, and so on. 
Â Any third-party plug-ins or other software installed along with LiveType
AppleCare Support can be reached online at http://www.apple.com/support/livetype/
index.html.     135
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B Creating and Editing EffectScripts
Effects in LiveType are based on the EffectScript language. Effects consist of a plain text 
file and a representative QuickTime movie, which appears in the Media Browser in the 
LiveType interface. 
Each line of an EffectScript consists of a command followed by a set of command 
arguments. Tabs and spaces are skipped. In any command, two hyphens (--) can be 
followed by a comment. Comments are ignored by the EffectScript interpreter.
Header
The following header commands should appear at the beginning of each EffectScript.
EffectScript 1.0
Â Use 1.0. as the EffectScript specification version number.
Name "effect name"
Â Name the effect. Quotation marks can be any non-space delimiter (", ', /, and so on).
Desc "description"
Â Describe the effect. The description may be a long string; the text wraps 
when displayed.
Default Timing
After the header, an EffectScript should have default timing settings.
DefOffset a b c
Â a is a numeric value.
Â b is %, Seconds, or Frames.
Â c is Start or End.
DefReverse a
Â a is 0 for forward, or 1 for reverse.136 Appendix B    Creating and Editing EffectScripts
DefSequence a b c
Â a is 0 for Off or 1 for On.
Â b is a numeric % value, may be floating point.
Â c is L for left first, or R for right first.
DefRandStart a b c
Â a is 0 for Off or 1 for On.
Â b is a numeric value, may be floating point.
Â c is %, Seconds, or Frames.
DefLoop a
Â a is a numeric value, must be an integer (use a large number like 9999 to loop 
forever).
DefSpeed a
Â a is a numeric % value, may be floating point.
Keyframes
After the header, an EffectScript defines a number of keyframes. A keyframe starts with 
a Time command:
Time t
Â t is the time of the keyframe in seconds.
Each Time command is followed by parameter commands. For example, here is a 
keyframe:
Time 0.0
Scale 50
Track -50
This keyframe means that at time Zero seconds, each glyph scales by 50 percent, and 
its tracking decreases by 50 percent.
The first keyframe must be at time 0.0, and there must be at least one other keyframe 
after that. All keyframes must be listed in order. All keyframes in a given effect should 
have the same set of parameter commands.
The following parameter commands are valid in a keyframe:
Accelerate n
Â n is a percentage of acceleration. This affects how all the other keyframe parameter 
values are interpolated between this keyframe and the next. 0 means no 
acceleration, 100% means speed up, -100% means slow down.Appendix B    Creating and Editing EffectScripts 137
Blur x [y]
Â x is the blur radius in pixels. If y is given, then the horizontal and vertical blur 
amounts are distinct.
CanvasOffset x y
Â x and y are the horizontal and vertical offsets, in percentage of the Canvas 
dimensions.
This is the parameter used for scrolls and crawls.
Color r g b [n]
Â r, g, and b are color values, in [0..255].
Â n is optional, and is an opacity percentage.
DoExtrude x
Â x is 0 for no extrusion, 1 for extrude.
DoGlow n
Â n is 0 for No or 1 for Yes.
DoShadow n
Â n is 0 for No or 1 for Yes.
ExtrudeDirection n
Â n is an angle in degrees, 0 for up, 90 for right, and so on.
ExtrudeLength n
Â n is the extrusion length in pixels.
ExtrudeColor r g b
Â r, g, and b are the extrusion color, in [0..255].
ExtrudeOutline n
Â n is 0 for no outline, 1 to outline the extrusion.
GlowBlur n
Â n is the glow blur radius in pixels.
GlowColor r g b
Â r, g, and b are the glow color, in [0..255].
GlowLayer n
Â n is 0 for behind all, 1 is behind track, 2 is in front, 3 is in front matted to glyph.
GlowOffset x y
Â x and y are the glow offsets in pixels.
GlowOpacity n
Â n is the glow opacity percentage.138 Appendix B    Creating and Editing EffectScripts
GlowScale x y
Â x and y are the glow scale percentages.
GlowWarp x1 y1 x2 y2 x3 y3 x4 y4
Â x, y pairs are the four Warp points.
HideChar n
Â n is 0 for Show the glyph in addition to lighting effects (Outline, Shadow, Glow, 
Extrude), or 1 to Hide it.
HSL h s l
Â h is the hue angle adjustment in degrees; 0 means no change.
Â s is the saturation adjustment in percent; 0 means no change.
Â l is the lightness adjustment in percent; 0 means no change.
Leading n
Â n is a % that adjusts the position of the next line in the track (for example, use 0 to 
put the next line on top of this one, 100 to leave it unchanged, or 200 to double it).
Matte n
Â n is 0 or 1 for Off or On.
Offset x y
Â x and y are the horizontal and vertical offsets, in pixels.
Opacity n
Â n is the opacity percentage. This is multiplied by the glyph’s opacity.
Outline n
Â n is the pixel width of the outline.
Rotate n
Â n is the rotation angle, in clockwise degrees.
Scale x y
Â x and y are the horizontal and vertical scale percent multipliers. Scaling is done about 
the glyph pivot point.
SetOutlineColor r g b
Â r, g, and b are the outline color, in [0..255].
SetOutlineBlur n
Â n is a number of pixels.
SetOutlineOnly n
Â n is 0 for No or 1 for Yes.Appendix B    Creating and Editing EffectScripts 139
SetOutlineWarp x1 y1 x2 y2 x3 y3 x4 y4
Â x, y pairs are the four Warp points.
ShadBlur n
Â n is the shadow blur radius in pixels.
ShadColor r g b
Â r, g, and b are the shadow color, in [0..255].
ShadLayer n
Â n is 0 for behind all, 1 for behind track, 2 for in front, 3 for in front matted to glyph.
ShadOffset x y
Â x and y are the shadow offsets in pixels.
ShadOpacity n
Â n is the shadow opacity percentage.
ShadScale x y
Â x and y are the shadow scale percentages.
ShadWarp x1 y1 x2 y2 x3 y3 x4 y4
Â x, y pairs are the four Warp points.
Size n
Â n is percent modifier for the glyph size. This affects not only the size of the glyph but 
also the leading and tracking, which are based on the size. Glyphs are sized about 
the glyph center on the baseline.
Slide n
Â n is the amount an element slides along its track, in percent of the track’s length.
Tracking n
Â n is a % that adjusts the position of the next glyph (for example, use 0 to put the 
next glyph on top of this one, 100 to leave it unchanged, or 200 to double it).140 Appendix B    Creating and Editing EffectScripts
Sample EffectScripts
You can view an EffectScript simply by opening one of the effect files stored in the 
/Library/Application Support/LiveType/Effects folder of your hard drive. Some simple 
EffectScripts follow:
Zoom In
EffectScript 1.0
--------------------------------------------------------------------
-- "Zoom In" example
Name "Zoom In"
Desc "Zoom In each glyph linearly from zero to normal from its anchor point. 
Simultaneously increase the kerning from zero to normal."
DefOffset 0 % Start
DefSequence 0 0 L
DefRandStart 0 0 %
DefLoop 1
DefSpeed 100
Time 0.0
    Tracking -100    -- -100% tracking, means zero tracking.
    Scale 0 0        -- 0% scale
Time 2.0
    Tracking 0       -- 0% tracking, means normal.
    Scale 100 100    -- 100% scale.
--------------------------------------------------------------------
Zoom Out
EffectScript 1.0
--------------------------------------------------------------------
-- "Zoom Out" example
Name "Zoom Out"
Desc "Zoom Out each glyph linearly from normal to zero from its anchor point. 
Simultaneously decrease the kerning from normal to zero."
DefOffset 0 % End
DefSequence 0 0 L
DefRandStart 0 0 %
DefLoop 1
DefSpeed 105
Time 0.0
    Tracking 0
    Scale 100 100
Time 2.0
    Tracking -100
    Scale 0 0
--------------------------------------------------------------------Appendix B    Creating and Editing EffectScripts 141
Tinted Rotate
EffectScript 1.0
--------------------------------------------------------------------
-- "Tinted Rotate" example
Name "Tinted Rotate"
Desc "Rotate each glyph around its anchor point at 1 rev/sec. For fun, 
simultaneously mess around with the color"
DefOffset 0 % Start
DefSequence 0 0 L
DefRandStart 1 100 %
-- note large loopCount so that it will loop through the whole duration.
DefLoop 9999
DefSpeed 100
Time 0
   Color 255 0 0  -- Tint Red (R=255, G=0, B=0)
   Rotate 0
Time 1
   Color 0 255 0  -- Tint Green (R=0, G=255, B=0)
   Rotate 120
Time 2
   Color 0 0 255  -- Tint Blur (R=0, G=0, B=255)
   Rotate 240
Time 3
   Color 255 0 0  -- Tint Red (R=255, G=0, B=0)
   Rotate 0
--------------------------------------------------------------------     143
Glossary
Glossary
16:9   A widescreen aspect ratio for video. The ratio of the width to the height of the 
visible area of the video frame, also called the picture aspect ratio, is 16:9, or 1.78.
alpha channel  An additional image channel used to store transparency information for 
compositing. Alpha channels are often 8-bit, but some applications support 16-bit 
alpha channels. Only certain formats, such as PICT and the QuickTime Animation codec, 
support alpha channels.
aspect ratio  A video frame’s width-to-height ratio on your viewing screen. The most 
common aspect ratio is 4:3, used for common television screens.
AVI   Acronym for Audio-Video Interleaved, Microsoft’s standard format for digital video.
Bezier handles   Two-direction handles that control or influence the curve of the line 
segment between the handle and the next point on either side. The farther a direction 
handle is pulled out from its vertex point, the more force it applies to its line segment 
to bend or curve it. Direction handles are moved by dragging them.
bin   In Final Cut Pro, the window that contains your clips, transitions, effects, and 
generators. The bin lets you organize all of these elements, sort them, add comments, 
rename items, and so on.
Canvas   One of the four main windows in the LiveType interface, where you position 
text and objects, create motion paths, and view the results as you design.
channels   May refer to color channels or alpha channels. Color and transparency 
information for video and graphics clips is divided into individual channels.
CMYK   Abbreviation for Cyan Magenta Yellow Black. The color space commonly used 
for images that will be printed with 4-color ink on offset presses.
codec   Short for compressor/decompressor. A software component used to translate 
video or audio between its uncompressed form and the compressed form in which it is 
stored. Sorenson Video and Cinepak are common QuickTime video codecs. Also 
referred to as a compressor.144 Glossary
compositing   The process of combining two or more video or electronic images into a 
single frame. This term can also describe the process of creating various video effects.
compression   The process by which video, graphics, and audio files are reduced in size 
by the removal of redundant or less important data. See also codec.
decompression   The process of creating a viewable image for playback from a 
compressed video, graphics, or audio file.
digital   A description of data that is stored or transmitted as a sequence of ones and 
zeros. Most commonly, this means binary data represented using electronic or 
electromagnetic signals. QuickTime movie files are digital.
digital video   Refers to the capturing, manipulation, and storage of video using a 
digital format, such as QuickTime. A digital video camcorder, for example, is a 
videocamera that captures and stores images on a digital medium such as DV. Video 
can then be easily imported.
duration   The length of time that a track or effect exists in the Timeline.
DVD   A DVD disc looks much like a CD-ROM or audio disc, but uses higher density 
storage methods to significantly increase its capacity.
effect   In LiveType, a set of attribute and timing parameters that animate an element.
element   In LiveType, anything that is placed on a track:  an individual character, a 
block of text on a single track, an object, a movie, a texture, or an image.
field   Half of an interlaced video frame consisting of the odd or the even scan lines. 
Alternating video fields are drawn every 1/60th of a second in NTSC video to create the 
perceived 30 frames per second video. There are two fields for every frame, an upper 
field and a lower field.
FireWire   The Apple trademark name for the IEEE 1394 standard. FireWire is a fast and 
versatile interface used to connect DV cameras to computers. FireWire is well suited to 
applications that move large amounts of data, and can also be used to connect hard 
disks, scanners, and other kinds of computer peripherals.
font   A complete set of a single typeface. See also LiveFont.
frame   Video consists of a number of still-image frames which, when they play back 
over time, give the illusion of motion. NTSC video plays back 29.97 frames per second, 
and PAL video plays back 25 frames per second. Each broadcast video frame is made 
up of two fields, which is different from the way film handles frames. A film frame is a 
single photographic image, and does not have separate fields.
glyph   A single character on a track. A glyph frequently refers to a letter or symbol, but 
an object, texture, or imported element can also be referred to as a glyph in LiveType.Glossary 145
importing   The process of bringing files of various types into a project in LiveType. 
Imported files have usually been created or captured in another application.
Inspector   One of the four main windows in the LiveType interface, which is used to 
insert text and apply attributes, styles, and effect parameters to titling elements.
keyframe   A special-purpose marker that denotes a value change of one or more 
parameters in an applied effect. When two keyframes are set in LiveType, the 
application calculates a smooth transition based on their values. 
LiveFont   LiveFonts are sets of 32-bit characters. Most LiveFonts are computer-based 
animations. However, they may also be composed of video footage or still 
photographs. 
LiveType media    The collective term for LiveFonts, textures, and objects in LiveType, 
all of which are built using the 32-bit .afd format for animated fonts.
markers   In Final Cut Pro, markers refer either to the edit points that define the Start 
and End points of a clip, or to points of reference you can use to denote places of 
interest in your clips and sequences.
Media Browser    One of the four main windows in the LiveType interface, which is 
used for selecting fonts, objects, textures, and effects.
NTSC format   NTSC stands for National Television Standards Committee, the 
organization that defines North American broadcast standards. The term “NTSC video” 
refers to the video standard defined by the committee, which has a specifically limited 
color gamut, is interlaced, and is approximately 720 x 480 pixels, 29.97 frames per 
second.
object   In LiveType, objects are single 32-bit elements. Like LiveFonts, they may be 
computer-based animations, real-world video, or still photographs, as well as other 
elements such as lower thirds.
PAL format   Acronym for Phase Alternating Line format. A 25 fps (625 lines per frame) 
interlaced video format used by many European countries.
PICT   A still-image file format developed by Apple. PICT files can contain both vector 
images and bitmap images, as well as text and an alpha channel. PICT is a ubiquitous 
image format on Mac OS computers.
pixel   One dot in a video or still image. A typical low-resolution computer screen is 
640 pixels wide and 480 pixels tall. Digital video movies are often 320 pixels wide and 
240 pixels tall.
pixel aspect ratio   The ratio of width to height for the pixels that compose the image. 
NTSC pixels are square (1:1 ratio), but D-1 pixels are nonsquare.146 Glossary
postproduction   The process of editing film or video after acquiring the footage.
QuickTime   The Apple cross-platform multimedia technology. Widely used for 
CD-ROM, web video, editing, and more.
RAID   Acronym for Redundant Array of Independent Disks. A method of providing 
nonlinear editors with many gigabytes of high-performance data storage by teaming 
together a group of slower, smaller, cheaper hard disks.
RAM   Acronym for random-access memory. Your computer’s memory capacity, 
measured in bytes, which determines the amount of data the computer can process 
and temporarily store at any moment.
render   In LiveType, the process of combining project elements with any applied 
effects, one frame at a time. Once rendered, your titling sequence can be played in real 
time.
RGB   Abbreviation for Red Green Blue. A color space commonly used on computers. 
Each color is described by the strength of its red, green, and blue components. This 
color space directly translates to the red, green, and blue phosphors used in computer 
monitors. The RGB color space has a very large gamut, meaning it can reproduce a very 
wide range of colors.
SECAM   Acronym for Sequential Couleur Avec Memoire. The French television standard 
for playback. Similar to PAL, the playback rate is 25 fps.
sequencing    An effect treatment in which each glyph on a track is transformed 
individually. A sequenced effect starts by transforming one character, then moves to 
the adjacent character, and so on.
texture   In LiveType, textures are full-screen animations, useful as backgrounds, texture 
mattes, or borders.
TIFF   Acronym for Tagged Image File Format. A widely used bitmapped graphics file 
format, developed by Aldus and Microsoft, that handles monochrome, grayscale, 8- and 
24-bit color.
timecode   A method of associating each frame of film or video in a clip with a unique, 
sequential unit of time. The format is hours:minutes:seconds:frames.
Timeline    One of the four main windows in the LiveType interface, which shows the 
timing of project elements and the effects applied to them.
title safe area   The part of the video image that is guaranteed to be visible on all 
televisions. The title safe area is 80 percent of the screen.Glossary 147
track   In LiveType, a track is what contains an element and its attributes. In the Canvas, 
a track appears as a dark blue line, usually at the base of the text, object, or image it 
contains. A track can be shaped to form a motion path for the track’s contents to move 
along. In the Timeline, a track is represented by a numbered bar, often with applied 
effects underlying it.
widescreen   Widescreen format is a way of shooting and projecting a movie in 
theaters. The original footage doesn’t get cut off because of the 4:3 aspect ratio. With 
the advent of high definition video, widescreen 16:9 video is coming into more popular 
use.
wireframe   The most elementary preview mode in LiveType, representing characters 
and objects as bounding boxes. Wireframe previews are useful because they render 
very quickly, showing the motion of elements.
x   Used to refer to the x coordinate in Cartesian geometry. The x coordinate describes 
horizontal placement.
y   Used to refer to the y coordinate in Cartesian geometry. The y coordinate describes 
vertical placement in motion effects.     149
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Component Video codec  115
compositing  144
compression  144
compressors. See codecs
control points  15, 49–51
copying items
effects  93, 101
keyframes  101
tracks  52, 101
crawling text  129
crosshair guides  18
curved tracks  50–51, 121–123
D
data, digital  144
data files  30
decompression  144
delaying items
effects  91
LiveFonts effects  61
track contents  54
Delay slider  54
deleting items
keyframes  100
tracks  52
description field  36
digital data  144
digital images  85
See also images
digital video  144
direction of extrusions  71
draft quality  112
duplicating items
effects  93, 101
keyframes  101
strings of elements  84
tracks  101
duration
described  144
effects  89, 91, 92
tracks  54
DV codec  115
DV format  43, 82
DV Stream format  115
DVCPRO-NTSC codec  115
DVCPRO-PAL codec  115
DVD discs  144
E
editing LiveType movies in Final Cut Pro  114
effects
adding keyframes to  101
adjusting timing  90–92
applying to tracks  88–89
considerations  87
copying keyframes in  101
creating custom  103–106
described  22, 87, 135, 144
disabling  28, 55, 89, 113
duplicating  93
duration of  144
effects files  28
examples of  98–100
finding  107
groups of  92
using individual characters or glyphs  106
list of  88
in LiveType  8
modifying  93–100
order of  93
preset. See preset effects
previewing  89, 102
renaming  102
saving  102
sequenced  146
storing  29, 140Index 151
in Timeline  27
timing settings  23, 90–92
EffectScripts  135–141
Effects folder  29, 140
Effects tab  22, 87
elements
See also objects
creating strings of  84–85
described  144
imported. See imported elements
locked  133
problems selecting  133
repositioning  83
resizing  83
rotating  66–67, 83
types of  8
Enable/Disable buttons  28
endpoints
linking  51
tracks  15
exploding fonts  126
exporting items  113, 114, 115–116
extruded outlines  71
Extrude style  22, 71, 85
F
Fade In effect  98–100
FAQs (frequently asked questions)  131–133
Field Dominance option  36
fields
described  144
description field  36
rendering order  36, 38–39
"file pair" formats  29
files
data  30
effects files  135
imported  30
included with LiveType  28
project files  32
support profiles  134
file sizes  113, 123
filling elements. See matte feature
Final Cut Pro
editing LiveType movies from  114
importing LiveType movies  113
rendering LiveType projects in  113
finding items using the Timeline  107
FireWire  144
FLC format  115
folders  29–30
FontBook application  78
Font dialog  124
FontMaker utility  8
fonts
See also text
animated  8
changing for text tracks  59
choosing  58
color  64–65
described  144
disabling  78
problems with  131
required fonts  78
system  59, 60, 65
formats
See also specific formats
export  115–116
import  43, 82
formatting text  62–71
frame rates  35
frame ruler  26
frames
See also keyframes
described  144
poster frames  111
proxy frames  19, 111
time settings  36
viewing in Timeline  26
freezing previews  109
frequently asked questions (FAQs)  131–133
G
GIF format  35, 43, 82
Glow style  22, 68–69, 85, 119–121, 132
Glyph pane  64–67
glyphs  132, 144
assigning effects to  106
color  64–65
elements as  84
modifying individual glyphs  77–78
motion paths  96
removing effects from  90
special character effects  123–126
transformation options  65–67
graphics. See images
Graphics codec  115
grid
customizing  18
hiding  37
settings  18, 37
showing  17, 37
grouping items
effects  92
tracks  27, 56
guides, Canvas  18
H
H.261 and 263 codecs  115
handles on objects  79152 Index
hardware
field rendering and  38
noting for support calls  134
headers in EffectScripts  135
height settings for GIFs  35
help, onscreen  10–11
Heuris MPEG format  115
hidden elements  76
hidden keyframes  132
high quality  112
Hold First and Hold Last options  61, 92
holes in layers. See matte feature
hot keys  28
HSL (Hue, Saturation, and Lightness)  64
Hue values  64
I
IEEE 1394 (FireWire)  144
images
background  44
digital  85
filling track contents with  75
finding  107
importing  44, 82
pixelated  131
still  44
storing  30
Images folder  30
imported elements
See also elements
creating strings of  84–85
resizing  83
size considerations  113
system performance and  113
transforming  83–85
importing items
background images  44
background movies  43–45
data files  30
described  145
LiveType projects into Final Cut Pro  113
formats for  43, 82
images  44, 82
movies  43–45, 82
still images  44
into third-party applications  114
In Point/Out Point markers  27
Inspector  20–24
described  13, 20, 145
formatting options  62
illustrated  13, 20
LEDs in  96
Live Wireframe Preview  21
tabs in  21–24
text-entry boxes  20, 58
Intel Indeo Video r3.2 format  115
Intel Raw codec  115
interlaced video  36
invisible elements  76
invisible keyframes  132
.ipr extension  32
J
JPEG 2000 Image format  115
JPEG format  43, 82, 115
K
keyboard shortcuts  28
Keyboard Viewer  60
Key Cap utility. See Keyboard Viewer
keyframes  94–96
adding to effects  101
adjusting parameters  95–96
copying  101
deleting  100
described  27, 145
EffectScripts  136–139
hidden  132
modifying all keyframes  96
moving  100
overview  94
rotation and  66
“stuck”  132
viewing parameters  94
L
layers
advanced techniques  126–127
assigning to treatments  68
holes in. See matte feature
track  55
leading, text  63
LEDs, Inspector  96
length of extrusions  71
Lightness values  64
linking endpoints  51
LiveFonts
adjusting timing  60–61
advanced techniques  126–127
character sets  60
described  8, 145
vs. system fonts  59
LiveFonts folder  29
LiveType
effects files  28
introduction to  7–12
media files  28, 145
onscreen help  10–11
restoring default layout of  14
unable to open  132Index 153
website  11
LiveType projects. See projects
Live Wireframe Preview  20, 21, 109, 132, 147
locked items
characters  133
elements  133
movies  83
textures  83
tracks  27
Loop button  110
looping items
effects  92
LiveFonts effects  61
.ltfx extension  29
.ltlf extension  29
.ltob extension  29
.lttm extension  29
.lttx extension  29
M
Mac OS, version of  134
MacPaint format  115
magnifying view. See zoom controls
mailing lists for Pro Apps Developers  133
markers
described  145
In Point  27
Out Point  27
Render Selection  27, 113
sequencing  94–96
timing  45
matte feature  24, 72–76, 85, 117–119
Media Browser
categories in  30
described  13, 25, 145
media files in  29
media files
described  145
importing  30
included with LiveType  28
older versions of  29
memory  113, 134, 146
Missing AFD dialog  111
Motion JPEGA and JPEGB codecs  115
motion paths
adding to effects  104
described  96
scrolling or crawling text  128
unsmooth  132
movies
See also titling movies
attributes  85
background  43–45
filling track contents with  75
finding using the Timeline  107
importing  43–45, 82
looping through  110
output quality  112
preview. See preview movies
rendering  114–116
styles  85
unlocking position of  83
moving items
grouped tracks  56
groups of effects  92
MPEG-2 format  43, 82, 115
MPEG-4 format  43, 82, 102, 115
N
names of modified effects  102
Needle Drop effect  119–121
Nitro LiveFont  126
normal quality  112
NTSC format  145
NTSC monitors  132
NTSC pixels  132
NTSC video  144, 145
O
objects
See also elements
adding to Canvas  80
animated  8
attributes  85
creating strings of  84–85
described  8, 145
resizing  83
storing  29
styles  85
transforming  83–85
treatments  22
working with  80
Objects folder  29
Objects tab  80
offsetting items
attributes for  24
Canvas Offset parameter  128
glow or shadows  69
non-text elements  85
text  66
opacity
attributes  24
backgrounds  41
glow or shadows  69
mattes. See matte feature
rendering backgrounds and  45
transparent text  65
order of effects  93
Outline extrusion option  71
Outline style  22, 70–71, 85154 Index
P
PAL format  145
PAL video  144
Parameter pop-up menu  97
parameters
active parameters  97
of keyframes  94
LED indicators  96
Particles objects  19
pausing previews  110
performance, preview  112–113, 133
PhotoJPEG codec  115
Photoshop format  43, 82, 115
PICS format  43, 82
PICT files  145
PICT format  43, 82, 115, 145
picture aspect ratio  143
pixel aspect ratio  36, 145
pixelated images  131
pixels  36, 132, 145
Planar RGB codec  115
playhead  26
PLS format  43, 82
PNG codec  115
PNG format  44, 82, 115
poster frames  111
postproduction process  146
precedence order of effects  93
Preferences dialog  29
preset effects
See also effects
applying to tracks  88–89
disabling  89
for individual characters or glyphs  106
list of  88
modifying  93–102
order of  93
previewing  89
timing settings  90–92
presets, project  35
previewing items
effects  102
freezing previews  109
Live Wireframe Preview  20
pausing previews  110
preset effects  89
RAM preview  17, 37, 110
titling movies  109–111
Wireframe previews  21, 37, 109, 132, 147
preview movies
described  111
quality of  112
rendering  111
saving  111
preview performance  112–113, 133
Project Properties dialog  34–37, 112
projects
backgrounds. See backgrounds
defaults  33
presets for  35
properties  31, 34–37
quality settings  36
rendering  114–116
rendering in Final Cut Pro  113
saving as templates  32
setting up  31–37
starting  33
timing in. See timing settings
project tabs, Timeline  26
properties, project  31, 34–37, 112
proxy frames  19, 111
Q
quality settings  36
QuickTime
codecs  115, 143
described  146
effects and  102
preview clips and  102
QuickTime image format  44, 82, 115
QuickTime movie format  44, 82, 114
R
RAID storage  146
RAM  113, 146
RAM preview  17, 37, 110
Random option
for effects  91
for LiveFonts effects  61
removing guides  18
Render Background setting  37
rendering  114–116
backgrounds  37, 45
changing selection  27
described  146
field rendering order  36, 38–39
in Final Cut Pro  113
improving speed of  113
preview movies  111
quality of  112
quality settings  37
settings for  112
time requirements  112
Render Selection markers  27, 113
reordering effects  93
replacing elements in tracks  85
resources
Apple websites  ??–12
for troubleshooting  131
restoring character positions  78Index 155
Reveal in Finder command  107
Reveal in Media Browser command  107
RGB color space  146
ripple drags  54
rotating items
attributes for  24
EffectScript for  141
non-text elements  85
nontext elements  83
text  66–67, 77
rotation handles  79
rulers
hiding  37
settings  37
showing  17, 37
S
Saturation values  64
saving modified effects  102
scale handles  79
Scale parameter  66
scaling items
attributes for  24
glow or shadow effects  69
non-text elements  85
non-text items  83
text elements  66
Screech effect  121
scripts (EffectScripts)  135–141
scrolling text  128
searching for items using the Timeline  107
SECAM format  146
segmented LiveFont animation  61
sequenced effects  61, 91, 146
sequencing markers  94–96
SGI format  44, 82, 115
Shadow style  22, 68–69, 85, 119–121, 132
shortcuts  28
Show Outline only setting  70
Size parameter  66
Slide effect  121
Slide parameter  51
SMPTE Drop time setting  36
SMPTE time format  36
Sorenson Video and Video 3 codecs  115
source files  30
spacing in text  63
speed
adjusting for track contents  54
of effects  91
LiveFont movies  61
square pixels  132
still images  44
styles
digital images  85
imported elements  85
movies  85
objects  85
text  68–71, 119–121
Style tab  22, 68–71
support profiles  134
symbols  123–126
system fonts
changing color of  65
described  59
duration of  60
vs. LiveFonts  59
in scrolling or crawling text  128
T
Targa format  44, 82
Template Browser  32
templates  31–32
described  9
opening  32
saving projects as  32
storing  29
Templates folder  29
terminology  143–147
testing field rendering  38
text  57–78
aligning  63
baselines  66
color  64–65
entering and adjusting  21, 58
extrusion effect  71
fonts. See fonts
formatting  62–71
glow effect  68–69, 119–121
inserting  57–59
leading  63
matte effect  24, 72–76, 117–119
modifying characters  77–78
outline effect  70–71
rotating  66–67, 77
scrolls and crawls  128–129
shadow effect  68–69, 119–121
size of  63, 66
special characters  123–126
styles  68–71, 119–121
tracking  63
transforming  65–67
treatments  22
warping  69, 119–121
words within words effect  117–119
text-entry boxes  20, 58
Text tab  21, 62
text tracks
aligning  63
changing fonts  59156 Index
curved  121–123
modifying characters on  77–78
text in  57
textures
adding to Canvas  81
animated  8
background  42
creating strings of  84–85
described  8, 146
filling track contents with  76
resizing  83
storing  29
transforming  83–85
unlocking position of  83
working with  81
Textures folder  29
Textures tab  81
TGA codec  115
TGA format  115
third-party applications  114
TIFF codec  115
TIFF format  44, 82, 146
timecode  26, 146
Timeline  26–28
background bar  43
described  13, 26, 146
effects in  27
illustrated  13, 26
moving keyframes in  100
playhead  26
project tabs  26
searching for items with  107
timecode  26
viewing frames in  26
working with tracks in  27, 53–56, 147
Timeline zoom slider  28
timing markers  45
timing settings
controlling  23
effects  90–92
EffectScripts  135–136
LiveFonts  60–61
start time  36
time format  36
in Timing tab  61
Timing tab  23, 61, 90–92
Tinted Rotate EffectScript  141
title safe area  15, 146
title safe guidelines  15
titling movies
See also movies
creation workflow  9
previewing  109–111
rendering  114–116
titling process  7, 8
tracking options for text  63
tracks  47–56
adding  52
applying preset effects to  88–89
attributes  95, 133
control points  49–51
creating strings of elements on  84–85
curved  50–51, 121–123
delaying appearance  54
deleting  52
described  15, 47, 147
disabled  28, 55, 113
duplicating  52
duplicating effects in  93
duration  54, 144
empty  52
endpoints  15
entering text onto  58
filling with images  75
filling with movies  75
filling with texture  76
grouping  27, 56
groups of effects in  92
illustrated  48
isolating in Canvas  19
layers  55
linking endpoints  51
locking position  27
moving  48, 54
numbering  27
rendering previews  113
reordering  55
replacing elements in  85
resizing  48
selecting  62
shape of  48
sloping  48
text. See text tracks
timing  23, 53–54
turning on/off  28
ungrouping  56
working with in Canvas  15, 147
working with in Timeline  147, 53–56
transforming items
imported elements  83–85
text  65–67
transparency
backgrounds  41
rendering and  45
text  65
transparent backgrounds  73–74
transport controls  16
troubleshooting  131–134
common problems  131–133
disabling fonts  78
distorted field rendering  38
LiveFonts in large text sizes  63Index 157
positions of matte and background images  75
resources for  131
scrolling or crawling text  128
U
ungrouping tracks  56
V
video
digital  144
interlaced  36
NTSC  144
PAL  144
Video codec  115
W
warping items  69, 119–121
web banners  35
websites
Apple Applications  133
AppleCare  131, 134
Apple Developer Connection  133
Apple Service and Support  11
Apple Store  12
FireWire  12
LiveType  11
weight of outlined text  70
widescreen format  147
width of GIF images  35
Wireframe previews  21, 37, 109, 132, 147
words within words effect  117
workflows, title creation  9
X
x coordinate  147
Y
y coordinate  147
Z
zoom controls
in Canvas  16
EffectScripts for  140
Timeline zoom slider  28
Zoom In EffectScript  140
Zoom Out EffectScript  140
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About iPod nano
Congratulations on choosing iPod nano. With iPod nano, you 
can take your music, video, and photo collections with you 
wherever you go.
To use iPod nano, you put music, videos, photos, and other files on your computer and 
then add them to iPod nano.
Read this guide to learn how to:
Â Set up iPod nano to play music, music videos, movies, TV shows, podcasts, 
audiobooks, and more.
Â Use iPod nano as your pocket photo album, portable hard drive, alarm clock, game 
console, and voice memo recorder.
Â View video and photo slideshows on your TV.
Â Get the most out of all the features in iPod nano.Preface    About iPod nano 5
What’s New in iPod nano
Â Genius, which automatically creates playlists of songs from your library that go great 
together
Â A motion sensor that lets you control certain functions by rotating or shaking 
iPod nano
Â Full-screen photo viewing in portrait or landscape format
Â Quick browsing for songs based on the album or artist you’re listening to
Â Direct access to more options from the Now Playing screen
Â New voice recording options
Â Improved accessibility with spoken menus1
6  
1 iPod nano Basics
Read this chapter to learn about the features of iPod nano, 
how to use its controls, and more.
iPod nano at a Glance
Get to know the controls on iPod nano:
Dock connector
Menu
Previous/Rewind
Play/Pause
Hold switch
Headphones port
Click Wheel
Next/Fast-forward 
Center buttonChapter 1    iPod nano Basics 7
Using iPod nano Controls
The controls on iPod nano are easy to find and use. Press any button to turn on 
iPod nano. The main menu appears.
Use the Click Wheel and Center button to navigate through onscreen menus, 
play songs, change settings, and get information. Move your thumb lightly around the 
Click Wheel to select a menu item. To choose the item, press the Center button. 
To go back to the previous menu, press Menu on the Click Wheel.
Here’s what else you can do with iPod nano controls.
To Do this
Turn on iPod nano Press any button.
Turn off iPod nano Press and hold Play/Pause (’).
Turn on the backlight Press any button or use the Click Wheel.
Disable the iPod nano controls
(so nothing happens if you press 
them accidentally)
Slide the Hold switch to HOLD (an orange bar appears).
Reset iPod nano
(if it isn’t responding)
Slide the Hold switch to HOLD and back again. Press the Menu and 
Center buttons at the same time for about 6 seconds, until the 
Apple logo appears.
Choose a menu item Scroll to the item and press the Center button.
Go back to the previous menu Press Menu.
Go directly to the main menu Press and hold Menu.
Browse for a song From the main menu, choose Music.
Browse for a video From the main menu, choose Videos.
Play a song or video Select the song or video and press the Center button or Play/Pause 
(’). iPod nano must be ejected from your computer to play songs 
and videos.
Pause a song or video Press Play/Pause (’) or unplug your headphones.
Change the volume From the Now Playing screen, use the Click Wheel.8 Chapter 1    iPod nano Basics 
Play all the songs in a playlist 
or album
Select the playlist or album and press Play/Pause (’).
Play all songs in random order From the main menu, choose Shuffle Songs. You can also shuffle 
songs by shaking iPod nano.
Enable or disable Shake for 
shuffling songs
Choose Settings > Playback, choose Shake, and then select Shuffle 
or Off.
Skip to any point in a song or 
video
From the Now Playing screen, press the Center button to show the 
scrubber bar (a diamond icon on the bar shows the current 
location), and then scroll to any point in the song or video.
Skip to the next song or 
chapter in an audiobook or 
podcast
Press Next/Fast-forward (‘).
Start a song or video over Press Previous/Rewind (]).
Play the previous song or 
chapter in an audiobook or 
podcast
Press Previous/Rewind (]) twice.
Fast-forward or rewind a song  Press and hold Next/Fast-forward (‘) or Previous/Rewind (]).
Create a Genius playlist Play or select a song, and then press and hold the Center button 
until a menu appears. Select Start Genius, and then press the 
Center button (Start Genius appears only if there is Genius data for 
the song).
Save a Genius playlist Create a Genius playlist, select Save Playlist, and then press the 
Center button.
Play a saved Genius playlist From the Playlist menu, select a Genius playlist, and then press 
Play/Pause (’).
Add a song to the On-The-Go 
playlist
Play or select a song, and then press and hold the Center button 
until a menu appears. Select “Add to On-The-Go,” and then press 
the Center button.
Access additional options Press and hold the Center button until a menu appears.
Find the iPod nano serial 
number
From the main menu, choose Settings > About and press the 
Center button until you see the serial number, or look on the back 
of iPod nano.
To Do thisChapter 1    iPod nano Basics 9
Browsing Music Using Cover Flow
You can browse your music collection using Cover Flow, a visual way to flip through 
your library. Cover Flow displays your albums alphabetically by artist name.
You can activate Cover Flow from the main menu, any music menu, or the Now Playing 
screen.
To use Cover Flow:
1 Rotate iPod nano 90 degrees to the left or the right. Cover Flow appears.
2 Use the Click Wheel to move through your album art.
3 Select an album and press the Center button.
4 Use the Click Wheel to select a song, and then press the Center button to play it.
You can also browse quickly through your albums in Cover Flow by moving your 
thumb quickly on the Click Wheel.
Note:  Not all languages are supported.
To browse quickly in Cover Flow:
1 Move your thumb quickly on the Click Wheel, to display a letter of the alphabet on the 
screen.
2 Use the Click Wheel to navigate through the alphabet until you find the first letter of 
the artist you’re looking for.10 Chapter 1    iPod nano Basics 
Albums by various artists and by artists beginning with a symbol or number appear 
after the letter “Z.”
3 Lift your thumb momentarily to return to normal browsing.
4 Select an album and press the Center button.
5 Use the Click Wheel to select a song, and then press the Center button to play it.
Scrolling Quickly Through Long Lists
You can scroll quickly through a long list by moving your thumb quickly on the 
Click Wheel.
Note:  Not all languages are supported.
To scroll quickly:
1 Move your thumb quickly on the Click Wheel, to display a letter of the alphabet on the 
screen.
2 Use the Click Wheel to navigate through the alphabet until you find the first letter of 
the item you’re looking for. 
Items beginning with a symbol or number appear after the letter “Z.”
3 Lift your thumb momentarily to return to normal scrolling.
4 Use the Click Wheel to navigate to the item you want.
Searching Music
You can search iPod nano for songs, playlists, album titles, artist names, audio podcasts, 
and audiobooks. The search feature doesn’t search videos, notes, calendar items, 
contacts, or lyrics.
Note:  Not all languages are supported.
To search for music:
1 From the Music menu, choose Search.
2 Enter a search string by using the Click Wheel to navigate the alphabet and pressing 
the Center button to enter each character.
iPod nano starts searching as soon as you enter the first character, displaying the 
results on the search screen. For example, if you enter “b,” iPod nano displays all music 
items containing the letter “b.” If you enter “ab,” iPod nano displays all items containing 
that sequence of letters.
To enter a space, press the Next/Fast-forward button.
To delete the previous character, press the Previous/Rewind button.
3 Press Menu to display the results list, which you can now navigate.
Items appear in the results list with icons identifying their type:  song, video, artist, 
album, audiobook, or podcast. Chapter 1    iPod nano Basics 11
To return to Search (if Search is highlighted in the menu), press the Center button.
Using iPod nano Menus
When you turn on iPod nano, you see the main menu. Choose menu items to perform 
functions or go to other menus. Icons along the top of the screen show iPod nano 
status.
Adding or Removing Items on the Main Menu
You might want to add often-used items to the iPod nano main menu. For example, 
you can add a Songs item to the main menu, so you don’t have to choose Music before 
you choose Songs.
To add or remove items on the main menu:
1 Choose Settings > General > Main Menu.
2 Select each item you want to appear in the main menu. A checkmark indicates which 
items have been added.
Display item Function
Menu title Displays the title of the current menu.
Lock icon The Lock icon appears when the Hold switch (on the top of 
iPod nano) is set to HOLD. This indicates that the iPod nano 
controls are disabled.
Play icon The Play (“) icon appears when a song, video, or other item is 
playing. The Pause (1) icon appears when the item is paused.
Battery icon The Battery icon shows the approximate remaining battery charge.
Menu items Use the Click Wheel to scroll through menu items. Press the Center 
button to choose an item. An arrow next to a menu item indicates 
that choosing it leads to another menu or screen.
Preview panel Displays album art, photos, and other items and information 
relating to the menu item selected.
Menu title
Lock icon Battery icon
Menu items
Preview panel
Play icon12 Chapter 1    iPod nano Basics 
Turning Off the Preview Panel
The preview panel at the bottom of the main menu, which displays album art, photo 
thumbnails, available storage, and other information, can be turned off to allow more 
space for menu items.
To turn off the preview panel:
m Choose Settings > General > Main Menu > Preview Panel and then choose Off.
To turn the preview panel on again, choose Settings > General > Main Menu > 
Preview Panel, and then choose On.
The preview panel only displays art for a category if iPod nano contains at least four 
items with art in the category.
Setting the Font Size in Menus
iPod nano can display text in two different sizes, standard and large.
To set the font size:
m Choose Settings > General > Font Size, and then press the Center button to select 
Standard or Large.
Setting the Language
iPod nano can be set to use different languages.
To set the language:
m Choose Settings > Language, and then choose a language from the list.
Setting the Backlight Timer
You can set the backlight to turn on and illuminate the screen for a certain amount of 
time when you press a button or use the Click Wheel. The default is 10 seconds.
To set the backlight timer:
m Choose Settings > General > Backlight Timer, and then choose the time you want. 
Choose “Always On” to prevent the backlight from turning off (choosing this option 
decreases battery performance).
Setting the Screen Brightness
You can adjust the brightness of the iPod nano screen by moving a slider.
To set the screen brightness:
m Choose Settings > General > Brightness, and then use the Click Wheel to move the 
slider. Moving it to the left dims the screen; moving it to the right increases the screen 
brightness.
You can also set the brightness during a slideshow or video. Press the Center button to 
display or dismiss the brightness slider.Chapter 1    iPod nano Basics 13
Turning Off the Click Wheel Sound
When you scroll through menu items, you can hear a clicking sound through the 
headphones and through the iPod nano internal speaker. If you like, you can turn off 
the Click Wheel sound through the headphones, the speaker, or both.
To turn off the Click Wheel sound:
m Choose Settings > General and set Clicker to Off.
To turn the Click Wheel sound on again, set Clicker to Speaker, Headphones, or Both.
Getting Information About iPod nano
You can get details about your iPod nano, such as the amount of space available, the 
number of songs, videos, photos, and other items, and the serial number, model, and 
software version.
To get information about iPod nano:
m Choose Settings > About, and press the Center button to cycle through the screens of 
information.
Resetting All Settings
You can reset all the items on the Settings menu to their default setting.
To reset all settings:
m Choose Settings > Reset Settings, and then choose Reset.
Disabling iPod nano Controls
If you don’t want to turn iPod nano on or activate controls accidentally, you can disable 
them with the Hold switch. The Hold switch disables all Click Wheel controls, and also 
disables functions that are activated by movement, such as shaking to shuffle and 
rotating to enter or exit Cover Flow. 
To disable iPod nano controls:
m Slide the Hold switch to HOLD (so you can see the orange bar).14 Chapter 1    iPod nano Basics 
If you disable the controls while using iPod nano, the song, playlist, podcast, or video 
that’s playing continues to play. To stop or pause, slide the Hold switch to enable the 
controls again.
Connecting and Disconnecting iPod nano
You connect iPod nano to your computer to add music, videos, photos, and files, and to 
charge the battery. Disconnect iPod nano when you’re done.
Important:  The battery doesn’t charge when your computer is in sleep mode.
Connecting iPod nano
To connect iPod nano to your computer:
m Plug the included iPod Dock Connector to USB 2.0 cable into a high-powered USB 2.0 
port on your computer, and then connect the other end to iPod nano.
If you have an iPod Dock, you can connect the cable to a USB 2.0 port on your 
computer, connect the other end to the Dock, and then put iPod nano in the Dock.
Note:  The USB port on most keyboards doesn’t provide enough power. Connect 
iPod nano to a USB 2.0 port on your computer.
By default, iTunes syncs songs on iPod nano automatically when you connect it to your 
computer. When iTunes is finished, you can disconnect iPod nano. You can sync songs 
while your battery is charging.
If you connect iPod nano to a different computer and it’s set to sync music 
automatically, iTunes prompts you before syncing any music. If you click Yes, the songs 
and other audio files already on iPod nano will be erased and replaced with songs and 
other audio files on the computer iPod nano is connected to. For information about 
adding music to iPod nano and using iPod nano with more than one computer, see 
Chapter 2, “Setting Up iPod nano,” on page 20.Chapter 1    iPod nano Basics 15
Disconnecting iPod nano
It’s important not to disconnect iPod nano while it’s syncing. You can see if it’s OK to 
disconnect iPod nano by looking at the iPod nano screen.
Important:  Don’t disconnect iPod nano if you see the “Connected” or “Synchronizing” 
messages. You could damage files on iPod nano. If you see one of these messages, you 
must eject iPod nano before disconnecting it. 
If you set iPod nano to manage songs manually (see “Managing iPod nano Manually” 
on page 29) or enable iPod nano for disk use (see “Using iPod nano as an External Disk” 
on page 53), you must always eject iPod nano before disconnecting it.
If you see one of these messages, you must eject iPod nano 
before disconnecting it
If you see the main menu or a large battery icon, you can disconnect iPod nano.16 Chapter 1    iPod nano Basics 
To eject iPod nano:
m Click the Eject (C) button next to iPod nano in the list of devices in the iTunes source 
list.
If you’re using a Mac, you can also eject iPod nano by dragging the iPod nano icon on 
the desktop to the Trash.
If you’re using a Windows PC, you can also eject iPod nano in My Computer or by 
clicking the Safely Remove Hardware icon in the Windows system tray and selecting 
iPod nano.
To disconnect iPod nano:
1 Unplug the headphones if they’re attached.
2 Disconnect the cable from iPod nano. If iPod nano is in the Dock, simply remove it. 
You can safely disconnect iPod nano while either of these messages is displayed.Chapter 1    iPod nano Basics 17
About the iPod nano Battery
iPod nano has an internal, non-user-replaceable battery. For best results, the first time 
you use iPod nano, let it charge for about three hours or until the battery icon in the 
status area of the display shows that the battery is fully charged. If iPod nano isn’t used 
for a while, the battery might need to be charged. 
Note:  iPod nano continues to use battery power after it’s been turned off.
The iPod nano battery is 80-percent charged in about one and a half hours, and fully 
charged in about three hours. If you charge iPod nano while adding files, playing 
music, watching videos, or viewing a slideshow, it might take longer. 
Charging the iPod nano Battery
You can charge the iPod nano battery in two ways:
Â Connect iPod nano to your computer.
Â Use the Apple USB Power Adapter, available separately. 
To charge the battery using your computer:
m Connect iPod nano to a USB 2.0 port on your computer. The computer must be turned 
on and not in sleep mode. 
If the battery icon on the iPod nano screen shows the Charging screen, the battery is 
charging. If it shows the Charged screen, the battery is fully charged.
If you don’t see the Charging screen, iPod nano might not be connected to a 
high-power USB port. Try another USB port on your computer. 18 Chapter 1    iPod nano Basics 
Important:  If a “Charging, Please Wait” or “Connect to Power” message appears on the 
iPod nano screen, the battery needs to be charged before iPod nano can communicate 
with your computer. See“If iPod nano displays a “Connect to Power” message” on 
page 66.
If you want to charge iPod nano when you’re away from your computer, you can 
purchase the Apple USB Power Adapter.
To charge the battery using the Apple USB Power Adapter:
1 Connect the AC plug adapter to the power adapter (they might already be connected).
2 Connect the iPod Dock Connector to USB 2.0 cable to the power adapter, and plug the 
other end of the cable into iPod nano. 
3 Plug the power adapter into a working electrical outlet. 
WARNING:  Make sure the power adapter is fully assembled before plugging it into an 
electrical outlet.
AC plug adapter
(The plug on your Power Adapter may look different.)
USB Power Adapter
iPod Dock Connector to USB 2.0 CableChapter 1    iPod nano Basics 19
Understanding Battery States
When iPod nano isn’t connected to a power source, a battery icon in the top-right 
corner of the iPod nano screen shows approximately how much charge is left. 
If iPod nano is connected to a power source, the battery icon changes to show that the 
battery is charging or fully charged.
You can disconnect and use iPod nano before it’s fully charged.
Note:  Rechargeable batteries have a limited number of charge cycles and might 
eventually need to be replaced. Battery life and number of charge cycles vary by use 
and settings. For information, go to www.apple.com/batteries.
Improving Battery Performance with Energy Saver
Energy Saver can extend the time between battery charges by turning off the 
iPod nano screen when you aren’t using the controls.
To turn Energy Saver on or off:
m Choose Settings > Playback > Energy Saver, and then select On or Off.
Battery less than 20% charged
Battery about halfway charged
Battery fully charged
Battery charging (lightning bolt)
Battery fully charged (plug)2
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2 Setting Up iPod nano
To set up iPod nano, you use iTunes on your computer to 
import, buy, and organize your music, video, podcasts, 
audiobooks, games, and other media content. Then you 
connect iPod nano to your computer and sync it to your 
iTunes library.
Using iTunes
iTunes is the software application you use with iPod nano. iTunes can sync music, 
audiobooks, podcasts, and more with iPod nano. When you connect iPod nano to your 
computer, iTunes opens automatically. 
This guide explains how to use iTunes to download songs and other audio and video to 
your computer, create personal compilations of your favorite songs (called playlists), 
sync them to iPod nano, and adjust iPod nano settings.
iTunes also has a feature called Genius that creates instant playlists of songs from your 
iTunes library that go great together. You can sync Genius playlists that you create in 
iTunes to iPod nano, and you can create Genius playlists on iPod nano. To use Genius, 
you need iTunes 8.0 or later and an iTunes Store account.
iTunes has many other features. You can burn your own CDs that play in standard CD 
players (if your computer has a recordable CD drive); listen to streaming Internet radio; 
watch videos and TV shows; rate songs according to preference; and much more. 
For information about using these iTunes features, open iTunes and choose 
Help > iTunes Help.
If you already have iTunes 8.0 installed on your computer and you’ve set up your iTunes 
library, you can skip ahead to the next section, “Syncing iPod nano.” To learn how to set 
up Genius in iTunes, see “Using Genius in iTunes” on page 25.Chapter 2    Setting Up iPod nano 21
Importing Music into Your iTunes Library
To listen to music on iPod nano, you first need to get that music into iTunes on your 
computer.
There are three ways of getting music and other audio into iTunes:
Â Purchase music, audiobooks, and videos, or download podcasts online from the 
iTunes Store.
Â Import music and other audio from audio CDs.
Â Add music and other audio that’s already on your computer to your iTunes library.
Purchasing Songs and Downloading Podcasts Using the iTunes Store
If you have an Internet connection, you can easily purchase and download songs, 
albums, audiobooks, and videos online using the iTunes Store. You can also subscribe 
to and download podcasts.
To purchase music online using the iTunes Store, you set up an Apple account in 
iTunes, find the songs you want, and then buy them. If you already have an Apple 
account, or if you have an America Online (AOL) account (available in some countries 
only), you can use that account to sign in to the iTunes Store and buy songs.
You don’t need an iTunes Store account to download or subscribe to podcasts.
To sign in to the iTunes Store:
m Open iTunes and then:
Â If you already have an iTunes account, choose Store > Sign In.
Â If you don’t already have an iTunes account, choose Store > Create Account and follow 
the onscreen instructions to set up an Apple account or enter your existing Apple 
account or AOL account information.
You can browse or search the iTunes Store to find the album, song, or artist you’re 
looking for. Open iTunes and select iTunes Store in the source list.
Â To browse the iTunes Store, choose a category (for example, Music) on the left side of 
the main page in the iTunes Store. You can choose a genre, look at new releases, click 
one of the featured songs, look at Top Songs and more, or click Browse under Quick 
Links in the main iTunes Store window.22 Chapter 2    Setting Up iPod nano 
Â To browse for podcasts, click the Podcasts link on the left side of the main page in the 
iTunes Store.
Â To search the iTunes Store, type the name of an album, song, artist, or composer in the 
search field.
Â To narrow your search, type something in the search field, press Return or Enter on 
your keyboard, and then click links in the Search Bar at the top of the results page. 
For example, to narrow your search to songs and albums, click the Music link.
Â To search for a combination of items, click Power Search in the Search Results window.
Â To return to the main page of the iTunes Store, click the Home button in the status line 
at the top of the window.
To buy a song, album, music video, or audiobook:
1 Select iTunes Store in the source list, and then find the item you want to buy.
You can double-click a song or other item to listen to a portion of it and make sure it’s 
what you want. (If your network connection is slower than 128 kbps, choose iTunes > 
Preferences, and in the Store pane, select the “Load complete preview before playing” 
checkbox.)
2 Click Buy Song, Buy Album, Buy Video, or Buy Book.
The song or other item is downloaded to your computer and charged to the credit card 
listed on your Apple or AOL account.
To download or subscribe to a podcast:
1 Select iTunes Store in the source list.
2 Click the Podcasts link on the left side of the main page in the iTunes Store.
3 Browse for the podcast you want to download.
Â To download a single podcast episode, click the Get Episode button next to the 
episode.
Â To subscribe to a podcast, click the Subscribe button next to the podcast graphic. 
iTunes downloads the most recent episode. As new episodes become available, they 
are automatically downloaded to iTunes when you connect to the Internet.
For more information, see “Adding Podcasts to iPod nano” on page 30 and “Watching 
and Listening to Podcasts” on page 42.
Adding Songs Already on Your Computer to Your iTunes Library
If you have songs on your computer encoded in file formats that iTunes supports, you 
can easily add the songs to iTunes.
To add songs on your computer to your iTunes library:
m Drag the folder or disk containing the audio files to Library in the iTunes source list (or 
choose File > Add to Library and select the folder or disk). If iTunes supports the song 
file format, the songs are automatically added to your iTunes library.Chapter 2    Setting Up iPod nano 23
You can also drag individual song files to iTunes. 
Note:  Using iTunes for Windows, you can convert nonprotected WMA files to AAC or 
MP3 format. This can be useful if you have a library of music encoded in WMA format. 
For more information, open iTunes and choose Help > iTunes Help.
Importing Music From Your Audio CDs Into iTunes
Follow these instructions to get music from your CDs into iTunes.
To import music from an audio CD into iTunes:
1 Insert a CD into your computer and open iTunes. 
If you have an Internet connection, iTunes gets the names of the songs on the CD from 
the Internet (if available) and lists them in the window.
If you don’t have an Internet connection, you can import your CDs and, later, when you’re 
connected to the Internet, choose Advanced > Get CD Track Names. iTunes will bring in 
the track names for the imported CDs. 
If the CD track names aren’t available online, you can enter the names of the songs 
manually. See “Entering Song Names and Other Details” below.
With song information entered, you can browse for songs in iTunes or on iPod by title, 
artist, album, and more. 
2 Click to remove the checkmark next to any song you don’t want to import.
3 Click the Import button. The display area at the top of the iTunes window shows how 
long it will take to import each song.
By default, iTunes plays songs as they are imported. If you’re importing a lot of songs, 
you might want to stop the songs from playing to improve performance.
4 To eject the CD, click the Eject (C) button.
You cannot eject a CD until the import is done.
5 Repeat these steps for any other CDs with songs you want to import.
Entering Song Names and Other Details
To enter CD song names and other information manually:
1 Select the first song on the CD and choose File > Get Info.
2 Click Info.
3 Enter the song information.
4 Click Next to enter information for the next song. 
5 Click OK when you finish.24 Chapter 2    Setting Up iPod nano 
Adding Lyrics
You can enter song lyrics in plain text format into iTunes so that you can view the song 
lyrics on iPod nano while the song is playing. 
To enter lyrics into iTunes:
1 Select a song and choose File > Get Info.
2 Click Lyrics.
3 Enter song lyrics in the text box.
4 Click Next to enter lyrics for the next song. 
5 When you finish, click OK.
For more information, see “Viewing Lyrics on iPod nano” on page 35.
Adding Album Artwork
Music you purchase from the iTunes Store includes album artwork, which iPod nano 
can display. You can add album artwork automatically for music you’ve imported from 
CDs, if the CDs are available from the iTunes Store. You can add album artwork 
manually if you have the album art on your computer.
To add album artwork automatically:
m Choose Advanced > Get Album Artwork.
You must have an iTunes Store account to add album artwork automatically.
To add album artwork to iTunes manually:
1 Select a song and choose File > Get Info.
2 Click Artwork.
3 Click Add, navigate to the artwork file, and click Choose.
4 Use the slider to adjust the size of the artwork.
5 Click Next to add artwork for the next song or album. 
6 Click OK when you finish.
For more information, see “Viewing Album Artwork on iPod nano” on page 36.
Organizing Your Music
Using iTunes, you can organize songs and other items into lists, called playlists, in any 
way you want. For example, you can create playlists with songs to listen to while 
exercising, or playlists with songs for a particular mood. 
You can also create Smart Playlists that update automatically based on rules you define. 
When you add songs to iTunes that match the rules, they automatically get added to 
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You can create as many playlists as you like using any of the songs in your iTunes 
library. Adding a song to a playlist or later removing it doesn’t remove it from your 
library. 
To create a playlist in iTunes:
1 Click the Add (+) button or choose File > New Playlist.
2 Type a name for the playlist.
3 Click Music in the Library list, and then drag a song or other item to the playlist. 
To select multiple songs, hold down the Shift key or the Command (x) key on a Mac, 
or the Shift key or the Control key on a Windows PC, as you click each song.
To create a Smart Playlist:
m Choose File > New Smart Playlist and define the rules for your playlist.
Note:  To create playlists on iPod nano when iPod nano isn’t connected to your 
computer, see “Creating On-The-Go Playlists on iPod nano” on page 37.
Using Genius in iTunes
Genius automatically creates playlists containing songs in your library that go great 
together. To use Genius on iPod nano, you first need to set up Genius in iTunes. Genius 
is a free service, but an iTunes Store account is required (if you don’t have one, you can 
set one up when you turn on Genius).
To set up Genius:
1 In iTunes, choose Store > Turn On Genius.
2 Follow the onscreen instructions.
iTunes collects anonymous information about your library and compares it with all 
songs available at the iTunes Store and with the libraries of other iTunes Store 
customers. The amount of time this takes can vary according to the size of your library, 
connection speed, and other factors.
3 Connect and sync iPod nano.
You can now use Genius on iPod nano (see page 38).
To create a Genius playlist in iTunes:
1 Click Music in the Library list or select a playlist.
2 Select a song.
3 Click the Genius button at the bottom of the iTunes window.26 Chapter 2    Setting Up iPod nano 
4 To change the maximum number of songs included in the playlist, choose a number 
from the pop-up menu.
5 To save the playlist, click Save Playlist. You can add and remove items from a saved 
Genius playlist. You can also click Refresh to create a new playlist based on the same 
original song.
Genius playlists created in iTunes can be synced to iPod nano like any iTunes playlist. 
See “Syncing Music From Selected Playlists to iPod nano” on page 28.
Purchasing or Renting Videos and Downloading 
Video Podcasts
To purchase videos—movies, TV shows, and music videos—or rent movies online from 
the iTunes Store (part of iTunes and available in some countries only), you sign in to 
your iTunes Store account, find the videos you want, and then buy or rent them. 
A rented movie expires 30 days after you rent it or 24 hours after you begin playing it, 
whichever comes first. Expired rentals are deleted automatically.
Note:  These terms apply to U.S. rentals. Rental terms vary among countries.
To browse videos in the iTunes Store:
1 In iTunes, select iTunes Store in the source list.
2 Click an item (Movies, TV Shows, or Music Videos) in the iTunes Store list on the left.
You can also find some music videos as part of an album or other offer. 
You can view movie trailers or TV show previews. Videos in iTunes and in the iTunes 
Store have a display ( ) icon next to them.
To buy or rent a video:
1 Select iTunes Store in the source list, and then find the item you want to buy or rent.
2 Click Buy Video, Buy Episode, Buy Season, Buy Movie, or Rent Movie. 
Purchased videos appear when you select Movies or TV Shows (under Library) or 
Purchased (under Store) in the source list. Rented videos appear when you select 
Rented Movies (under Library).
Some items have other options, such as TV shows that let you buy a season pass for all 
episodes. 
To download a video podcast:
Video podcasts appear alongside other podcasts in the iTunes Store. You can subscribe 
to them and download them just as you would other podcasts. You don’t need an 
iTunes Store account to download podcasts. See “Purchasing Songs and Downloading 
Podcasts Using the iTunes Store” on page 21.Chapter 2    Setting Up iPod nano 27
Converting Your Own Videos to Work with iPod nano
You can view other video files on iPod nano, such as videos you create in iMovie on a 
Mac or videos you download from the Internet. Import the video into iTunes, convert it 
for use with iPod nano, if necessary, and then add it to iPod nano.
iTunes supports all the video formats that QuickTime supports. For more information, 
choose Help > QuickTime Player Help from the QuickTime Player menu bar.
To import a video into iTunes:
m Drag the video file to your iTunes library.
Some videos may be ready for use with iPod nano after you import them to iTunes. 
If you try to add a video to iPod nano (see “Syncing Videos Automatically” on page 31), 
and a message says the video can’t play on iPod nano, then you must convert the 
video for use with iPod nano.
To convert a video for use with iPod nano:
1 Select the video in your iTunes library.
2 Choose Advanced > “Convert Selection to iPod.”
Depending on the length and content of a video, converting it for use with iPod nano 
can take several minutes to several hours.
When you convert a video for use with iPod nano, the original video remains in your 
iTunes library. 
For more about converting video for iPod nano, go to 
www.info.apple.com/kbnum/n302758.
Adding Music to iPod nano 
After your music is imported and organized in iTunes, you can easily add it to 
iPod nano.
To set how music is added from your computer to iPod nano, you connect iPod nano to 
your computer, and then use iTunes preferences to choose iPod nano settings.28 Chapter 2    Setting Up iPod nano 
You can set iTunes to add music to iPod nano in three ways:
Â Sync all songs and playlists:  When you connect iPod nano, it’s automatically updated 
to match the songs and other items in your iTunes library. Any other songs on 
iPod nano are deleted. 
Â Sync selected playlists:  When you connect iPod nano, it’s automatically updated to 
match the songs in playlists you select in iTunes.
Â Manually add music to iPod nano:  When you connect iPod nano, you can drag songs 
and playlists individually to iPod nano, and delete songs and playlists individually 
from iPod nano. Using this option, you can add songs from more than one computer 
without erasing songs from iPod nano. When you manage music yourself, you must 
always eject iPod nano from iTunes before you can disconnect it.
Syncing Music Automatically
By default, iPod nano is set to sync all songs and playlists when you connect it to your 
computer. This is the simplest way to add music to iPod nano. You just connect 
iPod nano to your computer, let it add songs, audiobooks, videos, and other items 
automatically, and then disconnect it and go. If you added any songs to iTunes since 
the last time you connected iPod nano, they are synced with iPod nano. If you deleted 
songs from iTunes, they are removed from iPod nano.
To sync music with iPod nano:
m Simply connect iPod nano to your computer. If iPod nano is set to sync automatically, 
the update begins.
Important:  The first time you connect iPod nano to a computer, a message asks if you 
want to sync songs automatically. If you accept, all songs, audiobooks, and videos are 
erased from iPod nano and replaced with songs and other items from that computer. 
If you don’t accept, you can still add songs to iPod nano manually without erasing any 
of the songs already on iPod nano.
While music is being synced from your computer to iPod nano, the iTunes status 
window shows progress, and you see a sync icon next to the iPod nano icon in the 
source list.
When the update is done, a message in iTunes says “iPod update is complete.”
Syncing Music From Selected Playlists to iPod nano
Setting iTunes to sync selected playlists to iPod nano is useful if the music in your 
iTunes library doesn’t all fit on iPod nano. Only the music in the playlists you select is 
synced to iPod nano.
To set iTunes to sync music from selected playlists to iPod nano:
1 In iTunes, select iPod nano in the source list and click the Music tab. 
2 Select “Sync music” and then choose “Selected playlists.”Chapter 2    Setting Up iPod nano 29
3 Select the playlists you want.
4 To include music videos and display album artwork, select those options.
5 Click Apply.
If “Sync only checked songs and videos” is selected in the Summary pane, iTunes syncs 
only items that are checked.
Managing iPod nano Manually
Setting iTunes to let you manage iPod nano manually gives you the most flexibility for 
managing music and video on iPod nano. You can add and remove individual songs 
(including music videos) and videos (including movies and TV shows). Also, you can 
add music and video from multiple computers to iPod nano without erasing items 
already on iPod nano.
Setting iPod nano to manually manage music and video turns off the automatic sync 
options in the Music, Movies, and TV Shows panes. You cannot manually manage one 
and automatically sync another at the same time.
To set iTunes to let you manage music and video on iPod nano manually:
1 In iTunes, select iPod nano in the source list and click the Summary tab. 
2 In the Options section, select “Manually manage music and video.”
3 Click Apply.
When you manage songs and video yourself, you must always eject iPod nano from 
iTunes before you disconnect it.
To add a song, video, or other item to iPod nano:
1 Click Music or another Library item in the iTunes source list.
2 Drag a song or other item to iPod nano in the source list.
To remove a song, video, or other item from iPod nano:
1 In iTunes, select iPod nano in the source list.
2 Select a song or other item on iPod nano and press the Delete or Backspace key on 
your keyboard.
If you manually remove a song or other item from iPod nano, it isn’t deleted from your 
iTunes library.
To create a new playlist on iPod nano:
1 In iTunes, select iPod nano in the source list, and then click the Add (+) button or 
choose File > New Playlist. 
2 Type a name for the playlist.
3 Click an item, such as Music, in the Library list, and then drag songs or other items to 
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To add songs to or remove songs from a playlist on iPod nano:
m Drag a song to a playlist on iPod nano to add the song. Select a song in a playlist and 
press the Delete key on your keyboard to delete the song.
If you set iTunes to manage music manually, you can reset it later to sync automatically. 
To reset iTunes to sync all music automatically on iPod nano:
1 In iTunes, select iPod nano in the source list and click the Music tab. 
2 Select “Sync music” and then choose “All songs and playlists.”
3 Click Apply.
The update begins automatically.
If “Only sync checked items” is selected in the Summary pane, iTunes syncs only items 
that are checked in your Music and other libraries.
Adding Podcasts to iPod nano
The settings for adding podcasts to iPod nano are unrelated to the settings for adding 
songs. Podcast update settings don’t affect song update settings, and vice versa. You 
can set iTunes to automatically sync all or selected podcasts, or you can add podcasts 
to iPod nano manually.
To set iTunes to update the podcasts on iPod nano automatically:
1 In iTunes, select iPod nano in the source list and click the Podcasts tab.
2 In the Podcasts pane, select “Sync … episodes” and choose the number of episodes 
you want in the pop-up menu.
3 Click “All podcasts” or “Selected podcasts.” If you click “Selected podcasts,” also select 
the podcasts in the list that you want to sync.
4 Click Apply.
When you set iTunes to sync iPod nano podcasts automatically, iPod nano is updated 
each time you connect it to your computer.
Note:  If “Only sync checked items” is selected in the Summary pane, iTunes syncs only 
items that are checked in your Podcasts and other libraries.
To manually manage podcasts:
1 In iTunes, select iPod nano in the source list and click the Summary tab.
2 Select “Manually manage music and videos” and click Apply.
3 Select the Podcasts library in the source list and drag the podcasts you want to 
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Adding Videos to iPod nano
You add movies and TV shows to iPod nano much the same way you add songs. You 
can set iTunes to sync all movies and TV shows to iPod nano automatically when you 
connect iPod nano, or you can set iTunes to sync only selected playlists. Alternatively, 
you can manage movies and TV shows manually. Using this option, you can add videos 
from more than one computer without erasing videos already on iPod nano. 
Note:  Music videos are managed with songs, under the Music tab in iTunes. 
See “Adding Music to iPod nano” on page 27.
Important:  You can view a rented movie on only one device at a time. For example, if 
you rent a movie from the iTunes Store and add it to iPod nano, you can only view it on 
iPod nano. If you transfer the movie back to iTunes, you can only view it there and not 
on iPod nano. All standard time limits apply to rented movies added to iPod nano.
Syncing Videos Automatically
By default, iPod nano is set to sync all videos when you connect it to your computer. 
This is the simplest way to add videos to iPod nano. You just connect iPod nano to your 
computer, let it add videos and other items automatically, and then disconnect it and 
go. If you added any videos to iTunes since the last time you connected iPod nano, 
they are added to iPod nano. If you deleted videos from iTunes, they are removed from 
iPod nano.
You can set iPod nano to sync videos automatically when you connect it to your 
computer.
To sync videos to iPod nano:
m Simply connect iPod nano to your computer. If iPod nano is set to sync automatically, 
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Important:  The first time you connect iPod nano to a different computer and have the 
automatic sync option set, a message asks if you want to sync songs and videos 
automatically. If you accept, all songs, videos, and other items are deleted from 
iPod nano and replaced with the songs, videos, and other items in the iTunes library on 
that computer. If you don’t accept, you can still add videos to iPod nano manually 
without deleting any of the videos already on iPod nano. 
iTunes includes a feature to sync purchased items from iPod nano to another computer. 
For more information, see iTunes Help.
While videos are being synced from your computer to iPod nano, the iTunes status 
window shows progress and the iPod nano icon in the source list flashes red.
When the update is done, a message in iTunes says “iPod update is complete.”
Syncing Selected Videos to iPod nano
Setting iTunes to sync selected videos to iPod nano is useful if you have more videos in 
your iTunes library than will fit on iPod nano. Only the videos you specify are synced 
with iPod nano. You can sync selected videos or selected playlists that contain videos.
To set iTunes to sync unwatched or selected movies to iPod nano:
1 In iTunes, select iPod nano in the source list and click the Movies tab.
2 Select “Sync movies.”
3 Select the movies or playlists you want.
Unwatched movies:  Select “… unwatched movies” and choose the number you want 
from the pop-up menu.
Selected movies or playlists:  Click “Selected …,” choose “movies” or “playlists” from the 
pop-up menu, and then select the movies or playlists you want.
4 Click Apply.
If “Only sync checked items” is selected in the Summary pane, iTunes syncs only movies 
that are checked.
To set iTunes to sync most recent episodes or selected TV shows to iPod nano:
1 In iTunes, select iPod nano in the source list and click the TV Shows tab.
2 Select “Sync … episodes” and choose the number of episodes you want from the 
pop-up menu.
3 Click “Selected …” and choose “TV shows” or “playlists” from the pop-up menu.
4 Select the movies or playlists you want to sync.
5 Click Apply.
If “Only sync checked items” is selected in the Summary pane, iTunes syncs only TV 
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Managing Videos Manually
Setting iTunes to let you manage iPod nano manually gives you the most flexibility for 
managing videos on iPod nano. You can add and remove movies, TV shows, and other 
items individually. You can also add videos from multiple computers to iPod nano 
without removing videos already on iPod nano. See “Managing iPod nano Manually” 
on page 29.
If you set iTunes to manage movies and TV shows manually, you can reset iTunes later 
to sync them automatically. If you set iTunes to sync automatically after you’ve been 
manually managing iPod nano, you lose any items on iPod nano that aren’t part of your 
iTunes library.
To set iTunes to sync all movies automatically on iPod nano:
1 In iTunes, select iPod nano in the source list and click the Movies tab.
2 Select “Sync movies” and then select “All movies.”
3 Click Apply.
If “Only sync checked items” is selected in the Summary pane, iTunes syncs only movies 
that are checked.
To set iTunes to sync all TV shows automatically on iPod nano:
1 In iTunes, select iPod nano in the source list and click the TV Shows tab.
2 Select “Sync … episodes” and choose “all” from the pop-up menu.
3 Select “All TV shows.”
4 Click Apply.
If “Only sync checked items” is selected in the Summary pane, iTunes syncs only TV 
shows that are checked.
Adding Video Podcasts to iPod nano
You add video podcasts to iPod nano the same way you add other podcasts 
(see “Adding Podcasts to iPod nano” on page 30). If a podcast has a video component, 
the video plays when you choose it from Podcasts.3
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3 Listening to Music
After you set up iPod nano, you can listen to songs, podcasts, 
audiobooks, radio, and more. Read this chapter to learn 
about listening on the go.
Playing Music and Other Audio
Use the Click Wheel and Center button to browse for a song or music video. 
To browse for and play a song:
m Choose Music, browse for a song or music video, and press the Play/Pause button. 
Note:  When you browse for music videos in the Music menu, you only hear the music. 
When you browse for them in the Videos menu, you also see the video.
When a song is playing, the Now Playing screen appears. The following table describes 
the elements on the Now Playing screen of iPod nano.
Now Playing screen item Function
Shuffle (¡) icon Appears if iPod nano is set to shuffle songs or albums.
Repeat (⁄) icon Appears if iPod nano is set to repeat all songs. The Repeat Once 
(!) icon appears if iPod nano is set to repeat one song.
Album art Shows the album art, if it’s available.
Song information
(click the Center button 
to see the scrubber bar, 
Genius or shuffle slider, 
song rating and lyrics)
Album art
Shuffle icon
Repeat iconChapter 3    Listening to Music 35
To change the playback volume:
m When you see the progress bar, use the Click Wheel to change the volume. 
To listen to a different part of a song:
1 Press the Center button until you see the scrubber bar.
2 Use the Click Wheel to move the diamond along the scrubber bar.
To return to the previous menu:
m From any screen, press the Menu button to return to the previous menu.
Viewing Lyrics on iPod nano
If you enter lyrics for a song in iTunes (see “Adding Lyrics” on page 24) and then add 
the song to iPod nano, you can view the lyrics on iPod nano. Lyrics will not appear if 
you did not enter them.
To view lyrics on iPod nano while a song is playing:
m On the Now Playing screen, press the Center button until you see the lyrics. You can 
scroll through the lyrics as the song plays.
Rating Songs
You can assign a rating to a song (from 1 to 5 stars) to indicate how much you like it. 
You can use song ratings to help you create Smart Playlists automatically in iTunes.
To rate a song:
1 Start playing the song. 
2 From the Now Playing screen, press the Center button until the five rating bullets 
appear. 
3 Use the Click Wheel to choose a rating (represented by stars).
Note:  You cannot assign ratings to video podcasts.
Song information Displays the song title, artist, and album title.
Song time progress bar Shows the elapsed and remaining times for the song that’s playing.
Scrubber bar Allows you to quickly navigate to a different part of the track.
Genius slider Creates a Genius playlist based on the current song (doesn’t appear 
if Genius information isn’t available for the current song).
Shuffle slider Allows you to shuffle songs or albums directly from the Now 
Playing screen.
Song Rating Displays stars if you rate the song.
Lyrics Displays the lyrics of the song that’s playing (doesn’t appear if you 
didn’t enter the song’s lyrics).
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Viewing Album Artwork on iPod nano
By default, iTunes displays album artwork on iPod nano. If the artwork is available, you’ll 
see it on iPod nano in Cover Flow, in the album list, and when you play music from the 
album.
To set iTunes to display album artwork on iPod nano:
1 Connect iPod nano to your computer.
2 In iTunes, select iPod nano in the source list and click the Music tab.
3 Select “Display album artwork on your iPod.”
To see album artwork on iPod nano:
m Hold iPod nano horizontally to view Cover Flow, or play a song that has album artwork.
For more information about album artwork, open iTunes and choose Help > iTunes 
Help.
Accessing Additional Commands
Some iPod nano commands can be accessed directly from the Now Playing screen and 
some menus.
To access additional commands:
m Press and hold the Center button until a menu appears, select a command, and then 
press the Center button again.
Browsing Songs by Album or Artist
When you’re listening to a song, you can browse more songs by the same artist or all 
the songs in the current album.
To browse songs by album:
1 From the Now Playing screen, press and hold the Center button until a menu appears.
2 Choose Browse Album, and then press the Center button.
You see all the songs from the current album that are on iPod nano. You can select a 
different song or return to the Now Playing screen.Chapter 3    Listening to Music 37
To browse songs by artist:
1 From the Now Playing screen, press and hold the Center button until a menu appears.
2 Choose Browse Artist, and then press the Center button.
You see all the songs by that artist that are on iPod nano. You can select a different 
song or return to the Now Playing screen.
Creating On-The-Go Playlists on iPod nano
You can create playlists on iPod nano, called On-The-Go Playlists, when iPod nano isn’t 
connected to your computer.
To create an On-The-Go playlist:
1 Select a song, and then press and hold the Center button until a menu appears.
2 Choose “Add to On-The-Go.”
3 To add more songs, repeat steps 1 and 2.
4 Choose Music > Playlists > On-The-Go to browse and play your list of songs.
You can also add a group of songs. For example, to add an album, highlight the album 
title, press and hold the Center button until a menu appears, and then choose “Add to 
On-The-Go.”
To play songs in the On-The-Go playlist:
m Choose Music > Playlists > On-The-Go, and then choose a song.
To remove a song from the On-The-Go playlist:
1 Select a song in the playlist and hold down the Center button until a menu appears.
2 Choose “Remove from On-The-Go,” and then press the Center button.
To clear the entire On-The-Go playlist:
m Choose Music > Playlists > On-The-Go > Clear Playlist, and then click Clear.
To save the On-The-Go playlist on iPod nano:
m Choose Music > Playlists > On-The-Go > Save Playlist.
The first playlist is saved as “New Playlist 1” in the Playlists menu. The On-The-Go 
playlist is cleared. You can save as many playlists as you like. After you save a playlist, 
you can no longer remove songs from it.
To copy On-The-Go playlists from iPod nano to your computer:
m If iPod nano is set to update songs automatically (see “Syncing Music Automatically” on 
page 28) and you create an On-The-Go playlist, the playlist is automatically copied to 
iTunes when you connect iPod nano. The new On-The-Go playlist appears in the list of 
playlists in iTunes. You can rename, edit, or delete the new playlist, just as you would 
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Using Genius on iPod nano
When iPod nano isn’t connected to your computer, Genius can still automatically create 
instant playlists of songs that go great together. To use Genius, you need to set up 
Genius in the iTunes Store, and then sync iPod nano to iTunes. You can also create 
Genius playlists in iTunes and add them to iPod nano.
To set up Genius in iTunes, see “Using Genius in iTunes” on page 25.
To make a Genius playlist with iPod nano:
1 Select a song, and then press and hold the Center button until a menu appears.
You can select a song from a menu or playlist, or you can start from the Now Playing 
screen.
2 Choose Start Genius, and then press the Center button. The new playlist appears.
Start Genius doesn’t appear if any of the following apply:
Â You haven’t set up Genius in iTunes and then synced iPod nano to iTunes.
Â Genius doesn’t recognize the song you’ve selected.
Â Genius recognizes the song but there aren’t at least ten similar songs in your library. 
3 To keep the playlist, choose Save Playlist.
The playlist is saved with the song title and artist of the song you used to make the 
playlist.
4 To change the playlist to a new one based on the same song, choose Refresh. If you 
refresh a saved playlist, the new playlist replaces the previous one. You can’t recover the 
previous playlist.
You can also start Genius from the Now Playing screen by pressing the Center button 
until you see the Genius slider, and then using the Click Wheel to move the slider to the 
right. The Genius slider won’t appear if Genius doesn’t recognize the song that’s 
playing.
Genius playlists saved on iPod nano sync to iTunes when you connect iPod nano to 
your computer.
To play a Genius playlist:
m Choose Music > Playlists and choose the playlist.Chapter 3    Listening to Music 39
Setting iPod nano to Shuffle Songs 
You can set iPod nano to play songs, albums, or your entire library in random order.
To set iPod nano to shuffle and play all your songs: 
m Choose Shuffle Songs from the iPod nano main menu. 
iPod nano begins playing songs from your entire music library in random order, 
skipping audiobooks and podcasts.
To set iPod nano to always shuffle songs or albums:
1 Choose Settings from the iPod nano main menu.
2 Set Shuffle to either Songs or Albums.
When you set iPod nano to shuffle songs by choosing Settings > Shuffle, iPod nano 
shuffles songs within the list (for example, album or playlist) you choose to play. 
When you set iPod nano to shuffle albums, it plays all the songs on an album in order, 
and then randomly selects another album in the list and plays through it in order. 
You can also set iPod nano to shuffle songs directly from the Now Playing screen by 
clicking the Center button until the shuffle slider appears, and then using the Click 
Wheel to set iPod nano to shuffle songs or albums.
To shuffle songs while a song is playing or paused:
m Shake iPod nano from side to side. A new song starts to play.
Shaking to shuffle doesn’t change your shuffle settings, whether you set them by 
choosing Settings > Shuffle or by using the shuffle slider.40 Chapter 3    Listening to Music 
To disable shaking:
m Choose Settings > Playback > Shake and select Off.
To turn shaking on again, choose Settings > Playback > Shake, and then select On.
Shaking is also disabled when the Hold switch is in the HOLD position, or if the display 
is off. If iPod nano is off, you can’t turn it on by shaking it.
Setting iPod nano to Repeat Songs
You can set iPod nano to repeat a song over and over, or repeat songs within the list 
you choose to play.
To set iPod nano to repeat songs:
m Choose Settings from the iPod nano main menu.
Â To repeat all songs in the list, set Repeat to All.
Â To repeat one song over and over, set Repeat to One.
Customizing the Music Menu
You can add items to or remove them from the Music menu, just as you do with the 
main menu. For example, you can add a Compilations item to the Music menu, so you 
can easily choose compilations that are put together from various sources.
To add or remove items in the Music menu:
1 Choose Settings > General > Music Menu.
2 Select each item you want to appear in the Music menu. A checkmark indicates which 
items have been added. To revert to the original Music menu settings, choose Reset 
Menu.
Setting the Maximum Volume Limit
You can set a limit for the maximum volume on iPod nano and assign a combination to 
prevent the setting from being changed.
To set the maximum volume limit for iPod nano:
1 Choose Settings > Playback > Volume Limit.
The volume control shows the current volume. 
2 Use the Click Wheel to select the maximum volume limit.
3 Press the Center button to set the maximum volume limit.
A triangle on the volume bar indicates the maximum volume limit.Chapter 3    Listening to Music 41
To require a combination to change the maximum volume:
1 After setting the maximum volume, use the Click Wheel to select Lock and then press 
the Center button.
2 In the screen that appears, enter a combination. 
To enter a combination:
Â Use the Click Wheel to select a number for the first position. Press the Center button 
to confirm your choice and move to the next position. 
Â Use the same method to set the remaining numbers of the combination. You can use 
the Next/Fast-forward button to move to the next position and the Previous/Rewind 
button to move to the previous position. Press the Center button in the final position 
to confirm the entire combination.
The volume of songs and other audio may vary depending on how the audio was 
recorded or encoded. See “Setting Songs to Play at the Same Volume Level” on page 42 
for information about how to set a relative volume level in iTunes and on iPod nano. 
Volume level may also vary if you use different earphones or headphones. With the 
exception of the iPod Radio Remote, accessories that connect through the iPod Dock 
Connector don’t support volume limits.
If you set a combination, you must enter it before you can change or remove the 
maximum volume limit. 
To change the maximum volume limit:
1 Choose Settings > Playback > Volume Limit. 
2 If you set a combination, enter it by using the Click Wheel to select the numbers and 
pressing the Center button to confirm them. 
3 Use the Click Wheel to change the maximum volume limit.
4 Press the Play/Pause button to accept the change.
To remove the maximum volume limit:
1 If you’re currently listening to iPod nano, press Pause.
2 Choose Settings > Playback > Volume Limit. 
3 If you set a combination, enter it by using the Click Wheel to select the numbers and 
pressing the Center button to confirm them. 
4 Use the Click Wheel to move the volume limit to the maximum level on the volume bar. 
This removes any restriction on volume.
5 Press the Play/Pause button to accept the change.
If you forget the combination, you can restore iPod nano. See “Updating and Restoring 
iPod Software” on page 69.42 Chapter 3    Listening to Music 
Setting Songs to Play at the Same Volume Level
iTunes can automatically adjust the volume of songs, so they play at the same relative 
volume level. You can set iPod nano to use the iTunes volume settings.
To set iTunes to play songs at the same sound level:
1 In iTunes, choose iTunes > Preferences if you’re using a Mac, or choose 
Edit > Preferences if you’re using a Windows PC.
2 Click Playback and select Sound Check, and then click OK.
To set iPod nano to use the iTunes volume settings:
m Choose Settings and set Sound Check to On.
If you haven’t activated Sound Check in iTunes, setting it on iPod nano has no effect.
Using the Equalizer
You can use equalizer presets to change the sound on iPod nano to suit a particular 
music genre or style. For example, to make rock music sound better, set the equalizer 
to Rock. 
To use the equalizer to change the sound on iPod nano:
m Choose Settings > Playback > EQ, and then choose an equalizer preset. 
If you assigned an equalizer preset to a song in iTunes and the iPod nano equalizer is 
set to Off, the song plays using the iTunes setting. See iTunes Help for more 
information.
Crossfading Between Songs
You can set iPod nano to fade out at the end of each song and fade in at the beginning 
of the song following it.
To turn on crossfading:
m Choose Settings > Playback > Audio Crossfade and select On.
Note:  Songs that are grouped for gapless playback play without gaps even when 
crossfading is on.
Watching and Listening to Podcasts
Podcasts are downloadable audio or video shows you get at the iTunes Store. You can 
listen to audio podcasts and watch video podcasts. Podcasts are organized by shows, 
episodes within shows, and chapters within episodes. If you stop watching or listening 
to a podcast and go back to it later, the podcast begins playing from where you left off.
To watch or listen to a podcast:
1 From the main menu, choose Podcasts, and then choose a show.Chapter 3    Listening to Music 43
Shows appear in reverse chronological order so that you can watch or listen to the 
most recent one first. You see a blue dot next to shows and episodes you haven’t 
watched or listened to yet.
2 Choose an episode to play it.
The Now Playing screen displays the show, episode, and date information, along with 
elapsed and remaining time. Press the Center button to see more information about 
the podcast. If the podcast includes artwork, you also see a picture. Podcast artwork 
can change during an episode.
If the podcast has chapters, you can press the Next/Fast-forward or Previous/Rewind 
button to skip to the next chapter or the beginning of the current chapter in the 
podcast.
For more information about podcasts, open iTunes and choose Help > iTunes Help. 
Then search for “podcasts.”
Listening to Audiobooks
You can purchase and download audiobooks from the iTunes Store or from 
audible.com and listen to them on iPod nano.
Use iTunes to add audiobooks to iPod nano the same way you add songs. If you stop 
listening to an audiobook on iPod nano and go back to it later, the audiobook begins 
playing from where you left off. iPod nano skips audiobooks when set to shuffle.
If the audiobook you’re listening to has chapters, you can press the Next/Fast-forward 
or Previous/Rewind button to skip to the next chapter or the beginning of the current 
chapter.
You can play audiobooks at speeds faster or slower than normal.
To set audiobook play speed:
m Choose Settings > Playback > Audiobooks and choose a speed, or press and hold the 
Center button from the Now Playing window.
Setting the play speed affects only audiobooks purchased from the iTunes Store or 
audible.com.
Listening to FM Radio
You can listen to radio using the optional iPod Radio Remote accessory for iPod nano. 
iPod Radio Remote attaches to iPod nano using the Dock connector cable. When you’re 
using iPod Radio Remote, you see a Radio menu item on the iPod nano main menu. 
For more information, see the iPod Radio Remote documentation.4
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4 Watching Videos
You can use iPod nano to watch TV shows, movies, video 
podcasts, and more. Read this chapter to learn about 
watching videos on iPod nano and on your TV.
You can view and listen to videos on iPod nano. If you have an AV cable from Apple 
(available separately at www.apple.com/ipodstore), you can watch videos from 
iPod nano on your TV.
Watching and Listening to Videos on iPod nano
Videos you add to iPod nano appear in the Videos menus. Music videos also appear in 
Music menus. 
To watch a video on iPod nano:
m Choose Videos and browse for a video. Select a video and then press Play/Pause.
To watch the video, hold iPod nano horizontally. If you rotate iPod nano to the left or 
right, the video adjusts accordingly.
When you play a video on iPod nano, you see and hear the video. Chapter 4    Watching Videos 45
To just listen to a music video:
m Choose Music and browse for a music video.
When you play the video, you hear it but don’t see it.
When you play a playlist that includes video podcasts, you hear the podcasts but don’t 
see them.
To watch a video podcast:
m From the main menu, choose Podcasts and then choose a video podcast.
See “Watching and Listening to Podcasts” on page 42 for more information.
Watching Videos on a TV Connected to iPod nano
If you have an AV cable from Apple, you can watch videos on a TV connected to your 
iPod nano. First you set iPod nano to display videos on a TV, then connect iPod nano to 
your TV, and then play a video.
Note:  Use the Apple Component AV Cable, the Apple Composite AV Cable, or the 
Apple AV Connection Kit. Other similar RCA-type cables might not work. You can 
purchase the cables at www.apple.com/ipodstore.
To set iPod nano to display videos on a TV:
m Choose Videos > Settings, and then set TV Out to Ask or On.
If you set TV Out to Ask, iPod nano gives you the option of displaying videos on TV or 
on iPod nano every time you play a video.
You can also set video to display full screen or widescreen, and set video to display on 
PAL or NTSC devices.
To set TV settings:
m Choose Videos > Settings, and then follow the instructions below.
To set Do this
Video to display on a TV Set TV Out to Ask or On.
Video to display on PAL or 
NTSC TVs
Set TV Signal to PAL or NTSC.
PAL and NTSC refer to TV broadcast standards. Your TV might use 
either of these, depending on the region where it was purchased. 
If you aren’t sure which your TV uses, check the documentation 
that came with your TV.
The format of your external TV Set TV Screen to Widescreen for 16:9 format or Standard for 4:3 
format.
Video to fit to your screen Set “Fit to Screen” to On.
If you set “Fit to Screen” to Off, widescreen videos display in 
letterbox format on iPod nano or a standard (4:3) TV screen.
Alternate audio to play Set Alternate Audio to On.46 Chapter 4    Watching Videos 
To use the Apple Component AV Cable to connect iPod nano to your TV:
1 Plug the red, green, and blue video connectors into the component video input 
(Y, Pb, and Pr) ports on your TV.
You can also use the Apple Composite AV cable. If you do, plug in the yellow video 
connector into the video input port on your TV. Your TV must have RCA video and 
audio ports.
2 Plug the white and red audio connectors into the left and right analog audio input 
ports, respectively, on your TV. 
3 Plug the iPod Dock Connector into your iPod nano or Universal Dock.
4 Plug the USB connector into your USB Power Adapter or your computer to keep your 
iPod nano charged.
5 Turn on iPod nano and your TV or receiver to start playing.
Make sure you set TV Out on iPod nano to On.
Note:  The ports on your TV or receiver may differ from the ports in the illustration.
To watch a video on your TV:
1 Connect iPod nano to your TV (see above).
2 Turn on your TV and set it to display from the input ports connected to iPod nano. 
See the documentation that came with your TV for more information.
3 On iPod nano, choose Videos and browse for a video.
Captions to display Set Captions to On.
Subtitles to display Set Subtitles to On.
To set Do this
USB Power
Adapter
iPod Left audio (white)
Dock Connector
Television
Video in (Y, Pb, Pr)
Right audio (red)
USB
connector5
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5 Photo Features
You can import digital photos to your computer and add 
them to iPod nano. You can view your photos on iPod nano 
or as a slideshow on your TV. Read this chapter to learn about 
importing and viewing photos.
Importing Photos
You can import digital photos from a digital camera to your computer, and then add 
them to iPod nano for viewing. You can connect iPod nano to your TV and view photos 
as a slideshow with music.
Importing Photos from a Camera to Your Computer
You can import photos from a digital camera or a photo card reader.
To import photos to a Mac using iPhoto:
1 Connect the camera or photo card reader to your computer. Open iPhoto (located in 
the Applications folder) if it doesn’t open automatically. 
2 Click Import. 
Images from the camera are imported into iPhoto.
You can import other digital images into iPhoto, such as images you download from 
the web. For more information about importing and working with photos and other 
images, open iPhoto and choose Help > iPhoto Help.48 Chapter 5    Photo Features 
iPhoto is available for purchase as part of the iLife suite of applications at 
www.apple.com/ilife. iPhoto might already be installed on your Mac, in the 
Applications folder.
If you don’t have iPhoto, you can import photos using Image Capture.
To import photos to a Mac using Image Capture:
1 Connect the camera or photo card reader to your computer.
2 Open Image Capture (located in the Applications folder) if it doesn’t open 
automatically.
3 To choose specific items to import, click Download Some. Or to download all items, 
click Download All.
To import photos to a Windows PC:
m Follow the instructions that came with your digital camera or photo application.
Adding Photos From Your Computer to iPod nano
You can add photos to iPod nano from a folder on your hard disk. If you have a Mac 
and iPhoto 6 or later, you can sync iPhoto albums automatically. If you have a Windows 
PC and Adobe Photoshop Album 2.0 or later, or Adobe Photoshop Elements 4.0 or later, 
you can sync photo collections automatically.
Adding photos to iPod nano the first time might take some time, depending on how 
many photos are in your photo library.
To sync photos from a Mac or Windows PC to iPod nano using a photo application:
1 In iTunes, select iPod nano in the source list and click the Photos tab.
2 Select “Sync photos from: …”
Â On a Mac, choose iPhoto from the pop-up menu.
Â On a Windows PC, choose Photoshop Album or Photoshop Elements from the 
pop-up menu.
Note:  Some versions of Photoshop Album and Photoshop Elements don’t support 
collections. You can still use them to add all your photos.Chapter 5    Photo Features 49
3 If you want to add all your photos, select “All photos and albums.” If you want to keep 
your photos organized by event, select “…events” and choose an option from the popup menu. If you want to add photos from only certain albums, select “Selected albums” 
and select the albums you want.
4 Click Apply.
Each time you connect iPod nano to your computer, photos are synced automatically.
To add photos from a folder on your hard disk to iPod nano:
1 Drag the images you want into a folder on your computer.
If you want images to appear in separate photo albums on iPod nano, create folders 
inside the main image folder, and drag images into the new folders.
2 In iTunes, select iPod nano in the source list and click the Photos tab.
3 Select “Sync photos from …” 
4 Choose “Choose Folder” from the pop-up menu and select your image folder.
5 Click Apply.
When you add photos to iPod nano, iTunes optimizes the photos for viewing. 
Full-resolution image files aren’t transferred by default. Adding full-resolution image 
files is useful, for example if you want to move them from one computer to another, 
but isn’t necessary for viewing the images at full quality on iPod nano.
To add full-resolution image files to iPod nano:
1 In iTunes, select iPod nano in the source list and click the Photos tab.
2 Select “Include full-resolution photos.”
3 Click Apply.
iTunes copies the full-resolution versions of the photos to the Photos folder on 
iPod nano.
To delete photos from iPod nano:
1 In iTunes, select iPod nano in the source list and click the Photos tab.
2 Select “Sync photos from: …”
Â On a Mac, choose iPhoto from the pop-up menu.
Â On a Windows PC, choose Photoshop Album or Photoshop Elements from the pop-up 
menu.
3 Choose “Selected albums” and deselect the albums you no longer want on iPod nano.
4 Click Apply.50 Chapter 5    Photo Features 
Adding Photos from iPod nano to a Computer
If you add full-resolution photos from your computer to iPod nano using the previous 
steps, they’re stored in a Photos folder on iPod nano. You can connect iPod nano to a 
computer and put these photos on the computer. iPod nano must be enabled for disk 
use (see “Using iPod nano as an External Disk” on page 53).
To add photos from iPod nano to a computer:
1 Connect iPod nano to the computer.
2 Drag image files from the Photos folder or DCIM folder on iPod nano to the desktop or 
to a photo editing application on the computer.
You can also use a photo editing application, such as iPhoto, to add photos stored in 
the Photos folder. See the documentation that came with the application for more 
information.
To delete photos from the Photos folder on iPod nano:
1 Connect iPod nano to the computer.
2 Navigate to the Photos folder on iPod nano and delete the photos you no longer want.
Viewing Photos
You can view photos on iPod nano manually or as a slideshow. If you have an optional 
AV cable from Apple (for example, Apple Component AV Cable), you can connect 
iPod nano to your TV and view photos as a slideshow with music.
Viewing Photos on iPod nano
To view photos on iPod nano:
1 On iPod nano, choose Photos > All Photos. Or choose Photos and a photo album to see 
only the photos in the album. Thumbnail views of the photos might take a moment to 
appear.
2 Select the photo you want and press the Center button.Chapter 5    Photo Features 51
3 To view photos, hold iPod nano vertically for portrait format, or horizontally for 
landscape format.
From any photo-viewing screen, use the Click Wheel to scroll through photos (if you’re 
viewing a slideshow, the Click Wheel controls music volume only). Press the Next/Fastforward or Previous/Rewind button to skip to the next or previous screen of photos. 
Press and hold the Next/Fast-forward or Previous/Rewind button to skip to the last or 
first photo in the library or album.
Viewing Slideshows
You can view a slideshow, with music and transitions if you choose, on iPod nano. 
If you have an optional AV cable from Apple, you can view the slideshow on your TV.
To set slideshow settings:
m Choose Photos > Settings, and then follow these instructions:
To set Do this
How long each slide is shown Choose Time Per Slide and pick a time.
The music that plays during 
slideshows
Choose Music and choose a playlist or Now Playing. If you’re using 
iPhoto, you can choose From iPhoto to copy the iPhoto music 
setting. Only the songs that you’ve added to iPod nano play.
Slides to repeat Set Repeat to On.
Slides to display in random 
order
Set Shuffle Photos to On.
Slides to display with 
transitions
Choose Transitions and choose a transition type.
Slideshows to display on 
iPod nano
Set TV Out to Ask or Off.52 Chapter 5    Photo Features 
To view a slideshow on iPod nano:
m Select any photo, album, or roll, and press the Play/Pause button. Or select any 
full-screen photo and press the Center button. To pause, press the Play/Pause button. 
To skip to the next or previous photo, press the Next/Fast-forward or Previous/Rewind 
button.
When you view a slideshow, the Click Wheel controls just the music volume. You can’t 
use the Click Wheel to scroll through photos during a slideshow.
To connect iPod nano to your TV:
1 Connect the optional Apple Component or Composite AV cable to iPod nano.
Use the Apple Component AV Cable, Apple Composite AV Cable, or Apple AV 
Connection Kit. Other similar RCA-type cables won’t work. You can purchase the cables 
at www.apple.com/ipodstore.
2 Connect the audio connectors to the ports on your TV (for an illustration, 
see page 46).
Your TV must have RCA video and audio ports.
To view a slideshow on your TV:
1 Connect iPod nano to your TV (see above).
2 Turn on your TV and set it to display from the input ports connected to iPod nano. 
See the documentation that came with your TV for more information.
3 On iPod nano, select any photo or album and press the Play/Pause button. Or select 
any full-screen photo and press the Center button. To pause, press the Play/Pause 
button. To skip to the next or previous photo, press the Next/Fast-forward or Previous/
Rewind button.
If you selected a playlist in Photos > Settings > Music, the playlist plays automatically 
when you start the slideshow. The photos display on your TV and advance 
automatically according to settings in the Slideshow > Settings menu.
Slideshows to display on TV Set TV Out to Ask or On.
If you set TV Out to Ask, iPod nano gives you the option of showing 
slideshows on TV or on iPod nano every time you start a slideshow.
Slides to show on PAL 
or NTSC TVs
Set TV Signal to PAL or NTSC.
PAL and NTSC refer to TV broadcast standards. Your TV might use 
either of these, depending on the region where it was purchased. 
If you aren’t sure which your TV uses, check the documentation 
that came with your TV.
To set Do this6
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6 More Settings, Extra Features,
and Accessories
iPod nano can do a lot more than play songs. And you can do 
a lot more with it than listen to music.
Read this chapter to find out more about the extra features of iPod nano, including 
how to use it as an external disk, alarm, or sleep timer; play games; show the time of 
day in other parts of the world; display notes; and sync contacts, calendars, and to-do 
lists. Learn about how to use iPod nano as a stopwatch and to lock the screen, and 
about the accessories available for iPod nano.
Using iPod nano as an External Disk
You can use iPod nano as an external disk to store data files. 
You won’t see songs you add using iTunes in the Mac Finder or in Windows Explorer. 
And if you copy music files to iPod nano in the Mac Finder or Windows Explorer, you 
won’t be able to play them on iPod nano.
To enable iPod nano as an external disk:
1 In iTunes, select iPod nano in the source list and click the Summary tab.
2 In the Options section, select “Enable disk use.”
3 Click Apply.
When you use iPod nano as an external disk, the iPod nano disk icon appears on 
the desktop on Mac, or as the next available drive letter in Windows Explorer on a 
Windows PC.
Note:  Clicking Summary and selecting “Manually manage music and videos” in the 
Options section also enables iPod nano to be used as an external disk. Drag files to and 
from iPod nano to copy them.
If you use iPod nano primarily as a disk, you might want to keep iTunes from opening 
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To prevent iTunes from opening automatically when you connect iPod nano to your 
computer:
1 In iTunes, select iPod nano in the source list and click the Summary tab.
2 In the Options section, deselect “Open iTunes when this iPod is connected.”
3 Click Apply.
Using Extra Settings
You can set the date and time, clocks in different time zones, and alarm and sleep 
features on iPod nano. You can use iPod nano as a stopwatch or to play games, and you 
can lock the iPod nano screen.
Setting and Viewing the Date and Time
The date and time are set automatically from your computer’s clock when you connect 
iPod nano, but you can change the settings.
To set date and time options:
1 Choose Settings > Date & Time.
2 Choose one or more of the following options:
Adding Clocks for Other Time Zones
To add clocks for other time zones:
1 Choose Extras > Clocks.
2 On the Clocks screen, click the Center button and choose Add.
3 Choose a region and then choose a city.
The clocks you add appear in a list. The last clock you added appears last.
To delete a clock:
1 Choose Extras > Clocks.
2 Choose the clock.
To  Do this
Set the date Choose Date. Use the Click Wheel to change the selected value. 
Press the Center button to move to the next value.
Set the time Choose Time. Use the Click Wheel to change the selected value. 
Press the Center button to move to the next value.
Specify the time zone Choose Time Zone and use the Click Wheel to select a city in 
another time zone.
Display the time in 24-hour 
format
Choose 24 Hour Clock and press the Center button to turn the 
24-hour format on or off. 
Display the time in the title bar Choose Time in Title and press the Center button to turn the option 
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3 Press the Center button.
4 Choose Delete.
Setting Alarms
You can set an alarm for any clock on iPod nano.
To use iPod nano as an alarm clock:
1 Choose Extras > Alarms.
2 Choose Create Alarm and set one or more of the following options:
If you sync calendar events with alarms to iPod nano, the events appear in the Alarms 
menu.
To delete an alarm:
1 Choose Extras > Alarms.
2 Choose the alarm and then choose Delete.
Setting the Sleep Timer
You can set iPod nano to turn off automatically after playing or other content for a 
specific period of time.
To set the sleep timer:
1 Choose Extras > Alarms.
2 Choose Sleep Timer and choose how long you want iPod nano to play.
Using the Stopwatch
You can use the stopwatch as you exercise to track your overall time and, if you’re 
running on a track, your lap times. You can play music while you use the stopwatch.
To Do this
Turn the alarm on Choose Alarm and choose On.
Set the date Choose Date. Use the Click Wheel to change the selected value. 
Press the Center button to move to the next value.
Set the time Choose Time. Use the Click Wheel to change the selected value. 
Press the Center button to move to the next value.
Set a repeat option Choose Repeat and choose an option (for example, “weekdays”).
Choose a sound Choose Alerts or a playlist. If you choose Alerts, select Beep to hear 
the alarm through the internal speaker. If you choose a playlist, 
you’ll need to connect iPod nano to speakers or headphones to 
hear the alarm.
Name the alarm Choose Label and choose an option (for example, “Wake up”).56 Chapter 6    More Settings, Extra Features, and Accessories 
To use the stopwatch:
1 Choose Extras > Stopwatch.
2 Press Play/Pause to start the timer. 
3 Press the Center button to record lap times. The two most recent lap times appear 
above the overall time. All lap times are recorded in the log.
4 Press Play/Pause to stop the overall timer. To start the timer again, press Play/Pause.
To start a new stopwatch session, press the Menu button and then choose New Timer.
To review or delete a logged stopwatch session:
1 Choose Extras > Stopwatch.
The current log and a list of saved sessions appear.
2 Choose a log to view session information.
iPod nano stores stopwatch sessions with dates, times, and lap statistics. You see the 
date and time the session started; the total time of the session; the shortest, longest, 
and average lap times; and the last several lap times.
3 Press the Center button and choose Delete Log to delete the chosen log, or Clear Logs 
to delete all current logs.
Playing Games
iPod nano comes with three games:  Klondike, Maze, and Vortex. 
To play a game:
m Choose Extras > Games and choose a game.
When you play a game created for previous versions of iPod nano, you’re first shown 
how iPod nano controls work in the game you’re about to play.
You can purchase additional games from the iTunes Store (in some countries) to play 
on iPod nano. After purchasing games in iTunes, you can add them to iPod nano by 
syncing them automatically or by managing them manually. 
Many games can be played in portrait or landscape mode.
To buy a game:
1 In iTunes, select iTunes Store in the source list.
2 Choose iPod Games from the iTunes Store list.
3 Select the game you want and click Buy Game.
To sync games automatically to iPod nano:
1 In iTunes, select iPod nano in the source list and click the Games tab.
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3 Click “All games” or “Selected games.” If you click “Selected games,” also select the 
games you want to sync.
4 Click Apply.
Locking the iPod nano Screen
You can set a combination to prevent iPod nano from being used by someone without 
your permission. If you lock iPod nano while it isn’t connected to a computer, you must 
then enter a combination to unlock and use it.
This combination is different from the Hold button, which just prevents iPod nano 
buttons from being pressed accidentally. The combination prevents another person 
from using iPod nano.
To set a combination for iPod nano:
1 Choose Extras > Screen Lock.
2 On the New Combination screen, enter a combination:
Â Use the Click Wheel to select a number for the first position. Press the Center button 
to confirm your choice and move to the next position. 
Â Use the same method to set the remaining numbers of the combination. You can use 
the Next/Fast-forward button to move to the next position and the Previous/Rewind 
button to move to the previous position. Press the Center button in the final 
position.
3 On the Confirm Combination screen, enter the combination to confirm it, or press 
Menu to exit without locking the screen.
When you finish, you return to the Screen Lock screen, where you can lock the screen 
or reset the combination. Press the Menu button to exit without locking the screen.
To lock the iPod nano screen:
m Choose Extras > Screen Lock > Lock.
If you just finished setting your combination, Lock will already be selected on the 
screen. Just press the Center button to lock iPod.
When the screen is locked, you see a picture of a lock. 
You might want to add the Screen Lock menu item to the main menu so that you can 
quickly lock the iPod nano screen. See “Adding or Removing Items on the Main Menu” 
on page 11.
When you see the lock on the screen, you can unlock the iPod nano screen in two 
ways:
Â Press the Center button to enter the combination on iPod nano. Use the Click Wheel 
to select the numbers and press the Center button to confirm them. If you enter the 
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Â Connect iPod nano to the primary computer you use it with, and iPod nano 
automatically unlocks.
Note:  If you try these methods and you still can’t unlock iPod nano, you can restore 
iPod nano. See “Updating and Restoring iPod Software” on page 69.
To change a combination you’ve already set:
1 Choose Extras > Screen Lock > Reset.
2 On the Enter Combination screen, enter the current combination.
3 On the New Combination screen, enter and confirm a new combination.
If you can’t remember the current combination, the only way to clear it and enter a 
new one is to restore the iPod nano software. See “Updating and Restoring iPod 
Software” on page 69.
Syncing Contacts, Calendars, and To-Do Lists
iPod nano can store contacts, calendar events, and to-do lists for viewing on the go. 
You can use iTunes to sync the contact and calendar information on iPod nano with 
Address Book and iCal.
If you’re using Windows XP, and you use Windows Address Book or Microsoft Outlook 
2003 or later to store your contact information, you can use iTunes to sync the address 
book information on iPod nano. If you use Microsoft Outlook 2003 or later to keep a 
calendar, you can also sync calendar information.
To sync contacts or calendar information using Mac OS X v10.4.11 or later:
1 Connect iPod nano to your computer.
2 In iTunes, select iPod nano in the source list and click the Contacts tab.
3 Do one of the following:
Â To sync contacts, in the Contacts section, select “Sync Address Book contacts,” and 
select an option:
Â To sync all contacts automatically, select “All contacts.”
Â To sync selected groups of contacts automatically, select “Selected groups” and 
select the groups you want to sync.
Â To copy contacts’ photos to iPod nano, when available, select “Include contacts’ 
photos.”
When you click Apply, iTunes updates iPod nano with the Address Book contact 
information you specified. 
Â To sync calendars, in the Calendars section, select “Sync iCal calendars,” and choose 
an option:
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Â To sync selected calendars automatically, choose “Selected calendars” and select 
the calendars you want to sync.
When you click Apply, iTunes updates iPod nano with the calendar information you 
specified. 
To sync contacts or calendars using Windows Address Book or Microsoft Outlook for 
Windows:
1 Connect iPod nano to your computer.
2 In iTunes, select iPod nano in the source list and click the Contacts tab.
3 Do one of the following:
Â To sync contacts, in the Contacts section, select “Sync contacts from” and choose 
Windows Address Book or Microsoft Outlook from the pop-up menu. Then select 
which contact information you want to sync.
Â To sync calendars from Microsoft Outlook, in the Calendars section, select “Sync 
calendars from Microsoft Outlook.”
4 Click Apply.
You can also add contact and calendar information to iPod nano manually. iPod nano 
must be enabled as an external disk (see “Using iPod nano as an External Disk” on 
page 53).
To add contact information manually: 
1 Connect iPod nano and open your favorite email or contacts application. You can add 
contacts using Palm Desktop, Microsoft Outlook, Microsoft Entourage, and Eudora, 
among others.
2 Drag contacts from the application’s address book to the Contacts folder on iPod nano.
In some cases, you might need to export contacts and then drag the exported file or 
files to the Contacts folder. See the documentation for your email or contacts 
application.
To add appointments and other calendar events manually:
1 Export calendar events from any calendar application that uses the standard iCal 
format (filenames end in .ics) or vCal format (filenames end in .vcs).
2 Drag the files to the Calendars folder on iPod nano. 
To add to-do lists to iPod nano manually, save them in a calendar file with an .ics or .vcs 
extension.
To view contacts on iPod nano:
m Choose Extras > Contacts.
To sort contacts by first or last name:
m Choose Settings > General > Sort Contacts, and then select First or Last.60 Chapter 6    More Settings, Extra Features, and Accessories 
To view calendar events:
m Choose Extras > Calendars > All Calendars, and then choose a calendar.
To view to-do lists:
m Choose Extras > Calendars > To Do’s.
Storing and Reading Notes
You can store and read text notes on iPod nano if it’s enabled as an external disk 
(see “Using iPod nano as an External Disk” on page 53).
1 Save a document in any word-processing application as a text (.txt) file.
2 Place the file in the Notes folder on iPod nano.
To view notes:
m Choose Extras > Notes.
Recording Voice Memos
You can record voice memos using an optional iPod nano–compatible microphone 
(available for purchase at www.apple.com/ipodstore). You can set chapter marks while 
you record, store voice memos on iPod nano and sync them with your computer, and 
add labels to voice memos.
Voice memos cannot be longer than two hours. If you record for more than two hours, 
iPod nano automatically starts a new voice memo to continue your recording.
To record a voice memo:
1 Connect a microphone to the Dock connector port on iPod nano.
The Voice Memos item appears in the main menu.
2 To begin recording, choose Voice Memo > Start Recording. 
3 Hold the microphone a few inches from your mouth and speak. To pause recording, 
press the Menu button.
Choose Resume to continue recording.
4 When you finish, press Menu and then choose “Stop and Save.” Your saved recording is 
listed by date and time.
To set chapter marks:
m While recording, press the Center button whenever you want to set a chapter mark.
During playback, you can go directly to the next chapter by pressing the Next/Forward 
button. Press the Previous/Rewind button once to go to the start of the current 
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To label a recording:
1 Choose Voice Memos > Recordings, and then choose a saved recording.
2 Choose Label, and then choose a label for the recording.
You can choose Podcast, Interview, Lecture, Idea, Meeting, or Memo. To remove a label 
from a recording, choose None.
To play a recording:
m In the main menu, choose Voice Memos and select the recording.
You won’t see a Voice Memos menu item if you’ve never connected a microphone to 
iPod nano.
To sync voice memos with your computer:
Voice memos are saved in a Recordings folder on iPod in the WAV file format. If you 
enable iPod nano for disk use, you can drag voice memos from the folder to copy 
them.
If iPod nano is set to sync songs automatically (see “Syncing Music Automatically” on 
page 28) voice memos on iPod nano are automatically synced as an album in iTunes 
(and removed from iPod nano) when you connect iPod nano. The new Voice Memos 
playlist appears in the source list.
Using Spoken Menus for Accessibility
iPod nano features optional spoken menus, enabling visually impaired users to browse 
through their iPod nano content more easily. 
iTunes generates spoken menus using voices that are included in your computer’s 
operating system or that you may have purchased from third parties. Not all voices 
from computer operating systems or third parties are compatible with spoken menus, 
and not all languages are supported. 
You must enable spoken menus in iTunes before you can activate them on iPod nano.
To enable spoken menus in iTunes:
1 Connect iPod nano to your computer.
2 In iTunes, select iPod nano in the source list and click the Summary tab.
3 Select “Enable spoken menus for accessibility.” 
In Mac OS X, if you have VoiceOver turned on in Universal Access preferences, this 
option is selected by default.
4 Click Apply.
After iPod nano syncs with iTunes, spoken menus are enabled and activated on your 
iPod nano. iPod nano takes longer to sync if spoken menus are being enabled.62 Chapter 6    More Settings, Extra Features, and Accessories 
To deactivate spoken menus on iPod nano:
m Choose Settings > Spoken Menus and then choose Off.
To turn spoken menus on again, choose Settings > General > Spoken Menus, and then 
choose On.
Note:  The Spoken Menus option appears in the Settings menu on iPod nano only if 
spoken menus have been enabled in iTunes.
Learning About iPod nano Accessories
iPod nano comes with some accessories, and many other accessories are available. 
To purchase iPod nano accessories, go to www.apple.com/ipodstore. 
Available accessories include:
Â Apple Headphones with Remote and Mic
Â Apple In-Ear Headphones with Remote and Mic
Â Nike + iPod Sport Kit
Â Apple Universal Dock
Â Apple Component AV Cable
Â Apple Composite AV Cable
Â Apple AV Connection Kit
Â Apple USB Power Adapter 
Â Apple USB/FireWire Adapter
Â iPod In-Ear Headphones
Â iPod Radio Remote
Â World Travel Adapter Kit
Â iPod Socks
Â iPod Earphones
Â Third-party accessories—such as speakers, headsets, cases, car stereo adapters, 
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To use the earphones included with iPod nano:
m Plug the earphones into the Headphones port. Then place the earbuds in your ears as 
shown. 
WARNING:  Permanent hearing loss may occur if earbuds or headphones are used at 
high volume. You can adapt over time to a higher volume of sound that may sound 
normal but can be damaging to your hearing. If you experience ringing in your ears or 
muffled speech, stop listening and have your hearing checked. The louder the volume, 
the less time is required before your hearing could be affected. Hearing experts 
suggest that to protect your hearing:
Â Limit the amount of time you use earbuds or headphones at high volume.
Â Avoid turning up the volume to block out noisy surroundings. 
Â Turn the volume down if you can’t hear people speaking near you.
For information about setting a maximum volume limit on iPod, see “Setting the 
Maximum Volume Limit” on page 40.
The earphones
cord is adjustable.7
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7 Tips and Troubleshooting
Most problems with iPod nano can be solved quickly by 
following the advice in this chapter.
General Suggestions
Most problems with iPod nano can be solved by resetting it. First, make sure iPod nano 
is charged.
To reset iPod nano:
1 Toggle the Hold switch on and off (slide it to HOLD and then back again).
2 Press and hold the Menu and Center buttons for at least 6 seconds, until the 
Apple logo appears.
If iPod nano won’t turn on or respond
Â Make sure the Hold switch isn’t set to HOLD.
Â The iPod nano battery might need to be recharged. Connect iPod nano to your 
computer or to an Apple USB Power Adapter and let the battery recharge. Look for 
the lightning bolt icon on the iPod nano screen to verify that iPod nano is receiving a 
charge.
To charge the battery, connect iPod nano to a USB 2.0 port on your computer. 
The 5 Rs:  Reset, Retry, Restart, Reinstall, Restore
Remember these five basic suggestions if you have a problem with iPod nano. Try 
these steps one at a time until your issue is resolved. If one of the following doesn’t 
help, read on for solutions to specific problems. 
Â Reset iPod nano. See “General Suggestions,” below.
Â Retry with a different USB port if you cannot see iPod nano in iTunes.
Â Restart your computer, and make sure you have the latest software updates 
installed.
Â Reinstall iTunes software from the latest version on the web.
Â Restore iPod nano. See “Updating and Restoring iPod Software” on page 69.Chapter 7    Tips and Troubleshooting 65
Â Try the 5 Rs, one by one, until iPod nano responds.
If you want to disconnect iPod nano, but you see the message “Connected” or “Sync 
in Progress”
Â If iPod nano is syncing music, wait for it to complete.
Â Select iPod nano in the iTunes source list and click the Eject (C) button.
Â If iPod nano disappears from the list of devices in the iTunes source list, but you still 
see the “Connected” or “Sync in Progress” message on the iPod nano screen, 
disconnect iPod nano.
Â If iPod nano doesn’t disappear from the list of devices in the iTunes source list, drag 
the iPod nano icon from the desktop to the Trash (if you’re using a Mac) or, if you’re 
using a Windows PC, eject the device in My Computer or click the Safely Remove 
Hardware icon in the system tray and select iPod nano. If you still see the 
“Connected” or “Sync in Progress” message, restart your computer and eject 
iPod nano again.
If iPod nano isn’t playing music
Â Make sure the Hold switch isn’t set to HOLD.
Â Make sure the headphone connector is pushed in all the way.
Â Make sure the volume is adjusted properly. A maximum volume limit might have 
been set. You can change or remove it by using Settings > Volume Limit. See “Setting 
the Maximum Volume Limit” on page 40.
Â iPod nano might be paused. Try pressing the Play/Pause button.
Â Make sure you’re using iTunes 8.0 or later (go to www.apple.com/ipod/start). Songs 
purchased from the iTunes Store using earlier versions of iTunes won’t play on 
iPod nano until you upgrade iTunes.
Â If you’re using the iPod Universal Dock, make sure the iPod nano is seated firmly in 
the Dock and make sure all cables are connected properly. 
If you connect iPod nano to your computer and nothing happens
Â Make sure you have installed the latest iTunes software from 
www.apple.com/ipod/start.
Â Try connecting to a different USB port on your computer. 
Note:  A USB 2.0 port is recommended to connect iPod nano. USB 1.1 is significantly 
slower than USB 2.0. If you have a Windows PC that doesn’t have a USB 2.0 port, in 
some cases you can purchase and install a USB 2.0 card. For more information, go to 
www.apple.com/ipod. 
Â iPod nano might need to be reset (see page 64). 
Â If you’re connecting iPod nano to a portable or laptop computer using the iPod Dock 
Connector to USB 2.0 Cable, connect the computer to a power outlet before 
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Â Make sure you have the required computer and software. See “If you want to doublecheck the system requirements” on page 68.
Â Check the cable connections. Unplug the cable at both ends and make sure no 
foreign objects are in the USB ports. Then plug the cable back in securely. Make sure 
the connectors on the cables are oriented correctly. They can be inserted only one 
way.
Â Try restarting your computer.
Â If none of the previous suggestions solves your problems, you might need to restore 
iPod nano software. See “Updating and Restoring iPod Software” on page 69.
If iPod nano displays a “Connect to Power” message
This message may appear if iPod nano is exceptionally low on power and the battery 
needs to be charged before iPod nano can communicate with your computer. To 
charge the battery, connect iPod nano to a USB 2.0 port on your computer. 
Leave iPod nano connected to your computer until the message disappears and 
iPod nano appears in iTunes or the Finder. Depending on how depleted the battery is, 
you may need to charge iPod nano for up to 30 minutes before it will start up. 
To charge iPod nano more quickly, use the optional Apple USB Power Adapter.
If iPod nano displays a “Use iTunes to restore” message
Â Make sure you have the latest version of iTunes on your computer (download it from 
www.apple.com/ipod/start).
Â Connect iPod nano to your computer. When iTunes opens, follow the onscreen 
prompts to restore iPod nano. 
Â If restoring iPod nano doesn’t solve the problem, iPod nano may need to be repaired. 
You can arrange for service at the iPod Service & Support website:
www.apple.com/support/ipod
If songs or data sync more slowly over USB 2.0
Â If you sync a large number of songs or amount of data using USB 2.0 and the 
iPod nano battery is low, iPod nano syncs the information at a reduced speed in 
order to conserve battery power.
Â If you want to sync at higher speeds, you can stop syncing and keep the iPod nano 
connected so that it can recharge, or connect it to the optional iPod USB 2.0 Power 
Adapter. Let iPod nano charge for about an hour, and then resume syncing your 
music or data.
If you can’t add a song or other item to iPod nano
The song may have been encoded in a format that iPod nano doesn’t support. The 
following audio file formats are supported by iPod nano. These include formats for 
audiobooks and podcasting:
Â AAC (M4A, M4B, M4P, up to 320 Kbps)Chapter 7    Tips and Troubleshooting 67
Â Apple Lossless (a high-quality compressed format)
Â MP3 (up to 320 Kbps)
Â MP3 Variable Bit Rate (VBR)
Â WAV
Â AA (audible.com spoken word, formats 2, 3, and 4)
Â AIFF
A song encoded using Apple Lossless format has full CD-quality sound, but takes up 
only about half as much space as a song encoded using AIFF or WAV format. The same 
song encoded in AAC or MP3 format takes up even less space. When you import music 
from a CD using iTunes, it’s converted to AAC format by default.
Using iTunes for Windows, you can convert nonprotected WMA files to AAC or MP3 
format. This can be useful if you have a library of music encoded in WMA format. 
iPod nano doesn’t support WMA, MPEG Layer 1, MPEG Layer 2 audio files, or 
audible.com format 1.
If you have a song in iTunes that isn’t supported by iPod nano, you can convert it to a 
format iPod nano supports. For more information, see iTunes Help.
If iPod nano displays a “Connect to iTunes to activate Genius” message:
You haven’t activated Genius in iTunes, or you haven’t synced iPod nano since you 
activated Genius in iTunes. See “Using Genius in iTunes” on page 25.
If iPod nano displays a “Genius is not available for the selected song” message:
Genius is activated but doesn’t recognize the song you selected to start a Genius 
playlist. New songs are added to the iTunes Store Genius database all the time, so try 
again soon.
If you accidentally set iPod nano to use a language you don’t understand
You can reset the language.
1 Press and hold Menu until the main menu appears.
2 Choose the sixth menu item (Settings).
3 Choose the last menu item (Reset Settings).
4 Choose the first item (Reset) and select a language.
Other iPod nano settings, such as song repeat, are also reset.
Note:  If you added or removed items from the iPod nano main menu (see “Adding or 
Removing Items on the Main Menu” on page 11) the Settings menu item may be in a 
different place. If you can’t find the Reset Settings menu item, you can restore 
iPod nano to its original state and choose a language. See “Updating and Restoring 
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If you can’t see videos or photos on your TV
Â You must use RCA-type cables made specifically for iPod nano, such as the Apple 
Component or Apple Composite AV cables, to connect iPod nano to your TV. Other 
similar RCA-type cables won’t work.
Â Make sure your TV is set to display images from the correct input source (see the 
documentation that came with your TV for more information).
Â Make sure all cables are connected correctly (see “Watching Videos on a TV 
Connected to iPod nano” on page 45).
Â Make sure the yellow end of the Apple Composite AV Cable is connected to the 
video port on your TV.
Â If you’re trying to view a video, choose Videos > Settings and set TV Out to On, and 
then try again. If you’re trying to view a slideshow, choose Photos > Slideshow 
Settings and set TV Out to On, and then try again.
Â If that doesn’t work, choose Videos > Settings (for video) or Photos > Settings (for a 
slideshow) and set TV Signal to PAL or NTSC, depending on which type of TV you 
have. Try both settings.
If you want to double-check the system requirements
To use iPod nano, you must have:
Â One of the following computer configurations:
Â A Mac with a USB 2.0 port
Â A Windows PC with a USB 2.0 or a USB 2.0 card installed
Â One of the following operating systems:
Â Mac OS X v10.4.11 or later
Â Windows Vista
Â Windows XP Home or Professional with Service Pack 3 or later
Â iTunes 8.0 or later (iTunes can be downloaded from www.apple.com/ipod/start)
If your Windows PC doesn’t have a USB 2.0 port, you can purchase and install a USB 2.0 
card. For more information about cables and compatible USB cards, go to 
www.apple.com/ipod.
On the Mac, iPhoto 6 or later is recommended for adding photos and albums to 
iPod nano. This software is optional. iPhoto might already be installed on your Mac. 
Check the Applications folder.
On a Windows PC, iPod nano can sync photo collections automatically from Adobe 
Photoshop Album 2.0 or later, and Adobe Photoshop Elements 4.0 or later, available at 
www.adobe.com. This software is optional. 
On both Mac and Windows PC, iPod nano can sync digital photos from folders on your 
computer’s hard disk.Chapter 7    Tips and Troubleshooting 69
If you want to use iPod nano with a Mac and a Windows PC
If you’re using iPod nano with a Mac and you want to use it with a Windows PC, you 
must restore the iPod software for use with the PC (see “Updating and Restoring iPod 
Software” on page 69). Restoring the iPod software erases all data from iPod nano, 
including all songs.
You cannot switch from using iPod nano with a Mac to using it with a Windows PC 
without erasing all data on iPod nano.
If you lock the iPod nano screen and can’t unlock it
Normally, if you can connect iPod nano to the computer it’s authorized to work with, 
iPod nano automatically unlocks. If the computer authorized to work with iPod nano is 
unavailable, you can connect iPod nano to another computer and use iTunes to restore 
iPod software. See the next section for more information.
If you want to change the screen lock combination and you can’t remember the 
current combination, you must restore the iPod software and then set a new 
combination.
Updating and Restoring iPod Software
You can use iTunes to update or restore iPod software. It’s recommended that you 
update iPod nano to use the latest software. You can also restore the software, which 
puts iPod nano back to its original state.
Â If you choose to update, the software is updated, but your settings and songs aren’t 
affected. 
Â If you choose to restore, all data is erased from iPod nano, including songs, videos, 
files, contacts, photos, calendar information, and any other data. All iPod nano 
settings are restored to their original state.
To update or restore iPod nano:
1 Make sure you have an Internet connection and have installed the latest version of 
iTunes from www.apple.com/ipod/start.
2 Connect iPod nano to your computer.
3 In iTunes, select iPod nano in the source list and click the Summary tab.
The Version section tells you whether iPod nano is up to date or needs a newer version 
of the software. 
4 Click Update to install the latest version of the software.
5 If necessary, click Restore to restore iPod nano to its original settings (this erases all data 
from iPod nano). Follow the onscreen instructions to complete the restore process.8
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8 Safety and Cleaning
Read the following important safety and handling 
information for Apple iPods.
Keep the iPod Safety Guide and the features guide for your iPod handy for future 
reference.
Important Safety Information
Handling iPod  Do not bend, drop, crush, puncture, incinerate, or open iPod. 
Avoiding water and wet locations  Do not use iPod in rain, or near washbasins or other 
wet locations. Take care not to spill any food or liquid into iPod. In case iPod gets wet, 
unplug all cables, turn iPod off, and slide the Hold switch (if available) to HOLD before 
cleaning, and allow it to dry thoroughly before turning it on again.
Repairing iPod  Never attempt to repair iPod yourself. iPod does not contain any userserviceable parts. For service information, choose iPod Help from the Help menu in 
iTunes or go to www.apple.com/support/ipod. The rechargeable battery in iPod should 
be replaced only by an Apple Authorized Service Provider. For more information about 
batteries, go to www.apple.com/batteries.
± Read all safety information below and operating instructions before using 
iPod to avoid injury. 
WARNING:  Failure to follow these safety instructions could result in fire, electric shock, 
or other injury or damage.Chapter 8    Safety and Cleaning 71
Using the Apple USB Power Adapter (available separately)  If you use the Apple USB 
Power Adapter (sold separately at www.apple.com/ipodstore) to charge iPod, make 
sure that the power adapter is fully assembled before you plug it into a power outlet. 
Then insert the Apple USB Power Adapter firmly into the power outlet. Do not connect 
or disconnect the Apple USB Power Adapter with wet hands. Do not use any power 
adapter other than an Apple iPod power adapter to charge your iPod.
The iPod USB Power Adapter may become warm during normal use. Always allow 
adequate ventilation around the iPod USB Power Adapter and use care when handling.
Unplug the iPod USB Power Adapter if any of the following conditions exist:
Â The power cord or plug has become frayed or damaged.
Â The adapter is exposed to rain, liquids, or excessive moisture.
Â The adapter case has become damaged.
Â You suspect the adapter needs service or repair.
Â You want to clean the adapter.
Avoiding hearing damage  Permanent hearing loss may occur if earbuds or 
headphones are used at high volume. Set the volume to a safe level. You can adapt 
over time to a higher volume of sound that may sound normal but can be damaging to 
your hearing. If you experience ringing in your ears or muffled speech, stop listening 
and have your hearing checked. The louder the volume, the less time is required before 
your hearing could be affected. Hearing experts suggest that to protect your hearing:
Â Limit the amount of time you use earbuds or headphones at high volume.
Â Avoid turning up the volume to block out noisy surroundings.
Â Turn the volume down if you can’t hear people speaking near you.
For information about how to set a maximum volume limit on iPod, see “Setting the 
Maximum Volume Limit” on page 40.
Using headphones safely  Use of headphones while operating a vehicle is not 
recommended and is illegal in some areas. Be careful and attentive while driving. Stop 
using iPod if you find it disruptive or distracting while operating any type of vehicle or 
performing any other activity that requires your full attention.
Avoiding seizures, blackouts, and eye strain  If you have experienced seizures or 
blackouts, or if you have a family history of such occurrences, please consult a 
physician before playing video games on iPod (if available). Discontinue use and 
consult a physician if you experience: convulsion, eye or muscle twitching, loss of 
awareness, involuntary movements, or disorientation. When watching videos or playing 
games on iPod (if available), avoid prolonged use and take breaks to prevent eye strain.72 Chapter 8    Safety and Cleaning 
Important Handling Information
Carrying iPod  iPod contains sensitive components, including, in some cases, a hard 
drive. Do not bend, drop, or crush iPod. If you are concerned about scratching iPod, 
you can use one of the many cases sold separately.
Using connectors and ports  Never force a connector into a port. Check for 
obstructions on the port. If the connector and port don’t join with reasonable ease, 
they probably don’t match. Make sure that the connector matches the port and that 
you have positioned the connector correctly in relation to the port.
Keeping iPod within acceptable temperatures  Operate iPod in a place where the 
temperature is always between 0º and 35º C (32º to 95º F). iPod play time might 
temporarily shorten in low-temperature conditions.
Store iPod in a place where the temperature is always between -20º and 45º C 
(-4º to 113º F). Don’t leave iPod in your car, because temperatures in parked cars can 
exceed this range.
When you’re using iPod or charging the battery, it is normal for iPod to get warm. 
The exterior of iPod functions as a cooling surface that transfers heat from inside the 
unit to the cooler air outside.
Keeping the outside of iPod clean To clean iPod, unplug all cables, turn iPod off, and 
slide the Hold switch (if available) to HOLD. Then use a soft, slightly damp, lint-free 
cloth. Avoid getting moisture in openings. Don’t use window cleaners, household 
cleaners, aerosol sprays, solvents, alcohol, ammonia, or abrasives to clean iPod.
Disposing of iPod properly  For information about the proper disposal of iPod, 
including other important regulatory compliance information, see “Regulatory 
Compliance Information” on page 74.
NOTICE:  Failure to follow these handling instructions could result in damage to iPod 
or other property.9
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9 Learning More, Service, 
and Support 
You can find more information about using iPod nano in 
onscreen help and on the web.
The following table describes where to get more iPod-related software and service 
information.
To learn about Do this
Service and support, 
discussions, tutorials, and 
Apple software downloads
Go to:  www.apple.com/support/ipodnano
Using iTunes Open iTunes and choose Help > iTunes Help. 
For an online iTunes tutorial (available in some areas only), go to:   
www.apple.com/support/itunes
Using iPhoto (on Mac OS X) Open iPhoto and choose Help > iPhoto Help.
Using iCal (on Mac OS X) Open iCal and choose Help > iCal Help.
The latest information on 
iPod nano
Go to:  www.apple.com/ipodnano
Registering iPod nano To register iPod nano, install iTunes on your computer and connect 
iPod nano.
Finding the iPod nano serial 
number
Look at the back of iPod nano or choose Settings > About and 
press the Center button. In iTunes (with iPod nano connected to 
your computer), select iPod nano in the source list and click the 
Settings tab.
Obtaining warranty service First follow the advice in this booklet, the onscreen help, and 
online resources. Then go to:  www.apple.com/support/ipodnano/
service74    
Regulatory Compliance Information
FCC Compliance Statement
This device complies with part 15 of the FCC rules. 
Operation is subject to the following two conditions: 
(1) This device may not cause harmful interference, 
and (2) this device must accept any interference 
received, including interference that may cause 
undesired operation. See instructions if interference 
to radio or TV reception is suspected.
Radio and TV Interference
This computer equipment generates, uses, and can 
radiate radio-frequency energy. If it is not installed 
and used properly—that is, in strict accordance with 
Apple’s instructions—it may cause interference with 
radio and TV reception.
This equipment has been tested and found to 
comply with the limits for a Class B digital device in 
accordance with the specifications in Part 15 of FCC 
rules. These specifications are designed to provide 
reasonable protection against such interference in a 
residential installation. However, there is no 
guarantee that interference will not occur in a 
particular installation.
You can determine whether your computer system is 
causing interference by turning it off. If the 
interference stops, it was probably caused by the 
computer or one of the peripheral devices.
If your computer system does cause interference to 
radio or TV reception, try to correct the interference 
by using one or more of the following measures:
Â Turn the TV or radio antenna until the interference 
stops.
Â Move the computer to one side or the other of the 
TV or radio.
Â Move the computer farther away from the TV or 
radio.
Â Plug the computer in to an outlet that is on a 
different circuit from the TV or radio. (That is, make 
certain the computer and the TV or radio are on 
circuits controlled by different circuit breakers or 
fuses.)
If necessary, consult an Apple Authorized Service 
Provider or Apple. See the service and support 
information that came with your Apple product. Or, 
consult an experienced radio/TV technician for 
additional suggestions.
Important:  Changes or modifications to this product 
not authorized by Apple Inc. could void the EMC 
compliance and negate your authority to operate 
the product.
This product was tested for EMC compliance under 
conditions that included the use of Apple peripheral 
devices and Apple shielded cables and connectors 
between system components. 
It is important that you use Apple peripheral devices 
and shielded cables and connectors between system 
components to reduce the possibility of causing 
interference to radios, TV sets, and other electronic 
devices. You can obtain Apple peripheral devices and 
the proper shielded cables and connectors through 
an Apple Authorized Reseller. For non-Apple 
peripheral devices, contact the manufacturer or 
dealer for assistance. 
Responsible party (contact for FCC matters only):
Apple Inc. Corporate Compliance
1Infinite Loop, M/S 26-A
Cupertino, CA 95014-2084
Industry Canada Statement
This Class B device meets all requirements of the 
Canadian interference-causing equipment 
regulations.
Cet appareil numérique de la classe B respecte 
toutes les exigences du Règlement sur le matériel 
brouilleur du Canada.
VCCI Class B Statement
Korea Class B Statement
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Russia
European Community
Battery Replacement
The rechargeable battery in iPod nano should be 
replaced only by an authorized service provider. For 
battery replacement services go to:    
www.apple.com/support/ipod/service/battery
Disposal and Recycling Information
Your iPod must be disposed of properly according to 
local laws and regulations. Because this product 
contains a battery, the product must be disposed of 
separately from household waste. When your iPod 
reaches its end of life, contact Apple or your local 
authorities to learn about recycling options. 
For information about Apple’s recycling program, 
go to:  www.apple.com/environment/recycling
Deutschland:  Dieses Gerät enthält Batterien. Bitte 
nicht in den Hausmüll werfen. Entsorgen Sie dieses 
Gerätes am Ende seines Lebenszyklus entsprechend 
der maßgeblichen gesetzlichen Regelungen.
Nederlands:  Gebruikte batterijen kunnen worden 
ingeleverd bij de chemokar of in een speciale 
batterijcontainer voor klein chemisch afval (kca) 
worden gedeponeerd.
China:
Taiwan:  
European Union—Disposal Information:  
This symbol means that according to local laws and 
regulations your product should be disposed of 
separately from household waste. When this product 
reaches its end of life, take it to a collection point 
designated by local authorities. Some collection 
points accept products for free. The separate 
collection and recycling of your product at the time 
of disposal will help conserve natural resources and 
ensure that it is recycled in a manner that protects 
human health and the environment.
Apple and the Environment 
At Apple, we recognize our responsibility to 
minimize the environmental impacts of our 
operations and products.
For more information, go to:
www.apple.com/environment
© 2008 Apple Inc. All rights reserved. Apple, the Apple logo, FireWire, 
iCal, iLife, iPhoto, iPod, iPod Socks, iTunes, Mac, Macintosh, and Mac OS 
are trademarks of Apple Inc., registered in the U.S. and other countries. 
Finder, the FireWire logo, and Shuffle are trademarks of Apple Inc. 
iTunes Store is a service mark of Apple Inc., registered in the U.S. and 
other countries. NIKE is a trademark of NIKE, Inc. and its affiliates and is 
used under license. Other company and product names mentioned 
herein may be trademarks of their respective companies.
Mention of third-party products is for informational purposes only and 
constitutes neither an endorsement nor a recommendation. Apple 
assumes no responsibility with regard to the performance or use of 
these products. All understandings, agreements, or warranties, if any, 
take place directly between the vendors and the prospective users. 
Every effort has been made to ensure that the information in this 
manual is accurate. Apple is not responsible for printing or clerical 
errors.
The product described in this manual incorporates copyright 
protection technology that is protected by method claims of certain 
U.S. patents and other intellectual property rights owned by 
Macrovision Corporation and other rights owners. Use of this 
copyright protection technology must be authorized by Macrovision 
Corporation and is intended for home and other limited viewing uses 
only unless otherwise authorized by Macrovision Corporation. Reverse 
engineering or disassembly is prohibited.
Apparatus Claims of U.S. Patent Nos. 4,631,603, 4,577,216, 4,819,098 and 
4,907,093 licensed for limited viewing uses only.
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connecting iPod  14
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connecting iPod
about  14
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using  7
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D
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setting  54
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about  14
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G
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H
handling information  70
hearing loss warning  63
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I
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images. See photos
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from camera to computer  47
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importing videos  27
iPhoto
getting help  47, 73
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iPod USB power adapter  17
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getting help  73
setting not to open automatically  53
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browsing videos  26
searching  22
signing in  21
L
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locking iPod screen  57
lyrics
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M
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main menu
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N
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notes, storing and reading  60
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NTSC TV  45, 52
O
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making  37, 38
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P
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pausing
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a video  7
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podcasting  42
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USB  68
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problems. See troubleshooting
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saving On-The-Go playlists  37
screen lock  57
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subscribing to podcasts  22
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See also adding
T
third-party accessories  62
time, displaying in title bar  54
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troubleshooting
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PAL or NTSC  45, 52
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Figures, Tables, and ListingsSafari is a full-featured Web browser for Mac OS, Windows, and iOS. You don't need to add any Safari-specific
tweaks to make your website work with Safari or to make your website work on iOS-based devices. If you
design your website using W3C standardsfor HTML, CSS, and JavaScript, and don't rely on third-party plug-ins,
users can view and interact with your website using Safari on all supported platforms.
Making websites work with Safari is just a first step, however. It should be your goal to optimize websites to
create the best experience for all users, including people using Safari on handheld devices with touch screens.
Use CSS to change the layout of your website in portrait or landscape modes, for example; add touch and
gesture support; animate changes in CSS properties for Safari users, and so on.
At a Glance
There are three main areas to focus on when creating web content for Safari:
● Make sure your website is compatible with Safari.
● Enhance the user experience in Safari, particularly on mobile devices.
● Make the best use of dynamically changing network bandwidth when delivering audio and video.
Making It Work
Safari has an array of built-in tools for quickly spotting incompatibilities and debugging problems. If you have
a website up and running, and are getting complaintsthat the site doesn't work with Safari, it is usually because
of one of the following problems:
● The site uses Internet Explorer extensions that other browsers don't support.
● The site includes media compressed in a format that Safari doesn't support.
● The site relies on plug-ins to handle audio, video, or animation.
Use the Error Console to immediately identify and locate any unsupported HTML, CSS, or JavaScript, making
it easy to correct.
2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
9
Developing Web Content for SafariThere are Safari-compatible media formats and embedding techniques for every job. Safari supports audio
media in AAC, MP3, AIFF, and WAVE formats on all platforms. Safari supports video media encoded using H.264
compression, commonly used in MPEG-4 format, on all platforms. Handheld devicessupport a somewhat more
limited set of MPEG-4 profiles than desktop devices.
Safari on the desktop supports plug-ins. There are Safari-compatible versions of all common plug-ins, including
QuickTime, Flash, and SilverLight. Safari on iOS does not support plug-ins. To make your website accessible
using handheld devices, do not rely on plug-ins to display content. Use the HTML5  and 
tags to embed audio and video files in supported formats, with fallback to a plug-in for older browsers on the
desktop. Use CSS or Canvas to embed animation and create special effects.
Relevant Chapter:  See “Creating Compatible Web Content” (page 18) for ways to quickly test for,
identify, and correct problems.
Enhancing the User Experience
Enhance the user's experience by providing different page layouts for handheld and desktop devices using
simple CSS and JavaScript detection and CSS layout. You can also detect portrait and landscape orientation
on handheld devices and automatically switch between layouts using elegant CSS and JavaScript syntax.
It's easy to add touch and gesture support by adding a few event handlers to your site. Make navigation easier
for touchscreen users by making links large enough to reliably hit with a finger, and by surrounding links with
enough whitespace to avoid accidentally hitting the wrong link. Leave a blank gutter or border on the page
as well, so the user can easily scroll the screen with a finger without touching a link.
iOS-specific enhancements can turn your website into a web app that behaves like a native iOS app. Optimize
websites for iOS by providing an icon for the user's home screen, by making your website into a fullscreen web
app, and by including links that dial a phone number, open a map, link to the Address Book, or open other
built-in iOS apps.
Relevant Chapters:  See “Configuring the Viewport” (page 38) and “Configuring Web
Applications” (page 87) for tips and guidance.
Use caching and client-side storage to make your website work even when the user is offline or the user’s
device loses network connectivity. Safari supports HTML5 client-side storage and caching, “lazy” caching for
offline reading, and techniques for allowing web-based games to work offline.
Developing Web Content for Safari
At a Glance
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10Relevant Chapter:  See “Storing Data on the Client” (page 97) for more information.
How to Use This Document
You can read this document from start to finish, or you can jump to a specific chapter to accomplish a task.
If you are creating a new website and plan to support Safari and iOS devices, read the rest of the chapters in
order.
If you are modifying an existing website to work with Safari, read “Creating Compatible Web Content” (page
18).
If you are showcasing an app on your website, read “Promoting Apps with Smart App Banners” (page 84).
If you are using video on your website, read “Creating Video” (page 91).
If you are debugging web content on your iOS device, read “Debugging” (page 104).
Prerequisites
You need a solid understanding of HTML, familiarity with JavaScript, and a basic understanding of CSS in order
to make the best use of this document.
See Also
● Safari Developer Tools Guide—How to use Safari’s built-in tools for debugging and optimization, such as
the Error Console and the Web Inspector.
● Safari HTML5 Audio and Video Guide—How to embed audio and video without using plug-ins, or by using
a plug-in as a fallback.
● Safari HTML5 Canvas Guide—How to add sophisticated animation and interactive games to a website
without using plug-ins.
● Safari CSS Visual Effects Guide—How to enhance websites using WebKit extensions for masks, gradients,
reflections, CSS animation, and 3D transformations.
● Safari Client-Side Storage and Offline Applications Programming Guide—How to create websitesthat work
when the user is offline, or that contain HTML5 client-side databases.
● HTTP Live Streaming Overview—How to optimize network bandwidth forstreaming audio and video from
a standard web server.
Developing Web Content for Safari
How to Use This Document
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11● Safari HTML Reference—HTML elements and attributes supported in Safari.
● Safari CSS Reference—CSS properties and classes supported in Safari.
● Safari DOM Additions Reference—Events and other DOM additions supported in Safari.
Developing Web Content for Safari
See Also
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12Safari runs on multiple operating systems and devices. All versions of Safari—Safari on the desktop and Safari
on iOS—use the same WebKit engine. Therefore, web content intended for the desktop might work well on
devices running iOS without any modifications. Some differences exist, however, so at a minimum you should
ensure that your webpages are compatible with Safari on iOS. Next, you might optimize your webpages for
iOS simply as a convenience to the user. For example, ensure that your webpages work over Wi-Fi, 3G, and
EDGE, scale correctly when rendered, and contain media that is viewable on iOS. There are also a few
modifications you can make for specific devices such as iPad. Finally, you might build custom web applications
for either platform that look and behave like native applications.
Safari on the desktop isthe Safari application that runs on OS X and Windows. It is a full-featured web browser
for the desktop that supports industry standards as well as many WebKit extensions. In addition, it includes a
number of tools that developers can use to analyze, test, and debug websites and web applications.
Safari on iOS, the application for browsing the web on devices such as iPhone, iPod touch, and iPad, is also a
full web browser running on a small handheld device with a high-resolution screen. This unique implementation
of Safari responds to a finger as the input device and supports gestures for zooming and panning. It also
renders webpages in portrait or landscape orientation. It contains many built-in features such as PDF viewing,
video playback, and support for links to the native Phone, Mail, Maps, and YouTube applications.
WebKit is an open source project as well as a framework in OS X that lets developers embed a web browser
in their Cocoa applications. WebKit has a JavaScript and Objective-C interface to access the Document Object
Model (DOM) of a webpage. Dashboard, Mail, and many otherOS X applications also useWebKit as an embedded
browser. You can use the UIWebView class in UIKit on iOS to embed a web browser in an native application.
In addition to providing browser functionality, WebKit also implements some extensions to HTML, CSS, and
JavaScript, including severalspecific to Safari. Safari extensionsinclude CSS animation and transform properties,
and JavaScript database support. Safari on iOS includesJavaScript multitouch eventsupport. Some extensions
are fully supported on both platforms and others are not. Check reference documents for specific availability
of those features you want to use.
This document teaches you how to create web content compatible with Safari running on any platform and
how to separate your iOS-specific web content from your other web content so that when you optimize your
web content for iOS, it still works on the desktop and other browsers. This document also covers some basics
on tailoring web applications for iOS.
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IntroductioniOS Note:  Safari on iOS behaves the same on different devices except when the user taps links to
device-only applications. Read Apple URL Scheme Reference for information on the links that behave
differently on other devices. On iPad, the behavior of HTML5 media elementsissimilar to the desktop.
Read Safari HTML5 Audio and Video Guide for the differences on iPad.
Who Should Read This Document
You should read this document if you want your web content to look good and perform well on either the
desktop or iOS, plan to write iOS-specific web content, use iOS-specific style sheets, or use iOS native application
linksin your web content. Definitely read this document if you are creating a custom web application for either
platform.
iOS Note:  Also read iOS Human Interface Guidelines which describes how Safari on iOS behaves
and contains metrics and tips on designing user interfaces for iOS. Understanding how Safari on iOS
presents web content to the user and how the user can zoom, pan, and double-tap on your webpages
are prerequisites for reading this document.
Organization of This Document
This chapter covers important information that you should read first:
●
“Creating Compatible Web Content” (page 18) provides guidelines for creating web content that is
compatible with Safari on the desktop and Safari on iOS.
This chapter covers the first steps you need to follow to optimize web content for Safari:
●
“Optimizing Web Content” (page 33) describes how to detect Safari on different platforms and use
conditional Cascading Style Sheets (CSS) so that you can begin optimizing web content for iOS.
These chapters describe different ways to optimize web content for iOS:
●
“Configuring the Viewport” (page 38) explains how to use the viewport tag to control the layout of your
webpages.
●
“Customizing Style Sheets” (page 58) covers how to adjust the textsize when zooming and how to control
highlighting using CSS.
●
“Designing Forms” (page 62) explains how to lay out forms, design custom form controls, and turn auto
correction and capitalization on and off.
Introduction
Who Should Read This Document
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14●
“Handling Events” (page 68) provides information on what events you can handle in JavaScript.
This chapter describes how to create video content for multiple platforms:
●
“Creating Video” (page 91) explains how to create video content for playback on iOS in general, including
video content embedded in your webpages.
This chapter covers information on how to store data locally:
●
“Storing Data on the Client” (page 97) describes how to use the HTML5 application cache for storing
resources locally.
This chapter covers information on how to debug web content:
●
“Debugging” (page 104) describes the Safari on iOS console which you use to help test and debug your
webpages.
If you are new to web development, read these appendixes that provide introductions to HTML and CSS:
●
“HTML Basics” (page 110) provides an overview on how to create structured HTML web content.
●
“CSS Basics” (page 117) describes how to add style sheets to existing HTML web content.
See Also
There are a variety of other resources for Safari web content developers in the ADC Reference Library.
If you are creating an iOS web application, then you should also read:
●
iOS Human Interface Guidelines, which provides user interface guidelines for designing webpages and
web applications for Safari on iOS.
● Apple URL Scheme Reference , which describes how to use the Phone, Mail, Text, YouTube, iTunes, and
Maps applications from your webpages.
If you want to learn more about visual effects, then you should read:
● Safari Visual Effects Guide , which describes how to use the CSS visual effects properties including the
transition, animation, and transforms properties. It also coversthe JavaScript APIsfor handling visual effects
events.
If you want to embed video and audio in your webpages read:
Introduction
See Also
2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
15● Safari Guide to HTML5 Audio and Video , which describes how to use the HTML5 audio and video elements
in your webpages.
If you want to learn more about JavaScript multi-touch event support, then you should read:
● Safari DOM Additions Reference , which describes DOM additions including touch event classes that you
use to handle multi-touch gestures in JavaScript on iOS.
If you want to learn more about JavaScript database support, then you should read:
● Safari Client-Side Storage and Offline Applications Programming Guide , which describes a simple relational
database that you can use to store persistent data in JavaScript that cannot be stored in cookies.
If you want to use the JavaScript media APIs, then you should read:
●
JavaScript Scripting Guide for QuickTime , which describes how to use JavaScript to query and control the
QuickTime plug-in directly.
If you want to learn more about what HyperText Markup Language (HTML) tags and Cascading Style Sheets
(CSS) properties are supported in Safari, then read:
● Safari HTML Reference , which describes the HTML elements and attributes supported by various Safari
and WebKit applications.
● Safari CSS Reference , which describes the CSS properties supported by various Safari and WebKit
applications.
If you are using JavaScript and want access to the DOM or use the canvas object, then read:
● WebKit DOM Programming Topics, which describes how to use JavaScript in web content for WebKit-based
applications.
If you are developing web content for Safari on the desktop and iOS, then you should read:
● Safari User Guide for Web Developers, which describes how to use the Debug menu in Safari.
● Dashcode User Guide , which describes how to use Dashcode to create web applications.
If you want to embed a browser in your iOS application, then read:
● UIWebView Class Reference for a description of the UIWebView class.
Introduction
See Also
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16If you want to learn more about WebKit or contribute to the open source project, then go to The WebKit Open
Source Project.
If you want to read the WebKit W3C proposals, then go to: http://www.webkit.org/specs.
Introduction
See Also
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17This chapter covers best practices in creating web content that is compatible with Safari on the desktop and
Safari on iOS. Many of these guidelines simply improve the reliability, performance, look, and user experience
of your webpages on both platforms. If your target is iOS, the first step is to get your web content working
well on the desktop. If your target is the desktop, with minimal modifications, you can get your web content
to look good and perform well on iOS too.
For example, you need to pay attention to the layout of your content and execution limits on iOS. If you use
conditional CSS, as recommended in “Optimizing Web Content” (page 33), your webpages optimized for iOS
still work in other browsers. Read the rest of this document for how to optimize your web content for Safari.
iOS Note:  When designing your webpages, be aware of how Safari on iOS presents webpages to
the user and how the user interacts with your webpages using gesturesto zoom, pan, and double-tap.
Read iOS Human Interface Guidelines for metrics and tips on designing user interfaces for iOS.
Use Standards
The first design rule is to use web standards. Standards-based web development techniques ensure the most
consistent presentation and functionality across all modern browsers, including Safari. A well-designed website
probably requires just a few refinements to look good and work well on Safari.
The WebKit engine, shared by Safari on the desktop and Safari on iOS, supports all the latest modern web
standards, including:
● HTML 4.01
● XHTML 1.0
● CSS 2.1 and partial CSS3
● ECMAScript 3 (JavaScript)
● DOM Level 2
● AJAX technologies, including XMLHttpRequest
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Creating Compatible Web ContentThe web is always evolving, and as it does, so does WebKit and Safari. You’ll want to keep informed of the
evolving standards emanating from the Web Hypertext Application Technology Working Group (WHATWG)
and World Wide Web Consortium (W3C) standards bodies. The WHATWG and W3C websites are a good place
to start learning more about these standards and the upcoming HTML5:
www.whatwg.org
www.w3.org
Refer to Safari reference documents, such as Safari HTML Reference and Safari CSS Reference , for availability
of features on specific platforms.
Follow Good Web Design Practices
You should follow well-established rules of good web design. This section covers a few basic rules that are
critical for Safari. Read Web Page Development: Best Practicesfor more general advice on designing webpages.
● Add a DOCTYPE declaration to your HTML files.
Preface your HTML files with a DOCTYPE declaration, which tells browsers which specification to parse
your webpage against. See “HTML Basics” (page 110) for how to do this.
● Separate your HTML, CSS, and JavaScript into different files.
Your webpages are more maintainable if you separate page content into distinct files for mark-up,
presentation, and interaction.
● Use well-structured HTML.
You increase cross-platform browser compatibility by running your HTML files through a validator. You
should fix common problems such as missing quotes, missing close tags, incorrect nesting, incorrect case,
and malformed doctype. See http://validator.w3.org or use the validator provided by your web development
tools.
● Be browser independent.
Avoid using the user agentstring to check which browser is currently running. Instead, read Object Detection
to learn how to determine if a browsersupports a particular object, property, or method, and read Detecting
WebKit with JavaScript to learn how to detect specific WebKit versions. Also use the W3C standard way
of accessing page objects—that is, use getElementByID("elementName"). Only as a last resort, use
the user agent string as described in “Using the Safari User Agent String” (page 36) to detect Safari on
iOS.
Read “HTML Basics” (page 110) and “CSS Basics” (page 117) for how to write structured HTML and add CSS to
existing HTML.
Creating Compatible Web Content
Follow Good Web Design Practices
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19Use Security Features
Safari on all platforms usesthe same SSL implementation to provide end-to-end security. The same encryption
that prevents listening on the wire is just as secure when used in a wireless situation, whether through Wi-Fi,
3G, or EDGE. Specifically, Safari supports:
● SSL 2, SSL 3, and TLS with many popular cipher suites
● RSA keys up to 4096
● HTTPS
iOS Note:  Note that the Diffie-Hellman protocol, DSA keys, and self-signed certificates are not
available on iOS.
Avoid Framesets
In general, avoid using complicated framesets that rely on the ability to scroll individual frames because there
are no scroll bars on iOS.
On the desktop, frames in a frameset can be independently scrolled as shown on the left in Figure 1-1. On iOS,
scrollable framesin a frameset are expanded to fit their content and then a frame isscaled down to fit itsregion
as shown on the right in Figure 1-1. Scrollable full-width inline frames are expanded to fit their content, too.
All other scrollable inline frames can be panned using the two-finger gesture. See “Two-Finger Events” (page
72) for the events generated from the two-finger gesture.
Creating Compatible Web Content
Use Security Features
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20Because there are no scroll bars on the inline frames, this is not an optimal user experience for viewing web
content on iOS, so avoid using framesets. Instead use columns as described in “Use Columns and Blocks” (page
21).
Figure 1-1 Comparison of frameset on the desktop and iOS
Frameset on the desktop Frameset on iPhone
980 x 544 pixels
488 x 544 pixels 488 x 544 pixels
Use Columns and Blocks
To be compatible with iOS, use columns and blocks to lay out your webpage like many online newspapers.
This makes your webpage more readable and also works better with double-tapping on iOS.
Creating Compatible Web Content
Use Columns and Blocks
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21Text blocks that span the full width of the webpage are difficult to read on iOS as shown on the left in Figure
1-2. Columns not only break up the webpage, making it easy to read, as shown on the right in Figure 1-2, but
allow the user to easily double-tap objects on the page.
Figure 1-2 Comparison of no columns vs. columns
No columns Columns
When the user double-taps a webpage, Safari on iOS looks at the element that was double-tapped, and finds
the closest block (as identified by elements like 
, 
, 
, and 
) or image element. If the
found element is a block, Safari on iOS zooms the content to fit the screen width and then centers it. If it is an
image, Safari on iOS zooms to fit the image and then centers it. If the block or image is already zoomed in,
Safari on iOS zooms out.
Your webpage works well with double-tapping if you use columns and blocks. Read “CSS Basics” (page 117)
for how to add CSS to existing HTML.
Creating Compatible Web Content
Use Columns and Blocks
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22Know iOS Resource Limits
Your webpage performing well on the desktop is no guarantee that it will perform well on iOS. Keep in mind
that iOS uses EDGE (lower bandwidth, higher latency), 3G (higher bandwidth, higher latency), and Wi-Fi (higher
bandwidth, lower latency) to connect to the Internet. Therefore, you need to minimize the size of your webpage.
Including unused or unnecessary images, CSS, and JavaScript in your webpages adversely affects your site’s
performance on iOS.
Because of the memory available on iOS, there are limits on the number of resources it can process:
● The maximum size for decoded GIF, PNG, and TIFF images is 3 megapixels for devices with less than 256
MB RAM and 5 megapixels for devices with greater or equal than 256 MB RAM.
That is, ensure that width * height ≤ 3 * 1024 * 1024 for devices with less than 256 MB RAM.
Note that the decoded size is far larger than the encoded size of an image.
● The maximum decoded image size for JPEG is 32 megapixels using subsampling.
JPEG images can be up to 32 megapixels due to subsampling, which allows JPEG images to decode to a
size that has one sixteenth the number of pixels. JPEG images larger than 2 megapixels are
subsampled—that is, decoded to a reduced size. JPEG subsampling allows the user to view images from
the latest digital cameras.
● The maximum size for a canvas element is 3 megapixels for devices with less than 256 MB RAM and 5
megapixels for devices with greater or equal than 256 MB RAM.
The height and width of a canvas object is 150 x 300 pixels if not specified.
●
JavaScript execution time is limited to 10 seconds for each top-level entry point.
If your script executes for more than 10 seconds, Safari on iOS stops executing the script at a random place
in your code, so unintended consequences may result.
This limit is imposed because JavaScript execution may cause the main thread to block, so when scripts
are running, the user is not able to interact with the webpage.
Read “Debugging” (page 104) for how to debug JavaScript on iOS.
● The maximum number of documents that can be open at once is eight on iPhone and nine on iPad.
Creating Compatible Web Content
Know iOS Resource Limits
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23iOS Note:  In iOS 1.1.4 and earlier, the JavaScript execution time was limited to 5 seconds and the
size of allocations to 10 MB. Also, the limit on the size of canvas elements was the same as Safari on
the desktop.
In iOS 2.2.1 and earlier, the sum of all of the frames needs to be less than 2 megapixels—that is,
width * height * number of frames ≤ 2 * 1024 * 1024. In iOS 3.0 and later, the limit
only applies to one frame at a time.
You also need to size images appropriately. Don’t rely on browser scaling. For example, don’t put a 100 x 100
image in a 10 x 10  element. Tile small backgrounds images; don’t use large background images.
Checking the Size of Webpages
You can check the size of your webpages by using Safari’s Web Inspector as described in “Optimizing Download
Time” in Safari User Guide for Web Developers or by saving your webpage as a web archive. The total size of
the web archive is the size of the page and its associated resources. Follow these steps to create a web archive:
1. Choose File > Save As.
2. Enter the filename in the Save As text field.
3. Choose Web Archive from the Format pop-up menu.
4. Click Save.
On OS X, check the size of the web archive using either Finder or Terminal. Typically, pages under 30 MB work
fine on iOS.
Creating Compatible Web Content
Know iOS Resource Limits
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24Use the Select Element
If you use the select HTML element in your webpage, iOS displays a custom select control that is optimized
for selecting items in the list using a finger as the input device. On iOS, the user can flick to scroll the list and
tap to select an item from the list. Figure 1-3 compares the select element on the desktop with the select
element on iOS.
Figure 1-3 Comparison of the select element on the desktop and iOS
Select on the desktop Select on iPhone
Use Supported JavaScript Windows and Dialogs
Use windows and dialogs supported by Safari on iOS and avoid the others.
You can open a new window in JavaScript by invoking window.open(). Remember that the maximum number
of documents—hence, the maximum number of open windows—is eight on iOS.
Creating Compatible Web Content
Use the Select Element
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25Supported JavaScript dialog methodsinclude alert, confirm, print, and prompt. If you use these methods,
Safari on iOS displays an attractive dialog that doesn’t obscure the webpage, as show in Figure 1-4.
Figure 1-4 Confirm dialog
iOS Note:  Note that the showModalDialog method is not supported in Safari on iOS.
Use Supported Content Types and iOS Features
Be aware of the features you get for free in Safari on iOS by using supported content types and elements that
tailor the presentation of content for small handheld devices with touch screens. In particular, Safari on iOS
handles content types such as video and PDF files different from the desktop. Safari on iOS also has the ability
to preview content types and launch another application if it is available to display that type of document.
Following links such as phone numbers in your web content may launch applications too.
Creating Compatible Web Content
Use Supported Content Types and iOS Features
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26On iPhone and iPod touch, the video and audio is played back in fullscreen mode only. The video automatically
expands to the size of the screen and rotates when the user changes orientation, as shown in Figure 1-5. The
controls automatically hide when they are not in use. On iPad, the video and audio is played either inline in
the webpage or in fullscreen mode. Read “Creating Video” (page 91) for how to export video for iOS.
Figure 1-5 Playing video on iOS
Creating Compatible Web Content
Use Supported Content Types and iOS Features
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27PDF documents are easy to view using Safari on iOS and even easier to page through as shown in Figure 1-6.
PDF documents linked from web content are opened automatically. The page indicator keeps track of where
the user isin a document. And just as with video, the user can rotate iOS to view a PDF in landscape orientation.
Figure 1-6 Viewing PDF documents on iOS
Safari on iOS previews other content typeslike MS Office (Word, Excel and PowerPoint), iWork (Pages, Numbers,
and Keynote), and RTF documents. If another application registersfor a content type that Safari on iOS previews,
then that application is used to open the document. For example, on iPad, Pages may be used to open Word
and Pages documents that are previewed in Safari on iOS. If another application registers for a content type
that Safari on iOS doesn’tsupport natively or preview, then Safari on iOS allowsthe document to be downloaded
and opened using that application.
iOS Note:  Previews of RTF documents is available in iOS 3.2 and later. The ability to open a
downloaded file is available in iOS 3.2 and later.
When the user taps certain types of links, Safari on iOS may launch a native application to handle the link—for
example, Mail to compose an email message, Maps to get directions, and YouTube to view a video. If the user
taps a telephone number link on a phone device, a dialog appears asking whether the user wants to dial that
number.On the desktop,most ofthese linksredirectto the respective website. Read Apple URL Scheme Reference
to learn more about using these types of links in your web content.
Creating Compatible Web Content
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28iOS Note:  Note that Java and Flash content types are not supported. See “Don’t Use Unsupported
iOS Technologies” (page 30) for a complete list of unsupported technologies.
Use Canvas for Vector Graphics and Animation
You can use the same canvas object used by Dashboard widgets to implement sophisticated user interfaces
for web applications. The canvas object was introduced in Safari 2.0, is adopted by other browser engines, and
is part of the WHATWG specification. Read WebKit DOM Programming Topics to learn more about using the
canvas object.
Use the HTML5 Audio and Video Elements
You can use the HTML5 audio and video elements to add audio and video to your webpages. On smaller
deviceslike iPhone and iPad touch, the movie playsin fullscreen mode only and automatic playback is disabled
so a user action is required to initiate playback. On iPad, the video plays inline in the webpage. When the video
is played inline, you can create custom controls and receive media events—for example, pause and play
events—to enhance the user experience. Use the HTMLMediaElement class and its subclasses, described in
Safari DOM Additions Reference , to do this. Read Safari HTML5 Audio and Video Guide for more in-depth
information on the audio and video elements. Read “Creating Video” (page 91) for how to create media files
compatible with Safari.
Use Supported iOS Rich Media MIME Types
Table 1-1 lists the rich media MIME types supported by Safari on iOS. Files with these MIME types and filename
extensions can be played on iOS.
Table 1-1 Supported iOS rich media MIME types
MIME type Description Extensions
audio/3gpp 3GPP media 3gp, 3gpp
audio/3gpp2 3GPP2 media 3g2, 3gp2
audio/aiff AIFF audio aiff, aif, aifc, cdda
audio/x-aiff
audio/amr AMR audio amr
Creating Compatible Web Content
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29MIME type Description Extensions
audio/mp3 MP3 audio mp3, swa
audio/mpeg3
audio/x-mp3
audio/x-mpeg3
audio/mp4 MPEG-4 media mp4
audio/mpeg MPEG audio mpeg, mpg, mp3, swa
audio/x-mpeg
audio/wav WAVE audio wav, bwf
audio/x-wav
audio/x-m4a AAC audio m4a
audio/x-m4b AAC audio book m4b
audio/x-m4p AAC audio (protected) m4p
video/3gpp 3GPP media 3gp, 3gpp
video/3gpp2 3GPP2 media 3g2, 3gp2
video/mp4 MPEG-4 media mp4
video/quicktime QuickTime Movie mov, qt, mqv
video/x-m4v Video m4v
Don’t Use Unsupported iOS Technologies
In general, Safari on iOS does not support any third-party plug-ins or features that require access to the file
system. The following web technologies are not supported on iOS:
● Modal dialogs
Don’t use window.showModalDialog() in JavaScript. Read “Use Supported JavaScript Windows and
Dialogs” (page 25) for a list of supported dialogs.
● Mouse-over events
The user cannot “mouse-over” a nonclickable element on iOS. The element must be clickable for a
mouseover event to occur as described in “One-Finger Events” (page 69).
Creating Compatible Web Content
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30● Hover styles
Since a mouseover event is sent only before a mousedown event, hover styles are displayed only if the
user touches and holds a clickable element with a hover style. Read “Handling Events” (page 68) for all
the events generated by gestures on iOS.
● Tooltips
Similar to hover styles, tooltips are not displayed unless the user touches and holds a clickable element
with a tooltip.
●
Java applets
● Flash
Don’t bring up JavaScript alerts that ask users to download Flash.
● QuickTime VR (QTVR) movies
● Plug-in installation
● Custom x.509 certificates
● WML
Safari on iOS is not a miniature web browser—it is a full web browser that renders pages as
designed—therefore, there is no need for Safari on iOS to support Wireless Markup Language (WML).
Alternatively, it does support XHTML mobile profile document types and sites at .mobi domains.
The XHTML mobile document type is:

● File uploads and downloads
Safari on iOS does not support file uploading, that is,  elements. If your webpage
includes an input-file control, Safari on iOS disables it.
Because iOS does not support file downloads, do not prompt the user to download plug-ins like Flash on
iOS. See “Using the Safari User Agent String” (page 36) for how to detect Safari on iOS.
By default, Safari on iOS blocks pop-up windows. However, it is a preference that the user can change. To
change the Safari settings, tap Settings followed by Safari. The Block Pop-ups setting appears in the Security
section.
Creating Compatible Web Content
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31iOSNote:  The HTML contenteditable attribute issupported in iOS 5.0 and later. In earlier versions,
replace contenteditable, used to enable textinput within a styled element, with a styled textarea
element. In Safari, you can customize the appearance of textarea elements using CSS. If necessary,
you can even disable any platform-specific, built-in styling on a textarea element by
setting -webkit-appearance to none.
The window.print() method is supported in iOS 4.2 and later.
Downloadable web fonts are supported in iOS 1.1.4 and earlier, and iOS 4.2 and later.
SVG is supported in iOS 2.1 and later.
XSLT is supported in iOS 2.0 and later.
Creating Compatible Web Content
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32The first step in optimizing web content for iOS is to separate your iOS-specific content from your desktop
content and the next step is to tailor the web content for iOS. You might want to follow these steps even if
iOS is not your target platform so your web content is more maintainable in the future.
Use conditional CSS so that you can create iOS-specific style sheets as described in “Using Conditional CSS” (page
33). You can also use object detection and WebKit detection as described in “Follow Good Web Design
Practices” (page 19) to use extensions but remain browser-independent. Only if necessary, use the user agent
string as described in “Using the Safari User Agent String” (page 36) to detect Safari on iOS or a specific device.
After optimizing your content, read the rest of the chapters in this document to learn how to set viewport
properties, adjust text size, lay out forms, handle events, use application links, and export media for iOS. Finally
read “Debugging” (page 104) for how to debug your webpages.
Using Conditional CSS
Once you use CSS to lay out your webpage in columns, you can use conditional CSS to create different layouts
for specific platforms and mobile devices. Using CSS3 media queries, you can add iOS-specific style sheets to
your webpage without affecting how your webpages are rendered on other platforms.
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Optimizing Web ContentFor example, Figure 2-1 shows a webpage containing conditional CSS specifically for iOS. Figure 2-2 shows
the same webpage rendered on the desktop.
Figure 2-1 Small device rendering
Figure 2-2 Desktop rendering
CSS3 recognizes several media types, including print, handheld, and screen. iOS ignores print and handheld
media queries because these types do not supply high-end web content. Therefore, use the screen media type
query for iOS.
Optimizing Web Content
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34To specify a style sheet that isjust for iOS without affecting other devices, use the only keyword in combination
with the screen keyword in your HTML file. Older browsers ignore the only keyword and won’t read your
iOS style sheet. Use max-device-width, and min-device-width to describe the screen size.
For example, to specify a style sheet for iPhone and iPod touch, use an expression similar to the following:


To specify a style sheet for devices other than iOS, use an expression similar to the following:


Alternatively, you can use this format inside a CSS block in an HTML file, or in an external CSS file:
@media screen and (min-device-width: 481px) { ... }
Here are some examples of CSS3 media-specific style sheets where you might provide a different style for
screen and print. Listing 2-1 displays white text on dark gray background for the screen. Listing 2-2 displays
black text on white background and hides navigation for print.
Listing 2-1 Screen-specific style sheet
@media screen {
#text { color: white; background-color: black; }
}
Listing 2-2 Print-specific style sheet
@media print {
#text { color: black; background-color: white; }
#nav { display: none; }
}
For more information on media queries, see: http://www.w3.org/TR/css3-mediaqueries/.
Optimizing Web Content
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35Using the Safari User Agent String
A browser sends a special string, called a user agent, to websites to identify itself. The web server, or JavaScript
in the downloaded webpage, detects the client’s identity and can modify its behavior accordingly. In the
simplest case, the user agentstring includes an application name—for example, Navigator asthe application
name and 6.0 as the version. Safari on the desktop and Safari on iOS have their own user agent strings, too.
The Safari user agent string for iOS is similar to the user agent string for Safari on the desktop except for two
additions: It contains a platform name and the mobile version number. The device name is contained in the
platform name. For example, you can detect iOS and the specific device such as iPad. Typically, you do not
send iPhone-specific web content to an iPad since it has a much larger screen. Note that the version numbers
in this string are subject to change over time as new versions of iOS become available, so any code that checks
the user agent string should not rely on version numbers.
For example, Listing 2-3 shows the user agent string for an iPhone running iOS 2.0 and later, where the string
XXXX is replaced with the build number.
Listing 2-3 iPhone running on iOS 2.0 user agent string
Mozilla/5.0 (iPhone; U; CPU iOS 2_0 like Mac OS X; en-us) AppleWebKit/525.18.1
(KHTML, like Gecko) Version/3.1.1 Mobile/XXXXX Safari/525.20
The parts of the Safari on iOS user agent string are as follows:
(iPhone; U; CPU iOS 2_0 like Mac OS X; en-us)
The platform string. iPhone is replaced with iPod when running on an iPod touch and iPad when
running on an iPad.
AppleWebKit/525.18.1
The WebKit engine build number.
Version/3.1.1
The Safari family version.
Mobile/XXXXX
The mobile version number, where XXXX is the build number.
Safari/525.20
The Safari build number.
For example, the user agent string for an iPod touch contains iPod in the platform name as shown in Listing
2-4.
Optimizing Web Content
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36Listing 2-4 iPod touch running iOS 1.1.3 user agent string
Mozilla/5.0 (iPod; U; CPU like Mac OS X; en) AppleWebKit/420.1 (KHTML, like Gecko)
Version/3.0 Mobile/4A93 Safari/419.3
The user agent string for an iPad contains iPad in the platform name as shown in Listing 2-5.
Listing 2-5 iPad running iOS 3.2 user agent string
Mozilla/5.0 (iPad; U; CPU OS 3_2 like Mac OS X; en-us) AppleWebKit/531.21.10 (KHTML,
like Gecko) Version/4.0.4 Mobile/7B334b Safari/531.21.10
Note that the user agent string is slightly different for earlier Safari on iOS releases. Listing 2-6 shows the user
agent string for an iPhone running iOS 1.1.4 and earlier. Note that the platform string does not contain the
iOS version number.
Listing 2-6 iPhone running iOS 1.0 user agent string
Mozilla/5.0 (iPhone; U; CPU like Mac OS X; en) AppleWebKit/420+ (KHTML, like Gecko)
Version/3.0 Mobile/1A543 Safari/419.3
Typically, you use the WebKit build number to test for supported WebKit HTML tags and CSS properties. The
Safari family version, or marketing version, is included in the user agent string for Safari on the desktop, too.
Therefore, you can use it to track usage statistics across all Safari platforms.
Go to these websites to learn more about other recommended techniques for detecting Safari and WebKit:
● webkit.org
http://trac.webkit.org/projects/webkit/wiki/DetectingWebKit
Contains JavaScript sample code for detecting Safari on iPhone and iPod touch.
● developer.apple.com
http://developer.apple.com/internet/webcontent/objectdetection.html
Optimizing Web Content
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37Safari on iOS displays webpages at a scale that worksfor most web content originally designed for the desktop.
If these default settings don’t work for your webpages, it is highly recommended that you change the settings
by configuring the viewport. You especially need to configure the viewport if you are designing webpages
specifically for iOS. Configuring the viewport is easy—just add one line of HTML to your webpage—but
understanding how viewport properties affect the presentation of your webpages on iOS is more complex.
Before configuring the viewport, you need a deeper understanding of what the visible area and viewport are
on iOS.
If you are already familiar with the viewport on iOS, read “Using the Viewport Meta Tag” (page 46) for details
on the viewport tag and “Viewport Settingsfor Web Applications” (page 55) for web application tips. Otherwise,
read the sections in this chapter in the following order:
● Read “Layout and Metrics on iPhone and iPod touch” (page 39) to learn about the available screen space
for webpages on small devices.
● Read “What Is the Viewport?” (page 39) for a deeper understanding of the viewport on iOS.
● Read “Default Viewport Settings” (page 46) and “Using the Viewport Meta Tag” (page 46) for how to use
the viewport meta tag.
● Read “Changing the Viewport Width and Height” (page 47) and “How Safari Infers the Width, Height, and
Initial Scale” (page 50) to understand better how setting viewport properties affects the way webpages
are rendered on iOS.
● Read “Viewport Settings for Web Applications” (page 55) if you are designing a web application for iOS.
See “Supported Meta Tags” for a complete description of the viewport meta tag.
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Configuring the ViewportLayout and Metrics on iPhone and iPod touch
Because Safari on iOS adds controls above and below your web content, you don’t have access to the entire
screen real estate. In portrait orientation, the visible area for web content on iPhone and iPod touch is 320 x
356 pixels as shown in Figure 1-1. In landscape orientation, the visible area is 480 x 208 pixels.
Figure 3-1 Layout and metrics in portrait orientation
480 pixels
Status bar: 20 pixels
URL text field: 60 pixels
Visible area: 320 x 356 pixels
Button bar: 44 pixels
Note that if the URL text field is not in use, it is anchored above the webpage and moves with the webpage
when the user pans. This adds 60 pixels to the height of the visible area. However, since the URL text field can
appear at any time, you should not rely on this extra real estate when designing your webpage. Video playback
uses the entire screen on small devices.
Read “Laying Out Forms” (page 62) in “Designing Forms” (page 62) for more metrics when the keyboard is
displayed for user input.
Note:  Although it is helpful to know the metrics on small devices like iPhone and iPod touch, you
should avoid using these values in your code. Read “Using the Viewport Meta Tag” (page 46) for
how to use the viewport meta tag constants.
What Is the Viewport?
The viewport on the desktop and the viewport on iOS are slightly different.
Configuring the Viewport
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39Safari on iOS has no windows, scroll bars, or resize buttons as shown on the right in Figure 3-2. The user pans
by flicking a finger. The user zooms in by double-tapping and pinch opening, and zooms out by pinch
closing—gestures that are not available for Safari on the desktop. Because of the differences in the way users
interact with web content, the viewport on the desktop and on iOS are not the same. Note that these differences
between the viewports may affect some of the HTML and CSS instructions on iOS.
Figure 3-2 Differences between Safari on iOS and Safari on the desktop
Safari on the desktop Safari on iPhone
Configuring the Viewport
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40Safari on the Desktop Viewport
The viewport on the desktop is the visible area of the webpage as shown in Figure 3-3. The user resizes the
viewport by resizing the window. If the webpage is larger than the viewport, then the user scrolls to see more
of the webpage. When the viewport isresized, Safari may change the document’slayout—for example, expand
or shrink the width of the text to fit. If the webpage is smaller than the viewport, it is filled with white space
to fit the size of the viewport.
Figure 3-3 Safari on desktop viewport
Viewport
Safari on iOS Viewport
For Safari on iOS, the viewport is the area that determines how content is laid out and where text wraps on
the webpage. The viewport can be larger or smaller than the visible area.
When the user pans a webpage on iOS, gray bars appear on the right and bottom sides of the screen as visual
feedback to show the user the size of the visible area as compared to the viewport (similar to the length of
scroll bars on the desktop). Using the double tap, pinch open, and pinch close gestures, users can change the
scale of the viewport but not the size. The only exception is when the user changes from portrait to landscape
orientation—under certain circumstances, Safari on iOS may adjust the viewport width and height, and
consequently, change the webpage layout.
You can set the viewport size and other properties of your webpage. Mostly, you do this to improve the
presentation the first time iOS renders the webpage.
Configuring the Viewport
What Is the Viewport?
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41Examples of Viewports on iOS
The viewport on iOS is best illustrated using a few examples. Figure 3-4 shows a webpage on iPhone, containing
a single 320 x 356 pixel image, that is rendered for the first time using the default viewport settings.
Figure 3-4 Viewport with default settings
Viewport
default width = 980 pixels
Configuring the Viewport
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42Figure 3-5 shows the same webpage with the viewport set to the size of the visible area, which is also the size
of the image.
Figure 3-5 Viewport with width set to 320
Viewport
width = 320 pixels
scale = 1.0
Configuring the Viewport
What Is the Viewport?
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43However, the viewport can be larger or smaller than the visible area. If the viewport is larger than the visible
area, as shown in Figure 3-6, then the user pans to see more of the webpage.
Figure 3-6 Viewport with width set to 320 and scale set to 150%
Viewport
width = 320 pixels
scale = 1.5
Visible area
Configuring the Viewport
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44Figure 3-7 show the webpage when it is smaller than the viewport and filled with white space.
Figure 3-7 Viewport with width set to 320 and scale set to 50%
Viewport
width = 320 pixels
scale = 0.5
The user can also zoom in and out using gestures. When zooming in and out, the user changes the scale of
the viewport, not the size of the viewport. Consequently, panning and zooming do not change the layout of
the webpage. Figure 3-8 shows the same webpage when the user zooms in to see details.
Figure 3-8 Viewport with arbitrary user scale
User zoom, arbitrary scale
Configuring the Viewport
What Is the Viewport?
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45Default Viewport Settings
Safari on iOS sets the size and scale of the viewport to reasonable defaults that work well for most webpages,
as shown on the left in Figure 3-9. The default width is 980 pixels. However, these defaults may not work well
for your webpages, particularly if you are tailoring your website for a particular device. For example, the
webpage on the right in Figure 3-9 appears too narrow. Because Safari on iOS provides a viewport, you can
change the default settings.
Figure 3-9 Default settings work well for most webpages
Works well Too narrow
Using the Viewport Meta Tag
Use the viewport meta tag to improve the presentation of your web content on iOS. Typically, you use the
viewport meta tag to set the width and initialscale of the viewport. For example, if your webpage is narrower
than 980 pixels, then you should set the width of the viewport to fit your web content. If you are designing
an iPhone or iPod touch-specific web application, then set the width to the width of the device. Refer to
“Additional meta Tag Keys” in Safari HTML Reference for a detailed description of the viewport meta tag.
Because iOS runs on devices with differentscreen resolutions, you should use the constantsinstead of numeric
values when referring to the dimensions of a device. Use device-width for the width of the device and
device-height for the height in portrait orientation.
Configuring the Viewport
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46You do not need to set every viewport property. If only a subset of the properties are set, then Safari on iOS
infers the other values. For example, if you set the scale to 1.0, Safari assumes the width is device-width in
portrait and device-height in landscape orientation. Therefore, if you want the width to be 980 pixels and
the initial scale to be 1.0, then set both of these properties.
For example, to set the viewport width to the width of the device, add this to your HTML file:


To set the initial scale to 1.0, add this to your HTML file:

To set the initial scale and to turn off user scaling, add this to your HTML file:

Use the Safari on iOS console to help debug your webpages as described in “Debugging” (page 104). The
console contains tips to help you choose viewport values—for example, it reminds you to use the constants
when referring to the device width and height.
Changing the Viewport Width and Height
Typically, you set the viewport width to match your web content. Thisisthe single most important optimization
that you can do for iOS—make sure your webpage looks good the first time it is displayed on iOS.
Configuring the Viewport
Changing the Viewport Width and Height
2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
47The majority of webpages fit nicely in the visible area with the viewport width set to 980 pixels in portrait
orientation, as shown in Figure 3-10. If Safari on iOS did not set the viewport width to 980 pixels, then only
the upper-left corner of the webpage, shown in gray, would be displayed. However, this default doesn’t work
for all webpages, so you’ll want to use the viewport meta tag if your webpage is different.
Figure 3-10 Comparison of 320 and 980 viewport widths
320 pixels
980 pixels
356 pixels
1090 pixels
If your webpage is narrower than the default width, as shown on the left in Figure 3-11, then set the viewport
width to the width of your webpage, as shown on the right in Figure 3-11. To do this, add the following to
your HTML file inside the  block, replacing 590 with the width of your webpage:
Configuring the Viewport
Changing the Viewport Width and Height
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Figure 3-11 Webpage is too narrow for default settings
Default width Custom width
980 pixels 590 pixels
Configuring the Viewport
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49It is particularly important to change the viewport width for web applications designed for devices with smaller
screens such as iPhone and iPod touch. Figure 3-12 shows the effect of setting the viewport width to
device-width. Read “Viewport Settings for Web Applications” (page 55) for more web application tips.
Figure 3-12 Web application page is too small for default settings
Default width Width set to device-width
980 pixels 320 pixels
Similarly you can set the viewport height to match your web content.
How Safari Infers the Width, Height, and Initial Scale
If you set only some of the properties, then Safari on iOS infers the values of the other properties with the goal
of fitting the webpage in the visible area. For example, if just the initial scale is set, then the width and height
are inferred. Similarly, if just the width is set, then the height and initial scale are inferred, and so on. If the
inferred values do not work for your webpage, then set more viewport properties.
Since any of the width, height, and initial scale may be inferred by Safari on iOS, the viewport may resize when
the user changes orientation. For example, when the user changes from portrait to landscape orientation by
rotating the device, the viewport width may expand. This is the only situation where a user action might resize
the viewport, changing the layout on iOS.
Configuring the Viewport
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50Specifically, the goal of Safari on iOS is to fit the webpage in the visible area when completely zoomed out by
maintaining a ratio equivalent to the ratio of the visible area in either orientation. This is best illustrated by
setting the viewport propertiesindependently, and observing the effect on the other viewport properties. The
following series of examples shows the same web content with different viewport settings.
Figure 3-13 shows a typical webpage displayed with the default settings where the viewport width is 980 and
no initial scale is set.
Figure 3-13 Default width and initial scale
default = 980 pixels
Configuring the Viewport
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51Figure 3-14 shows the same webpage when the initial scale is set to 1.0 on iPhone. Safari on iOS infers the
width and height to fit the webpage in the visible area. The viewport width is set to device-width in portrait
orientation and device-height in landscape orientation.
Figure 3-14 Default width with initial scale set to 1.0
320 pixels
356 pixels
480 pixels
208 pixels
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52Similarly, if you specify only the viewport width, the height and initial scale are inferred. Figure 3-15 shows the
rendering of the same webpage when the viewport width is set to 320 on iPhone. Notice that the portrait
orientation is rendered in the same way as in Figure 3-14 (page 52), but the landscape orientation maintains
a width equal to device-width, which changes the initial scale and has the effect of zooming in when the
user changes to landscape orientation.
Figure 3-15 Width set to 320 with default initial scale
320 pixels
356 pixels
320 pixels
139 pixels
Configuring the Viewport
How Safari Infers the Width, Height, and Initial Scale
2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
53You can also set the viewport width to be smaller than the visible area with a minimum value of 200 pixels.
Figure 3-16 shows the same webpage when the viewport width is set to 200 pixels on iPhone. Safari on iOS
infers the height and initial scale, which has the effect of zooming in when the webpage is first rendered.
Figure 3-16 Width set to 200 with default initial scale
200 pixels
223 pixels
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54Finally, Figure 3-17 shows the same webpage when both the width and initial scale are set on iPhone. Safari
on iOS infers the height by maintaining a ratio equivalent to the ratio of the visible area in either orientation.
Therefore, if the width is set to 980 and the initial scale is set to 1.0 on iPhone, the height is set to 1091 in
portrait and 425 in landscape orientation.
Figure 3-17 Width set to 980 and initial scale set to 1.0
Width = 980 pixels
Height = 1091 pixels
Initial scale = 1.0
Width = 980 pixels
Height = 425 pixels
Initial scale = 1.0
The minimum-scale and maximum-scale properties also affect the behavior when changing orientations.
The range of these property values is from >0 to 10.0. The default value for minimum-scale is 0.25 and
maximum-scale is 5.0.
Viewport Settings for Web Applications
If you are designing a web application specifically for iOS, then the recommended size for your webpages is
the size of the visible area on iOS. Apple recommends that you set the width to device-width so that the
scale is 1.0 in portrait orientation and the viewport is not resized when the user changesto landscape orientation.
Configuring the Viewport
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55If you do not change the viewport properties, Safari on iOS displays your webpage in the upper-left corner as
shown in Figure 3-18. Setting the viewport width should be the first task when designing web applications for
iOS to avoid the user zooming in before using your application.
Figure 3-18 Not specifying viewport properties
Viewport
width = 980 pixels
By setting the width to device-width in portrait orientation, Safari on iOS displays your webpage as show
in Figure 3-19. Users can pan down to view the rest of the webpage if it is taller than the visible area. Add this
line to your HTML file to set the viewport width to device-width:
Configuring the Viewport
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Figure 3-19 Width set to device-width pixels
Viewport
width = 320 pixels
You may not want users to scale web applications designed specifically for iOS. In this case, set the width and
turn off user scaling as follows:

Configuring the Viewport
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57Although configuring the viewport is an important way to optimize your web content for iOS, style sheets
provide further techniques for optimizing. For example, use iOS CSS extensions to control text resizing and
element highlighting. If you use conditional CSS, then you can use these settings without affecting the way
other browsers render your webpages.
Read “Optimizing Web Content” (page 33) for how to use conditional CSS and “CSS Basics” (page 117) for how
to add CSS to existing HTML. See Safari CSS Reference for a complete list of CSS properties supported by Safari.
Leveraging CSS3 Properties
There are many CSS3 properties available for you to use in Safari on the desktop and iOS. CSS properties that
begin with -webkit- are usually proposed CSS3 properties or Apple extensions to CSS. For example, you can
use the following CSS properties to emulate the iOS user interface:
-webkit-border-image
Allows you to use an image as the border for a box. See "-webkit-border-image" in Safari CSS Reference for
details.
-webkit-border-radius
Creates elements with rounded corners. See “Customizing Form Controls” (page 64) for code samples.
See "-webkit-border-radius" in Safari CSS Reference for details.
Adjusting the Text Size
In addition to controlling the viewport, you can control the text size that Safari on iOS uses when rendering a
block of text.
Adjusting the textsize isimportantso that the text islegible when the user double-taps. If the user double-taps
an HTML block element—such as a  element—then Safari on iOS scales the viewport to fit the block
width in the visible area. The first time a webpage is rendered, Safari on iOS gets the width of the block and
determines an appropriate text scale so that the text is legible.
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Customizing Style SheetsIf the automatic text size-adjustment doesn’t work for your webpage, then you can either turn this feature off
or specify your own scale as a percentage. For example, text in absolute-positioned elements might overflow
the viewport after adjustment. Other pages might need a few minor adjustments to make them look better.
In these cases, use the -webkit-text-size-adjust CSS property to change the default settings for any
element that renders text.
Figure 4-1 compares a webpage rendered by Safari on iOS with -webkit-text-size-adjust set to auto,
none, and 200%. On iPad, the default value for -webkit-text-size-adjust is none. On all other devices,
the default value is auto.
Figure 4-1 Comparison of text adjustment settings
Auto None 200%
To turn automatic text adjustment off, set -webkit-text-size-adjust to none as follows:
html {-webkit-text-size-adjust:none}
To change the text adjustment,set -webkit-text-size-adjust to a percentage value asfollows, replacing
200% with your percentage:
html {-webkit-text-size-adjust:200%}
Listing 4-1 shows setting this property for different types of blocks using inline style in HTML.
Customizing Style Sheets
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59Listing 4-1 Setting the text size adjustment property




Highlighting Elements
By default, when the user taps a link or a JavaScript clickable element, Safari on iOS highlights the area in a
transparent gray color. Using the -webkit-tap-highlight-color CSS property, you can either modify or
disable this default behavior on your webpages.
The syntax for setting this CSS property is:
-webkit-tap-highlight-color:
This is an inherited property that changes the tap highlight color, obeying the alpha value. If you don’t specify
an alpha value, Safari on iOS applies a default alpha value to the color. To disable tap highlighting, set the
alpha to 0 (invisible). If you set the alpha to 1.0 (opaque), then the element won’t be visible when tapped.
Listing 4-2 uses an alpha value of 0.4 for the custom highlight color shown on the right in Figure 4-2.
Listing 4-2 Changing the tap highlight color


default highlight color


custom highlight color

Customizing Style Sheets
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Figure 4-2 Differences between default and custom highlighting
Default highlight Custom highlight
Note that changing this behavior does not affect the color of the information bubble when the user touches
and holds.
You can also use the -webkit-tap-highlight-color CSS property in combination with setting a touch
event to configure buttons to behave similar to the desktop. On iOS, mouse events are sent so quickly that
the down or active state is never received. Therefore, the :active pseudo state is triggered only when there
is a touch eventset on the HTML element—for example, when ontouchstart isset on the element asfollows:
Testing Touch on iOS
Now when the button is tapped and held on iOS, the button changes to the specified color without the
surrounding transparent gray color appearing.
Read “Handling Events” (page 68) for the definition of a clickable element. See "-webkit-tap-highlight-color" in
Safari CSS Reference to learn more about this property. Read “Handling Multi-Touch Events” (page 74) for
details on touch events.
Customizing Style Sheets
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61There are many adjustments you can make to your forms so that they work better on iOS. The forms should
fit neatly on the iOS screen, especially if you are designing a web application specifically for iOS. Web applications
can have a rich user interface and even look like native applications to the user. Consequently, the user may
expect them to behave like native applications, too.
This chapter explains what you can do to make your forms work well on iOS:
● Take into account the available screen space when the keyboard is and isn’t displayed.
● Use CSS extensions to create custom controls.
● Control where automatic correction and capitalization are used.
See iOS Human Interface Guidelines for more tips on laying out forms and designing web applications for iOS.
Read “Hiding Safari User Interface Components” (page 89) for how to use the full-screen like a native application.
Laying Out Forms
The available area for your forms changes depending on whether or not the keyboard is displayed on iOS. You
should compute this area and design your forms accordingly.
Figure 5-1 shows the layout of Safari controls when the keyboard is displayed on iPhone. The status bar that
appears at the top of the screen contains the time and Wi-Fi indicator. The URL text field is displayed below
the status bar. The keyboard is used to enter text in forms and is displayed at the bottom of the screen. The
form assistant appears above the keyboard when editing forms. It contains the Previous, Next, and Done
buttons. The user taps the Next and Previous buttons to move between form elements. The user taps Done
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Designing Formsto dismissthe keyboard. The button bar containsthe back, forward, bookmarks, and page buttons and appears
at the bottom of the screen. The tool bar is not visible when the keyboard is visible. Your webpage is displayed
in the area below the URL text field and above the tool bar or keyboard.
Figure 5-1 Form metrics when the keyboard is displayed
Status bar: 20 pixels
URL text field: 60 pixels
Form assistant: 44 pixels
Keyboard: 216 pixels
480 pixels
Table 5-1 contains the metrics for the objects that you need to be aware of, in both portrait and landscape
orientation, when laying out forms to fit on iPhone and iPod touch.
Table 5-1 Form metrics
Object Metrics in pixels
Status bar Height = 20
URL text field Height = 60
Form assistant Height = 44
Portrait height = 216
Landscape height = 162
Keyboard
Portrait height = 44
Landscape height = 32
Button bar
Designing Forms
Laying Out Forms
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63Use this information to compute the available area for your web content when the keyboard is and isn't
displayed. For example, when the keyboard is not displayed, the height available for your web content on
iPhone is 480 - 20 - 60 - 44 = 356. Therefore, you should design your content to fit within 320 x 356 pixels in
portrait orientation. If the keyboard is displayed, the available area is 320 x 140 pixels on iPhone.
iOS Note:  In iOS 1.1.4 and earlier, the keyboard height in landscape orientation on iPhone and iPod
touch was 180 pixels.
Customizing Form Controls
Form controls in Safari on iOS are resolution independent and can be styled with CSS specifically for iOS. You
can create custom checkboxes, text fields, and select elements.
For example, you can create a custom checkbox designed for iOS as shown in Figure 5-2 with the CSS code
fragment in Listing 5-1. This example uses the -webkit-border-radius property—an Apple extension to
WebKit. See Safari CSS Reference for details on more WebKit properties.
Figure 5-2 A custom checkbox
Listing 5-1 Creating a custom checkbox with CSS
{
Designing Forms
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height: 100px;
-webkit-border-radius:50px;
background-color:purple;
}
Figure 5-3 shows a custom text field with rounded corners corresponding to the CSS code in Listing 5-2 (page
65).
Figure 5-3 A custom text field
Listing 5-2 Creating a custom text field with CSS
{
-webkit-border-radius:10px;
}
Designing Forms
Customizing Form Controls
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65Figure 5-4 shows a custom select control corresponding to the CSS code in Listing 5-3 (page 66).
Figure 5-4 A custom select element
Listing 5-3 Creating a custom select control with CSS
{
background:red;
border: 1px dashed purple;
-webkit-border-radius:10px;
}
Configuring Automatic Correction and Capitalization
You can also control whether or not automatic correction or capitalization are used in your forms on iOS. Set
the autocorrect attribute to on if you want automatic correction and the autocapitalize attribute to a
value if you want automatic capitalization. If you do notset these attributes, then the browser chooses whether
or not to use automatic correction or capitalization. For example, Safari on iOS turns the autocorrect and
autocapitalize attributes off in login fields and on in normal text fields.
For example, the following line turns the autocorrect attribute on:
Designing Forms
Configuring Automatic Correction and Capitalization
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The following line turns the autocorrect attribute off:

In iOS 5.0, the autocapitalize attribute allows finer control on how automatic capitalization behaves than
just specifying on and off values. For example, if autocapitalize is words, each word is capitalized, as in
“Jane Doe,” appropriate for a first and last name input field. If autocapitalize is characters, each letter
is capitalized, as in “NY” and “CA,” appropriate for a state input field.
You can also use the autocorrect and autocapitalize attributes on  elements to give inner form
controls (like  and  elements) default behavior. If the inner form controls have these
attributes set, those values are used instead. If they don’t have these attributes set, the value is inherited from
their parent  element. If neither element has these attributes set, the default value is used.
For example, the following code fragment sets the autocapitalize attribute to words on the form but to
characters on the state and none on the username input fields. The first-name and last-name input
fields inherit the words setting from the form element.

First Name: 
Last Name: 
State: 
Username: 
Comment: 


Refer to autocorrect and autocapitalize in Safari HTML Reference for all possible values and defaults.
Designing Forms
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67This chapter describes the events that occur when the user interacts with a webpage on iOS. Forms and
documents generate the typical events in iOS that you might expect on the desktop. Gestures handled by
Safari on iOS emulate mouse events. In addition, you can register for iOS-specific multi-touch and gesture
events directly. Orientation events are another example of an iOS-specific event. Also, be aware that there are
some unsupported events such as cut, copy, and paste.
Gestures that the user makes—for example, a double tap to zoom and a flick to pan—emulate mouse events.
However, the flow of events generated by one-finger and two-finger gestures are conditional depending on
whether or not the selected element is clickable or scrollable as described in “One-Finger Events” (page 69)
and “Two-Finger Events” (page 72).
A clickable element is a link, form element, image map area, or any other element with mousemove, mousedown,
mouseup, or onclick handlers. A scrollable element is any element with appropriate overflow style, text areas,
and scrollable iframe elements. Because of these differences, you might need to change some of your elements
to clickable elements, as described in “Making Elements Clickable” (page 73), to get the desired behavior in
iOS.
In addition, you can turn off the default Safari on iOS behavior as described in “Preventing Default
Behavior” (page 79) and handle your own multi-touch and gesture events directly. Handling multi-touch and
gesture events directly gives developers the ability to implement unique touch-screen interfaces similar to
native applications. Read “Handling Multi-Touch Events” (page 74) and “Handling Gesture Events” (page 77)
to learn more about DOM touch events.
If you want to change the layout of your webpage depending on the orientation of iOS, read “Handling
Orientation Events” (page 79).
See “Supported Events” (page 81) for a complete list of events supported in iOS.
On iOS, emulated mouse events are sent so quickly that the down or active pseudo state of buttons may never
occur. Read “Highlighting Elements” (page 60) for how to customize a button to behave similar to the desktop.
It’s very common to combine DOM touch events with CSS visual effects. Read Safari CSS Visual Effects Guide
to learn more about CSS visual effects.
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Handling EventsOne-Finger Events
This section uses flow charts to break down gestures into the individual actions that might generate events.
Some of the events generated on iOS are conditional—the events generated depend on what the user is
tapping or touching and whether they are using one or two fingers. Some gestures don’t generate any events
on iOS.
One-finger panning doesn’t generate any events until the userstops panning—an onscroll event is generated
when the page stops moving and redraws—as shown in Figure 6-1.
Figure 6-1 The panning gesture
Pan (no events)
Finger down
Finger stop
onscroll
Finger move
Displaying the information bubble doesn’t generate any events as shown in Figure 6-2. However, if the user
touches and holds an image, the image save sheet appears instead of an information bubble.
Handling Events
One-Finger Events
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Figure 6-2 The touch and hold gesture
Information bubble
(no events)
Finger down
Finger held down
Clickable element
Handling Events
One-Finger Events
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70Finally, a double tap doesn’t generate any events either as shown in Figure 6-3.
Figure 6-3 The double-tap gesture
Finger down
Quick finger up
Double-tap zoom
(no events)
Quick finger down
Quick finger up
Handling Events
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71Mouse events are delivered in the same order you'd expect in other web browsers illustrated in Figure 6-4. If
the user taps a nonclickable element, no events are generated. If the user taps a clickable element, events
arrive in this order: mouseover, mousemove, mousedown, mouseup, and click. The mouseout event occurs
only if the user taps on another clickable item. Also, if the contents of the page changes on the mousemove
event, no subsequent events in the sequence are sent. This behavior allows the user to tap in the new content.
Figure 6-4 One-finger gesture emulating a mouse
Content change
Finger down
Not a clickable
element
No events
Finger up
Clickable element
mouseover, mousemove No events
No content change
mousedown, mouseup, click
Two-Finger Events
The pinch open gesture does not generate any mouse events as shown in Figure 6-5.
Figure 6-5 The pinch open gesture
Fingers separate Pinch zoom
(no events)
Two fingers down
Figure 6-6 illustrates the mouse events generated by using two fingers to pan a scrollable element. The flow
of events is as follows:
Handling Events
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If the user holds two fingers down on a scrollable element and moves the fingers, mousewheel events
are generated.
●
If the element is not scrollable, Safari on iOS pans the webpage. No events are generated while panning.
● An onscroll event is generated when the user stops panning.
Figure 6-6 Two-finger panning gesture
Two fingers down
Scrollable element
Two fingers move
Not a scrollable element
mousewheel
Pan (no events)
Finger stop
onscroll
Form and Document Events
Typical events generated by forms and documents include blur, focus, load, unload, reset, submit,
change and abort. See “Supported Events” (page 81) for a complete list of supported events on iOS.
Making Elements Clickable
Because of the way Safari on iOS creates events to emulate a mouse, some of your elements may not behave
as expected on iOS. In particular, some menus that only use mousemove handlers, as in Listing 6-1, need to
be changed because iOS doesn’t recognize them as clickable elements.
Listing 6-1 A menu using a mouseover handler

To fix this, add a dummy onclick handler, onclick = "void(0)", so that Safari on iOS recognizes the
span element as a clickable element, as shown in Listing 6-2.
Listing 6-2 Adding an onclick handler

WHERE TO BUY

Handling Multi-Touch Events
You can use JavaScript DOM touch event classes available on iOS to handle multi-touch and gesture events
in a way similar to the way they are handled in native iOS applications.
If you register for multi-touch events, the system continually sends TouchEvent objectsto those DOM elements
as fingers touch and move across a surface. These are sent in addition to the emulated mouse events unless
you prevent this default behavior as described in “Preventing Default Behavior” (page 79). A touch event
provides a snapshot of all touches during a multi-touch sequence, most importantly the touches that are new
or have changed for a particular target. The different types of multi-touch events are described in TouchEvent
Class Reference in Safari DOM Additions Reference .
A multi-touch sequence begins when a finger first touches the surface. Other fingers may subsequently touch
the surface, and all fingers may move across the surface. The sequence ends when the last of these fingers is
lifted from the surface. An application receives touch event objects during each phase of any touch.
Handling Events
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74Touch events are similar to mouse events except that you can have simultaneous touches on the screen at
different locations. A touch event object is used to encapsulate all the touches that are currently on the screen.
Each finger is represented by a touch object. The typical properties that you find in a mouse event are in the
touch object, not the touch event object.
Note that a sequence of touch eventsis delivered to the element that received the original touchstart event
regardless of the current location of the touches.
Follow these steps to use multi-touch events in your web application.
1. Register handlers for multi-touch events in HTML as follows:


2. Alternatively, register handlers in JavaScript as follows:
element.addEventListener("touchstart", touchStart, false);
element.addEventListener("touchmove", touchMove, false);
element.addEventListener("touchend", touchEnd, false);
element.addEventListener("touchcancel", touchCancel, false);
3. Respond to multi-touch events by implementing handlers in JavaScript.
For example, implement the touchStart method as follows:
function touchStart(event) {
// Insert your code here
}
4. Optionally, get all touches on a page using the touches property as follows:
var allTouches = event.touches;
Note that you can get all other touches for an event even when the event is triggered by a single touch.
Handling Events
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755. Optionally, get all touches for the target element using the targetTouches property:
var targetTouches = event.targetTouches;
6. Optionally, get all changed touches for this event using the changedTouches property:
var changedTouches = event.changedTouches;
7. Access the Touch object properties—such as the target, identifier, and location in page, client, or screen
coordinates—similar to mouse event properties.
For example, get the number of touches:
event.touches.length
Get a specific touch object at index i:
var touch = event.touches[i];
Finally, get the location in page coordinates for a single-finger event:
var x = event.touches[0].pageX;
var y = event.touches[0].pageY;
You can also combine multi-touch events with CSS visual effectsto enable dragging orsome other user action.
To enable dragging, implement the touchmove event handler to translate the target:
function touchMove(event) {
event.preventDefault();
curX = event.targetTouches[0].pageX - startX;
curY = event.targetTouches[0].pageY - startY;
event.targetTouches[0].target.style.webkitTransform =
'translate(' + curX + 'px, ' + curY + 'px)';
}
Handling Events
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76Typically, you implement multi-touch event handlers to track one or two touches. But you can also use
multi-touch event handlersto identify custom gestures. That is, custom gesturesthat are not already identified
for you by gesture events described in “Handling Gesture Events” (page 77). For example, you can identify a
two-finger tap gesture as follows:
1. Begin gesture if you receive a touchstart event containing two target touches.
2. End gesture if you receive a touchend event with no preceding touchmove events.
Similarly, you can identify a swipe gesture as follows:
1. Begin gesture if you receive a touchstart event containing one target touch.
2. Abort gesture if, at any time, you receive an event with >1 touches.
3. Continue gesture if you receive a touchmove event mostly in the x-direction.
4. Abort gesture if you receive a touchmove event mostly the y-direction.
5. End gesture if you receive a touchend event.
Handling Gesture Events
Multi-touch events can be combined together to form high-level gesture events.
GestureEvent objects are also sent during a multi-touch sequence. Gesture events contain scaling and
rotation information allowing gestures to be combined, if supported by the platform. If not supported, one
gesture ends before another starts. Listen for GestureEvent objects if you want to respond to gestures only,
not processthe low-level TouchEvent objects. The different types of gesture events are described in GestureEvent
Class Reference in Safari DOM Additions Reference .
Follow these steps to use gesture events in your web application.
1. Register handlers for gesture events in HTML:


2. Alternatively, register handlers in JavaScript:
Handling Events
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77element.addEventListener("gesturestart", gestureStart, false);
element.addEventListener("gesturechange", gestureChange, false);
element.addEventListener("gestureend", gestureEnd, false);
3. Respond to gesture events by implementing handlers in JavaScript.
For example, implement the gestureChange method as follows:
function gestureChange(event) {
// Insert your code here
}
4. Get the amount of rotation since the gesture started:
var angle = event.rotation;
The angle is in degrees, where clockwise is positive and counterclockwise is negative.
5. Get the amount scaled since the gesture started:
var scale = event.scale;
The scale is smaller if less than 1.0 and larger if greater than 1.0.
You can combine gesture events with CSS visual effects to enable scaling, rotating, or some other custom user
action. For example, implement the gesturechange event handler to scale and rotate the target as follows:
onGestureChange: function(e) {
e.preventDefault();
e.target.style.webkitTransform =
'scale(' + e.scale + startScale + ') rotate(' + e.rotation + startRotation
+ 'deg)';
}
Handling Events
Handling Gesture Events
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iOS Note:  The preventDefault method applies to multi-touch and gesture input in iOS 2.0 and
later.
The default behavior of Safari on iOS can interfere with your application’s custom multi-touch and gesture
input. You can disable the default browser behavior by sending the preventDefault message to the event
object.
For example, to preventscrolling on an element in iOS 2.0, implement the touchmove and touchstart event
handlers as follows :
function touchMove(event) {
// Prevent scrolling on this element
event.preventDefault();
...
}
To disable pinch open and pinch close gesturesin iOS 2.0, implement the gesturestart and gesturechange
event handlers as follows:
function gestureChange(event) {
// Disable browser zoom
event.preventDefault();
...
}
Important:  The default browser behavior may change in future releases.
Handling Orientation Events
An event is sent when the user changes the orientation of iOS. By handling this event in your web content,
you can determine the current orientation of the device and make layout changes accordingly. For example,
display a simple textual list in portrait orientation and add a column of icons in landscape orientation.
Similar to a resize event, a handler can be added to the 

 element in HTML as follows:
Handling Events
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where updateOrientation is a handler that you implement in JavaScript.
In addition, the window object has an orientation property set to either 0, -90, 90, or 180. For example, if
the user starts with the iPhone in portrait orientation and then changes to landscape orientation by turning
the iPhone to the right, the window’s orientation property is set to -90. If the user instead changes to
landscape by turning the iPhone to the left, the window’s orientation property is set to 90.
Listing 6-3 adds an orientation handler to the body element and implements the updateOrientation
JavaScript method to display the current orientation on the screen. Specifically, when an orientationchange
event occurs, the updateOrientation method isinvoked, which changesthe string displayed by the division
element in the body.
Listing 6-3 Displaying the orientation





Supported Events
Be aware of all the events that iOS supports and under what conditions they are generated. Table 6-1 specifies
which events are generated by Safari on iOS and which are generated conditionally depending on the type of
element selected. This table also lists unsupported events.
Handling Events
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81iOS Note:  Although drag and drop are notsupported, you can produce the same effect using touch
events as described in “Using Touch to Drag Elements” in Safari CSS Visual Effects Guide .
The unload event may not work as expected for back and forward optimization. Use the pageshow
and pagehide events instead.
Table 6-1 Types of events
Event Generated Conditional Available
abort Yes No iOS 1.0 and later.
blur Yes No iOS 1.0 and later.
change Yes No iOS 1.0 and later.
click Yes Yes iOS 1.0 and later.
copy No N/A
cut No N/A
drag No N/A
drop No N/A
focus Yes No iOS 1.0 and later.
gesturestart Yes N/A iOS 2.0 and later.
gesturechange Yes N/A iOS 2.0 and later.
gestureend Yes N/A iOS 2.0 and later.
load Yes No iOS 1.0 and later.
mousemove Yes Yes iOS 1.0 and later.
mousedown Yes Yes iOS 1.0 and later.
mouseup Yes Yes iOS 1.0 and later.
mouseover Yes Yes iOS 1.0 and later.
mouseout Yes Yes iOS 1.0 and later.
orientationchange Yes N/A iOS 1.1.1 and later.
Handling Events
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pagehide Yes No iOS 4.0 and later.
pageshow Yes No iOS 4.0 and later.
paste No N/A
reset Yes No iOS 1.0 and later.
selection No N/A
submit Yes No iOS 1.0 and later.
touchcancel Yes N/A iOS 2.0 and later.
touchend Yes N/A iOS 2.0 and later.
touchmove Yes N/A iOS 2.0 and later.
touchstart Yes N/A iOS 2.0 and later.
unload Yes No iOS 1.0 and later.
Handling Events
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83Safari has a new Smart App Banner feature in iOS 6 and later that provides a standardized method of promoting
apps on the App Store from a website, as shown in Figure 7-1 (page 84).
Figure 7-1 A Smart App Banner of the Apple Store app
Note:  Smart App Banners only show on iOS, not OS X.
Smart App Banners vastly improve users’ browsing experience compared to other promotional methods. As
banners are implemented in iOS 6, they will provide a consistent look and feel across the web that users will
come to recognize. Users will trust that tapping the banner will take them to the App Store and not a third-party
advertisement. They will appreciate that banners are presented unobtrusively at the top of a webpage, instead
of as a full-screen ad interrupting the web content. And with a large and prominent close button, a banner is
easy for users to dismiss.
If the app is already installed on a user's device, the banner intelligently changes its action, and tapping the
banner will simply open the app. If the user doesn’t have your app on his device, tapping on the banner will
take him to the app’s entry in the App Store. When he returns to your website, a progress bar appears in the
banner, indicating how much longer the download will take to complete. When the app finishes downloading,
the View button changes to an Open button, and tapping the banner will open the app while preserving the
user’s context from your website.
Smart App Banners automatically determine whether the app is supported on the user’s device. If the device
loading the banner does not support your app, or if your app is not available in the user's location, the banner
will not display.
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Promoting Apps with Smart App BannersImplementing a Smart App Banner on Your Website
To add a Smart App Banner to your website, include the following meta tag in the head of each page where
you’d like the banner to appear:

You can include three comma-separated parameters in the content attribute:
● app-id: (Required.) Your app's unique identifier. To find your app ID from the iTunes Link Maker, type
the name of your app in the Search field, and select the appropriate country and media type. In the results,
find your app and select iPhone App Link in the column on the right. Your app ID is the nine-digit number
in between id and ?mt.
● affiliate-data: (Optional.) Your iTunes affiliate string, if you are an iTunes affiliate. If you are not, find
out more about becoming an iTunes affiliate at http://www.apple.com/itunes/affiliates/.
● app-argument: (Optional.) A URL that provides context to your native app. If you include this, and the
user has your app installed, she can jump from your website to the corresponding position in your iOS
app. Typically, it is beneficial to retain navigational context because:
●
If the user is deep within the navigational hierarchy of your website, you can pass the document’s
entire URL, and then parse it in your app to reroute her to the correct location in your app.
●
If the user performs a search on your website, you can passthe query string so thatshe can seamlessly
continue the search in your app without having to retype her query.
●
If the user isin the midst of creating content, you can passthe session ID to download the web session
state in your app so she can nondestructively resume her work.
You can generate the app-argument of each page dynamically with a server-side script. You can format
it however you'd like, as long as it is a valid URL.
Note:  You cannot display Smart App Banners inside of a frame.
Providing Navigational Context to Your App
In your app, implement the application:openURL:sourceApplication:annotation: method in your
app delegate, which fires when your app is launched from a URL. Then provide logic that can interpret the
URL that you pass. The value you set to the app-argument parameter is available as the NSURL url object.
Promoting Apps with Smart App Banners
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85The example in Listing 7-1 (page 86) illustrates a website that passes data to a native iOS app. To accomplish
this, detect if the URL contains the string /profile. If it does, then open the profile view controller and pass
the profile ID number that is in the query string.
Listing 7-1 Routing the user to the correct view controller
- (BOOL)application:(UIApplication *)application openURL:(NSURL *)url
sourceApplication:(NSString *)sourceApplication annotation:(id)annotation
{
// in this example, the URL from which the user came is
http://example.com/profile/?12345
// determine if the user was viewing a profile
if ([[url path] isEqualToString:@"/profile"]) {
// switch to profile view controller
[self.tabBarController setSelectedViewController:profileViewController];
// pull the profile id number found in the query string
NSString *profileID = [url query];
// pass profileID to profile view controller
[profileViewController loadProfile:profileID];
}
return YES;
}
Promoting Apps with Smart App Banners
Providing Navigational Context to Your App
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86A web application is designed to look and behave in a way similar to a native application—for example, it is
scaled to fit the entire screen on iOS. You can tailor your web application for Safari on iOS even further, by
making it appear like a native application when the user adds it to the Home screen. You do this by using
settings for iOS that are ignored by other platforms.
For example, you can specify an icon for your web application used to represent it when added to the Home
screen on iOS, as described in “Specifying a Webpage Icon for Web Clip” (page 87). You can also minimize the
Safari on iOS user interface, as described in “Changing the Status Bar Appearance” (page 89) and “Hiding Safari
User Interface Components” (page 89), when your web application is launched from the Home screen. These
are all optional settings that when added to your web content are ignored by other platforms.
Read “Viewport Settings for Web Applications” (page 55) for how to set the viewport for web applications on
iOS.
Specifying a Webpage Icon for Web Clip
iOS Note:  The Web Clip feature is available in iOS 1.1.3 and later. The
apple-touch-icon-precomposed.png filename is available in iOS 2.0 and later. Support for
multiple icons for different device resolutions is available in iOS 4.2 and later.
You may want users to be able to add your web application or webpage link to the Home screen. These links,
represented by an icon, are called Web Clips. Follow these simple steps to specify an icon to represent your
web application or webpage on iOS.
● To specify an icon for the entire website (every page on the website), place an icon file in PNG format in
the root document folder called apple-touch-icon.png or apple-touch-icon-precomposed.png.
If you use apple-touch-icon-precomposed.png as the filename, Safari on iOS won’t add any effects
to the icon.
● To specify an icon for a single webpage or replace the website icon with a webpage-specific icon, add a
link element to the webpage, as in:
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In the above example, replace custom_icon.png with your icon filename. If you don’t want Safari on
iOS to add any effectsto the icon, replace apple-touch-icon with apple-touch-icon-precomposed.
● To specify multiple icons for different device resolutions—for example, support both iPhone and iPad
devices—add a sizes attribute to each link element as follows:






The icon that is the most appropriate size for the device is used. If no sizes attribute is set, the element’s
size defaults to 57 x 57.
If there is no icon that matches the recommended size for the device, the smallest icon larger than the
recommended size is used. If there are no icons larger than the recommended size, the largest icon is used. If
multiple icons are suitable, the icon that has the precomposed keyword is used.
If no icons are specified using a link element, the website root directory is searched for icons with the
apple-touch-icon... or apple-touch-icon-precomposed... prefix. For example, if the appropriate
icon size for the device is 57 x 57, the system searches for filenames in the following order:
1. apple-touch-icon-57x57-precomposed.png
2. apple-touch-icon-57x57.png
3. apple-touch-icon-precomposed.png
4. apple-touch-icon.png
See “Custom Icon and Image Creation Guidelines” for webpage icon metrics.
Configuring Web Applications
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iOS Note:  Specifying a startup image is available in iOS 3.0 and later.
On iOS,similar to native applications, you can specify a startup image that is displayed while your web application
launches. This is especially useful when your web application is offline. By default, a screenshot of the web
application the last time it was launched is used. To set another startup image, add a link element to the
webpage, as in:


In the above example, replace startup.png with your startup screen filename. On iPhone and iPod touch,
the image must be 320 x 460 pixels and in portrait orientation.
Hiding Safari User Interface Components
On iOS, as part of optimizing your web application, have it use the standalone mode to look more like a native
application. When you use this standalone mode, Safari is not used to display the web content—specifically,
there is no browser URL text field at the top of the screen or button bar at the bottom of the screen. Only a
status bar appears at the top of the screen. Read “Changing the Status Bar Appearance” (page 89) for how to
minimize the status bar.
Set the apple-mobile-web-app-capable meta tag to yes to turn on standalone mode. For example, the
following HTML displays web content using standalone mode.

You can determine whether a webpage is displaying in standalone mode using the
window.navigator.standalone read-only Boolean JavaScript property.
Changing the Status Bar Appearance
If your web application displays in standalone mode like that of a native application, you can minimize the
status bar that is displayed at the top of the screen on iOS. Do so using the status-bar-style meta tag.
Configuring Web Applications
Specifying a Startup Image
2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
89This meta tag has no effect unless you firstspecify standalone mode as described in “Hiding Safari User Interface
Components” (page 89). Then use the status bar style meta tag,
apple-mobile-web-app-status-bar-style, to change the appearance of the status bar depending on
your application needs. For example, if you want to use the entire screen, set the status bar style to translucent
black.
For example, the following HTML sets the background color of the status bar to black:

Configuring Web Applications
Changing the Status Bar Appearance
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90Safari supports audio and video viewing in a webpage on the desktop and iOS. You can use audio and video
HTML elements or use the embed element to use the native application for video playback. In either case, you
need to ensure that the video you create is optimized for the platform and different bandwidths.
iOS streams movies and audio using HTTP over EDGE, 3G, and Wi-Fi networks. iOS uses a native application to
play back video even when video is embedded in your webpages. Video automatically expands to the size of
the screen and rotates when the user changes orientation. The controls automatically hide when they are not
in use and appear when the user taps the screen. This is the experience the user expects when viewing all
video on iOS.
Safari on iOS supports a variety of rich media, including QuickTime movies, as described in “Use Supported
iOS Rich Media MIME Types” (page 29). Safari on iOS does not support Flash so don’t bring up JavaScript alerts
that ask usersto download Flash. Also, don’t use JavaScript movie controlsto play back video since iOS supplies
its own controls.
Safari on the desktop supports the same audio and video formats as Safari on iOS. However, if you use the
audio and video HTML elements on the desktop, you can customize the play back controls. See Safari DOM
Additions Reference for more details on the HTMLMediaElement class.
Follow these guidelines to deliver the best web audio and video experience in Safari on any platform:
● Follow current best practices for embedding movies in webpages as described in “Sizing Movies
Appropriately” (page 92), “Don’t Let the Bit Rate Stall Your Movie” (page 92), and “Using Supported Movie
Standards” (page 92).
● Use QuickTime Pro to encode H.264/AAC at appropriate sizes and bit ratesfor EDGE, 3G, and Wi-Fi networks,
as described in “Encoding Video for Wi-Fi, 3G, and EDGE” (page 93).
● Use reference movies so that iOS automatically streams the best version of your content for the current
network connection, as described in “Creating a Reference Movie” (page 94).
● Use posterJPEGs(not poster framesin a movie) to display a preview of your embedded movie in webpages,
as described in “Creating a Poster Image for Movies” (page 94).
● Make sure the HTTP servers hosting your media files support byte-range requests, as described in
“Configuring Your Server” (page 95).
●
If your site has a custom media player, also provide direct links to the media files. iOS users can follow
these links to play those files directly.
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Creating VideoSizing Movies Appropriately
In landscape orientation on iOS, the screen is 480 x 320 pixels. Users can easily switch the view mode between
scaled-to-fit (letterboxed) and full-screen (centered and cropped). You should use a size that preserves the
aspect ratio of your content and fits within a 480 x 360 rectangle. 480 x 360 is a good choice for 4:3 aspect
ratio content and 480 x 270 is a good choice for widescreen content as it keeps the video sharp in full-screen
view mode. You can also use 640 x 360 or anamorphic 640 x 480 with pixel aspect ratio tagging for widescreen
content.
Don’t Let the Bit Rate Stall Your Movie
When viewing media over the network, the bit rate makes a crucial difference to the playback experience. If
the network cannot keep up with the media bit rate, playback stalls. Encode your media for iOS as described
in “Encoding Video for Wi-Fi, 3G, and EDGE” (page 93) and use a reference movie as described in “Creating a
Reference Movie” (page 94).
Using Supported Movie Standards
The following compression standards are supported:
● H.264 Baseline Profile Level 3.0 video, up to 640 x 480 at 30 fps. Note that B frames are not supported in
the Baseline profile.
● MPEG-4 Part 2 video (Simple Profile)
● AAC-LC audio, up to 48 kHz
Movie files with the extensions .mov, .mp4, .m4v, and .3gp are supported.
Any movies or audio files that can play on iPod play correctly on iPhone.
If you export your movies using QuickTime Pro 7.2, as described in “Encoding Video for Wi-Fi, 3G, and
EDGE” (page 93), then you can be sure that they are optimized to play on iOS.
Creating Video
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Because users may be connected to the Internet via wired or wireless technology, using either Wi-Fi, 3G, or
EDGE on iOS, you need to provide alternate media for these different connection speeds. You can use QuickTime
Pro, the QuickTime API, or any Apple applications that provide iOS exporters to encode your video for Wi-Fi,
3G, and EDGE. This section contains specific instructions for exporting video using QuickTime Pro.
Follow these steps to export video using QuickTime Pro 7.2.1 and later:
1. Open your movie using QuickTime Player Pro.
2. Choose File > Export for Web.
A dialog appears.
3. Enter the file name prefix, location of your export, and set of versions to export as shown in Figure 9-1.
Figure 9-1 Export movie panel
4. Click Export.
QuickTime Player Pro saves these versions of your QuickTime movie, along with a reference movie, poster
image, and ReadMe.html file to the specified location. See the ReadMe.html file for instructions on
embedding the generated movie in your webpage, including sample HTML.
Creating Video
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A reference movie contains a list of movie URLs, each of which has a list of tests, as show in Figure 9-2. When
opening the reference movie, a playback device or computer chooses one of the movie URLs by finding the
last one that passes all its tests. Tests can check the capabilities of the device or computer and the speed of
the network connection.
Figure 9-2 Reference movie components
iPhone over EDGE
iPhone over WiFi
Computer desktop
80 kbit
foo-iPhone-cell.3gp
1 Mbit
foo-iPhone.m4v
Main Profile 
foo-desktop.m4v
foo-ref.mov
If you use QuickTime Pro 7.2.1 or later to export your movies for iOS, as described in “Encoding Video for Wi-Fi,
3G, and EDGE” (page 93), then you already have a reference movie. Otherwise, you can use the MakeRefMovie
tool to create reference movies. For more information on creating reference movies see Creating Reference
Movies - MakeRefMovie .
Also, refer to the MakeiPhoneRefMovie sample for a command-line tool that creates reference movies.
For more details on reference movies and instructions on how to set them up see “Applications and Examples”
in HTML Scripting Guide for QuickTime .
Creating a Poster Image for Movies
The video is not decoded until the user enters movie playback mode. Consequently, when displaying a webpage
with video, users may see a gray rectangle with a QuickTime logo until they tap the Play button. Therefore,
use a poster JPEG as a preview of your movie. If you use QuickTime Pro 7.2.1 or later to export your movies, as
described in “Encoding Video for Wi-Fi, 3G, and EDGE” (page 93), then a poster image is already created for
you. Otherwise, follow these instructions to set a poster image.
If you are using the  element, specify a poster image by setting the poster attribute as follows:
Creating Video
Creating a Reference Movie
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If you are using an  HTML element, specify a poster image by setting the image for src, the movie
for href, the media MIME type for type, and myself as the target:

Make similar changes if you are using the  HTML element or JavaScript to embed movies in your
webpage.
On the desktop, this image is displayed until the user clicks, at which time the movie is substituted.
Configuring Your Server
HTTP servers hosting media files for iOS must support byte-range requests, which iOS uses to perform random
access in media playback. (Byte-range support is also known as content-range or partial-range support.) Most,
but not all, HTTP 1.1 servers already support byte-range requests.
If you are not sure whether your media server supports byte-range requests, you can open the Terminal
application in OS X and use the curl command-line tool to download a short segment from a file on the
server:
curl --range 0-99 http://example.com/test.mov -o /dev/null
If the tool reports that it downloaded 100 bytes, the media server correctly handled the byte-range request.
If it downloads the entire file, you may need to update the media server. For more information on curl, see
OS X Man Pages.
Ensure that your HTTP server sends the correct MIME types for the movie filename extensions shown in Table
9-1.
Table 9-1 File name extensions for MIME types
Extensions MIME type
.mov video/quicktime
.mp4 video/mp4
.m4v video/x-m4v
Creating Video
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.3gp video/3gpp
Be aware that iOS supports movies larger than 2 GB. However, some older web servers are not able to serve
files this large. Apache 2 supports downloading files larger than 2 GB.
RTSP is not supported.
Creating Video
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96There are several ways for a web application or website to store data on the client. You can use the JavaScript
database classes, described in SafariClient-Side Storage andOfflineApplications ProgrammingGuide , forstoring
application data or use the HTML5 application cache for storing resources on the client so webpages continue
to display offline when there is no network connection on the desktop and iOS. You can also use the application
cache to load webpages faster when there is a slow network connection. This chapter describes how to store
data locally using this HTML5 application cache.
To store resources on the client first you create a manifest file specifying which resources to cache. You declare
the manifest file in the main HTML file. Then you manipulate the cache and handle related events using
JavaScript. Webpages that were previously loaded and contain the resources you specify continue to display
correctly when there is no network. The application cache also persists between browser sessions. So, a web
application that was previously used on the computer or device can continue to work offline—for example,
when iOS has no network or is in airplane mode.
Creating a Manifest File
The manifest file specifies the resources—such as HTML, JavaScript, CSS, and image files —to downloaded
and store in the application cache. After the first time a webpage is loaded, the resources specified in the
manifest file are obtained from the application cache, not the web server.
The manifest file has the following attributes:
●
It must be served with type text/cache-manifest.
● The first line must contain the text CACHE MANIFEST.
● Subsequent lines may contain URLs for each resource to cache or comments.
● Comments must be on a single line and preceded by the # character.
● The URLs are file paths to resources you want to download and cache locally. The file paths should be
relative to the location of the manifest file—similar to file paths used in CSS—or absolute.
● The HTML file that declares the manifest file, described in “Declaring a Manifest File” (page 98), is
automatically included in the application cache. You do not need to add it to the manifest file.
For example, Listing 10-1 shows a manifest file that contains URLs to some image resources.
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Storing Data on the ClientListing 10-1 Sample manifest file
CACHE MANIFEST
demoimages/clownfish.jpg
demoimages/clownfishsmall.jpg
demoimages/flowingrock.jpg
demoimages/flowingrocksmall.jpg
demoimages/stones.jpg
demoimages/stonessmall.jpg
Declaring a Manifest File
After you create a manifest file you need to declare it in the HTML file. You do this by adding a manifest
attribute to the  tag as follows:

The argument to the manifest attribute is a relative or absolute path to the manifest file.
In most cases, creating a manifest file and declaring it is all you need to do to create an application cache. After
doing this, the resources are automatically stored in the cache the first time the webpage is displayed and
loaded from the cache by multiple browser sessions thereafter. Read the following sections if you want to
manipulate this cache from JavaScript.
Updating the Cache
You can wait for the application cache to update automatically or trigger an update using JavaScript. The
application cache automatically updates only if the manifest file changes. It does not automatically update if
resources listed in the manifest file change. The manifest file is considered unchanged if it is byte-for-byte the
same; therefore, changing the modification date of a manifest file also does not trigger an update. If this is not
sufficient for your application, you can update the application cache explicitly using JavaScript.
Note that errors can also occur when updating the application cache. If downloading the manifest file or a
resource specified in the manifest file fails, the entire update processfails. If the update processfails, the current
application cache is not corrupted—the browser continuesto use the previous version of the application cache.
If the update is successful, webpages begin using the new cache when they reload.
Storing Data on the Client
Declaring a Manifest File
2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
98Use the following JavaScript class to trigger an update to the application cache and check its status. There is
one application cache per document represented by an instance of the DOMApplicationCache class. The
application cache is a property of the DOMWindow object.
For example, you get the DOMApplicationCache object as follows:
cache = window.applicationCache;
You can check the status of the application cache as follows:
if (window.applicationCache.status == window.applicationCache.UPDATEREADY)...
If the application cache is in the UPDATEREADY state, then you can update it by sending it the update()
message as follows:
window.applicationCache.update();
If the update is successful, swap the old and new caches as follows:
window.applicationCache.swapCache();
The cache is ready to use when it returns to the UPDATEREADY state. See the documentation for
DOMApplicationCache for other status values. Again, only webpages loaded after an update use the new
cache, not webpages that are currently displayed by the browser.
iOS Note:  Using JavaScript to add and remove resources from the application cache is currently
not supported.
Handling Cache Events
You can also listen for application cache events using JavaScript. Events are sent when the status of the
application cache changes or the update processfails. You can register for these events and take the appropriate
action.
For example, register for the updateready event to be notified when the application cache is ready to be
updated. Also, register for the error event to take some action if the update process fails—for example, log
an error message using the console.
Storing Data on the Client
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cache.addEventListener('updateready', cacheUpdatereadyListener, false);
cache.addEventListener('error', cacheErrorListener, false);
See the documentation for DOMApplicationCache for a complete list of event types.
Storing Data on the Client
Handling Cache Events
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host device. These classes hide the implementation details of how the location information is obtained—for
example, using Global Positioning System (GPS), IP addresses, Wi-Fi, Bluetooth, or some other technology. The
classes allow you to get the current location or get continual updates on the location as it changes.
iOS Note:  Geographic location classes are available in iOS 3.0 and later.
Geographic Location Classes
The Navigator object has a read-only Geolocation instance variable. You obtain location information from
this Geolocation object. The parameters to the Geolocation methods that get location information are
mostly callbacks, instances of PositionCallback or PositionErrorCallback. Because there may be a
delay in getting location information, it cannot be returned immediately by these methods. The callbacks that
you specify are invoked when the location information is obtained or an error occurs. If the location information
is obtained, the position callback is passed a position object describing the geographic location. If an error
occurs, the error callback is passed an instance of PositionError describing the error. The position object
represents the location in latitude and longitude coordinates.
Getting the Current Location
The most common use of the Geolocation class is to get the current location. For example, your web
application can get the current location and display it on a map for the user. Use the getCurrentPosition
method in Geolocation to get the current location from the Navigator object. Pass your callback function
as the parameter to the getCurrentPosition method as follows:
// Get the current location
navigator.geolocation.getCurrentPosition(showMap);
Your callback function—the showMap function in this example—should take a position object asthe parameter
as follows:
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Getting Geographic Locationsfunction showMap(position) {
// Show a map centered at position
}
Use the coords instance variable of the passed-in position object to obtain the latitude and longitude
coordinates as follows:
latitude = position.coords.latitude;
longitude = position.coords.longitude;
Tracking the Current Location
You can also track the current location. For example, if your web application displays the current location on
a map, you can register for location changes and continually scroll the map as the current location changes.
When you register for location changes, you receive a callback every time the location changes. The callbacks
are continual until you unregister for location changes.
Use the watchPosition method in the Geolocation classto register for location changes. Pass your callback
function as the parameter. In this example, the scrollMap function is invoked every time the current location
changes:
// Register for location changes
var watchId = navigator.geolocation.watchPosition(scrollMap);
The callback function should take a position object as the parameter as follows:
function scrollMap(position) {
// Scroll the map to center position
}
Similar to “Getting the Current Location” (page 101), use the coords instance variable of the passed in position
object to obtain the latitude and longitude coordinates.
Use the clearWatch method in the Geolocation class to unregister for location changes. For example,
unregister when the user clicks a button or taps a finger on the map as follows:
Getting Geographic Locations
Tracking the Current Location
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// Unregister when the user clicks a button
navigator.geolocation.clearWatch(watchId);
}
Note:  Constantly tracking the current location may reduce the device’s battery life since the GPS
hardware is enabled in the tracking mode.
Handling Location Errors
Your web application should handle errors that can occur when requesting location information. For example,
display a message to the user if the location cannot be determined due to poor network connectivity or some
other error.
When registering for location changes, you can optionally pass an error callback to the watchPosition
method in the Geolocation class as follows:
// Register for location changes
var watchId = navigator.geolocation.watchPosition(scrollMap, handleError);
The error callback should take a PositionError object as the parameter as in:
function handleError(error) {
// Update a div element with the error message
}
Getting Geographic Locations
Handling Location Errors
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103With Safari on iOS 6 and later, you can debug your mobile web content from your Mac. You can view errors,
warnings, and logs for HTML, JavaScript, and CSS, just as you would when developing for Safari on OS X. This
chapter describes how to use Web Inspector to debug web content on iOS.
You should test your web content on both the desktop and various iOS devices. If you do not have iOS devices
for testing, you can use Simulator in the iOS SDK. Because there is a difference between web browsing on iOS
and OS X, you should specifically test your content on iPhone and iPad or emulate the hardware device in
Simulator. When testing in Safari on any platform, you can use Web Inspector to debug your web content.
Formore tips on debugging web contentin Safari,read SafariDeveloper ToolsGuide . Read the section “Changing
the User Agent String” in Safari User Guide for Web Developers to learn how to simulate iPhone- and iPad-like
behavior in Safari on OS X.
iOS Note:  Web Inspector is available on iOS 6 and later.
Enabling Web Inspector on iOS
Web Inspector provides valuable insight on what might be going wrong with your web content. Even though
Web Inspector is accessed through Safari on OS X, you can use it to inspect content that has loaded in Safari
or in any UIWebView on iOS.
To enable Web Inspector on iOS
1. Open the Settings app.
2. Tap Safari.
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Debugging3. Scroll down and select Advanced.
4. Switch Web Inspector to ON.
Debugging
Enabling Web Inspector on iOS
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When Web Inspector on iOS is enabled, connect your device to your Mac with a USB cable. A menu item in
the Develop menu of Safari on OS X appears, as shown in Figure 12-1.
Note:  The Develop menu can be enabled in the Advanced pane of Safari preferences.
Figure 12-1 The Develop menu
The name of the menu item will be either the name of each device connected and/or the name of the Simulator.
A submenu containing each available page for each inspectable app appears. Select the page that you are
interested in, and Web Inspector opens in a new window.
The same interface and workflow to debug web content on OS X is used to debug web content on iOS, as
shown in Figure 12-2.
Figure 12-2 Web Inspector
Debugging
Inspecting From Your Mac
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the DOM Tree—are available on iOS as well. The sole difference is that by selecting your web page through
the Develop menu, you actively inspect web content on your device instead of on your Mac. If you browse to
another URL on your device with the Inspector window still open, you’ll notice that the inspected data reloads
to reflect the page to which you navigated.
Note:  To maximize the usefulness of Web Inspector, consult Safari Developer Tools Guide .
Inspecting Content in a Web View
If you have a development provisioning profile installed on your device, you can debug any web view
(UIWebView object) in your app. This is particularly useful if your app manipulates the DOM on the fly and you
want to observe the generated code.
To inspect a UIWebView, make sure that your app is open to the desired view so it appears under the Develop
menu. The name of your app will appear under the name of your device. When debugging web content in a
web view, Web Inspector behaves in the same manner as debugging web content in Safari.
Debugging
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107Important:  You can only inspect apps on devices that have been transferred to your device from Xcode.
You cannot inspect apps that have been downloaded from the App Store, even if it is your app.
Using JavaScript to Interact with Your Device
You can communicate to your device from your Mac by sending JavaScript commands with the interactive
Web Inspector debug console. Through the debug console you have access to variables, functions, and the
DOM tree of the page being inspected. As you start typing, notice that acceptable values autopopulate. Press
Return to send your command, and you receive a response, as shown in Figure 12-3.
Figure 12-3 Observing the value of document.title in the debug console
Conversely, you can create messages on your device and send their values to your Mac for observation.
Throughout your JavaScript code, you can call the log(), warn(), and error() methods of the console
object. Pass an object containing any runtime variables you are curious about. In this way, you can determine
the value of an object at any stage of the loading process, instead of just at the end via the debug console.
For example, the following code prints the value of a variable to the console using the log() method:
console.log("The current value of myVariable is " + myVariable);
Observe the output of console logs, warnings, and erros in the Log navigator (control-8).
Debugging
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your device from your Mac. The example shown in Figure 12-4 calls window.alert(), but you can call any
top-level function available to the webpage, including functions of your own. This behavior is useful if you
want to closely examine the implementation of your code programmatically instead of through a user interface.
Figure 12-4 Alert dialog triggered from the debug console
Debugging
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109HyperText Markup Language (HTML) is the fundamental mark-up language used to create web content. Your
HTML needs to be well structured and valid to work well with Safari on the desktop and Safari on iOS. Read
this appendix to learn more about creating conforming HTML content.
See Safari HTML Reference for a complete guide to all the HTML elements supported by Safari.
What Is HTML?
HTML is the standard for content structure on the web. Its original intention of the designers was to provide
the structure required for web browsers to parse its content into a meaningful format. This structure could
define entire documents, complete with headings, text, lists, data tables, images, and more. As the web
flourished, it also began to incorporate style and multimedia aspects as well.
Arguably the most important feature of HTML is the ability to "hyperlink" text. This gives content providers
the ability to assign the URI of other content on the web to a block of text, allowing it to be clicked and followed
by the user of the content.
The most recent revisions of the HTML standard are returning to the "old days" of separating the structure of
web content (HTML) from the presentation of the content (using a technology called Cascading Style Sheets,
or CSS). You can learn more about creating effective web contentstyle in the “CSS Basics” (page 117) appendix.
This appendix, conversely, covers only the structure of HTML and how to properly format a document for a
variety of clients. It does not discuss advanced HTML features or proper webpage layout and design.
Basic HTML Structure
There are a few basic structure blocks that make up the core of an HTML document. The blocks are described
in the context of the HTML code shown in Listing A-1.
Listing A-1 Basic HTML document

2012-09-19   |   © 2012 Apple Inc. All Rights Reserved.
110
HTML Basics




Big Heading

This is our HTML sample code. It shows many elements:

	The HTML document block.
	The HEAD and title of the page.
	A paragraph.
	An unordered list.



The html document block: The  document block is the entirety of the HTML code for a webpage. In
the example, the tags defining this block— and —are located towards the top and bottom
of the document. The document is prefaced with a DOCTYPE declaration, which tells browsers which specification
to parse your webpage against. If you are following the strict conventions of the HTML specification, you should
use the declaration shown above. Otherwise it can be left off, but it defaults to a "quirks" mode. Refer to the
HTML 4.01 Specification for more on document validation types.
The head block: The  block defines a block of metadata about the webpage. In this case, you can see
the webpage has a  block also can contain a variety of other metadata, such as externally linked CSS style
sheets (using the link tag) and sets of JavaScript functions. This block should always contain at least the title,
and should always be external to the body content.
The body block: This block definesthe entire body of the document—itshould encompassthe visible content
of the webpage itself. The body block itself is not designed for inline content. Rather, you should define other
block elements (such as paragraphs, divisions, and headers) and embed content within them. The 
block should be used to specify style parameters for the entirety of the content.
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 block. They include:
● Heading. Specified in this case by the  and 
 tags, this defines the header for a following block
of content. The headers can be of six different sizes, ranging from a very large first-level heading (defined
with the  and 
 tags) down to a small sixth-level heading (defined with the  and 

tags). Itshould contain only brief text—other contentsuch aslarge text blocks, images, and moviesshould
be embedded in other appropriate block elements such as paragraphs and divisions.
● Paragraph. Specified by the  and 
 tags, this is one of the fundamental block elements for web
content. Each individual paragraph should contain the inline text content that definesthe readable content
of a webpage and should not enclose any other block elements. Generally, paragraph blocks are for text
only. An alternative to the paragraph is the division, and that is the most appropriate block element for
other media types such as images and movies.
● Division/Section. Specified by the  and 
 tags, the division is designed to contain all kinds
of content, including text, images, and other multimedia. It also can encompass other block elementssuch
as paragraphs, though enclosing divisions within other divisionsis generally not recommended. Generally,
division blocks are used to define unified styles for blocks of content. In the example above, the division
block contains the heading image for the webpage.
● List. HTML supports two basic kinds of lists, the ordered list (specified by the 
 and  tags) and
the unordered list (specified by the 
 and  tags), as in the example above. An ordered list tags
each list element (specified by the 	 and 

 tags) with an incremental number (1, 2, 3, and so on).
An unordered list tags each list element with a bullet, though this marker can be changed using CSS
styling.
Now you've learned some of the fundamental skeleton elements of HTML structure. Block elements such as
paragraphs and divisions are the core of the content—by themselves they are invisible, but they contain inline
elements such as text, images, and movies. The next section takes you a little deeper into some features of
HTML content.
Creating Effective HTML Content
You've learned about the fundamental elements that define HTML structure, but a webpage is useless without
any kind of content in it. Now that you've laid down the foundation for the webpage, you should place some
content to create a rich experience for your users. This appendix discusses some basic inline HTML elements;
for all the elements supported by Safari and WebKit, refer to Safari HTML Reference .
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that has a discussion of the day's events alongside a few photos from the journey. As the Internet has matured,
you may have seen more in the way of movies, animations, and other "rich" forms of content introduced to
the web. But the most common media is still a combination of text and images.
Displaying text is a simple thing in HTML. Once you've established the surrounding block element—a paragraph,
for example, as discussed in the previous section—the text can just be placed inline. An example from the
fictional travel journal might be as shown in Listing A-2:
Listing A-2 Adding a paragraph

Today, we arrived in Cupertino, California. We visited the Apple campus. It was a
bright sunny day and exhibited none of the fog that was so prevalent during our
stay in San Francisco.


It's a simple textual entry, but there's not much else to it. A good travel journal also marks the date and time
of each entry, so you should add that to the content, as well. Listing A-3 shows the time and date added as a
heading.
Listing A-3 Adding a heading
Friday, May 20, 2005 - 4:40PM


Today, we arrived in Cupertino, California. We visited the Apple campus. It was a
bright sunny day and exhibited none of the fog that was so prevalent during our
stay in San Francisco.


It's still a simple textual entry, but at least you've provided your reader with a little extra information. But what
if your reader has no idea what Apple is? One of the great features of HTML is the ability to "hyperlink"
documents—create links to external webpages. Using the  and  hyperlink tags, you can link your
reader to the Apple website as shown in Listing A-4.
Listing A-4 Creating a hyperlink
Friday, May 20, 2005 - 4:40PM


Today, we arrived in Cupertino, California. We visited the Apple campus. It was a
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stay in San Francisco.


Notice that the word "Apple" is now surrounded by this hyperlink element. The element describestwo particular
attributes:
● The href attribute: This links to the URL of the webpage you want to link to. If you specified a relative
URL, such as "myPage.html" or "/pages/myPage.html", the link would point to a file within the same folder
as your code, or in a separate folder, respectively. In this example, the value is a fully qualified URL, so it
simply links to that site (the Apple homepage).
● The title attribute: This is an optional attribute, but one you should get into the habit of using. The title
attribute provides an alternate description of the link. In Safari, holding the mouse over the hyperlink for
a couple of seconds reveals this value as a tooltip. It's a great way to provide information about a link
before the user clicks it, letting them decide if they want to leave your webpage or not. Additionally, this
information is used by screen readers and other accessibility devices, so by using this attribute, you help
extend your content to a larger community.
With this hyperlink in place, the word "Apple" in the travel journal is now displayed as a clickable link. Clicking
the word redirects the user to the Apple homepage.
So far the travel journal reads great. But to really capture the attention of your readers, you might want to
include an image. An image in HTML is specified by the  tag. It's important to note that an image is an
inline element, so needs to be placed within a block element such as a paragraph. It is also a little different
from some other inline elementsin that it doesn't require a closing tag. Listing A-5 shows how to add an image
to the travel journal entry.
Listing A-5 Adding an image
Friday, May 20, 2005 - 4:40PM





Today, we arrived in Cupertino, California. We visited the Apple campus. It was a
bright sunny day and exhibited none of the fog that was so prevalent during our
stay in San Francisco.
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the image (with the same rules for relative versus absolute URLs as in the hyperlink), and the alt attribute
defines a block of alternate text—this text can also be read by screen readers, or can be shown by some
browsers when images are turned off in the browser.
Another small element we added was the 
 line break element. Remember that an image is an inline
element, just like text. Without a forced line break, the image would display and the text would follow directly
after, left to right, one after the other. That's a little awkward for a travel journal, but useful when you have
small images (like mathematical equations) that you want integrated into the text. Add the line break to force
the next line of text to a new line.
Now you've learned about actual web content—the inline text and media that defines what a user reads and
views when they visit your webpage. This section is by no means an exhaustive discussion on the content you
can provide to your users. For more information on the content that Safari and WebKit support, refer to Safari
HTML Reference .
Using Other HTML Features
This section discusses a few more features of HTML that you may want to use in your web content.
One other common block element is the 
 block. You can add a 
 block to display any kind of
tabular data. To the previous example, let's add a table of temperatures that the journal writer experienced
on his or her day in Cupertino. For the information to be useful, you'll also want to add something about the
time at which the temperature was recorded. Both the time and temperature can be labeled using table
headers, specified by the 	 and 

 tags. Notice that the order of the table headers and table cells
(specified by the 	 and 

 tags) match within their particular row (specified by the 

 and 
tags) in Listing A-6.
Listing A-6 Creating a table
Friday, May 20, 2005 - 4:40PM





Today, we arrived in Cupertino, California. We visited the Apple campus. It was a
bright sunny day and exhibited none of the fog that was so prevalent during our
stay in San Francisco.
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	9:00AM	65 degrees
	12:00PM	76 degrees
	3:00PM	78 degrees


The table definition itself contains some special attributes. The border attribute defines the width of the
border surrounding the table. The cellpadding attribute defines the width of the space between the cell
border and the content within. The cellspacing attribute definesthe width of the spacing between individual
cells.
Another useful feature is the ability to integrate JavaScript—an interpreted language processed by web
browsers—within HTML. JavaScript can do a variety of tasks, many of which are addressed in WebKit DOM
Programming Topics. The JavaScript code can be embedded in external files, within the 











...
Notice that the definitions are bound by braces, and that the identifier ( notebox) is preceded by a period.
The latter allows you to use this set of style definitions for any element within your HTML content. If you want
to limit its use only to paragraph elements, change the identifier to:
P.notebox
This tells the browser to use the definitions only if they are defined within a  paragraph element. If you
want to use these styles for all paragraphs, then you don't need the custom identifier. Change the identifier
to p.
You've learned how to define the custom styles in the 
 block of your content. But how do you actually
tell the browser which paragraphs should use these styles? Here are two paragraphs of text in HTML:
This is some plain boring text.

This is a finely styled paragraph!

There’s a new attribute in the second paragraph: class. This is how you specify the style definition that a
particular element should render itself with. The top paragraph in the example above would render as usual,
in the default paragraph style for the browser. But with the style class of the second paragraph set to your new
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from the left margin. For any paragraph (or any element, since we didn't specify an explicit element it could
be assigned to), simply use that class attribute to name the identifier of your style definition.
There is however one disadvantage to this method of embedding CSS in a webpage. Though the definitions
are reusable within the webpage—you can now specify as many notebox paragraphs as you want—they are
not reusable across multiple webpages. If you want the paragraph'stext to be rendered in an italic style instead
of a bold one, you'd have to change that definition on each webpage where you integrated it. The nextsection
describes the most scalable way to use CSS within your web content.
External CSS
If you want to use a particular style across multiple webpages, there's only one way to do it: externally linked
style sheets. Since each webpage has to know about the style definitions you created, placing all of them into
an external file and then linking each webpage to that file seems like a reasonable way to inform them. That
way, if you want to change boldface to italic, you only have to change it once—in the external file.
An external style sheet is almost exactly the same as the 